Keysight Trueform Series Operating and Service Guide

Keysight Trueform Series Waveform Generator
Operation and Service Guide

This document includes user, service, and programming information for the Keysight Trueform Series waveform generators.

For the latest firmware and documentation, see www.keysight.com/find/trueform.

For the latest datasheet with all specifications and typical characteristics, see literature.cdn.keysight.com/litweb/pdf/5991-3272EN.pdf.

Keysight welcomes your comments and suggestions to improve our documentation. You can give feedback on this document at www.keysight.com/find/trueformdocfeedback.

Keysight BenchVue Software

The Keysight Trueform Series waveform generators work with BenchVue software, which provides easy multi-instrument control. For more information, go to www.keysight.com/find/benchvue.

Use BenchVue to:

  • View and control all of your bench instruments from a single screen
  • Save/recall the state of your entire bench
  • Acquire data and screenshots from multiple instruments

Save time with:

  • Time aligned multi-instrument export to Excel, Word, MATLAB
  • Export of waveform generator data to Word
  • Drag and drop waveforms between your waveform generator and oscilloscope
  • Integrated library capability for downloading instrument documentation, software drivers, firmware updates, FAQs, videos, and more

From anywhere:

  • Mobile companion apps to monitor and control your bench

Preliminary Information

Safety and Regulatory Information

Models and Options

Maximum Waveform Frequencies by Model

Operating Information

Introduction to Instrument

Quick Start

Front Panel Menu Operation

Front Panel Menu Reference

LAN Configuration Procedure

Set Up Arbitrary Waveform

Features and Functions

Waveform Generation Tutorial

Tutorial Animations

SCPI Programming Reference

Introduction to SCPI Language

Internal Function Waveforms

Alphabetical List of SCPI Commands and Queries

Programming Examples

Command Quick Reference

Factory Reset State

SCPI Error Messages

Service and Repair Information

Service and Repair Introduction

Calibration and Adjustment: 33500 Series

Calibration and Adjustment: 33600 Series

Block Diagram - 33500 Series

Block Diagram - 33600 Series

Power Supplies - 33500 Series

Power Supplies - 33600 Series

Troubleshooting - 33500 Series

Troubleshooting - 33600 Series

Self-Test Procedures

Replaceable Parts

Disassembly - 33500 Series

Disassembly - 33600 Series

Battery Replacement

Installing the Optional GPIB Interface

IO Libraries and Instrument Drivers

The Keysight IO Libraries Suite software, including installation instructions, is on the Keysight IO Libraries Suite CD provided with your instrument.

For information about connecting and configuring USB, LAN, and GPIB interfaces, refer to the Keysight USB/LAN/GPIB Interfaces Connectivity Guide on the Keysight IO Libraries Suite CD, and at www.keysight.com/find/connectivity.

Web Interface

The instrument includes a built-in Web Interface. You can use this interface over LAN for remote instrument access and control via a Java™-enabled Web browser, such as Microsoft Internet Explorer.

Web interface image

To use the Web Interface:

  1. Establish a LAN connection from your PC to the instrument.
  2. Open your PC's Web browser.
  3. Launch the instrument's Web Interface by entering the instrument's IP address or fully-qualified hostname in the browser address field.
  4. Follow the instructions in the Web Interface's on-line help.

Example Programs

There are several example programs on the product page Web site (www.keysight.com/find/trueform). These are application-focused programs that demonstrate different programming environments. This document also includes programming examples to help get you started.

Contacting Keysight Technologies

You can contact Keysight Technologies for warranty, service, or technical support.

    In the United States: (800) 829-4444

    In Europe: 31 20 547 2111

    In Japan: 0120-421-345

Use www.keysight.com/find/assist for information on contacting Keysight worldwide, or contact your Keysight Technologies representative.

© Keysight Technologies, Inc. 2013 - 2015

Edition 3

September, 2015


Safety and Regulatory Information

Notices

© Keysight Technologies, Inc. 2013, 2014

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Keysight Technologies, Inc. as governed by United States and international copyright laws.

Manual Information

Keysight Technologies, Inc.
900 S. Taft Ave.
Loveland, CO 80537 USA

Software and Documentation Updates and Licenses

Keysight releases software updates to fix defects and incorporate product enhancements. For the latest firmware and documentation, see www.keysight.com/find/trueform.

A portion of the software in this product is licensed under terms of the General Public License Version 2 ("GPLv2"). The text of the license and source code can be found at www.keysight.com/find/GPLV2.

This product uses Microsoft Windows CE. Keysight highly recommends that all Windows-based computers connected to Windows CE instruments use current anti-virus software. For more information, see www.keysight.com/find/trueform.

Warranty

The material contained in this document is provided "as is," and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Keysight disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Keysight shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Keysight and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Keysight Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Safety Notices

A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

Safety Symbols

Alternating current
Alternating current
Frame or chassis terminal
Frame or chassis terminal (functional ground)

Standby supply. Unit is not completely disconnected from AC mains when switch is off.
Caution - risk of electric shock
Caution Risk of electric shock
Caution - refer to accompanying documents
Caution Refer to accompanying documents
Ground with circle image
Protective Earth ground terminal (safety ground)
CE mark
The CE mark is a registered trademark of the European Community.
ETL Intertek logo | The ETL mark is a registered trademark of Intertek. Applies to 33500 Series instruments only.
The CSA mark with the 'c' and 'us' subscript indicates the instrument is certified to the applicable Canadian and United States of America standards respectively. Applies to 33600 Series instruments only.
N10149 logo | The C-tick mark is a registered trademark of the Spectrum Management Agency of Australia. This signifies compliance with the Australian EMC Framework regulations under the terms of the Radio Communications Act of 1992.
Circled 40 logo
Contains one or more of the 6 hazardous substances above the maximum concentration value (MCV), 40 Year EPUP.
1SM 1-A | This text indicates that the instrument is an Industrial Scientific and Medical Group 1 Class A product (CISPR 11, Clause 4).
ICES/NMB-001

This ISM device complies with Canadian ICES-001.

Cet appareil ISM est conforme à la norme NMB-001 du Canada.

This product complies with the WEEE Directive (2002/96/EC) marking equipment. The affixed product label indicates that you must not discard this electrical/electronic product in domestic household waste.

To return unwanted products, contact your local Keysight office, or see www.keysight.com/environment/product/ for more information.

This equipment is Class A suitable for professional use and is for use in electromagnetic environments outside of the home.

Additional Safety Notices

The following general safety precautions must be observed during all phases of operation of this instrument. Failure to comply with these precautions or with specific warnings or instructions elsewhere in this manual violates safety standards of design, manufacture, and intended use of the instrument. Keysight Technologies assumes no liability of the customer’s failure to comply with the requirements.

General

Do not use this product in any manner not specified by the manufacturer. The protective features of this product may be impaired if it is used in a manner not specified in the operation instructions.

Before Applying Power

Verify that all safety precautions are taken. Make all connections to the unit before applying power.

Ground the Instrument

This product is provided with protective earth terminals. To minimize shock hazard, the instrument must be connected to the AC power mains through a grounded power cable, with the ground wire firmly connected to an electrical ground (safety ground) at the power outlet. Any interruption of the protective (grounding) conductor or disconnection of the protective earth terminal will cause a potential shock hazard that could result in personal injury.

  • Do not operate in an explosive atmosphere.
  • Do not operate the instrument in the presence of flammable gases or fumes.
  • Only qualified, service-trained personnel who are aware of the hazards involved should remove instrument covers. Always disconnect the power cable and any external circuits before removing the instrument cover.

Do Not Modify the Instrument

Do not install substitute parts or perform any unauthorized modification to the product. Return the product to an Keysight Sales and Service Office for service and repair to ensure that safety features are maintained.

In Case of Damage

Instruments that appear damaged or defective should be made inoperative and secured against unintended operation until they can be repaired by qualified service personnel.

Unless otherwise noted in the specifications, this instrument or system is intended for indoor use in an installation category II, pollution degree 2 environment per IEC 61010-1 and 664 respectively. It is designed to operate at a maximum relative humidity of 5% to 80% at 40 °C or less (non-condensing). This instrument or system is designed to operate at altitudes up to 3000 meters, and at temperatures between 0 and 55 °C.

Technical Support

If you have questions about your shipment, or if you need information about warranty, service, or technical support, contact Keysight Technologies.

Declaration of Conformity

Declarations of Conformity for this product and for other Keysight products may be downloaded from the Keysight Regulatory Web site:

http://regulations.products.keysight.com/DoC/search.htm


Models and Options

This section describes the models and options in the Trueform Series of instruments. For information on loading licenses for options via the front panel, see License Installation. For information on loading licenses via SCPI, see the SYSTem:LICense commands.

Instrument Models

Instrument models with numbers of the form 335XXA or 335XXB are referred to as the 33500 Series, and instrument models with numbers of the form 336XXA are referred to as the 33600 Series. Collectively, the 33500 Series and 33600 Series instruments comprise the Trueform Series of waveform generators. Unless specified otherwise, all manual topics apply to all instruments in the Trueform Series.

To determine the model number of your instrument, read the label on the instrument's front panel. You can also either execute the *IDN? query over the remote interface or press [System] > Help > About on the front panel.

The Trueform Series model numbers and option numbers are shown and described in the table below.

Model | Description | Options
33521A | 30 MHz One channel Arbitrary waveforms NISPOM Security 1 MSa Memory per channel | 002 - 16MSa Arb Memory 004 - GPIB Interface 010 - High-stability OCXO Timebase
33522A | 30 MHz Two channels Arbitrary waveforms NISPOM Security 1 MSa memory per channel | 002 - 16MSa Arb Memory 004 - GPIB Interface 010 - High-stability OCXO Timebase
33509B | 20 MHz One channel No arbitrary waveforms | OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security
33510B | 20 MHz Two channels No arbitrary waveforms | OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security
33511B | 20 MHz One channel Arbitrary waveforms | MEM - 16 MSa Memory per channel OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security
33512B | 20 MHz Two channels Arbitrary waveforms | MEM - 16 MSa Memory per channel OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security IQP - Add IQ Baseband signal player
33519B | 30 MHz One channel No arbitrary waveforms | OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security
33520B | 30 MHz Two channels No arbitrary waveforms | OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security
33521B | 30 MHz One channel Arbitrary waveforms | MEM - 16 MSa Memory per channel OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security
33522B | 30 MHz Two channels Arbitrary waveforms | MEM - 16 MSa Memory per channel OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security IQP - Add IQ Baseband signal player
33611A | 80 MHz One channel Arbitrary waveforms | MEM - 64 MSa Memory per channel OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security
33612A | 80 MHz Two channels Arbitrary waveforms | MEM - 64 MSa Memory per channel OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security IQP - Add IQ Baseband signal player
33621A | 120 MHz One channel Arbitrary waveforms | MEM - 64 MSa Memory per channel OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security GPB - GPIB interface module – factory installed
33622A | 120 MHz Two channels Arbitrary waveforms | MEM - 64 MSa Memory per channel OCX - Add High-stability OCXO Timebase SEC - Enable NISPOM & File Security IQP - Add IQ Baseband signal player GPB - GPIB interface module – factory installed

One- and two-channel upgrades for 33500 Series

Model | Description
335BW1U | Increase bandwidth to 30 MHz for one-channel models
335BW2U | Increase bandwidth to 30 MHz for two-channel models
335ARB1U | Add arbitrary waveforms to one-channel models
335ARB2U | Add arbitrary waveforms to two-channel models
335MEM1U | 16 MSa per channel memory for one-channel models
335MEM2U | 16 MSa per channel memory for two-channel models
33500U-OCX | Add high-stability OCXO timebase
335SECU | Add NISPOM and File security
335IQPU | Add IQ Baseband signal player
33522B-DST | Enable all software options for demonstration

One- and two-channel upgrades for 33600 Series

Model | Description
336BW1U | Increase bandwidth to 120 MHz for one-channel models
336BW2U | Increase bandwidth to 120 MHz for two-channel models
336MEM1U | 64 MSa per channel memory for one-channel models
336MEM2U | 64 MSa per channel memory for two-channel models
33600U-OCX | Add high-stability OCXO timebase
336SECU | Add NISPOM and File security
336IQPU | Add IQ Baseband signal player
33622A-DST | Enable all software options for demonstration
3446GPBU | GPIB user installable interface module


Maximum Waveform Frequencies by Model

33500 Series, Lower Frequency Models

33509B 33510B 33511B 33512B

Waveform | Maximum Frequency
Sine | 20 MHz
Square/Pulse | 20 MHz
Noise | 20 MHz
Ramp/Triangle | 200 kHz
PRBS | 50 Mbps
Arbitrary | 160 MSa/s

33500 Series, Higher Frequency Models

33521A 33522A 33519B 33520B 33521B 33522B or other 33500 Series models with option 335BW1U or 335BW2U.

Waveform | Maximum Frequency
Sine | 30 MHz
Square/Pulse | 30 MHz
Noise | 30 MHz
Ramp/Triangle | 200 kHz
PRBS | 50 Mbps
Arbitrary | 250 MSa/s

33600 Series, Lower Frequency Models

33611A 33612A

Waveform | Maximum Frequency
Sine | 60 MHz up to 10 Vpp 80 MHz up to 8 Vpp
Square/Pulse | 50 MHz up to 10 Vpp
Noise | 60 MHz up to 10 Vpp 80 MHz up to 8 Vpp
Ramp/Triangle | 800 kHz
PRBS | 100 Mbps
Arbitrary | 660 MSa/s

33600 Series, Higher Frequency Models

33621A 33622A or other 33600 Series models with option 336BW1U or 336BW2U.

Waveform | Maximum Frequency
Sine | 60 MHz up to 10 Vpp 80 MHz up to 8 Vpp 120 MHz up to 4 Vpp
Square/Pulse | 50 MHz up to 10 Vpp 100 MHz up to 4 Vpp
Noise | 60 MHz up to 10 Vpp 80 MHz up to 8 Vpp 120 MHz up to 4 Vpp
Ramp/Triangle | 800 kHz
PRBS | 100 Mbps up to 10 Vpp 200 Mbps up to 4 Vpp
Arbitrary | 1 GSa/s


Operating Information

Introduction to Instrument

Quick Start

Front Panel Menu Operation

Front Panel Menu Reference

LAN Configuration Procedure

Set Up Arbitrary Waveform

Features and Functions

Waveform Generation Tutorial


Introduction to Instrument

The Keysight Technologies Trueform Series is a series of synthesized waveform generators with built-in arbitrary waveform and pulse capabilities.

Instrument at a Glance

Front Panel at a Glance

Front Panel Display at a Glance

Front Panel Number Entry

Rear Panel at a Glance

Instrument at a Glance

The instrument's combination of bench-top and system features makes it a versatile solution now and in the future.

Convenient bench-top features

  • 16 standard waveforms
  • Built-in 16-bit (33500 Series) or 14-bit (33600 Series) arbitrary waveform capability
  • Precise pulse waveform capabilities with adjustable edge time
  • LCD display with numeric and graphical views
  • Easy-to-use knob and numeric keypad
  • Instrument state storage with user-defined names
  • Portable, ruggedized case with non-skid feet
  • Isolated outputs to break ground loops

Flexible system features

  • Downloadable waveform memory of 1MSa (33500 Series) or 4 MSa (33600 Series). This can be upgraded to 16 MSa (33500 Series) or 64 MSa (33600 Series).
  • USB, GPIB, and LAN remote interfaces (GPIB is optional on some models; see Models and Options for details.)
  • LXI Class C Compliant
  • SCPI (Standard Commands for Programmable Instruments) compatibility

Front Panel at a Glance

The BNC connectors, both the shell and center pin, on the front panel of the instrument are isolated up to ±42 Vpk from chassis. The shells of these BNC connectors are connected to each other, and internal circuitry will attempt to keep the isolated voltage to within ±42 Vpk to chassis. Exceeding the isolation voltage beyond ±42 Vpk from chassis may destroy the instrument and cause a hazard that could result in personal injury or death.

Front panel, labeled

Item | Description
1 | USB Port
2 | On/Off Standby Switch
3 | Display
4 | Menu Softkeys
5 | Fixed Function Buttons (column of seven keys)
6 | Manual Trigger Button
7 | Sync Connector
8 | Numeric Keypad
9 | Channel 1 and Channel 2 (depending on model)
10 | Knob and cursor arrows

Note

Press and hold any front panel key or softkey to get context-sensitive help.

Front Panel Display at a Glance

Front panel display

Item | Description
1 | Channel 1 information
2 | Channel 2 information (depends on model)
3 | Waveform parameters
4 | Waveform display
5 | Sweep, modulation, or burst parameters
6 | Softkey labels

Front Panel Number Entry

You can enter numbers from the front panel in two ways:

  • Use the knob and cursor keys to modify the number. Rotate the knob to change a digit (clockwise increases). The arrows below the knob move the cursor.
    Knob and arrows

  • Use the keypad to enter numbers and the softkeys to select units. The [+/-] key changes the number's sign.
    Numeric keypad

Rear Panel at a Glance

The rear panels on the 33500 Series and 33600 Series instruments have similar features, but their locations vary, as shown below.

33500 Series

Rear panel, labeled with numbers

33600 Series

Item | Description
1 | External 10 MHz Reference Input
2 | Internal 10 MHz Reference Output
3 | GPIB Connector
4 | Chassis Ground
5 | Instrument Cable Lock
6 | AC Power
7 | External Modulation Input
8 | External Trig/Gate/FSK/Burst (Input and Output)
9 | USB Interface Connector
10 | Local Area Network (LAN) Connector

The external 10 MHz reference input BNC connector, both the shell and center pin, on the rear panel of the instrument is isolated up to ±42 Vpk from chassis. The shell of this BNC connector is isolated from the rest of the instrument. Internal circuitry will attempt to keep the isolated voltage to within ±42 Vpk to chassis. Attempts to float this input beyond ±42 Vpk from chassis may destroy the instrument and cause a hazard that could result in personal injury or death.

The external modulation input BNC connector, both the shell and center pin, on the rear panel of the instrument is isolated up to ±42 Vpk from chassis. The shell of this BNC connector is connected to the shells of the front panel BNC connectors. Internal circuitry will attempt to keep the isolated voltage to within ±42 Vpk to chassis. Attempts to float the outputs beyond ±42 Vpk from chassis may destroy the instrument and cause a hazard that could result in personal injury or death.

Warning

This is a Protection Class 1 equipment (chassis must be connected to a protective earth ground). The mains plug shall only be inserted in an outlet provided with a Protective Earth Terminal.


Quick Start

This section describes basic procedures to help you get started quickly with the instrument.

  • Prepare Instrument for Use
  • Adjust the Carrying Handle
  • Set Output Frequency
  • Set Output Amplitude
  • Set DC Offset Voltage
  • Set High-Level and Low-Level Values
  • Output a DC Voltage
  • Set Duty Cycle of a Square Wave
  • Configure a Pulse Waveform
  • Select a Stored Arbitrary Waveform
  • Use Built-in Help System
  • Rack Mount the Instrument

Prepare Instrument for Use

Verify that you received the following items. If anything is missing, please contact your nearest Keysight sales office or Keysight authorized reseller.

  • Power cord (for country of destination)
  • Certificate of Calibration
  • Keysight Trueform Series Product Reference CD (product software, programming examples, and manuals)
  • Keysight IO Libraries Suite CD
  • USB 2.0 cable

    Note: All product documentation is on the Keysight Trueform Series Product Reference CD. For the latest firmware and documentation, see www.keysight.com/find/trueform.

The instrument may be used with mains power of either 100-240 V, 50/60 Hz or 100-120 V, 400 Hz. The maximum power usage is 150 VA. Ensure that you are using the correctly rated mains cord based on the instrument’s rating and your country's electrical codes. Connect the power cord and LAN, GPIB, or USB cable as desired. Turn the instrument on by pressing the power switch in the lower left corner of front panel. The instrument runs a power-on self test and then displays a message about how to obtain help, along with the current IP address. It also displays the GPIB address if the GPIB option is installed and enabled.

Power Switch: Power switch

The instrument's default function is a 1 kHz, 100 mVpp sine wave (into a 50 Ω termination). At power-on, the channel output connectors are disabled. To enable output on a channel connector, press the key above the channel connector and then press the Output Off / On softkey.

If the instrument does not turn on, verify that the power cord is firmly connected. Also make sure that the instrument is connected to an energized power source. If the LED below the power switch is off, there is no AC power connected. If the LED is amber, the instrument is in standby mode with AC power connected, and if it is green, the instrument is on.

If the power-on self test fails, the display shows ERR in the upper right corner. It also prominently displays "Check for error messages in the error queue."

See SCPI Error Messages for information on error codes. See Service and Repair - Introduction for instructions on returning the instrument for service.

To turn off the instrument, hold the power switch down for about 500 ms. This prevents you from turning the instrument off by accidentally brushing the power switch.

Adjust the Carrying Handle

Grasp the sides of the handle, pull outward, and rotate the handle.

Adjust carrying handle

Set Output Frequency

The default frequency is 1 kHz. You can change the frequency, and you can specify frequency in units of period instead of Hz.

To change frequency with the knob:
Parameters key Frequency softkey Knob and arrows

To change frequency with the numeric keypad:

Parameters key Frequency softkey Numeric keypad
Finish by selecting frequency units:

Frequency units softkeys

To change the units to period instead of frequency:

Frequency / Period softkey (Period)

Set Output Amplitude

The instrument's default function is a 1 kHz, 100 mVpp sine wave (into a 50 Ω termination).

The following steps change the amplitude to 50 mVpp.

  1. Press [Units] > Amp/Offs or High/Low to make sure that you are in Amp/Offs.

    The displayed amplitude is either the power-on value or the amplitude previously selected. When you change functions, the same amplitude is used if it is valid for the new function. To choose whether you want to specify voltage as amplitude and offset or high and low values, press [Units] and then the second softkey. In this case, we will highlight Amp/Offs.

    Change amplitude to High/Low
  2. Enter the magnitude of the desired amplitude.
    Press [Parameters] > Amplitude. Using the numeric keypad, enter the number 50.

    Enter 50 for amplitude
  3. Select the desired units.

    Press the softkey that corresponds to the desired units. When you select the units, the instrument outputs the waveform with the displayed amplitude (if the output is enabled). For this example, press mVpp.

    You can also enter the desired value using the knob and arrows. If you do so, you do not need to use a units softkey. You can easily convert unit types. Simply press [Units] > Ampl As and select the desired units.

    Displayed amplitude units

Set DC Offset Voltage

At power-on, the DC offset is 0 V. The following steps change the offset to –1.5 VDC.

  1. Press [Parameters] > Offset.

    The displayed offset voltage is either the power-on value or the offset previously selected. When you change functions, the same offset is used if the present value is valid for the new function.

    Choose offset to change
  2. Enter the desired offset.
    In this case we will use the numeric keypad to enter –1.5.

    Enter -1.5 for offset
  3. Select the desired units.
    Press the softkey for the desired units. When you select the units, the instrument outputs the waveform with the displayed offset (if the output is enabled). For this example, press V. The voltage will be set as shown below.
    Choose VDC for voltage units

You can also enter the desired value using the knob and arrows.

Set High-Level and Low-Level Values

You can specify a signal by setting its amplitude and DC offset, described above. You can also specify the signal as high (maximum) and low (minimum) values. This is typically convenient for digital applications. In the following example, we will set the high level to 1.0 V and the low level to 0.0 V.

  1. Press [Units] > Ampl/Offs to toggle to High/Low as shown below.
  2. Press the [Parameters] > High Level. Using the numeric keypad or knob and arrows, select a value of 1.0 V. (If you are using the keypad, you will need to select the V unit softkey to enter the value.)
    Enter +1.000 for High Level
  3. Press the Low Level softkey and set the value.
    Again, use the numeric keypad or the knob to enter a value of 0.0 V.
    Enter 0.0 for Low Level

These settings (high-level = 1.0 V and low-level = 0.0 V) are equivalent to setting an amplitude of 1.0 Vpp and an offset of 500 mV.

Output a DC Voltage

You can output a constant DC voltage, from -5 V to +5 V into 50 Ω, or -10 V to +10 V into a high impedance load.

  1. Press [Waveforms] > More > DC.
    The Offset value becomes selected.
    Enter DC volts
  2. Enter the desired voltage offset.
    Enter 1.0 with the numeric keypad or knob, and press the V softkey if you used the keypad.
    Enter 1.0 DCV

Set Duty Cycle of a Square Wave

The power-on default for square wave duty cycle is 50%. The duty cycle is limited by the minimum pulse width specification of 16 ns on the 33500 Series, or 5 ns up to 4 Vpp and 8 ns up to 10 Vpp on the 33600 Series. The following procedure changes the duty cycle to 75%.

  1. Select the square wave function.
    Press [Waveforms] > Square.
  2. Press the Duty Cycle softkey.
    The displayed duty cycle is either the power-on value or the percentage previously selected. The duty cycle represents the amount of time per cycle that the square wave is at a high level.
    Enter duty cycle
  3. Enter the desired duty cycle.
    Using the numeric keypad or the knob and arrows, select a duty cycle value of 75. If you are using the numeric keypad, press Percent to finish the entry. The instrument adjusts the duty cycle immediately and outputs a square wave with the specified value (if the output is enabled).
    Square wave with 75% duty cycle

Configure a Pulse Waveform

You can configure the instrument to output a pulse waveform with variable pulse width and edge time. The following steps configure a 500 ms periodic pulse waveform with a pulse width of 10 ms and edge times of 50 ns.

  1. Select the pulse function.
    Press [Waveforms] > Pulse to select the pulse function.
  2. Set the pulse period.
    Press the [Units] key and then press Frequency/Period to choose Period. Then press [Parameters] > Period. Set the period to 500 ms.
    Select period for pulse
  3. Set the pulse width.
    Press [Parameters] > Pulse Width. Then set the pulse width to 10 ms. The pulse width represents the time from the 50% threshold of the rising edge to the 50% threshold of the next falling edge.
    Set pulse width to 10 ms
  4. Set the edge time for both edges.
    Press the Edge Times softkey and then set the edge time for both the leading and trailing edges to 50 ns. The edge time represents the time from the 10% threshold to the 90% threshold of each edge.

Select a Stored Arbitrary Waveform

There are nine built-in arbitrary waveforms stored in non-volatile memory. They are Cardiac, D-Lorentz, Exponential Fall, Exponential Rise, Gaussian, Haversine, Lorentz, Negative Ramp, and Sinc.

This procedure selects the built-in "exponential fall" waveform from the front panel. For information on creating a custom arbitrary waveform, refer to Set Up Arbitrary Waveform.

  1. Press [Waveforms] > Arb > Arbs.
  2. Choose Select Arb and use the knob to select Exp_Fall. Press Select.
    After selecting Exp_Fall

Use Built-in Help System

The built-in help system provides context-sensitive help on any front panel key or menu softkey. A list of help topics is also available to assist you with several front panel operations.

View the help information for a function key

Press and hold any softkey or front panel key, such as [Waveforms]. If the message contains more information than will fit on the display, press the down arrow softkey or use the knob to view the remaining information.

Press Done to exit Help.

View the list of help topics.

Press [System] > Help to view the list of available help topics. To scroll through the list, press the up and down arrow softkeys or use the knob. Select the topic Get HELP on any key and then press Select. Note that the topics may vary from the list shown below, depending on model and firmware version.

Press Done to exit Help.

View the help information for displayed messages.

Whenever a limit is exceeded or any other invalid configuration is found, the instrument displays a message. The built-in help system provides additional information on the most recent message. Press [System] > Help. Then select the topic View the last message displayed, and press Select.

Sample error message

Press Done to exit Help.

Note

Local Language Help

All messages, context-sensitive help, and help topics are available in English, Chinese, French, German, Japanese, Korean, and Russian. Softkey labels and status line messages are not translated. To select the language, press [System] > System Setup > User Settings > Help Lang. Then select the desired language.

Rack Mount the Instrument

You can mount the instrument in a standard 19-inch rack cabinet using one of two optional kits, each of which includes instructions and mounting hardware. Any Keysight System II instrument of the same size can be rack-mounted beside the instrument.

Note

Remove the carrying handle, and the front and rear rubber bumpers, before rack-mounting the instrument.

To remove the handle, rotate it to vertical and pull the ends outward.

To remove the rubber bumper, stretch a corner and then slide it off.

Symmetry 0 | Symmetry 100
Front | Rear (bottom view)

To rack mount a single instrument, order adapter kit 5063-9240.
Picture of 5063-9240

To rack mount two instruments side-by-side, order lock-link kit 5061-8769 and flange kit 5063-9212. Be sure to use the support rails in the rack cabinet.
5061-8769 picture

Note

To prevent overheating, do not block airflow to or from the instrument. Air enters at the rear of the instrument and exits at both sides and the bottom. Ensure that at least one side is unblocked to allow the ventilation air to exhaust freely. Do not block the fan on the instrument rear panel.

The 33600 Series instrument's fan speed runs at a constant speed up to an ambient temperature of 28 °C and increases when the ambient temperature goes above 28 °C.

The 33600 Series instruments monitor critical internal temperatures and will shut down if limits are exceeded. Failure of ventilation could result in shutdown.


Front-Panel Menu Reference

Front Panel Menu Operation

This section introduces front panel keys and menus. See Features and Functions, Front Panel Menu Reference, LAN Configuration Procedure, and Set Up an Arbitrary Waveform for additional front panel operation information.

  • Select Output Termination
  • Reset the Instrument
  • Output a Modulated Waveform
  • Output an FSK Waveform
  • Output a PWM Waveform
  • Output a Frequency Sweep
  • Output a Burst Waveform
  • Trigger a Sweep or Burst
  • Store or Retrieve the Instrument State

Select Output Termination

The instrument has a fixed series output impedance of 50 Ω to the front panel channel connectors. If the actual load impedance differs from the value specified, the displayed amplitude and offset levels will be incorrect. The load impedance setting is simply a convenience to ensure that the displayed voltage matches the expected load.

  1. Press a channel output key to open the channel configuration screen. Note that the current output termination values (both 50 Ω in this case) appear on the tabs at the top of the screen.
  2. Begin specifying the output termination by pressing Output Load.
    Specify channel load
  3. Select the desired output termination either by using the knob or numeric keypad to select the desired load impedance or by pressing Set to 50 Ω or Set to High Z.

Reset the Instrument

To reset the instrument to its factory default state, press [System] > Set to Defaults > Yes.

Output a Modulated Waveform

A modulated waveform consists of a carrier waveform and a modulating waveform. In AM (amplitude modulation), the carrier amplitude is varied by the modulating waveform. For this example, you will output an AM waveform with 80% modulation depth. The carrier will be a 5 kHz sine wave and the modulating waveform will be a 200 Hz sine wave.

  1. Select the function, frequency, and carrier amplitude.
    Press [Waveforms] > Sine. Press the Frequency, Amplitude, and Offset softkeys to configure the carrier waveform. For this example, select a 5 kHz sine wave with an amplitude of 5 Vpp, with 0 V offset.

    Note that you may specify amplitude in Vpp, Vrms or dBm.
  2. Select AM.
    Press [Modulate] and then select AM using the Type softkey. Then press the Modulate softkey to turn modulation on. Notice that the [Modulate] key is illuminated, and the status message "AM Modulated by Sine" appears at the top left of the display.
  3. Set the modulation depth.
    Press the AM Depth softkey and then set the value to 80% using the numeric keypad or the knob and arrows.
  4. Select the modulating waveform shape.
    Press Shape to select the modulating waveform's shape. For this example, select a sine wave.
  5. Press AM Freq. On the 33500 Series, you will first have to press the More softkey to get to the correct menu. Set the value to 200 Hz using the numeric keypad or the knob and arrows. Press Hz to finish entering the number if you are using the numeric keypad.

Output an FSK Waveform

You can configure the instrument to "shift" its output frequency between two preset values (called the "carrier frequency" and the "hop frequency") using FSK modulation. The rate at which the output shifts between these two frequencies is determined by the internal rate generator or the signal level on the rear-panel Ext Trig connector. For this example, you will set the "carrier" frequency to 5 kHz and the "hop" frequency to 500 Hz, with an FSK rate of 100 Hz.

FSK oscilloscope image

  1. Select the function, frequency, and carrier amplitude.
    Press [Waveforms] > Sine. Press the Frequency, Amplitude, and Offset softkeys to configure the carrier waveform. For this example, select a 5 kHz sine wave with an amplitude of 5 Vpp, with 0 V offset.
  2. Select FSK.
    Press [Modulate] and then select FSK using the Type softkey. Then press the Modulate softkey to turn modulation on. Notice the status message "FSK Modulated" at the top left of the display.
  3. Set the "hop" frequency.
    Press the Hop Freq softkey and then set the value to 500 Hz using the numeric keypad or the knob and arrows. If you use the numeric keypad, be sure to finish the entry by pressing Hz.
    Set hop frequency to 500
  4. Set the FSK "shift" rate.
    Press the FSK Rate softkey and then set the value to 100 Hz using the numeric keypad or the knob and arrows.
    Set FSK rate to 100 Hz

At this point, the instrument outputs an FSK waveform if the channel output is enabled.

Output a PWM Waveform

You can configure the instrument to output a pulse width modulated (PWM) waveform. PWM is only available for the Pulse waveform, and the pulse width varies according to the modulating signal. The amount by which the pulse width varies is called the width deviation, and it can be specified as a percentage of the waveform period (that is, duty cycle) or in units of time. For example, if you specify a pulse with 20% duty cycle and then enable PWM with a 5% deviation, the duty cycle varies from 15% to 25% under control of the modulating signal.

To change from pulse width to pulse duty cycle, press [Units].

For this example, you will specify a pulse width and pulse width deviation for a 1 kHz pulse waveform with a 5‑Hz sine wave modulating waveform.

  1. Select the carrier waveform parameters.
    Press [Waveforms] > Pulse. Use the Frequency, Amplitude, Offset, Pulse Width and Edge Times softkeys to configure the carrier waveform. For this example, select a 1 kHz pulse waveform with an amplitude of 1 Vpp, zero offset, a pulse width of 100 µs, and an edge time of 50 ns (both leading and trailing).
    All pulse settings
  2. Select PWM.
    Press [Modulate] > Type > PWM. Then press the first softkey (Modulate) to turn modulation on. Notice the status message "PWM Modulated by Sine" in the upper-left corner of the display.
    PWM modulate by sine
  3. Set the width deviation.
    Press the Width Dev softkey and set the value to 20 µs using the numeric keypad or the knob and arrows.
    Set width deviation to 20 microseconds
  4. Set the modulating frequency.
    Press the PWM Freq softkey and then set the value to 5 Hz using the numeric keypad or the knob and arrows.
    Set PWM frequency to 5 Hz
  5. Select the modulating waveform shape.
    Press Shape to select the modulating waveform's shape. For this example, select a sine wave.

To view the actual PWM waveform, you would need to output it to an oscilloscope. If you do this, you will see how the pulse width varies, in this case, from 80 to 120 µs. At a modulation frequency of 5 Hz, the deviation is easily visible.

Output a Frequency Sweep

In the frequency sweep mode, the instrument moves from the start frequency to the stop frequency at a sweep rate, which you specify. You can sweep up or down in frequency, and with either linear or logarithmic spacing, or using a list of frequencies. For this example, you will output a swept sine wave from 50 Hz to 5 kHz.

  1. Select the function and amplitude for the sweep.
    For sweeps, you can select sine, square, ramp, pulse, triangle, PRBS waveforms, or arbitrary waveforms (noise and DC are not allowed). For this example, select a sine wave with an amplitude of 5 Vpp.
    Sine wave 5 Vpp
  2. Select the sweep mode.
    Press [Sweep] and verify that the linear sweep mode is currently selected on the second softkey. Press the Sweep softkey to turn sweep on. Notice the Linear Sweep status message at the top of the tab for the current channel. The button is also illuminated.
  3. Set the start frequency.
    Press Start Freq and then set the value to 50 Hz using the numeric keypad or the knob and arrows.
    Set start frequency to 50
  4. Set the stop frequency.
    Press Stop Freq and set the value to 5 kHz using the numeric keypad or the knob and arrows.

At this point, the instrument outputs a continuous sweep from 50 Hz to 5 kHz if output is enabled.

Set stop frequency to 5 kHz

You can also set the sweep frequency boundaries of the sweep using a center frequency and frequency span. These parameters are similar to the start frequency and stop frequency (above) and they provide added flexibility. To achieve the same results, set the center frequency to 2.525 kHz and the frequency span to 4.950 kHz.

Sweep parameter units

To generate a frequency sweep, press [Trigger] twice. The first press puts the trigger in manual mode, and the second one sends a trigger. For more information, see Trigger Sweep or Burst.

Output a Burst Waveform

You can configure the instrument to output a waveform with for a specified number of cycles, called a burst. You can control the amount of time that elapses between bursts with the internal timer or the signal level on the rear-panel Ext Trig connector. For this example, you will output a three-cycle sine wave with a 20 ms burst period.

Burst scope image

  1. Select the function and amplitude for the burst.
    For burst waveforms, you can select sine, square, ramp, pulse, arbitrary waveforms, triangle, or PRBS. Noise is allowed only in the "gated" burst mode and DC is not allowed. For this example, select a sine wave with an amplitude of 5 Vpp.
    Sine wave 5 Vpp
  2. Select the burst mode.
    Press [Burst] > Burst Off/On. Notice that a status message N Cycle Burst, Trig Imm is shown in the tab of the current channel.
    Burst showing in tab
  3. Set the burst count.
    Press # of Cycles and set the count to "3" using the numeric keypad or knob. Press Enter to finish data entry if you are using the numeric keypad.
    Set cycle count to 3
  4. Set the burst period.
    Press Burst Period and set the period to 20 ms using the numeric keypad or the knob and arrows. The burst period sets the time from the start of one burst to the start of the next burst. At this point, the instrument outputs a continuous three-cycle burst at 20 ms intervals.
    Set burst period to 20 ms

You can generate a single burst (with the specified count) by pressing the [Trigger] key. For more information, see Trigger Sweep or Burst.

You can also use the external gate signal to create gated bursts, where a burst is produced while a gate signal is present on the input.

Trigger a Sweep or Burst

You can select one of four different types of triggers from the front panel for sweeps and bursts:

  • Immediate or "automatic" (default): instrument outputs continuously when sweep or burst mode is selected.
  • External: triggering controlled by rear panel Ext Trig connector.
  • Manual: initiates one sweep or burst each time you press [Trigger]. Continue pressing [Trigger] to re-trigger instrument.
  • Timer: issues one or more triggers a fixed time amount apart.

If sweep or burst is on, pressing [Trigger] displays the trigger menu. An illuminated [Trigger] key (solid or blinking) indicates that one or both channels are awaiting a manual trigger. Solid illumination occurs when the trigger menu is selected, and flashing illumination occurs when the trigger menu is not selected. The [Trigger] key is disabled when the instrument is in remote.

Pressing [Trigger] when it is solidly illuminated causes a manual trigger. Pressing [Trigger] when it is flashing selects the trigger menu; a second press causes a manual trigger.

Store or Retrieve the Instrument State

You can store instrument states in any number of state files, (extension .sta). You can do this for backup purposes, or you can save your state to a USB drive and load it on another instrument to have instruments with matching configurations. A stored state contains the selected function, frequency, amplitude, DC offset, duty cycle, symmetry, and any modulation or burst parameters in use. The instrument does not store volatile arbitrary waveforms.

  1. Select the desired storage location.
    System key Store - Recall softkey Store State softkey
  2. Press Name and specify the name for the selected location.

    Keypad and knob

    33500 Series
    To add characters, press the right-cursor key until the cursor is to the right of the existing name and then turn the knob. To delete a character, rotate the knob until you get to the blank character before the capital A. To delete all characters from the cursor position to the end of the line, press [+/-]. You can enter numbers directly from the numeric keypad.

    33600 Series
    Use the front panel right and left arrows (under the knob) to select the characters to edit. You can go past the final character to add a new character to the end. Then use the knob to select the desired character and use the arrows to move to the next character to edit.

    You can delete one or more characters with the Delete Char and Clear Entry softkeys.

    Press Done when you have finished entering the name.
  3. Store the instrument state.
    Store State softkey

To restore (retrieve) a stored state:
Store - Recall softkey Recall State softkey


Front-Panel Menu Reference

This chapter begins with an overview of the front panel menus. The remainder of this chapter contains examples of using the front panel menus.

Selects waveform

  • Sine
  • Square
  • Ramp
  • Pulse
  • Arbitrary
  • Triangle
  • Noise
  • PRBS
  • DC

Configures waveform-specific parameters

  • Period/Frequency
  • Amplitude or High and Low Voltage
  • Offset
  • Phase
  • Duty Cycle
  • Symmetry
  • Pulse Width
  • Edge Times
  • Arbitrary Waveform
  • Sample Rate
  • Filter
  • Arb Phase
  • Bandwidth
  • PRBS Data
  • Bit Rate

Specifies unit and parameter preferences

  • Arb Rate: Sa/s, Freq or Period
  • Voltage as Amplitude/Offset or High/Low
  • Voltage units as Vpp, Vrms, or dBm
  • Pulse Width or Duty Cycle
  • Burst Phase as Degrees, Radians, or Seconds
  • Arb Phase as Degrees, Radians, Seconds, or Samples
  • Frequency sweep as Center/Span or Start/Stop

Configures modulation parameters

  • Modulation on or off
  • Modulation type: AM, FM, PM, PWM, BPSK, FSK, or Sum
  • Modulation source
  • Modulation parameters (vary by modulation type)

Configures frequency sweep parameters

  • Sweep on or off
  • Sweep type: Linear, logarithmic or frequency list
  • Sweep time
  • Start/stop frequencies or center/span frequencies
  • Dwell, hold, and return times

Configures burst parameters

  • Burst on or off
  • Burst mode: triggered (N Cycle) or externally-gated
  • Cycles per burst (1 to 100,000,000 or infinite)
  • Starting phase angle of burst (-360° to +360°)
  • Burst period

Store - Recall softkey

Stores and recalls instrument states

  • Store instrument states in non-volatile memory.
  • Assign custom names to storage locations.
  • Recall stored instrument states.
  • Delete stored instrument states.
  • Select the instrument’s power-on configuration (last power-down or factory default).

I/O Config softkey

Configures instrument I/O interfaces

  • Turn LAN on and off
  • Configure LAN (IP address and network configuration)
  • Reset the LAN
  • Specify USB settings
  • Select GPIB address

Instr Setup softkey

Performs system administration tasks

  • Perform self-test
  • Calibrate instrument
  • Clear instrument memory (NISPOM secure)
  • Install licensed features
  • Update firmware

System Setup Softkey

Configures system-related parameters

  • Set screen layout
  • Select local language for front panel messages and help text
  • Select how periods and commas are used in numbers on display
  • Turn display on and off
  • Enable or disable error beeper
  • Enable disable keypad click
  • Enable or disable screen saver
  • Adjust display brightness
  • Set date and time
  • Manage files and folders (copy, rename, delete, screen capture, and so on)
  • Configure 10 MHz reference oscillator

Shows list of Help topics

  • View last message displayed
  • View remote command error queue
  • Get help on any key
  • Learn how to obtain technical support
  • View "about" data - serial number, IP address, firmware version, and so on

Enables and configures channels

  • Turn channel on and off
  • Specify which channel is the focus of the menus
  • Select output termination (1 Ω to 10 kΩ, or Infinite)
  • Enable / disable amplitude autoranging
  • Select waveform polarity (normal or inverted)
  • Specify voltage limits
  • Specify whether output is normal or gated
  • Configure dual channel operation (coupling, tracking, and combine)

Configures trigger settings and sync output signal

  • Perform a manual trigger, when illuminated
  • Specify the trigger source for sweep, burst or arbitrary waveform advance
  • Specify the trigger voltage level, count, and delay
  • Specify the slope (rising or falling edge) for an external trigger source
  • Specify the slope (rising or falling edge) of the trigger output signal
  • Enable / disable the signal output from the "Sync" connector
  • Specify the Sync source, polarity, mode, marker point, and so on


LAN Configuration Procedure

There are several parameters that you might need to set to establish network communication using the LAN interface. Primarily, you will need to establish an IP address. You might need to contact your network administrator for help in establishing communication with the LAN interface.

  1. Select the "I/O" menu.
    Press [System] > I/O Config.
  2. Select the LAN Settings menu.
    Press the LAN Settings softkey.

    You can select Modify Settings to change the LAN settings, or you can turn LAN Services on and off or restore the LAN settings to default values.
    LAN settings menu

    This screen reflects the 33500 Series display. The 33600 Series also includes a LAN Status indicator in the upper right corner to indicate whether the LAN connection is good or faulty.
  3. Press Modify Settings.
    Modify LAN settings

    To access most items on this screen, use the first softkey to switch from DHCP to Manual. With DHCP on, an IP address will automatically be set by DHCP (Dynamic Host Configuration Protocol) when you connect the instrument to the network, provided the DHCP server is found and is able to do so. DHCP also automatically deals with the subnet mask and gateway address, if required. This is typically the easiest way to establish LAN communication for your instrument. All you need to do is leave DHCP on. Contact your LAN administrator for details.
  4. Establish an "IP Setup."
    If you are not using DHCP (if the first softkey is set to Manual), you must establish an IP setup, including an IP address, and possibly a subnet mask and gateway address. The IP Address and Subnet Mask buttons are on the main screen, and you press More to configure the Gateway.

    Main LAN configuration screen

    Contact your network administrator for the IP address, subnet mask, and gateway to use. All IP addresses take the dot-notation form "nnn.nnn.nnn.nnn" where "nnn" in each case is a byte value in the range 0 through 255. You can enter a new IP address using the numeric keypad (not the knob). Just type in the numbers and the period delimiters using the keypad. Use the left cursor key as a backspace key. Do not enter leading zeros.
  5. Configure the "DNS Setup" (optional)
    DNS (Domain Name Service) is an Internet service that translates domain names into IP addresses. Ask your network administrator whether DNS is in use, and if it is, for the host name, domain name, and DNS server address to use.
  1. Set the "hostname." Press Host Name and enter the hostname. A hostname is the host portion of the domain name, which is translated into an IP address. The hostname is entered as a string using the knob and cursor keys to select and change characters. The hostname may include letters, numbers, and dashes ("-"). You can use the keypad for the numeric characters only.
  2. Set the "DNS Server" addresses. From the LAN configuration screen, press More to go to the second of three sets of softkeys.
    DNS configuration screen

    Enter the Primary DNS and Second DNS. See your network administrator for details.

More about IP Addresses and Dot Notation

Dot-notation addresses ("nnn.nnn.nnn.nnn" where "nnn" is a byte value from 0 to 255) must be expressed with care, as most PC web software interprets byte values with leading zeros as octal (base 8) numbers. For example, "192.168.020.011" is actually equivalent to decimal "192.168.16.9" because ".020" is interpreted as "16" expressed in octal, and ".011" as "9". To avoid confusion, use only decimal values from 0 to 255, with no leading zeros.


Set Up Arbitrary Waveform

Set Up an Arbitrary Waveform

The instrument includes an embedded waveform editor that allows you to create and edit arbitrary waveforms. You can create these waveforms by editing voltage values directly or by using an combination of up to 12 different kinds of standard waveforms.

The following tutorial creates and edits a basic waveform.

Insert Built-in Waveforms

  1. Start the embedded waveform editor by pressing [Waveforms] > Arb > Arbs. Press Edit New, accept the default file name, and then Start Editor. You now have a 0 VDC waveform of exactly 8 points (33500 Series) or 32 points (33600 Series).
    Default waveform

    The rest of this tutorial is based on the embedded waveform editor in a 33500 Series instrument, which has a minimum waveform size of 8 points. If you are using this tutorial on a 33600 Series instrument, please note that the minimum waveform size for the embedded waveform editor is 32 points.
  2. Press Insert Built-in > Choose Wave. Use the knob or the arrows below the knob to select D-Lorentz and press OK. Use the keypad and the V softkey that appears when you start typing on the keypad to set the Amplitude to 2 V, and then press OK. The waveform now has 100 additional points, as the D-Lorentz waveform of 100 points was inserted in front of the initial waveform.
    After inserting D-Lorentz
  3. Suppose that you want to undo the change that you just made. Press [System] > Undo. You are now back to the original 0 V waveform.
    After undoing D-Lorentz
  4. To put the D-Lorentz waveform back, press Redo. Then press Done to exit.
    After redoing D-Lorentz
  5. Now we will insert a sine wave. Begin by pressing Choose Wave. Make sure Sine (the default) is highlighted, and press OK. For help in understanding the various parameters on the screen, press Parameter Help. Then press Done to exit the help screen.
    Set up sine parameters
  6. Using the numeric keypad and the up and down arrow softkeys, set the Amplitude to 3.5 V, the Cycles to 4, and the Points to 200. Leave all other settings at their default values and press OK.
    After inserting sine wave

  7. Notice that the first softkey, Select Point # is highlighted. Put the marker on the 270th waveform point by using the numeric keypad to enter the number 270 and pressing Enter.
    Highlight point 270
  8. Press Choose Wave, select Square, and then press OK. Set the Amplitude to 3 V, the Offset to -2 V, the Cycles to 8, and the Points to 100. Press OK. Notice that the 8 square wave cycles have been inserted, beginning at the marker. Press Done.
    After inserting square wave

Edit Waveform Characteristics

  1. Press Edit Params and then set the Sampling Rate to 100 Sa/s. Press Cycle Period and notice that it has been set to 4.08 seconds. This is because you have 408 sample points in the waveform, and the sample rate is 100 Sa/s.
    Set sample rate to 100
  2. Change the Cycle Period to 2.04 seconds and then press Sampling Rate. It will now be set to 200 Sa/s in order to play the 408 point waveform in 2.04 seconds.
    Cut cycle period in half
  3. Press Done to exit the parameter editing screen. Press Edit Points and notice that the Point # softkey is highlighted. Enter the number 160 and press Enter to move the marker.
    Set marker to 160
  4. Press Voltage and change the voltage of the selected point to 4.2 V. Press Point # and change the point marker to 150 to move the marker off the point. When you press Enter to finish entering point 150, you will see the 4.2 V anomaly in the wave that you just created at point 160.
    Change voltage to 4.2

Zoom and Pan

  1. To see the point in detail, press [System] > Pan/Zoom Control. Notice that the first softkey is set to Horizontal, meaning that the zooming that we are about to do will be along the horizontal (time) axis. Change the Zoom to 500%, and the sine wave anomaly will be more obvious.
    Set horizontal zoom to 500
  2. Now set the first softkey to Vertical to zoom vertically. Set the Zoom to 500%. Notice that we have zoomed in on the voltage axis, but we are too low to see the 4.2 V anomaly in the sine wave.
    Set vertical zoom to 500
  3. Press Pan and set the Pan to 3 V in order to move higher on the waveform. The 4.2 V point is now clearly visible.
    Pan to 3 V
  4. To see the entire waveform again, press Show All. Then press Done and Done again to return to the Edit Points screen.
    After show all

Insert, Remove, Copy and Paste Points

  1. Press Insert Point 15 times and watch the display carefully. You will see 15 new waveform points at the same voltage level.
    Insert point 15 times
  2. Change the Point # to 220 and press Remove Point 20 times, watching the display carefully as you do so in order to see the points being removed from the waveform.
    Remove point 20 times
  3. You can also edit points by using a table of voltages. Press Advanced Edit > Edit Via Table. Set Point # to 200, and then set the Voltage for point 200 to 3 V. Use the knob to move between rows and set the Voltage for points 205 and 210 to 3 V. Press Done.
    Edit via table 200-210
  4. Notice the three 3 V spikes that you just made in the waveform at points 200, 205, and 210.
    Edit via table 200-210
  5. Press Cut/Copy Paste, and set Marker 1 to 150. Then press the first softkey and change the Marker to Marker 2. Set Marker 2 to 300. The range defined by the markers is now highlighted in black.
    Set copy markers
  6. Press Copy, then Paste, and then At Start. Notice that section you copied is now duplicated at the beginning of the waveform.
    Paste at start
  7. Now press Paste > At End. The same section of the waveform now also appears at the very end.
    Paste at end
  8. Now press Paste and change the Point # to 500. Then press OK, and the same portion of the waveform will be pasted in at point 500. Press Done to leave the Cut/Copy Paste menu.
    Paste at 500

Perform Math

The embedded waveform editor allows you to perform mathematical operations on the waveform. First you set markers to define the range of the waveform that you want to modify. You can then add, subtract or multiply that portion of the waveform by another waveform, or you can transform the waveform in ways that do not involve other waveforms.

  1. Press Perform Math. Set Marker 1 to 400 and Marker 2 to 500.
    Set markers to 400 and 500
  2. Press Add, then select Haversine and OK. Set the Amplitude to 3 V, the Offset to 0 V, and press OK. Notice that the highlighted section now rises in the middle as a result of the Haversine addition.
    Add Haversine
  3. Now press Multiply and select the Sine wave (press OK). Set the Cycles to 2 and press OK.
    Multiply by sine
  4. Now set Marker 1 to 200 and Marker 2 to 600.
    Set markers to 200 and 600
  5. Press Advanced Math > Mirror > OK.
    Advanced math - mirror
  6. Continue learning about the interface by trying other Advanced Math features, such as Invert, Absolute, Scale, and so on. Press Operation Help for more information.


Features and Functions

This section contains details on instrument features, including front panel and remote interface operation. You may want to read Front Panel Menu Reference first. See SCPI Programming Reference for details on SCPI commands and queries. This section covers:

Output Configuration

Pulse Waveforms

Amplitude Modulation (AM) and Frequency Modulation (FM)

Phase Modulation (PM)

Frequency-Shift Keying (FSK) Modulation

Pulse Width Modulation (PWM)

Sum Modulation

Frequency Sweep

Burst Mode

Triggering

Dual Channel Operations

IQ Player (Optional)

System-Related Operations

Remote Interface Configuration

External Timebase Reference

Embedded Waveform Editor

Throughout this document, "default" states and values are identified. These are the power-on default states provided you have not enabled the power-down recall mode (see Instrument State Storage).


Output Configuration

This section describes output channel configuration. Many commands associated with output configuration start with SOURce1: or SOURce2: to indicate a certain channel. If omitted, the default is channel 1. For example, VOLT 2.5 sets the output on channel 1 to 2.5 V, and SOUR2:VOLT 2.5 does the same for channel 2.

The instrument's display includes a "tab" for each channel that summarizes various aspects of each channel's output configuration:
Channel configuration tabs

On a two-channel instrument, the tab for channel 1 will be yellow, and the tab for channel 2 will be green.

Output Function

The instrument includes eight standard waveforms: sine, square, ramp, pulse, triangle, noise, PRBS (pseudo-random binary sequence), and DC. There are also nine built-in arbitrary waveforms, and you can create custom waveforms with the embedded waveform editor.

The table below shows which functions are allowed (•) with modulation, sweep, and burst. Selecting a function that is not allowed with a modulation or mode disables the modulation or mode.

Carrier | AM | FM | PM | FSK | BPSK | PWM | Sum | Burst | Sweep
Sine and Square | • | • | • | • | • |  | • | • | •
Pulse | • | • | • | • | • | • | • | • | •
Triangle and Ramp | • | • | • | • | • |  | • | • | •
Gaussian Noise | • |  |  |  |  |  | • | •a |
PRBS | • | • | • |  |  |  | • | • |
Arbitrary Waveform | • | • | •b |  | •b |  | • | • | •
Sequence | • |  |  |  |  |  | • |  |

(a) Gated burst only

(b) Applies to sample clock, not whole waveform

  • Frequency Limitations: Changing functions may change the frequency to meet the new function's frequency limits.
  • Amplitude Limitations: When the output units are Vrms or dBm, changing functions may lower the amplitude to the maximum for the new function due to variation in waveform shapes. For example, a 5 Vrms square wave (into 50 Ω) changed to a sine will decrease to 3.536 Vrms (sine’s upper limit).
  • Amplitude and offset cannot combine to exceed the instrument’s capability. The one you set last may be changed to stay within limits.
  • You may protect a device under test (DUT) by specifying upper and lower output voltage limits.
  • Front Panel:

    Channel key Output softkey (Off) Output softkey (On)

    To select another waveform:
    Waveforms key
  • For example, to specify a DC signal:
    Waveforms key More softkey DC softkey

    To produce the DC output:
    Channel key Output softkey (Off) Output softkey (On)
  • SCPI: [SOURce[1|2]:]FUNCtion <function>

The APPLy command configures a waveform with one command.

Output Frequency

The output frequency range depends on the function, model, and output voltage, as shown here. The default frequency is 1 kHz for all functions, and the minimum frequencies are shown in the table below.

Function | Minimum Frequency
Sine | 1 µHz
Square | 1 µHz
Ramp/Tri. | 1 µHz
Pulse | 1 µHz
PRBS | 1 µbps
Arbitrary | 1 µSa/s
  • Frequency Limitations: Changing functions may change the frequency to meet the new function's frequency limits. Arbitrary waveforms retain their last frequency setting.
  • Burst Limitation: For internally-triggered bursts, the minimum frequency is 126 µHz.
  • Duty Cycle Limitations: For Square and Pulse, Duty Cycle on the 33500 Series is limited by the 16-ns minimum pulse width specification. For example, at 1 kHz, Duty Cycle may be set as low as 0.01%, because that would result in a pulse width of 100 ns. At 1 MHz, the minimum Duty Cycle is 1.6%, and at 10 MHz it is 16%. Changing to a frequency that cannot produce the current duty cycle will adjust the duty cycle to meet the minimum pulse width specification.

    On the 33500 Series, the minimum pulse width is 16 ns. On the 33600 Series, the minimum pulse width is 5 ns up to 4 Vpp and 8 ns up to 10 Vpp.
  • Front Panel:
    Parameters key Frequency softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}

The APPLy command configures a waveform with one command.

Output Amplitude

The default amplitude is 100 mVpp (into 50 Ω) for all functions.

  • Offset Voltage Limitations: The relationship between amplitude and offset is shown below. Vmax is ±5 V for a 50 Ω load or ±10 V for a high-impedance load.

    Vpp < 2(Vmax – |Voffset|)
  • Limits Due to Output Termination: If the amplitude is 10 Vpp and you change the output termination setting from 50 Ω to "high impedance" (OUTPut[1|2]:LOAD INF), the displayed amplitude doubles to 20 Vpp. Changing from "high impedance" to 50 Ω halves the displayed amplitude. The output termination setting does not affect the actual output voltage; it only changes the values displayed and queried from the remote interface. Actual output voltage depends on the connected load.
  • Limits Due to Units Selection: Amplitude limits are sometimes determined by the output units selected. This may occur when the units are Vrms or dBm due to the differences in various functions' crest factors. For example, if you change a 5 Vrms square wave (into 50 Ω) to a sine wave, the instrument will adjust the amplitude to 3.536 Vrms (the upper limit for sine in Vrms). The remote interface will also generate a "Settings conflict" error.
  • You can set the output amplitude in Vpp, Vrms, or dBm. You cannot specify output amplitude in dBm if output termination is set to high impedance. See Output Units for details.
  • Arbitrary Waveform Limitations: For arbitrary waveforms, amplitude is limited if the waveform data points do not span the full range of the output DAC (Digital-to-Analog Converter). For example, the built-in "Sinc" waveform does not use the full range of values, so its maximum amplitude is limited to 6.087 Vpp (into 50 Ω).
  • Changing amplitude may briefly disrupt output at certain voltages due to output attenuator switching. The amplitude is controlled, however, so the output voltage will never exceed the current setting while switching ranges. To prevent this disruption, disable voltage autoranging using VOLTage:RANGe:AUTO OFF. The APPLy command automatically enables autoranging.
  • Setting the high and low levels also sets the waveform amplitude and offset. For example, if you set the high level to +2 V and the low level to -3 V, the resulting amplitude is 5 Vpp, with a -500 mV offset.
  • A DC signal's output level is controlled by the offset voltage (DC Offset Voltage). The DC level may be between ±5 V into a 50 Ω load or ±10 V with a high-impedance load.
  • Front Panel:
    Parameters key Amplitude softkey Keypad and knob

    To use a high level and low level instead:
    Units key Amp/Offs - High/Low softkey (Amp/Offs) Amp/Offs - High/Low softkey (High/Low)
  • SCPI:
    [SOURce[1|2]:]VOLTage {<amplitude>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]VOLTage:HIGH {<voltage>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]VOLTage:LOW {<voltage>|MINimum|MAXimum|DEFault}

The APPLy command configures a waveform with one command.

DC Offset Voltage

The default offset is 0 V for all functions.

  • Limits Due to Amplitude: The relationship between offset voltage and output amplitude is shown below. The peak output voltage (DC plus AC) cannot exceed the instrument output rating (±5 V into 50 Ω load, or ±10 V into an open circuit).
  • The relationship between offset voltage and output amplitude is shown below. Vmax is the maximum peak voltage for the selected output termination (5 V for a 50 Ω load or 10 V for a high-impedance load).

    |Voffset| < Vmax - Vpp/2

    If the specified offset voltage is not valid, the instrument will adjust it to the maximum DC voltage allowed with the specified amplitude. From the remote interface, a "Data out of range" error will also be generated.
  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details. Changing the output termination setting does not change the voltage present at the output terminals of the instrument. This only changes the displayed values on the front panel and the values queried from the remote interface. The voltage present at the instrument's output depends on the load connected to the instrument. See OUTPut[1|2]:LOAD for details.
  • Arbitrary Waveform Limitations: For arbitrary waveforms, amplitude is limited if the waveform data points do not span the full range of the output DAC (Digital-to-Analog Converter). For example, the built-in "Sinc" waveform does not use the full range of values, so its maximum amplitude is limited to 6.087 Vpp (into 50 Ω).
  • Setting the high and low levels also sets the waveform amplitude and offset. For example, if you set the high level to +2 V and the low level to -3 V, the resulting amplitude is 5 Vpp, with a -500 mV offset.
  • To output a DC voltage level, select the DC voltage function (FUNCtion DC) and then set the offset voltage (VOLTage:OFFSet). Valid values are between ±5 VDC into 50 Ω or ±10 VDC into an open circuit. While the instrument is in DC mode, setting amplitude has no effect.
  • Front Panel:
    Waveforms key More softkey DC softkey Keypad and knob
  • SCPI:
    [SOURce[1|2]:]VOLTage:OFFSet {<offset>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]VOLTage:HIGH {<voltage>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]VOLTage:LOW {<voltage>|MINimum|MAXimum|DEFault}

The APPLy command configures a waveform with one command.

Output Units

Applies to output amplitude only.

  • Output units: Vpp (default), Vrms, or dBm.
  • Setting is volatile.
  • Units selection applies to front panel and remote interface operations. For example, if you select "VRMS" remotely, the units are displayed as "VRMS" on the front panel.
  • Amplitude units cannot be dBm if output termination set to high impedance. Calculating dBm requires finite load impedance. In this case, units are converted to Vpp.
  • You can convert between units. For example, to convert 2 Vpp to Vrms equivalent:
    Units key Ampl as softkey (Vpp) Vrms softkey

    The converted value is 707.1 mVrms for a sine wave.
  • Front Panel:
    Units key Ampl as softkey (Vpp)
  • SCPI: [SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}

Output Termination

The instrument has a fixed series output impedance of 50 Ω to the front panel channel connectors. If the actual load impedance differs from the value specified, the displayed amplitude and offset levels will be incorrect. The load impedance setting is simply a convenience to ensure that the displayed voltage matches the expected load.

  • Output termination: 1 Ω to 10 kΩ, or infinite. The default is 50 Ω. The tab at the top of each channel indicates the value of this setting.
    Tabs showing impedance
  • If you specify a 50 Ω termination but actually terminate into an open circuit, the output will be twice the value specified. For example, if you set the DC offset to 100 mVDC (and specify a 50 Ω load) but terminate into an open circuit, the actual offset will be 200 mVDC.
  • Changing output termination setting, adjusts displayed output amplitude and offset (no error is generated). If the amplitude is 10 Vpp and you change the output termination setting from 50 Ω to "high impedance" (OUTPut[1|2]:LOAD INF), the displayed amplitude doubles to 20 Vpp. Changing from "high impedance" to 50 Ω halves the displayed amplitude. The output termination setting does not affect the actual output voltage; it only changes the values displayed and queried from the remote interface. Actual output voltage depends on the connected load.

    The output load can affect signal quality for pulse or other functions with high-speed transitions. High load resistance can produce reflections.
  • Units are converted to Vpp if output termination is high impedance.
  • You cannot change output termination with voltage limits enabled, because instrument cannot know which termination setting the limits apply to. Instead, disable voltage limits, set the new termination value, adjust voltage limits, and re-enable voltage limits.
  • Front Panel: Channel key Output Load softkey
  • SCPI: OUTPut[1|2]:LOAD {<ohms>|INFinity|MINimum|MAXimum|DEFault}

Duty Cycle (Square Waves)

A square wave’s duty cycle is the fraction of time per cycle that the waveform is at a high level (assuming the waveform is not inverted). (See Pulse Waveforms for pulse duty cycle details.)

Duty cycle 20 percent | Duty cycle 80 percent
20% Duty Cycle | 80% Duty Cycle
  • Duty Cycle:0.01% to 99.99% at low frequencies; range reduced at higher frequency. Stored in volatile memory; default 50%.
  • This setting is remembered when you change to another function. A 50% duty cycle is always used for a modulating square waveform; the duty cycle setting applies only to a square wave carrier.
  • Front Panel:
    Waveforms key Square softkey Duty Cycle softkey Keypad and knob

    If you use the keypad, press Percent to finish:
    Percent softkey
  • SCPI: [SOURce[1|2]:]FUNCtion:SQUare:DCYCle {<percent>|MINimum|MAXimum}

The APPLy command sets the duty cycle to 50%.

Symmetry (Ramp Waves)

Applies to ramp waves only. Symmetry represents the fraction of each cycle that the ramp wave is rising (assuming waveform is not inverted).

Symmetry 0 | Symmetry 100
0% Symmetry | 100% Symmetry
  • The symmetry (default 100%) is stored in volatile memory; and is remembered when you change to and from other waveforms.
  • When ramp is the modulating waveform for AM, FM, PM, or PWM, the symmetry setting does not apply.
  • Front Panel:
    Waveforms key Ramp softkey Symmetry softkey

    Then choose one of the following options. The Symmetry option allows you to use the knob or keypad to specify a value.
    Symmetry choices softkeys

    If you use the keypad, press Percent to finish:
    Percent softkey
  • SCPI: [SOURce[1|2]:]FUNCtion:RAMP:SYMMetry {<percent>|MINimum|MAXimum|DEFault}

The APPLy command sets the symmetry to 100%.

Voltage Autoranging

Autoranging is enabled by default and the instrument selects optimal attenuator settings. With autoranging disabled, the instrument uses the current attenuator settings and does not switch attenuator relays.

  • You can disable autoranging to eliminate momentary disruptions caused by attenuator switching while changing amplitude. However:
  • The amplitude and offset accuracy and resolution (and waveform fidelity) may be adversely affected when reducing the amplitude below a range change that would occur with autoranging on.
  • You may not achieve minimum amplitude with autoranging on.
  • Some instrument specifications do not apply with autoranging off.
  • Front Panel:
    Channel key Range softkey (Auto)
    or
    Channel key Range softkey (Auto) Range softkey (Hold)
  • SCPI: [SOURce[1|2]:]VOLTage:RANGe:AUTO {OFF|0|ON|1|ONCE}

The APPLy command always enables autoranging.

Output Control

By default, channel output is disabled at power on to protect other equipment. To enable a channel's output, see below. When channel output is enabled, the corresponding channel button is lit.

  • If an external circuit applies excessive voltage to a channel output connector, the instrument generates an error message and disables the output. To re-enable output, remove the overload and turn the channel on again.
  • Front Panel:
    Channel key Output softkey (Off) Output softkey (On)
  • SCPI: OUTPut[1|2] {ON|1|OFF|0}

The APPLy command always enables the channel output connector.

Waveform Polarity

In normal mode (default), the waveform goes positive at the beginning of the cycle. Inverted mode does the opposite.

  • As shown below, the waveform is inverted relative to the offset voltage. The offset voltage remains unchanged when the waveform is inverted.

    Without offset voltage | With offset voltage
    No Offset Voltage | With Offset Voltage
  • The Sync signal associated with an inverted waveform is not inverted.
  • Front Panel:
    Channel key Polarity softkey (Normal)
    or
    Channel key Polarity softkey (Normal) Polarity softkey (Inverted)
  • SCPI: OUTPut[1|2]:POLarity {NORMal|INVerted}

Sync Output Signal

A sync output is provided on the front panel Sync connector. All of the standard output functions (except DC and noise) have an associated Sync signal. For applications where you may not want to output the Sync signal, you can disable the Sync connector. The Sync signal may be derived from either output channel in a two-channel instrument.

General Behavior

  • By default, the Sync signal is derived from channel 1 and is routed to the Sync connector (enabled).
  • When the Sync signal is disabled, the output level on the Sync connector is at a logic "low."
  • The polarity of the Sync signal is specified by OUTPut:SYNC:POLarity {INVerted|NORMal}.
  • Inverting a waveform (see Waveform Polarity), does not invert the associated Sync signal .
  • For sine, pulse, ramp, square, and triangle waves, the Sync signal is a square wave that is "high" in the first half of the cycle and "low" in the last half. The Sync signal’s voltages are TTL-compatible when its load impedance exceeds 1 kΩ.
  • For arbitrary waveforms, the Sync signal rises at the beginning of the waveform and falls at the middle of the arbitrary waveform. You can override this default behavior by using MARKer:POINt to specify the point within the arbitrary waveform at which the Sync signal transitions to "low."

Modulation

  • For internally-modulated AM, FM, PM, and PWM, the Sync signal is normally referenced to the modulating waveform (not the carrier) and is a square waveform with a 50% duty cycle. The Sync signal is a TTL "high" during the first half of the modulating waveform. You can set up the Sync signal to follow the carrier waveform by using the command OUTPut:SYNC:MODE {CARRier|NORMal|MARKer} when modulating with internal modulation.
  • For externally-modulated AM, FM, PM, and PWM, the Sync signal is referenced to the carrier waveform (not the modulating waveform) and is a square waveform with a 50% duty cycle.
  • You can override normal sync behavior to force Sync to always follow the carrier waveform (OUTPut[1|2]:SYNC:MODE CARRier).
  • For FSK, the Sync signal is referenced to the FSK rate. The Sync signal is a TTL "high" on the transition to the "hop" frequency.

Sweep

  • The Sync signal is a TTL "high" at the beginning of the sweep and goes "low" at the sweep's midpoint. The Sync signal is synchronized with the sweep, but is not equal to the sweep time because its timing includes the re-arm time.
  • For frequency sweeps with Marker On, the Sync signal is a TTL "high" at the beginning of the sweep and a "low" at the marker frequency. You can change this with OUTPut[1|2]:SYNC:MODE MARKER.

Burst

  • For a triggered burst, the Sync signal is a TTL "high" when the burst begins. The Sync signal is a TTL "low" at the end of the specified number of cycles (may not be the zero-crossing point if the waveform has an associated start phase). For an infinite count burst, the Sync signal is the same as for a continuous waveform.
  • For an externally-gated burst, the Sync signal follows the external gate signal. However, the signal will not go "low" until the end of the last cycle (may not be a zero-crossing if the waveform has an associated start phase).

Configuring Sync Output

  • Front Panel:
    To toggle Sync off and on:
    Trigger key Sync softkey (On)

    To configure Sync:
    Trigger key Sync Setup softkey
  • SCPI:
    OUTPut:SYNC {ON|1|OFF|0}

    OUTPut[1|2]:SYNC:MODE {NORMal|CARRier|MARKer}

    OUTPut[1|2]:SYNC:POLarity {NORMal|INVerted}

    OUTPut:SYNC:SOURce {CH1|CH2}


Pulse Waveforms

As shown below, a pulse or square wave consists of a period, a pulse width, a rising edge, and a falling edge.

Period

  • Period: reciprocal of maximum frequency to 1,000,000 s. The default is 1 ms.
  • The instrument adjusts the pulse width and edge time as needed to accommodate the specified period.
  • Front Panel:

    Select Pulse waveform:

    Select period instead of frequency:
    Set freunits
    Units key Frequency - Period softkey (Frequency) Frequency/Period softkey (Period)

    Set the period:
    Parameters key Period softkey
  • SCPI: [SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault}

Pulse Width

Pulse width is the time from the 50% threshold of a pulse's rising edge to the 50% threshold of the next falling edge.

  • Pulse width: up to 1,000,000 s (see restrictions below). The default pulse width is 100 μs. The minimum pulse width is 16 ns on the 33500 Series and 5 ns up to 4 Vpp or 8 ns up to 10 Vpp on the 33600 Series.
  • The specified pulse width must also be less than the difference between the period and the minimum pulse width.
  • The instrument will adjust the pulse width to accommodate the specified period.
  • Front Panel:
    Waveforms key Pulse softkey Pulse Width softkey
  • SCPI: [SOURce[1|2]:]FUNCtion:PULSe:WIDTh {<seconds>|MINimum|MAXimum|DEFault}

Pulse Duty Cycle

The pulse duty cycle is defined as follows:

Duty Cycle = 100(Pulse Width)/Period

Pulse width is the time from the 50% threshold of a pulse's rising edge to the 50% threshold of the next falling edge.

  • Pulse duty cycle: 0.01% to 99.99% (see restrictions below). The default is 10%.
  • The pulse duty cycle must conform to the following restrictions determined by the minimum pulse width (Wmin). The instrument will adjust the pulse duty cycle to accommodate the specified period.

    Duty Cycle > 100(Minimum Pulse Width) / Period

    and

    Duty Cycle < 100(1 – (Minimum Pulse Width/ Period))

    The minimum pulse width is 16 ns on the 33500 Series and 5 ns up to 4 Vpp or 8 ns up to 10 Vpp on the 33600 Series.
  • The longer the edges, the greater the minimum pulse width. Longer edges will therefore restrict duty cycle more than shorter edges.
  • Front Panel:

    Select pulse function:
    Waveforms key Pulse softkey

    Toggle to Duty Cycle:
    Units key Width / Duty Cycle softkey (Width) Width / Duty Cycle softkey (Duty Cycle)

    Enter the Duty Cycle:
    Parameters key Duty Cycle softkey
  • SCPI: [SOURce[1|2]:]FUNCtion:PULSe:DCYCle {<percent>|MINimum|MAXimum|DEFault}

Edge Times

The edge times set the transition times for the leading and trailing edges of the pulse, either independently or together. The edge time represents the time between the 10% and 90% thresholds.

  • Edge time: Minimum of 8.4 ns on the 33500 Series, and 2.9 ns up to 4 Vpp, or 3.3 ns up to 10 Vpp on the 33600 Series. Maximum of 1 μs and default 10 ns.
  • The specified edge time must fit within the specified pulse width as shown above. The instrument will adjust the edge time to accommodate the specified pulse width.
  • Front Panel:
    Waveforms key Pulse softkey Edge Times softkey
  • SCPI:
    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing {<seconds>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling {<seconds>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}


Amplitude Modulation (AM) and Frequency Modulation (FM)

A modulated waveform consists of a carrier waveform and a modulating waveform. In AM, the carrier amplitude is varied by the voltage level of the modulating waveform. In FM, the carrier frequency is varied by the voltage level of the modulating waveform. The instrument accepts an internal or external modulation source. On a two-channel instrument, one channel can modulate the other.

Select AM or FM before setting up any other modulation parameter. For more information on modulation, see Modulation.

To Select AM or FM

  • The instrument allows only one modulation mode to be enabled on a channel. When you enable AM or FM, all other modulations are off. On two-channel models, the two channels’ modulations are independent from one another, and the instrument can add modulated waveforms from two channels. See PHASe:SYNChronize and COMBine:FEED for details.
  • The instrument will not allow AM or FM to be enabled with sweep or burst. Enabling AM or FM, turns off sweep and burst.
  • To avoid multiple waveform changes, enable modulation after configuring the other modulation parameters.
  • Front Panel:
    (Modulation) Type softkey (AM)
    or
    Modulate key (Modulation) Type softkey (AM) FM softkey Type softkey (FM)

    Then turn modulation on:
    Modulate key Modulate softkey (Off) Modulate softkey (ON)

    The waveform is output using the present carrier and modulating waveform settings.
  • SCPI:
    [SOURce[1|2]:]AM:STATe{ON|1|OFF|0}

    [SOURce[1|2]:]FM:STATe {ON|1|OFF|0}

Carrier Waveform Shape

  • AM or FM carrier shape: Sine (default), Square, Ramp, Pulse, Triangle, Noise (AM only), PRBS, or Arbitrary waveform. You cannot use DC as the carrier waveform.
  • For FM, the carrier frequency must always be greater than or equal to the frequency deviation. Attempting to set a deviation greater than the carrier frequency will cause the instrument to set the deviation equal to the carrier frequency.
  • The carrier frequency plus the deviation cannot exceed the selected function's maximum frequency plus 100 kHz. If you attempt to set the deviation to an invalid value, the instrument adjusts it to the maximum value allowed with the present carrier frequency. The remote interface also generates a "Data out of range" error.
  • Front Panel:
    Waveforms key
    Then select a waveform shape.
  • SCPI:
    [SOURce[1|2]:]FUNCtion <function>

The APPLy command configures a waveform with one command.

Carrier Frequency

The maximum carrier frequency varies by function, model, and output voltage, as shown here. The default is 1 kHz for all functions other than arbitrary waveforms. Arbitrary waveform "frequency" is also set using the FUNCtion:ARBitrary:SRATe command.

  • Front Panel:
    Parameters key Frequency softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}

The APPLy command configures a waveform with one command.

Modulating Waveform Shape

The instrument accepts an internal or external AM or FM modulation source. On a two-channel instrument you can modulate one channel with the other.

Note

You cannot modulate noise with noise, PRBS with PRBS, or an arbitrary waveform with an arbitrary waveform.
  • The modulating waveform shape (internal source) may be:
  • Sine wave
  • Square with 50% duty cycle Modulation Square 50
  • UpRamp with 100% symmetry Modulation UpRamp 100
  • Triangle with 50% symmetry Modulation Triangle 50
  • DnRamp with 0% symmetry Modulation DnRamp 0
  • Noise - white gaussian noise
  • PRBS - Pseudo Random Bit Sequence (polynomial PN7)
  • Arb - Arbitrary waveform
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM)
    or
    Modulate key (Modulation) Type softkey (AM) FM softkey

    Then choose the modulating shape:
    Shape softkey (Sine)
  • SCPI:
    [SOURce[1|2]:]AM:INTernal:FUNCtion <function>

    [SOURce[1|2]:]FM:INTernal:FUNCtion <function>

Modulating Waveform Frequency

The instrument accepts an internal or external modulation source.

  • Modulating frequency (internal source): minimum is 1 µHz, and the maximum values vary by model, function, and output, as shown here.
  • Modulating frequency (external source): 0 to 100 kHz
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) More softkey (33500 Series only) AM Freq softkey

    or
    Modulate key (Modulation) Type softkey (AM) FM softkey FM Freq softkey

    Then enter the AM or FM frequency with the knob and keypad:
    Keypad and knob

  • SCPI:
    [SOURce[1|2]:]AM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Modulation Depth (AM)

The modulation depth is a percentage that represents the amplitude variation. At 0% depth, the amplitude is one-half of the carrier’s amplitude setting. At 100% depth, the amplitude varies according to the modulating waveform, from 0% to 100% of the carrier’s amplitude.

  • Modulation depth: 0% to 120%. The default is 100%.
  • Even at greater than 100% depth, the instrument will not exceed ±5 V peak on the output (into a 50 Ω load). To achieve modulation depth greater than 100%, output carrier amplitude may be reduced.
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) AM Depth softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]AM[:DEPTh] {<depth_in_percent>|MINimum|MAXimum}

Double Sideband Suppressed Carrier AM

The instrument supports two forms of amplitude modulation, "Normal" and Double Sideband Suppressed Carrier (DSSC). In DSSC, the carrier is not present unless the modulating signal has an amplitude greater than zero.

  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) More softkey DSSC Off/On softkey (OFF) DSSC Off/On softkey (ON)
  • SCPI: [SOURce[1|2]:]AM:DSSC{ON|1|OFF|0}.

Frequency Deviation (FM)

The frequency deviation setting represents the peak variation in frequency of the modulated waveform from the carrier frequency.

When the carrier is PRBS, frequency deviation causes a change in the bit rate equal to one-half of the set frequency. For example, a 10 kHz deviation is equivalent to a 5 KBPS change in bit rate.

  • Frequency deviation: 1 µHz to (carrier frequency)/2, default 100 Hz.
  • For FM, the carrier frequency must always be greater than or equal to the frequency deviation. Attempting to set a deviation greater than the carrier frequency will cause the instrument to set the deviation equal to the carrier frequency.
  • The carrier frequency plus the deviation cannot exceed the selected function's maximum frequency plus 100 kHz. If you attempt to set the deviation to an invalid value, the instrument adjusts it to the maximum value allowed with the present carrier frequency. The remote interface also generates a "Data out of range" error.
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) FM softkey Freq Dev softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]FM[:DEViation] {<peak_deviation_in_Hz>|MINimum|MAXimum|DEFault}

Modulating Source

The instrument accepts an internal or external modulation source. On a two-channel instrument you can modulate one channel with the other.

On the 33600 Series, you can configure the modulation source to accept either a ±5 V signal or a ±1 V signal. See INPut:ATTenuation[:STATe] for details.
  • Modulating source: Internal (default), Other Channel, or External. The External modulation source may be up to 100 kHz.
  • With the External source, an external waveform modulates the carrier waveform. The modulation depth (AM) or frequency deviation (FM) is controlled by the signal level on the rear-panel Modulation In connector. The external modulation input has -3 dB bandwidth of 100 kHz.
  • AM example: with modulation depth 100%, when the modulating signal is at +5 V, the output will be at the maximum amplitude. When the modulating signal at -5 V, the output will be at minimum amplitude.
  • FM example: with deviation of 10 kHz, then a +5 V signal level corresponds to a 10 kHz increase in frequency. Lower external signal levels produce less deviation and negative signal levels reduce the frequency below the carrier frequency.
  • Front Panel:
    After enabling AM or FM, select the modulating source as shown:
    Source softkey (Internal)
  • SCPI:
    [SOURce[1|2]:]AM:SOURce {INTernal|EXTernal|CH1|CH2}

    [SOURce[1|2]:]FM:SOURce {INTernal|EXTernal|CH1|CH2}


Phase Modulation

Phase Modulation (PM)

A modulated waveform consists of a carrier waveform and a modulating waveform. PM is very similar to FM, but in PM the phase of the modulated waveform is varied by the instantaneous voltage of the modulating waveform.

For more information on the fundamentals of Phase Modulation, see Tutorial - Modulation.

To Select Phase Modulation

  • Only one modulation mode may be enabled at a time. Enabling PM disables the previous modulation mode.
  • Enabling PM turns off sweep and burst.
  • Front Panel: Modulate key (Modulation) Type softkey (AM) PM Softkey

    The waveform is output using the present carrier and modulating waveform settings.
  • To avoid multiple waveform changes, enable modulation after configuring the other modulation parameters.
  • SCPI: [SOURce[1|2]:]PM:STATe {ON|1|OFF|0}

Carrier Waveform Shape

  • PM carrier shape: Sine (default), Square, Ramp, Triangle, Pulse, PRBS, or Arbitrary. You cannot use Noise or DC as the carrier waveform.
  • Front Panel: Waveforms key

    Then select any waveform except Noise or DC.
  • SCPI: [SOURce[1|2]:]FUNCtion <function>
  • The APPLy command configures a waveform with one command.
  • When the carrier is an arbitrary waveform, modulation affects the sample "clock" instead of the full cycle defined by the arbitrary waveform sample set. Because of this, applying phase modulation to arbitrary waveforms is limited.

Carrier Frequency

The maximum carrier frequency varies by function, model, and output voltage, as shown here. The default is 1 kHz for all functions other than arbitrary waveforms. Carrier frequency must be greater than 20 times the peak modulation frequency.

  • Front Panel:
    AM Freq softkey or FM Freq softkey or any other Frequency key.

    After selecting the frequency key:
    Keypad and knob
  • SCPI: [SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}
  • The APPLy command configures a waveform with one command.

Modulating Waveform Shape

The instrument accepts an internal or external modulation source.

  • The modulating waveform shape (internal source) may be:
  • Sine wave
  • Square with 50% duty cycle Modulation Square 50
  • UpRamp with 100% symmetry Modulation UpRamp 100
  • Triangle with 50% symmetry Modulation Triangle 50
  • DnRamp with 0% symmetry Modulation DnRamp 0
  • Noise - white gaussian noise
  • PRBS - Pseudo Random Bit Sequence (polynomial PN7)
  • Arbitrary waveform
  • You can use noise as the modulating waveshape, but you cannot use noise or DC as the carrier waveform.
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) PM Softkey Shape softkey (Sine)
  • SCPI: [SOURce[1|2]:]PM:INTernal:FUNCtion <function>

Modulating Waveform Frequency

The instrument accepts an internal or external modulation source. The external modulation input has a -3dB bandwidth of 100 kHz.

  • Modulating frequency (internal): default 10 Hz, minimum 1 µHz; maximum varies by model, function, and output voltage, as shown here.
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) PM Softkey PM Freq softkey

    Then set the modulating waveform frequency:
    Keypad and knob
  • SCPI: [SOURce[1|2]:]PM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Phase Deviation

The phase deviation setting represents the peak variation in phase of the modulated waveform from the carrier waveform. The phase deviation can be set from 0 to 360 degrees (default 180).

  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) PM Softkey Phase Dev softkey

    Then set the phase deviation:
    Keypad and knob
  • SCPI: [SOURce[1|2]:]PM:DEViation {<deviation in degrees>|MINimum|MAXimum|DEFault}
  • When the carrier is an arbitrary waveform, the deviation applies to the sample clock. Therefore, the effect on the full arbitrary waveform is much less than that seen with standard waveforms. The extent of the reduction depends on the number of points in the arbitrary waveform.

Modulating Source

The instrument accepts an internal or external modulation source.

  • Modulating source: Internal (default), Other Channel, or External. The External modulation source may be up to 100 kHz.
  • With the External source, the carrier waveform is modulated with an external waveform. The ±5 V signal level present on the rear-panel Modulation In connector controls the phase deviation. For example, if the deviation is set to 180 degrees, a +5 V signal corresponds to a 180 degree phase shift. Lower levels produce less deviation.
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) PM Softkey Source softkey (Internal)
  • SCPI: [SOURce[1|2]:]PM:SOURce {INTernal|EXTernal|CH1|CH2}


Frequency-Shift Keying (FSK) Modulation

You can configure the instrument to "shift" its output frequency between two preset values (called the "carrier frequency" and the "hop frequency") using FSK modulation. The rate at which the output shifts between these two frequencies is determined by the internal rate generator or the signal level on the rear-panel Ext Trig connector.

See Front Panel Menu Operation - Output an FSK Waveform for details on FSK using the front panel.

To Select FSK Modulation

FSKey:STATe {OFF|ON}

  • Only one modulation mode may be enabled at a time. Enabling FSK turns off the previous modulation mode.
  • You cannot enable FSK when sweep or burst is enabled. Enabling FSK turns off sweep and burst.
  • To avoid multiple waveform changes, enable modulation after configuring the other modulation parameters.

FSK Carrier Frequency

[SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}

The maximum carrier frequency varies by function, model, and output voltage, as shown here. The default is 1 kHz for all functions other than arbitrary waveforms.

  • When the External source is selected, the output frequency is determined by the signal level on the rear-panel Ext Trig connector. When a logic low is present, the carrier frequency is output. With a logic high, the hop frequency is output.

FSK "Hop" Frequency

[SOURce[1|2]:]FSKey:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

The maximum alternate ("hop") frequency depends on the function. The default is 100 Hz for all functions. The internal modulating waveform is a 50% duty cycle square wave.

Function | Minimum Hop Frequency | Maximum Hop Frequency
Sine | 1 µHz | (varies by model, as shown here)
Square
Ramp/Triangle
Pulse
  • When the External source is selected, the output frequency is determined by the signal level on the rear-panel Ext Trig connector. When a logic low is present, the carrier frequency is output. With a logic high, the hop frequency is output.

FSK Rate

[SOURce[1|2]:]FSKey:INTernal:RATE {<rate_in_Hz>|MINimum|MAXimum}

The FSK rate is the rate at which the output frequency "shifts" between the carrier frequency and the hop frequency using the internal FSK source.

  • FSK rate (internal source): 125 µHz (33500 Series) or 250 µHz (33600 Series) up to 1 MHz, default 10 Hz.
  • The FSK rate is ignored when the external FSK source is selected.

FSK Source

[SOURce[1|2]:]FSKey:SOURce {INTernal|EXTernal}

May be Internal (default) or External.

  • When the Internal source is selected, the rate at which the output frequency "shifts" between the carrier frequency and hop frequency is determined by the FSK rate. The internal modulating waveform is a 50% duty cycle square wave.
  • When the External source is selected, the output frequency is determined by the signal level on the rear-panel Ext Trig connector. When a logic low is present, the carrier frequency is output. With a logic high, the hop frequency is output.
  • The connector used for externally-controlled FSK waveforms (Ext Trig) is not the same connector that is used for externally-modulated AM, FM, PM, and PWM waveforms (Modulation In). When used for FSK, the Ext Trig connector does not have adjustable edge polarity.


Pulse Width Modulation (PWM)

This section discusses PWM, which stands for pulse-width modulation. PWM is only available for the Pulse waveform, and the pulse width varies according to the modulating signal. The amount by which the pulse width varies is called the width deviation, and it can be specified as a percentage of the waveform period (that is, duty cycle) or in units of time. For example, if you specify a pulse with 20% duty cycle and then enable PWM with a 5% deviation, the duty cycle varies from 15% to 25% under control of the modulating signal.

The instrument accepts an internal or external modulation source.

To Select PWM

  • You cannot enable PWM when sweep or burst is enabled.
  • To avoid multiple waveform changes, enable modulation after configuring the other modulation parameters.
  • Front Panel:
    Waveforms key Pulse softkey
    Modulate key (Modulation) Type softkey (AM) PWM softkey
    Modulate softkey (Off) Modulate softkey (ON)

    The waveform is output using the present carrier and modulating waveform settings.
  • SCPI: [SOURce[1|2]:]PWM:STATe {ON|1|OFF|0}

Modulating Waveform Shape

The instrument accepts an internal or external modulation source.

  • The modulating waveform shape (internal source) may be:
  • Sine wave
  • Square with 50% duty cycle Modulation Square 50
  • UpRamp with 100% symmetry Modulation UpRamp 100
  • Triangle with 50% symmetry Modulation Triangle 50
  • DnRamp with 0% symmetry Modulation DnRamp 0
  • Noise - white gaussian noise
  • PRBS - Pseudo Random Bit Sequence (polynomial PN7)
  • Arbitrary waveform
  • Front Panel:

    Waveforms key Pulse softkey
    Modulate key (Modulation) Type softkey (AM) PWM softkey Shape softkey (Sine)
  • SCPI: [SOURce[1|2]:]PWM:INTernal:FUNCtion <function>

Modulating Waveform Frequency

The instrument accepts an internal or external modulation source. The external modulation input has a -3 dB bandwidth of 100 kHz.

  • Modulating frequency (internal source): The default is 10 Hz, and the minimum is 1 µHz. The maximum frequency varies by function, model, and output voltage, as shown here.
  • Front Panel:
    Waveforms key Pulse softkey
    Modulate key (Modulation) Type softkey (AM) PWM softkey PWM Freq softkey
  • SCPI: [SOURce[1|2]:]PWM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Width or Duty Cycle Deviation

The PWM deviation setting is the peak variation in width of the modulated pulse waveform. You can set it in units of time or duty cycle.

  • Front Panel:
    Waveforms key Pulse softkey
    Modulate key (Modulation) Type softkey (AM) PWM softkey Width Dev softkey

    To set deviation in terms of duty cycle:
    Units key Width / Duty Cycle softkey (Width) Width / Duty Cycle softkey (Duty Cycle)
    Modulate key Dty Cyc Dev softkey
  • SCPI: [SOURce[1|2]:]PWM:DEViation {<deviation>|MINimum|MAXimum|DEFault}
  • The sum of the pulse width and deviation must satisfy the formula:

    Pulse Width + Deviation < Period – 16 ns (33500 Series)

    Pulse Width + Deviation < Period – 8 ns (33600 Series above 4 Vpp)

    Pulse Width + Deviation < Period – 5 ns (33600 Series up to and including 4 Vpp)
  • If necessary, the instrument will adjust the deviation to accommodate the specified period.

Modulating Source

The instrument accepts an internal or external modulation source.

  • Modulating source: Internal (default), Other Channel, or External. The External modulation source may be up to 100 kHz.
  • If you select the External modulating source, the deviation is controlled by the ±5 V signal level (optionally ±1 V on the 33600 Series) on the rear-panel Modulation In connector. For example, if you have set the deviation to 1 µs, then a +5 V signal (optionally + 1 V on the 33600 Series) corresponds to a 1 µs increase in width. Lower signal levels produce less deviation.
  • Front Panel:
    Waveforms key Pulse softkey
    Modulate key (Modulation) Type softkey (AM) PWM softkey Source softkey (Internal)
  • SCPI: [SOURce[1|2]:]PWM:SOURce {INTernal|EXTernal|CH1|CH2}

Pulse Waveform

  • Pulse is the only waveform shape supported for PWM.
  • Front Panel:
    Waveforms key Pulse softkey
  • SCPI: FUNCtion PULSe
  • The APPLy command configures a waveform with one command.

Pulse Period

The range for the pulse period is from the reciprocal of the instrument's maximum frequency up to 1,000,000 s (default 100 µs). Note that the waveform period limits the maximum deviation.

  • Front Panel:
    Waveforms key Pulse softkey
    Units key Frequency - Period softkey (Frequency) Frequency / Period softkey (Period)
  • SCPI: [SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault}


Sum Modulation

Sum modulation adds a modulating signal to any carrier waveform; it is typically used to add gaussian noise to a carrier. The modulating signal is added to the carrier as a percentage of carrier waveform amplitude.

Enable Sum

  • To avoid multiple waveform changes, enable Sum after configuring other modulation parameters.
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) Sum softkey
    Modulate softkey (Off) Modulate softkey (ON)
  • SCPI: [SOURce[1|2]:]SUM:STATe {ON|1|OFF|0}

Modulating Waveform Shape

The instrument accepts an internal or external modulation source. On a two-channel instrument you can modulate one channel with the other.

  • The modulating waveform shape (internal source) may be:
  • Sine wave
  • Square with 50% duty cycle Modulation Square 50
  • UpRamp with 100% symmetry Modulation UpRamp 100
  • Triangle with 50% symmetry Modulation Triangle 50
  • DnRamp with 0% symmetry Modulation DnRamp 0
  • Noise
  • PRBS with PN7 sequence
  • Arbitrary waveform
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) Sum softkey Shape softkey (Sine)
  • SCPI: [SOURce[1|2]:]SUM:INTernal:FUNCtion <function>

Modulating Waveform Frequency

The instrument accepts an internal or external modulation source. On a two-channel instrument you can modulate one channel with the other.

  • Modulating frequency (internal source): The default 100 Hz and the minimum is 1 µHz. The maximum frequency varies by function, model, and output voltage, as shown here.
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) Sum softkey Sum Freq softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]SUM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Sum Amplitude

The Sum Amplitude represents the amplitude of the signal added to the carrier (in percent of carrier amplitude).

  • Amplitude setting: 0 to 100% of carrier amplitude, 0.01% resolution.
  • Sum Amplitude remains a constant fraction of carrier amplitude and tracks carrier amplitude changes.
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) Sum softkey
    Modulate Sum Ampl softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]SUM:AMPLitude {<amplitude>|MINimum|MAXimum|DEFault}

Modulating Source

The instrument accepts an internal or external modulation source. On a two-channel instrument you can modulate one channel with the other.

  • Modulating source: Internal (default), Other Channel, or External. The External modulation source may be up to 100 kHz.
  • With the external source, the carrier waveform is summed by the ±5 V signal level (optionally ±1 V on the 33600 Series) on the rear-panel Modulation In connector. For example, if you have set the sum amplitude to 10%, then when the modulating signal is at +5 V (optionally +1 V on the 33600 Series), the output will be at the maximum amplitude (110% of carrier amplitude). When the modulating signal is at -5 V (optionally -1 V on the 33600 Series), the output will be at the minimum amplitude (90% of carrier amplitude).

    If you are using the other channel as the source for SUM modulation, consider using the Combine feature instead. The Combine feature has fewer restrictions and less delay than SUM with other channel.
  • Front Panel:
    Modulate key (Modulation) Type softkey (AM) Sum softkey Source softkey (Internal)
  • SCPI: [SOURce[1|2]:]SUM:SOURce {INTernal|EXTernal|CH1|CH2}


Frequency Sweep

In frequency sweep mode, the instrument moves from the start frequency to the stop frequency at a specified sweep rate. You can sweep up or down in frequency, with either linear or logarithmic spacing. You can also configure the instrument to output one sweep from start frequency to stop frequency by applying an external or manual trigger. The instrument can sweep sine, square, pulse, ramp, triangle, or arbitrary waveforms (PRBS, noise and DC are not allowed).

You can specify a hold time, during which the sweep remains at the stop frequency, and a return time, during which the frequency changes linearly from the stop frequency to the start frequency.

For more information, see Frequency Sweep.

To Select Sweep

The instrument will not allow sweep or list mode to be enabled at the same time that burst or any modulation mode is enabled. When you enable sweep, the burst or modulation mode is turned off.

  • To avoid multiple waveform changes, enable the sweep mode after configuring the other parameters.
  • Front Panel:

    Sweep key Sweep softkey (OFF) Sweep Off/On softkey (ON)
  • SCPI:
    [SOURce[1|2]:]FREQuency:MODE SWEEP

    [SOURce[1|2]:]SWEep:STATe {ON|1|OFF|0}

Start Frequency and Stop Frequency

The start frequency and stop frequency set the sweep’s upper and lower frequency bounds. The sweep begins at the start frequency, sweeps to the stop frequency, and then resets back to the start frequency.

  • Start and Stop frequencies: 1 µHz to maximum frequency for the waveform. The sweep is phase continuous over the full frequency range. The default start frequency is 100 Hz. The default stop frequency is 1 kHz.
  • To sweep up in frequency, set the start frequency less than the stop frequency. To sweep down in frequency, set the opposite relationship.
  • Sync setting Normal: Sync pulse is high throughout the sweep.
  • Sync setting Carrier: Sync pulse has a 50% duty cycle for every waveform cycle.
  • Sync setting Marker: Sync pulse goes high at the beginning and goes low at the marker frequency. You can change this with OUTPut[1|2]:SYNC:MODE MARKER.
  • Front Panel:
    Sweep key Start Freq softkey Keypad and knob

    Sweep key Stop Freq softkey Keypad and knob
  • SCPI:
    [SOURce[1|2]:]FREQuency:STARt {<frequency>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FREQuency:STOP {<frequency>|MINimum|MAXimum|DEFault}

Center Frequency and Frequency Span

You can also set the sweep frequency boundaries of the sweep using a center frequency and frequency span. These parameters are similar to the start frequency and stop frequency (above) and they provide added flexibility.

  • Center frequency: 1 µHz to maximum frequency for the waveform. The default is 550 Hz.
  • Frequency span: Any value between ±maximum frequency for the waveform. The default is 900 Hz.
  • To sweep up in frequency, set a positive frequency span; to sweep down, set a negative frequency span.
  • Sync setting Normal: Sync pulse is high throughout the sweep.
  • Sync setting Carrier: Sync pulse has a 50% duty cycle for every waveform cycle.
  • Sync setting Marker: Sync pulse goes high at the beginning and goes low at the marker frequency. You can change this with OUTPut[1|2]:SYNC:MODE MARKER.
  • Front Panel:
    Units key Start-Stop Cntr-Span softkey (Start-Stop) Start-Stop Cntr-Span softkey (Cntr-Span)
    Sweep key Center softkey Keypad and knob
    Sweep key Span softkey Keypad and knob
  • SCPI:
    [SOURce[1|2]:]FREQuency:CENTer {<frequency>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]FREQuency:SPAN {<frequency>|MINimum|MAXimum|DEFault}

Sweep Mode

You can sweep with linear or logarithmic spacing, or with a list of sweep frequencies. For a linear sweep, the instrument varies the output frequency linearly during the sweep. A logarithmic sweep varies the output frequency logarithmically.

The selected mode does not affect the sweep return (from stop to start, if one is set). The sweep return is always linear.

  • Front Panel:
    Sweep key Type softkey (LINEAR)
    LINEAR Log List softkeys
  • SCPI: [SOURce[1|2]:]SWEep:SPACing {LINear|LOGarithmic}

Sweep Time

Sweep time specifies the number of seconds required to sweep from the start frequency to the stop frequency. The instrument calculates the number of points in the sweep based on the sweep time.

  • Sweep time: 1 ms to 250,000 seconds, default 1 s. For a linear sweep in immediate trigger mode, the maximum total sweep time (including hold time and return time) is 8,000 s. The maximum total sweep time for linear sweeps using other trigger modes is 250,000 s; the maximum total sweep time for logarithmic sweeps is 500 s.
  • Front Panel:
    Sweep key Sweep Time softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]SWEep:TIME {<seconds>|MINimum|MAXimum|DEFault}

Hold/Return Time

Hold time specifies time (in seconds) to remain at the stop frequency, and return time specifies the number of seconds to return from the stop frequency to the start frequency.

  • Hold time and return time: 0 to 3600 seconds (default 0).
  • Front Panel:
    Sweep key Hold & Return softkey Hold Time softkey
    Keypad and knob

    Sweep key Hold & Return softkey Return Time softkey
    Keypad and knob
  • SCPI:
    [SOURce[1|2]:]SWEep:HTIMe {<hold_time>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]SWEep:RTIMe {<return_time>|MINimum|MAXimum|DEFault}

Marker Frequency

If desired, you can set the frequency at which the signal on the front panel Sync connector goes to a logic low during the sweep. The Sync signal always goes from low to high at the beginning of the sweep.

  • Marker frequency: 1 µHz to maximum frequency for the waveform. The default is 500 Hz.
  • When the sweep mode is enabled, the marker frequency must be between the specified start frequency and stop frequency. If you attempt to set the marker frequency to a frequency not in this range, the instrument will set the marker frequency equal to the start frequency or stop frequency (whichever is closer).
  • You cannot configure the marker frequency with the front panel menus unless the Sync source is the sweeping channel.
  • Front Panel:
    Sweep key Sweep Off/On softkey (OFF) Sweep Off/On softkey (ON)
    Trigger key Sync Setup softkey
  • SCPI: [SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

Sweep Trigger Source

In sweep mode, the instrument outputs a single sweep when a trigger signal is received. After one sweep from the start frequency to the stop frequency, the instrument waits for the next trigger while outputting the start frequency.

  • Sweep trigger source: Immediate (default), External, Time, or Manual.
  • With the Immediate (internal) source, the instrument outputs a continuous sweep at a rate determined by the total of the hold time, sweep time and return time. The sweep time for this source is limited to 8000 seconds.
  • With the External source, the instrument accepts a hardware trigger on the rear-panel Ext Trig connector and initiates one sweep each time Ext Trig receives a TTL pulse with the specified polarity.
  • The trigger period must be greater than or equal to the specified sweep time.
  • With the Manual source, the instrument outputs one sweep each time the front panel [Trigger] key is pressed.
  • Front Panel:
    Trigger key (Trigger) Source softkey (Immed)
  • To specify the slope of the trigger signal edge:
    Trigger key Trig Out Setup softkey Trig Out softkey (Off)
  • SCPI:
    TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}

    TRIGger[1|2]:SLOPe {POSitive|NEGative}

See Triggering for more information.

Trigger Out Signal

A "trigger out" signal is provided on the rear-panel Ext Trig connector (used with burst and sweep only). When enabled, a pulse with either a rising edge (default) or falling edge is output from this connector at the beginning of the sweep or burst.

  • When the Immediate (internal) trigger source is selected, the instrument outputs a square waveform with a 50% duty cycle from the Ext Trig connector at the beginning of the sweep or burst. The frequency of the waveform corresponds to the specified burst period or total sweep time.
  • When the External trigger source is selected, the instrument disables the "trigger out" signal. The Ext Trig connector cannot be used for sweep or burst and trigger out at the same time (an externally-triggered waveform uses the same connector to trigger the sweep or burst).
  • When Manual or bus (software) trigger source is selected, the instrument outputs a pulse (>1 μs pulse width on the 33500 Series and 100 ns on the 33600 Series) from the Ext Trig connector at the beginning of each sweep or burst.
  • To specify whether the instrument triggers on the rising or falling edge on the Ext Trig connector, press [Trigger] > Trig Out Setup. Then select the desired edge by pressing Trig Out.
  • SCPI:
    OUTPut:TRIGger:SLOPe {POSitive|NEGative}

    OUTPut:TRIGger {ON|1|OFF|0}

Frequency List

In frequency list mode, the instrument "steps" through a list of frequencies, dwelling on each frequency for a specified period. You may also control progress through the list with triggering.

  • The instrument will not allow sweep or list mode to be enabled at the same time that burst or any modulation mode is enabled. When you enable sweep, the burst or modulation mode is turned off.
  • To avoid multiple waveform changes, enable list mode after configuring its parameters.
  • Front Panel: Enable list before setting any other list parameter. Press [Sweep] > Type > List.
  • SCPI:
    [SOURcd[1|2]:]FREQuency:MODE LIST

    [SOURce[1|2]:]LIST:FREQuency <freq1>[, <freq2>, etc.]
  • Progress through list is controlled by the trigger system. If trigger source is internal or immediate, the dwell time setting (LIST:DWELl) determines time spent at each frequency. For any other trigger source, dwell time is determined by trigger event spacing.


Burst Mode

The instrument can output a waveform for a specified number of cycles, called a burst. Burst is allowed with sine, square, triangle, ramp, pulse, PRBS, or arbitrary waveforms (noise is allowed only in gated burst mode; DC is not allowed).

For details, see Tutorial - Burst.

To Select Burst

Burst cannot be enabled when sweep or modulation is enabled. Enabling burst turns off sweep and modulation.

  • To avoid multiple waveform changes, enable burst mode after configuring other parameters.
  • Front Panel:
    Burst key Burst Off softkey Burst On softkey
  • SCPI: [SOURce[1|2]:]BURSt:STATe {ON|1|OFF|0}

Burst Mode

Burst has two modes, described below. Selected mode controls allowable trigger source, and which other burst parameters apply.

  • Triggered Burst Mode (default): The instrument outputs a waveform for specified number of cycles (burst count) each time trigger is received. After outputting specified number of cycles, instrument stops and waits for next trigger. The instrument can use an internal trigger to initiate burst, or you can provide external trigger by pressing the front panel [Trigger] key, applying trigger signal to rear-panel Ext Trig connector, or sending software trigger command from remote interface.
  • External Gated Burst Mode: Output waveform is on or off, based on level of external signal applied to rear-panel Ext Trig connector. When the gate signal is true, the instrument outputs a continuous waveform. When the gate signal goes false, the current waveform cycle is completed and the instrument stops while remaining at the voltage level corresponding to the starting burst phase of the selected waveform. The noise waveform output stops immediately when the gate signal goes false.
Parameter | Burst Mode (BURS:MODE) | Burst Count (BURS:NCYC) | Burst Period (BURS:INT:PER) | Burst Phase (BURS:PHAS) | Trigger Source (TRIG:SOUR)
Triggered Burst Mode: Internal Trigger | TRIGgered | Available | Available | Available | IMMediate
Triggered Burst Mode: External Trigger | TRIGgered | Available | Not Used | Available | EXTernal, BUS
Gated Burst Mode: External Trigger | GATed | Not Used | Not Used | Available | Not Used
Timer Burst Mode: Internal Trigger | TRIGgered | Available | Not Used | Available | TIMer
  • In gated mode, burst count, burst period, and trigger source are ignored (used for triggered burst only). Manual triggers ignored; no error generated.
  • In gated mode, you can specify polarity of signal on the rear-panel Ext Trig connector ([SOURce[1|2]:]BURSt:GATE:POLarity {NORMal|INVerted}). Default is NORMal (true-high).
  • Front Panel:
    Burst key NCycle softkey
  • SCPI: [SOURce[1|2]:]BURSt:MODE {TRIGgered|GATed}

Waveform Frequency

You can specify the signal frequency during the burst in triggered and external gated modes. In the triggered mode, the number of cycles specified by the burst count is output at the waveform frequency. In the external gated mode, the waveform frequency is output when the external gate signal is true.

This differs from the "burst period," which specifies interval between bursts (triggered mode only).

  • Waveform frequency: 1 µHz to maximum frequency of the waveform. The default value is 1 kHz. (For an internally triggered burst waveform, the minimum frequency is 126 µHz in the 33500 Series or 251 µHz in the 33600 Series.)
  • Front Panel:
    Parameters key Frequency softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}

The APPLy command configures a waveform with one command.

Burst Count

Number of cycles (1 to 100,000,000 or infinite) to be output per burst. Used in the triggered burst mode only (internal or external source).

  • With the Immediate trigger source, the specified number of cycles are output continuously at a rate determined by the burst period. The burst period is the time between the starts of consecutive bursts. Also, the burst count must be less than the product of burst period and waveform frequency:

    Burst Period > (Burst Count)/(Waveform Frequency) + 1µsec (33500 Series)

    Burst Period > (Burst Count)/(Waveform Frequency) + 500 ns (33600 Series)
  • The instrument will increase burst period to its maximum value to accommodate specified burst count (but waveform frequency will not be changed).
  • In gated burst mode, burst count is ignored. However, if you change the burst count from the remote interface while in the gated mode, the instrument remembers the new count and will use it when the triggered mode is selected.
  • Front Panel:
    Burst key Number of cycles softkey Keypad and knob
    or
    Burst key N Cycles Infinite softkey N Cycles Infinite softkey
  • SCPI: [SOURce[1|2]:]BURSt:NCYCles {<num_cycles>|INFinity|MINimum|MAXimum}

Burst Period

Burst period, which is used in internal triggered burst mode only, is the time from the start of one burst to the start of next burst (1 µs to 8000 s, default 10 ms for the 33500 Series). On the 33600 Series, the range is from 1 µs to 4000 s, and the default is also 10 ms. Burst period differs from "waveform frequency," which specifies the frequency of the bursted signal.

  • Burst period is used only when Immediate triggering is enabled. The burst period is ignored when manual or external triggering is enabled (or when the gated burst mode is selected).
  • You cannot specify a burst period that is too short for the instrument to output with the specified burst count and frequency. If the burst period is too short, the instrument will increase it as needed to continuously re-trigger the burst.
  • Front Panel:
    Burst key Burst Period softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]BURSt:INTernal:PERiod {<seconds>|MINimum|MAXimum}

Start Phase

Start phase of the burst, from -360 to +360 degrees (default 0).

  • Specify the start phase units with UNIT:ANGLe.
  • Always displayed in degrees on front panel (never radians). If set in radians from remote interface, instrument converts value to degrees on the front panel.
  • For sine, square, and ramp, 0 degrees is the point at which the waveform crosses 0 V (or DC offset) in a positive-going direction. For arbitrary waveforms, 0 degrees is the first waveform point. Start phase has no effect on noise.
  • Start phase also used in gated burst mode. When the gate signal goes false, the current waveform cycle finishes, and output remains at the voltage level of the starting burst phase.
  • Front Panel:
    Burst key Start Phase softkey Keypad and knob
  • SCPI: [SOURce[1|2]:]BURSt:PHASe {<angle>|MINimum|MAXimum}

Burst Trigger Source

In triggered burst mode:

  • The instrument outputs a waveform of the specified number of cycles (burst count) when a trigger is received. After the specified number of cycles have been output, the instrument stops and waits for next trigger.
  • IMMediate (internal): the instrument outputs continuously when burst mode is enabled. The rate at which the burst is generated is determined by BURSt:INTernal:PERiod.
  • EXTernal: the instrument accepts a hardware trigger at the rear-panel Ext Trig connector. The instrument outputs one burst of the specified number of cycles each time Ext Trig receives a level transition with the proper polarity (TRIGger[1|2]:SLOPe). External trigger signals during a burst are ignored.
  • BUS (software): the instrument initiates one burst each time a bus trigger (*TRG) is received. The front panel [Trigger] key is illuminated when the instrument is waiting for a bus trigger.
  • EXTernal or BUS: burst count and burst phase remain in effect, but burst period is ignored.
  • TIMer: trigger events are spaced by a timer, with the first trigger as soon as INIT occurs.
  • Front Panel:
    Trigger key Trigger Setup softkey (Trigger) Source softkey (Immed)
  • To specify whether the instrument triggers on a rising or falling edge of the signal at the Ext Trig connector, select the external trigger source before choosing Trigger Setup.
  • SCPI:
    TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}

    TRIGger[1|2]:SLOPe {POSitive|NEGative}

See Triggering for more information.

If the duty cycle is changed on a triggered bursted square wave with the trigger mode set to Timer, the current burst will finish and one more burst will be executed before the duty cycle of the burst changes.

Trigger Out Signal

A "trigger out" signal is provided on the rear-panel Ext Trig connector (used with burst and sweep only). When enabled, a pulse with either a rising edge (default) or falling edge is output from this connector at the beginning of the sweep or burst.

  • When the Immediate (internal) trigger source is selected, the instrument outputs a square waveform with a 50% duty cycle from the Ext Trig connector at the beginning of the sweep or burst. The frequency of the waveform corresponds to the specified burst period or total sweep time.
  • When the External trigger source is selected, the instrument disables the "trigger out" signal. The Ext Trig connector cannot be used for sweep or burst and trigger out at the same time (an externally-triggered waveform uses the same connector to trigger the sweep or burst).
  • When Manual or bus (software) trigger source is selected, the instrument outputs a pulse (>1 μs pulse width on the 33500 Series and 100 ns on the 33600 Series) from the Ext Trig connector at the beginning of each sweep or burst.
  • Front Panel
    Burst key Burst Off softkey alt="Burst Off softkey" Burst On softkey
    Trigger key Trig Out Setup softkey
    Then use this softkey to choose the desired edge direction:
    Trig Out softkey (Off)
  • SCPI:
    OUTPut:TRIGger:SLOPe {POSitive|NEGative}

    OUTPut:TRIGger {ON|1|OFF|0}


Triggering

This section describes the instrument's triggering system.

Trigger Overview

This triggering information applies to sweep and burst only. You can issue triggers for sweeps or bursts using internal triggering, external triggering, timer triggering, or manual triggering.

  • Internal or "automatic" (default): instrument outputs continuously when sweep or burst mode is selected.
  • External: uses rear-panel Ext Trig connector to control sweep or burst. The instrument initiates one sweep or outputs one burst each time Ext Trig receives a pulse. You can select whether instrument triggers on rising or falling edge.
  • Manual: triggering initiates one sweep or outputs one burst each time you press [Trigger] on the front panel.
  • When you sweep a list, trigger moves the waveform to the next frequency in the list.
  • The [Trigger] key is disabled when in remote and when a function other than burst or sweep is currently selected.

Trigger Sources

This triggering information applies to sweep and burst only. You must specify the source from which the instrument accepts a trigger.

  • Sweep and Burst trigger source: Immediate (default), External, Manual or Timer.
  • The instrument will accept a manual trigger, a hardware trigger from the rear-panel Ext Trig connector, or continuously output sweeps or bursts using an internal trigger. You can also trigger bursts based on a timer. At power-on, immediate trigger is selected.
  • Trigger source setting is volatile; set to internal trigger (front panel) or immediate (remote interface) by power cycle or *RST.
  • Front Panel:
    Enable sweep or burst. Then:
    Trigger key (Trigger) Source softkey (Immed)
  • SCPI: TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}
  • The APPLy command automatically sets the source to Immediate.

Immediate Triggering

Internal trigger mode (default): instrument continuously outputs sweep or burst (as specified by sweep time or burst period).

Front Panel:
Trigger key Source IMMED softkey

SCPI: TRIGger:SOURce IMMediate

Manual Triggering

Manual trigger mode (front panel only): you manually trigger the instrument by pressing [Trigger]. The instrument initiates one sweep or burst for each time you press [Trigger]. The button is lit when you are in the trigger menu and the instrument is waiting for a manual trigger. The button blinks when the instrument is waiting for a manual trigger, but you are not in the trigger menu. The key is disabled when the instrument is in remote.

External Triggering

In external trigger mode, the instrument accepts a hardware trigger at the rear-panel Ext Trig connector. The instrument initiates one sweep or burst each time Ext Trig receives a TTL pulse with the specified edge. The external trigger mode is like the manual trigger mode except that you apply the trigger to the Ext Trig connector.

See Trigger Input Signal, below.

Front Panel:
Trigger key (Trigger) Source softkey (Immed) External trigger softkey

To specify whether the instrument triggers on a rising or falling edge, press Trigger Setup and select the edge direction by pressing Slope.

SCPI:
TRIGger:SOURce EXTernal

TRIGger[1|2]:SLOPe {POSitive|NEGative}

Software (Bus) Triggering

Available only from remote interface, this is similar to manual trigger mode from the front panel, but you trigger the instrument with a bus trigger command. The instrument initiates one sweep or outputs one burst each time a bus trigger command is received. The key blinks when a bus trigger command is received.

To select the bus trigger source, send TRIGger:SOURce BUS.

To trigger instrument from remote interface (GPIB, USB, or LAN) when Bus source is selected, send TRIG or *TRG (trigger). The front panel [Trigger] key is illuminated when the instrument is waiting for a bus trigger.

Timer Triggering

The timer trigger mode issues triggers a fixed period apart. To select the bus trigger source, send TRIGger:SOURce TIMer.

Trigger Input Signal

This rear-panel connector is used in the following modes:

  • Triggered Sweep Mode: Press Trigger Setup > Source Ext, or execute TRIG:SOUR EXT (sweep must be enabled). When a level transition of the correct polarity is received on the Ext Trig connector, instrument outputs a single sweep.
  • Externally-Modulated FSK Mode: Press Source or execute FSK:SOUR EXT (FSK must be enabled). When a low level is present, carrier frequency is output. When a high level is present, hop frequency is output. Maximum external FSK rate is 100 kHz.
  • Triggered Burst Mode: Press Trigger Setup > Source Ext, or execute TRIG:SOUR EXT (burst must be enabled). The instrument outputs a waveform with specified number of cycles (burst count) each time a trigger is received from the specified trigger source.
  • External Gated Burst Mode: Press Gated softkey or execute BURS:MODE GAT with burst enabled. When external gate signal is true, instrument outputs a continuous waveform. When external gate signal goes false, the current waveform cycle completes and then instrument stops while remaining at voltage level corresponding to starting burst phase. For noise, output stops as soon as the gate signal goes false.

Trigger Output Signal

The trigger output signal is chassis referenced, and it is physically next to the external modulation input, which is floating. Use appropriate care not to touch the two signals simultaneously as you are connecting or disconnecting these cables. De-energize connections to the instrument output before connecting or disconnecting these cables.
  • A "trigger out" signal is provided on the rear-panel Ext Trig connector (used with burst and sweep only). When enabled, a pulse with either a rising edge (default) or falling edge is output from this connector at the beginning of the sweep or burst.
    Trigger Out, rising edge shown

    The diagram above shows the triggering on the 33500 Series. On the 33600 Series, the pulse width is 100 ns, and the voltage level is programmable (not necessarily the +3.3 V shown). See TRIGger:LEVel for details on how to set this value.
  • Internal (immediate) or Timer trigger source: instrument outputs a square wave with a 50% duty cycle from the Ext Trig connector at the beginning of the sweep or burst. Waveform period equals specified sweep time or burst period.
  • External trigger source: instrument disables "trigger out" signal. The rear-panel Ext Trig connector cannot be used for both operations simultaneously (an externally-triggered waveform uses the same connector to trigger sweep or burst).
  • Bus (software) or manual trigger source: instrument outputs a pulse (>1 μs pulse width) from Ext Trig connector at beginning of each sweep or burst.
  • Front Panel: Enable sweep or burst. Then:
    Trigger key Trig Out Setup softkey
    Then use this softkey to choose the desired edge direction:
    Trig Out softkey (Off)
  • SCPI:
    OUTPut:TRIGger:SLOPe {POSitive|NEGative}

    OUTPut:TRIGger {ON|1|OFF|0}


Dual Channel Operations

This section covers most topics related to dual channel operation. It does not cover the optional IQ Player.

Entering Dual Channel Operation

You enter dual channel configuration by pressing a channel output button, then More, then Dual Channel.

Dual Channel Configuration Menu

Frequency Coupling

Frequency coupling allows you to couple frequencies or sample rates between channels, either by a constant ratio or offset between them. Press Freq Cpl to turn frequency coupling on or off, and press Freq Cpl Settings to configure frequency coupling.

The Freq Cpl Settings softkey opens the menu shown below. The first softkey allows you to specify whether you want to couple the frequencies with a ratio or an offset, and the second softkey allows you to specify the ratio or offset.

Frequency coupling configuration menu

Amplitude Coupling

Amplitude coupling, enabled by the Ampl Cpl softkey, couples the amplitude and offset voltage between the channels so that changing the amplitude or offset on one channel affects both channels.

Tracking

Tracking, configured by the Tracking softkey, has three modes: Off, On and Invert. When tracking is off, the two channels operate independently. When tracking is on, they behave as one channel. The third mode, Invert, makes the channels’ outputs inverses of each other, resulting in a differential channel using both outputs.

Combine

The Combine feature combines two outputs into one connector. If you choose CH2 from the Channel 1 menu, they are combined on channel 1; choosing CH1 from the Channel 2 menu combines them on channel 2.

In the image below, the top waveform is a 100 mVpp, 1 kHz sine wave on channel 1, and the bottom waveform is a 100 mVpp, 5 kHz sine wave on channel 2.

The image below shows the two outputs combined on channel 1. Note that the X-axis has been compressed (zoomed out) to show more cycles.

The signals being combined do not have to be of the same type; for example, this image shows the same 5 kHz channel on channel 2 combined with a 100 mVpp square wave on channel 1.

When signals are combined, the DC Offset values are not added together. Only the DC Offset from the receiving channel is used in the combined output. The figure below shows 50 a mV DC Offset added to Channel 1. The 50 mV offset added to Channel 2 is ignored.

You may also use Combine with bursts. For example, consider the image below, which includes a 1 kHz sine wave on channel 1 and three-cycle bursts of a 5 kHz sine wave on channel 2.

When these signals are combined on channel 1, the result is a simple amplitude addition of the two signals, as shown below.

You also can combine the signals on channel 2, as shown below.


IQ Player Option

IQ Player (Optional)

The optional IQ Player is used to play dual arbitrary waveforms, such as IQ baseband signals.

A dual arbitrary waveform is analogous to a stereo music file. It has two channels of information that contain the same number of samples, always start and end together, and always play at the same sample rate.

File Formats

The instrument's native .ARB and .BARB files can contain either one or two channels of data. These files are typically created in Keysight BenchLink Waveform Builder software, and you can directly play them on the instrument.

You can also directly play files ending in .DAT, .ASC, .I, and .Q. These file formats contain one or two columns of ASCII numbers ranging between -1.0 and 1.0, in either scientific or decimal notation. The data represents the relative "shape" of the waveform at the current amplitude range.

Finally, you can import one- or two-column data files in .CSV or .TXT format. To import a file, press [Waveforms] > Arb > Arbs > Import Data. This opens a menu interface that quickly guides you through the process of importing a file.

Front Panel

Once you have a dual arbitrary waveform as the active waveform, the tab changes to a purple color, as shown below.

Dual arbitrary waveform screen

The waveform image is a constellation diagram, but you can change it to a time domain diagram. To do this, press [System] > System Setup > Screen Layout. This takes you to the following menu:

Screen layout menu

Pressing the Time softkey changes the graphic to a time domain image:

Dual arb screen time view

Balance Adjust

If you press More from the [Parameters] menu, you will go to page 2 of the [Parameters] menu:

Page 2 of Parameters menu

From this menu, you can press Balance Adjust to open a menu that will allow you specify the balance amplitude gain and channel offsets:

Dual Arb IQ balance

IQ Arb Skew

To compensate for minor channel-channel time skew, begin by pressing either of the channel output buttons and then pressing More to go to page 2 of the menu:

Dual arbitrary waveform output page 2

On this menu, press IQ Arb Skew to open the following menu, which allows you to compensate for up to 4 ns of skew on the 33500 Series or 1 ns of skew on the 33600 Series:

IQ Arb Skew menu

SCPI Commands

There are eight SCPI commands associated with the IQ Player:

Loading Dual Arbitrary Waveforms

[SOURce[1|2]:]DATA:ARBitrary[1|2] <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ARBitrary[1|2]:DAC <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ARBitrary2:FORMat {AABB|ABAB}

Adjusting Playback of Dual Arbitrary Waveforms

FUNCtion:ARBitrary:BALance:GAIN {<percent>|MINimum|MAXimum|DEFine}

FUNCtion:ARBitrary:BALance:OFFSet{1|2} {<volts>|MINimum|MAXimum|DEFault}

FUNCtion:ARBitrary:BALance[:STATe] {ON|1|OFF|0}

FUNCtion:ARBitrary:SKEW[:STATe] {ON|1|OFF|0}

FUNCtion:ARBitrary:SKEW:TIME [{<time>|MINimum|MAXimum|DEFault}]


System-Related Operations

This section covers instrument state storage, power-down recall, error conditions, self test, and display control. Though unrelated to waveform generation, these operations are important for instrument operation.

Instrument State Storage

  • There are two ways to store and retrieve instrument states:
  • Named state files, using front panel or MMEMory:STORe:STATe and MMEMory:LOAD:STATe
  • Memory locations 1 through 4, using *SAV and *RCL

    • For 33600 Series instruments, the state files associated with *SAV and *RCL are saved in files called STATE_0.STA through STATE_4.STA. These files are located in the Settings directory of internal memory. You can manage these files using MMEMory commands.
  • You can also use special storage location 0 with *SAV and *RCL, but location 0 is overwritten by the current instrument state on power down.
  • Both state storage methods remember the selected function (including arbitrary waveforms), frequency, amplitude, DC offset, duty cycle, symmetry, and modulation parameters.
  • If you delete an arbitrary waveform from non-volatile memory after storing the instrument state, the waveform data is lost and the instrument uses "exponential rise" in its place.
  • Stored states are not affected by *RST; a stored state remains until overwritten or specifically deleted.
  • Front Panel:
    System key Store - Recall softkey

    To save a state:
    Store State softkey Keypad and knob Store State softkey
    The state file will be created with .sta extension, using the name you specified with the knob and arrows.

    To recall a state:
    Recall State softkey Keypad and knob
    Use the right arrow to expand a folder. To select a file, press Select.

    To delete a state:
    Delete State softkey Keypad and knob
    Use the knob and arrows to select .sta file, and then press Select.
  • You can configure instrument to power-down state from location 0 on power up. The factory default is to recall factory default state at power-on.
  • Front Panel:
    System key Store - Recall softkey Power On softkey (FACTORY) Power On LAST softkey
  • SCPI: MEMory:STATe:RECall:AUTO {ON|1|OFF|0}

Error Conditions

Up to 20 command syntax or hardware errors can be stored in each interface-specific error queue (one each for GPIB, USB, VXI-11, and Telnet/Sockets.) See SCPI Error Messages for more information.

  • Front Panel:
    System key Help softkey Down arrow softkey Select softkey
  • SCPI: SYSTem:ERRor?

Beeper Control

The instrument normally beeps when an error is generated from the front panel or remote interface.

  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key System Setup Softkey User Settings softkey Beeper softkey
  • SCPI:
    SYSTem:BEEPer:STATe {ON|1|OFF|0}

    SYSTem:BEEPer
On the 33600 Series, you can also enable and disable the click heard when a key is pressed. See SYSTem:CLICk:STATe for details.

Display Screen Saver

The display's backlight normally turns off and reduces the screen brightness after eight hours of inactivity. You may disable this screen saver from the front panel only.

  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key System Setup Softkey User Settings softkey Display Options softkey Scrn Svr softkey (ON)

Display Brightness

You can adjust display brightness (10% to 100%) from the front panel only.

  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key System Setup Softkey User Settings softkey Display Options softkey Brightness softkey

Date and Time

You can set the instrument's date and time clock.

  • Front Panel:
    System key System Setup softkey Date-Time softkey
  • SCPI:
    SYSTem:DATE <yyyy>, <mm>, <dd>

    SYSTem:TIME <hh>, <mm>, <ss>

Manage Files

You can perform file management tasks, including copying, renaming, deleting, and creating new folders.

  • Front Panel:
    System key System Setup Softkey Manage Files softkey
    File management screen
  • You can copy, rename, or delete files or folders. Deleting a folder removes all of the files within the folder, so be sure that you want to delete all of the files within the folder.
  • The most important softkey is Action, which allows you to specify the operation to perform. Once you have chosen the action to perform, press Browse to select the file to manage. Once you are completely prepared to execute the task, press Perform.
  • SCPI: (see MEMory and MMEMory subsystems).

Self-Test

  • A limited power-on self-test occurs when you turn on the instrument to assure you that the instrument is operational. You can also run a more complete self-test. For details, see Self-Test Procedures.

Display Control

For security reasons, or to speed up the rate at which the instrument executes remote interface commands, you may want to turn off the display. You can also remotely display a message or clear a message on the display.

  • The display is enabled when power is cycled, after an instrument reset (*RST), or when you return to local (front panel) operation. Press the [Local] key or execute the IEEE-488 GTL (Go To Local) command from the remote interface to return to the local state.
  • The display state is saved when you store the instrument state with *SAV recalled by *RCL.
  • Front Panel:
    System key System Setup Softkey User Settings softkey Display Options softkey Display Off/On softkey (ON)
  • SCPI:
    DISPlay {ON|1|OFF|0}
    DISPlay:TEXT "<string>"

    DISPlay:TEXT:CLEar

Number Format

The instrument can display numbers on the front panel with periods or commas for the decimal point and digits separator. The default is a period decimal point with commas for digit separation (1.000,000,00 kHz).

  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key System Setup Softkey User Settings softkey Number Format softkey
  • SCPI: (No equivalent command)

Firmware Revision Query

Send *IDN? to determine which revision of firmware is currently installed. The query returns a string of the form:

Keysight Technologies,[Model Number],[10-char Serial Number],A.aa-B.bb-C.cc-DD-EE

  • Front Panel: System key Help softkey About softkey
  • SCPI: *IDN?

SCPI Language Version Query

The instrument complies with the rules and conventions of the present version of SCPI (Standard Commands for Programmable Instruments). Use SYSTem:VERSion? to determine the SCPI version with which the instrument complies. The query returns a string in the form "YYYY.V", representing the year and version number for that year (for example, 1999.0).

License Installation

The Trueform Series has several optional features that require licenses for installation. To install a license:

  1. Install the license file onto a USB drive and insert the USB drive into the instrument’s front panel.
  2. Press [System] > System Setup > Install License.
  3. Use the knob and arrows to select the file under External, then press Enter.

There are also several SCPI commands associated with license installation.


Remote Interface Configuration

The instrument supports remote interface communication over three interfaces: GPIB (optional), USB, and LAN. All three are "live" at power up.

  • GPIB Interface: Set the instrument's GPIB address connect to your PC using a GPIB cable.
  • USB Interface: No configuration; simply connect instrument to PC with a USB cable.
  • LAN Interface: By default, DHCP is on, which may enable communication over LAN. The acronym DHCP stands for Dynamic Host Configuration Protocol, a protocol for assigning dynamic IP addresses to networked devices. With dynamic addressing, a device can have a different IP address every time it connects to the network.

Connectivity Software and Product CDs

The instrument ships with two CDs:

  • Keysight IO Libraries Suite CD: Contains Keysight IO Libraries Suite software, which must be installed to enable remote-interface operations. The CD auto-starts and provides information on installing the software. Also includes Keysight Technologies USB/LAN/GPIB Connectivity Guide, which contains additional information.
  • Keysight Trueform Series Product Reference CD: Contains instrument drivers, product documentation, and programming examples. Auto-starts and provides instructions.

GPIB Configuration

Each device on the GPIB (IEEE-488) interface must have a unique whole number address between 0 and 30. The instrument ships with a default address of 10, and the GPIB address is displayed at power-on.

  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Your computer’s GPIB interface card address must not conflict with any instrument on the interface bus.
  • Front Panel:
    Press [System] > I/O Config > GPIB Settings to set the GPIB address and turn GPIB on or off.
  • SCPI:
    SYSTem:COMMunicate:GPIB:ADDRess <address>
    SYSTem:COMMunicate:ENABle <state>,GPIB
    SYSTem:COMMunicate:ENABle? GPIB

LAN Configuration

The following sections describe the primary front panel LAN configuration functions, including SCPI commands where applicable. Some LAN configuration functions that can be performed only via SCPI. See LAN Configuration Introduction for all LAN configuration commands, and see LAN Configuration Procedure for a procedure to configure the LAN via the front panel.

Note

Some LAN settings require you to cycle power on the instrument in order for them to be activated. The instrument briefly displays a message when this is the case, so be sure to watch the screen closely as you change LAN settings.

Resetting the LAN

You can clear the Web Interface password, turn DHCP on, and restart the LAN at any time:

  • Front panel:
    System key I/O Config softkey LAN Reset softkey
    The message "Performing LAN Reset" is displayed while the LAN is reset.
  • SCPI: (No equivalent command)

DHCP On/Off

DHCP (Dynamic Host Configuration Protocol) can automatically assign a dynamic IP address to a LAN device. Typically easiest way to configure instrument for LAN.

  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key I/O Config softkey LAN Settings softkey Modify Settings softkey

    Finally, toggle the first softkey to DHCP to use DHCP to automatically assign an IP address.
  • SCPI: SYSTem:COMMunicate:LAN:DHCP {ON|1|OFF|0}

To manually set an IP address, Subnet Mask, or Default Gateway, turn DHCP off, then change IP setup as described below.

IP Address

You can enter a static IP address for the instrument as a four-byte integer expressed in dot notation. Each byte is a decimal value, with no leading zeros (for example, 169.254.2.20).

  • If DHCP is on, it attempts to assign an IP address to the instrument. If it fails, AutoIP attempts to assign an IP address to the instrument.
  • Contact your LAN administrator to obtain an IP address.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key I/O Config softkey LAN Settings softkey Modify Settings softkey
  • Finally, toggle the first softkey to Manual and press IP Address to enter a new IP address. Enter the desired address.
  • SCPI: SYSTem:COMMunicate:LAN:IPADdress "<address>"

Subnet Mask

Subnetting allows the LAN administrator to subdivide a network to simplify administration and minimize network traffic. The subnet mask indicates the portion of the host address used to indicate the subnet.

  • Contact your LAN administrator for details.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key I/O Config softkey LAN Settings softkey Modify Settings softkey
  • Finally, toggle the first softkey to Manual and press Subnet Mask to enter a new subnet mask with the numeric keypad or knob (for example: 255.255.0.0).
  • SCPI: SYSTem:COMMunicate:LAN:SMASk "<mask>"

Default Gateway

A gateway is a network device that connects networks. The default gateway setting is the IP address of such a device.

  • You need not set a gateway address if using DHCP or AutoIP.
  • Contact your LAN administrator for gateway details.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key I/O Config softkey LAN Settings softkey Modify Settings softkey

    Finally, toggle the first softkey to Manual and press More and Gateway. Then set the appropriate gateway address using the numeric keypad or knob.
  • SCPI: SYSTem:COMMunicate:LAN:GATeway "<address>"

Hostname

A hostname is the host portion of the domain name, which is translated into an IP address.

  • The instrument receives a unique hostname at the factory, but you may change it. The hostname must be unique on the LAN.
  • The name must start with letter; other characters can be upper or lower case letters, numeric digits, or dashes ("-").
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key I/O Config softkey LAN Settings softkey Modify Settings softkey

    Finally, press Host Name and enter the hostname with the knob and arrows. The knob changes the character; cursor arrows move between characters.
  • SCPI: SYSTem:COMMunicate:LAN:HOSTname "<name>"

Domain Name

A domain name is a registered Internet name that gets translated into an IP address. You cannot set it from the front panel or SCPI.

DNS Server

DNS (Domain Name Service) is an Internet service that translates domain names into IP addresses. The DNS server address is the IP address of a server that performs this service.

  • Normally, DHCP discovers DNS address information; you only need to change this if DHCP is unused or not functional. Contact your LAN administrator for DNS server details.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel:
    System key I/O Config softkey LAN Settings softkey Modify Settings softkey

    Finally, toggle the first softkey to Manual and press More and Primary DNS or Second DNS to enter a DNS address using the numeric keypad or knob.
  • SCPI: SYSTem:COMMunicate:LAN:DNS[1|2] "<address>"

Current Configuration (LAN)

  • Select the Currently Active Settings display to view the MAC address and current LAN configuration.
  • Front Panel: System key I/O Config softkey LAN Settings softkey
  • SCPI: (No equivalent command)

The display reflects only currently active settings when first displayed; it does not update with changes occurring after the information is displayed. For example, if DHCP assigns an IP address with display open, a new IP address will not appear.

If the instrument goes into remote, all LAN changes will be canceled, and the display will go to a different screen. Re-selecting the LAN Settings page will display the new settings if a LAN restart took place.

See SYSTem Subsystem Introduction for additional LAN configuration commands.

Web Interface

The instrument includes a built-in Web Interface. You can use this interface over LAN for remote instrument access and control via a Java™-enabled Web browser, such as Microsoft Internet Explorer.

Web interface image

To use the Web Interface:

  1. Establish a LAN connection from your PC to the instrument.
  2. Open your PC's Web browser.
  3. Launch the instrument's Web Interface by entering the instrument's IP address or fully-qualified hostname in the browser address field.
  4. Follow the instructions in the Web Interface's on-line help.

USB Configuration

Front Panel:
System key I/O Config softkey USB Settings softkey

On the 33500 Series, there are no user-configurable USB parameters. You can only retrieve the USB ID string (set by the manufacturer) by using the Show USB Id softkey.

Easy File Access (33600 Series only)

Easy File Access uses media transfer protocol (MTP) to easily download instrument files to your PC. Simply connect the rear-panel USB port on the instrument to a USB port on your PC. The DMM will appear as a read-only drive on your PC's file system. Note that the instrument's internal storage includes a pre-defined directory structure, as shown below.

You can use your PC's standard file management features to copy files from the DMM to your PC.

To use Easy File Access at the same time that you are remotely programming the instrument with SCPI over the USB interface (USB SCPI), you must have Keysight IO Libraries Suite 16.3 or later installed on your PC. You may download the latest version at www.keysight.com/find/iosuite.

To use Easy File Access on a PC running the Windows XP operating system, make sure you have Microsoft Windows Media Player 11 for Windows XP or later installed before you hook up the USB cable. You may download this software at www.microsoft.com/en-us/download/details.aspx?id=8163.


External Timebase Reference

The external 10 MHz reference input BNC connector, both the shell and center pin, on the rear panel of the instrument is isolated up to ±42 Vpk from chassis. The shell of this BNC connector is isolated from the rest of the instrument. Internal circuitry will attempt to keep the isolated voltage to within ±42 Vpk to chassis. Attempts to float this input beyond ±42 Vpk from chassis may destroy the instrument and cause a hazard that could result in personal injury or death.

The external timebase reference provides rear panel connectors (10 MHz In and 10 MHz Out) and circuitry to allow synchronization between multiple instruments or to an external 10 MHz clock signal. You can also set the phase offset of the output waveform from the front panel or over the remote interface.

To align the phase of two instruments, use a dual-channel oscilloscope to compare the output signals:

  1. Connect the two instruments, with 10 MHz Out connected to 10 MHz In. Use the instrument with the more precise timebase as the 10 MHz reference output source.

    Instruments connected to lock timebases
  2. Connect instrument outputs to scope channel inputs:

    Connect instruments to scope
  3. Set the same frequency on both instruments. The scope should show the signals to be in sync with regard frequency, but not phase. (A square wave works well to show the phase difference.)
  4. For two-channel instruments, phase sync the two channels to each other. This also synchronizes each channel’s modulating waveforms to the carrier.

    Front panel:

    Channel key Parameters key Phase softkey Sync Internal softkey

    SCPI: [SOURce[1|2]:]PHASe:SYNChronize
  5. Leaving the phase setting at its default (zero) on the first instrument, use Adjust Phase to adjust the phase of the second instrument to align the output signals:
Unaligned image | Aligned image
Out of Phase | Aligned

You can use Set 0 Phase to set a new zero-phase reference point with the two instruments now aligned.

  • Front Panel:
    Channel key Parameters key Phase softkey

    Then set the phase angle using the keypad or knob. Once they are aligned, press Set 0 Phase.
  • SCPI:
    [SOURce[1|2]:]PHASe {<angle>|MINimum|MAXimum|DEFault}

    [SOURce[1|2]:]PHASe:REFerence


Embedded Waveform Editor

The instrument includes an embedded waveform editor for creating and editing single-channel arbitrary waveforms in ASCII arbitrary waveforms (.ARB suffix). You can enter and edit voltage values directly or by combining up to 12 different kinds of standard waveforms, as described in the following sections:

Standard Waveforms

Basic Waveform Editing

Advanced Edit

Advanced Math

Utility Menu

Regardless of what options may be installed, the maximum waveform size for the embedded waveform editor is 1 MSa.

Standard Waveforms

The embedded waveform editor includes the following 12 waveforms:

Sine | Sine wave | y = sin(x)
Square | Square wave | A square wave that switches between two voltage levels
Ramp | Ramp wave | A waveform with linearly rising or falling voltage
Line | Line segment | Line segment
DC | DC voltage | A DC voltage
Noise | Random noise | Random noise
Gaussian | Gaussian wave | A gaussian bell curve (normal distribution)
Sinc | Sinc wave | y = sin(x)/x
D-Lorentz | D-Lorentz wave | The derivative of the Lorentz function. The Lorentz function is y = 1/(x²+1), so the D-Lorentz function is y = -2x/(x²+1)².
Expo Fall | Exponential fall | Exponential decay: y = e-kx
Expo Rise | Exponential rise | Exponential rise: y = 1 – e-kx
Haversine | Haversine waveform | y = [1 – cos(x)]/2

When you select a waveform, the instrument displays a screen for specifying the waveform’s parameters, listed below.

Amplitude | The peak height above 0 V when the waveform has 0 offset, from 10 μV to 10 V (default 1).
Offset | The distance the waveform is shifted up or down relative to 0 V, from -10 to 10 V (default 0).
The Amplitude plus the Offset must be between -10 V and 10 V.
Phase | The number of degrees that the waveform is advanced (positive value) or retarded (negative value) from 0 degrees, from -360 to 360 (default 0).
Cycles | The number of complete output cycles (a positive integer) that the waveform includes.
Points | The number of points the waveform includes up to 1,000,000 (default 100). The minimum number of points on the 33500 Series is 8, and the minimum number of points on the 33600 Series is 32.
Half Width (D-Lorentz only) | A value that controls the waveform width; larger values make wider curves. An integer from 1 to the total number of points in one cycle (default 10).
Fall Factor (Expo Fall only) | A decimal number from -99 to 99 that controls how fast the waveform falls or rises (default -5).
Rise Factor (Expo Rise only)
Full Width (Gaussian only) | The width of the bell curve between the points on the curve that are one-half the curve's height, from 1 to the number of points in one cycle (default 10).
Symmetry (Ramp only) | The percentage of time (per cycle period) that the ramp rises, a decimal from 0 to 100 (default 100).
Zero Crossing (Sinc only) | The number of times the waveform crosses the horizontal axis on one side of the waveform, from 0 to 100 (default 10).
Duty Cycle (Square only) | The percentage of the time (per cycle period) that the waveform voltage is high, from 0 to 100 (default 50).
Start Level (Line only) | The voltage at the beginning or end of the line segment.
End Level (Line only)

Basic Waveform Editing

When you start the embedded waveform editor ([Waveforms] > Arb > Arbs > Edit Arb File > New Arb File), the opening screen appears. (Note that the same menu that contains the Edit Arb File softkey also contains an Import Data softkey. You can use this to import ASCII files from oscilloscopes and other common instruments.)

WFE opening screen

Edit Points allows you to edit the voltage values of individual points in the waveform. You can also insert and remove points in the waveform, and you can access the Advanced Edit features, described below. The current screen image shows the default new arbitrary waveform of 8 points at 0 VDC.

The default arbitrary waveform size is 8 points the 33500 Series and 32 points on the 33600 Series.

WFE edit points

Edit Params allows you to set the waveform’s sample rate, which is the rate (in points per second) in which the waveform is played. You can specify this value as a rate or as a period. If you change one, the other will recalculate based on the number of points in the waveform. This feature also allows you to specify whether the waveform is labeled with units of time or points along the horizontal axis.

WFE edit parameters

Insert Built-In allows you to insert one of 12 pre-defined waveforms into the current waveform.

WFE insert built-in

Select Point # allows you to specify where the waveform is to be inserted, and the Choose Wave softkey allows you to specify which one of the 12 waveform types is to be inserted.

New list of waveforms

Once you have used the arrow keys to select the waveform to insert and pressed OK, the instrument displays the parameters for the waveform to be inserted. Note the up and down arrow softkeys, which you use to select a parameter for editing. Specify the parameters and press OK.

WFE enter parameters

Save allows you to save the current waveform at its current location in the instrument’s internal memory.

Exit Editor closes the waveform editor and resumes normal operation.

WFE exit editor

If you have unsaved changes, a message gives you the option of staying in the embedded waveform editor. After you exit the editor, you will have the option to play the waveform on the waveform generator.

WFE Exit Without Saving warning

Advanced Edit

As described above, the Edit Points menu includes an Advanced Edit softkey. This softkey allows you to cut, copy and paste portions of the waveform, edit waveform points in a table, and perform mathematical operations on the waveform.

WFE advanced edit

Cut/Copy/Paste allows you to define a range of the waveform between two markers and then cut or copy the waveform points defined by the markers. Once you have cut or copied the range, you can paste it as many times as desired by using the Paste softkey.

WFE edit selection

Paste Location allows you to paste a range at the start of the waveform, the end of the waveform, or any point within the waveform.

WFE paste location menu

Edit Via Table allows you to edit the voltage values of individual points in a table. You can use the knob to scroll through the table, or you can use the Point # softkey to directly select any particular point. You can also insert or remove waveform points.

WFE edit via table

Perform Math allows you to use markers to specify a range of the waveform. You can then add, subtract, or multiply the voltage values in that range by the voltage values in another waveform.

WFE perform math

Once you have pressed Add, Subtract, or Multiply, the instrument displays a list of waveforms. Pick the waveform and press OK.

Add math waveform help

When you press OK, the instrument displays a list of parameters that you can use to specify the waveform. In this case, the screen below shows that you picked D-Lorentz. You can also use the From Point and To Point parameters to specify the range of points on which to perform the mathematical operation.

WFE perform math waveform parameters

Advanced Math

Advanced Math allows you to perform several mathematical operations on the waveform. To begin, press Edit Points > Advanced Edit > Perform Math > Advanced Math.

WFE perform math

The Advanced Math menu opens with the following screen. Each of the operations shown below will be described below, using images taken before and after each operation to demonstrate the operations’ effects.

WFE advanced math main screen

Invert reflects the waveform across the horizontal axis.

Image Before Invert

WFE before each operation

Image After Invert

WFE after invert

Absolute multiplies all negative waveform values by -1.

Image Before Absolute
WFE before each operation

Image After Absolute
WFE after absolute

Mirror reverses order of the points in the range.

Image Before Mirror
WFE before each operation

Image After Mirror
WFE after mirror

Scale allows you to scale the waveform’s amplitude and offset. Here, the amplitude scale was set to 180% and the offset scale was set to 1 V.

Image Before Scale
WFE before each operation

Image After Scale

WFE after scale

Clip allows you to change voltage values outside upper and lower limits to be equal to the limits. In this example, the waveform was clipped to stay within the -400 mV lower limit and the 700 mV upper limit.

Image Before Clip
WFE before each operation

Image After Clip

WFE after clip

Trim allows you to use markers to "crop" the waveform so that only the points defined by the marker range remain in the waveform.

Image Before Trim
WFE before each operation

Image After Trim

WFE after trim

Utility Menu

You can access several utility features by pressing the [System] key from within the embedded waveform editor.

Undo allows you to undo recent operations, subject to the amount of available memory and the size of the undo operation. Redo allows you to redo "undone" tasks, subject to the same limitations.

Pan/Zoom Control allows you to pan or zoom horizontally or vertically. You zoom using a percentage zoom factor, and you pan by specifying a point, and or voltage.

WFE pan/zoom control

Show All resets the scaling to display the entire waveform.


Waveform Generation Tutorial

This section describes theory of operation information for several waveform types and instrument operating modes. The last two topics include information that may help you improve signal quality.

  • Arbitrary Waveforms
  • Quasi-Gaussian Noise
  • PRBS
  • Modulation
  • Burst
  • Frequency Sweep
  • Attributes of AC Signals
  • Signal Imperfections
  • Ground Loops

Arbitrary Waveforms

Arbitrary waveforms can meet needs not met by the instrument’s standard waveforms. For example, you might need a unique stimulus, or you might want to simulate signal imperfections such as overshoot, ringing, glitching, or noise. Arbitrary waveforms can be very complex, making them suitable for simulating signals in modern communications systems.

You can create arbitrary waveforms from a minimum of 8 points (33500 Series) or 32 points (33600 Series) up to 1,000,000 points. The instrument stores these numeric data points, known as "samples," in memory and then converts them into voltages as the waveform is generated. The frequency at which points are read is the "sample rate," and the waveform frequency equals the sample rate divided by the number of points in the waveform. For example, suppose a waveform has 40 points and the sample rate is 10 MHz. The frequency would be (10 MHz)/40 = 250 kHz and its period would be 4 µs.

Dual Arbitrary Waveforms

Arbitrary waveforms may be single-channel waveforms, or (with option IQP), they may be dual-channel arbitrary waveforms, such as IQ baseband signals. A dual arbitrary waveform is analogous to a stereo music file. It has two channels of information that contain the same number of samples, always start and end together, and always play at the same sample rate.

You can control the skew and balance between channels on dual arbitrary waveforms either via commands in the SCPI FUNCtion subsystem or via the front panel.

Waveform Filters

The instrument includes two filters to smooth transitions between points as arbitrary waveforms are generated.

  • Normal filter: a wide, flat frequency response, but its step response exhibits overshoot and ringing
  • Step filter: a nearly ideal step response, but with more roll-off in its frequency response than the Normal filter
  • Off: output changes abruptly between points, with a transition time of approximately 10 ns.

Each filter’s cutoff frequency is a fixed fraction of the waveform’s sample rate. The Normal filter’s response is -3 dB at 27% of the sample rate and the Step filter’s response is -3 dB at 13% of the sample rate. For example, for an arbitrary waveform at 100 MSa/s, the Normal filter’s -3 dB frequency bandwidth is 27 MHz.

Turning the filter off may change the sample rate to a lower rate if the sample rate was greater than 250 MSa/s before the filter was turned off.

Waveform Sequencing Applications

Arbitrary waveform sequences are useful when the waveform you want to generate in two situations:

  • The waveform is very long and contains repetitions of shorter fragments. These fragments can be repeated any number of times in any order.
  • You need real-time control (triggers) to change from one waveform fragment to another.

For an example of the first case, consider a signal that must play the same introductory waveform several times, then play three other waveforms once each, and then return to play the first waveform continuously. This might be a simulated modem data packet consisting of an "idle" signal, a header, some data, a checksum, and a return to the "idle" signal.

This might consist of the following sequence description:

  1. Play "idle.arb" 10 times
  2. Play "header.arb" once
  3. Play "data.arb" once
  4. Play "checksum.arb" once
  5. Play "idle.arb," repeating indefinitely.

In the second case, you may want to initiate the sending of "header.arb" using an external hardware trigger. This case might use the following description:

  1. Play "idle.arb" repeatedly until a trigger is received
  2. Play "header.arb" once
  3. Play "data.arb" once
  4. Play "checksum.arb" once
  5. Play "idle.arb," repeating indefinitely.

A sequence file (*.seq) contains the information in the numbered lists, and the arbitrary waveform files (*.arb) contain the individual waveforms themselves.

Waveform Sequencing Implementation

The instrument can assemble long, complex sequences of arbitrary waveforms (segments). Switching between segments occurs seamlessly in real time. As an analogy, think of segments as songs in a music player and sequences as play lists.

Each sequence step specifies a segment and how many times it is played. It also specifies whether the sequence waits for a trigger before the next step and how the Sync signal is generated on a step-by-step basis.

For each segment, you can either:

  • play the segment from 1 to 1,000,000 times and then advance to the next step
  • play the segment once and then stop and wait for a trigger before advancing
  • repeat the segment until a trigger occurs and then advance
  • repeat the segment until explicitly stopped

Options for Sync signal generation include:

  • assert Sync at the beginning of the segment
  • negate Sync at the beginning of the segment
  • maintain the current Sync state throughout the segment
  • assert Sync at the beginning of the segment and negate it at a defined point within the segment

To start a sequence on a trigger, place a brief DC waveform of 0 V (or any other desired value) in front of the other waveforms in the sequence, and set the segment to wait for a trigger before advancing. For 33500 Series instruments, the minimum segment length is 8 Sa, and for 33600 Series instruments, the minimum segment length is 32 Sa.

If a segment is set up to repeat until a trigger is received, the segment will always finish before continuing to the next segment. In addition, a short segment may repeat for additional cycles in order to clear the sequence sample buffer before continuing.

Quasi-Gaussian Noise

The Noise waveform is optimized for both quantitative and qualitative statistical properties. It does not repeat for more than 50 years of continuous operation. Unlike a true gaussian distribution, there is zero probability of getting a voltage beyond the instrument’s Vpp setting. The crest factor (peak voltage divided by RMS voltage) is approximately 4.6.

You can vary the Noise bandwidth from 1 mHz to the instrument's maximum bandwidth. The energy in the noise signal is concentrated in a band from DC to the selected bandwidth, so the signal has greater spectral density in the band of interest when the bandwidth setting is lower. In audio work, for example, you might set the bandwidth to 30 kHz, to make the audio band signal strength 30 dB higher than if the bandwidth were set to 30 MHz.

PRBS

A Pseudo-Random Bit Sequence (PRBS) has two levels (high and low), and it switches between them in a manner that is difficult to predict without knowing the sequence generation algorithm. A PRBS is generated by a linear-feedback shift register (LFSR), shown below.

An LFSR is specified by the number of stages it contains and which stages ("taps") feed the exclusive-or (XOR) gates in its feedback network. The PRBS output is taken from the last stage. With properly chosen taps, an L-stage LFSR produces a repetitive PRBS of length 2L-1. The clocking frequency of the LFSR determines the "bit rate" of the PRBS.

The 33500 Series models allow you to set L to 7, 9, 11, 15, 20, or 23, resulting in sequences from 127 to 8,388,607 bits in length.

The 33600 Series models allow you to set L to any whole number value from 3 to 32, resulting in sequences from 7 to 4,294,967,295 bits in length.

The default value for L is 7, resulting in a sequence of 127 bits in length.

Modulation

Amplitude Modulation (AM)

The instrument implements two forms of AM:

  • Double-sideband full-carrier (DSB-FC), which has an ITU designation of A3E and is used in AM broadcasting.

    The equation for DSB-FC is

    y(t)= [(½)+(½)•d•m(t)]•Ac•sin(ωc t)

    where

    m(t) is the modulating signal
    Ac is the carrier amplitude
    ωc is the carrier frequency of the carrier
    d is the "modulation depth," or fraction of the amplitude range is used by the modulation

    For example, a depth setting of 80% varies the amplitude from 10% to 90% of the amplitude setting (90% - 10% = 80%) with either an internal or a full-scale (±5 V on the 33500 Series, ±5 V or ±1 V on the 33600 Series) external modulating signal. You may set depth as high as 120%, as long as you do not exceed the instrument’s maximum output voltage of (±5 V into 50 Ω, ±10 V into high impedance).

    The top trace below represents the modulating signal; the bottom trace represents the modulated carrier.

  • Double-sideband suppressed-carrier (DSSC). Many modern communications systems employ DSSC on each of two carriers that have the same frequency but a 90-degree phase difference. This is called quadrature amplitude modulation (QAM).

    The equation for DSSC is y(t)=d•m(t)•sin(ωc t)

    In DSB-SC, the carrier signal is inverted whenever m(t) < 0. For QAM, the second carrier signal would be cos(ωc t), making it 90 degrees out of phase from the first carrier.

Frequency Modulation (FM)

Frequency modulation varies a carrier signal’s frequency according to the modulating signal:

y(t)=Ac•sin[(ωc+d•m(t) )•t]

where m(t) is the modulating signal and d is the frequency deviation. FM is called narrowband if the deviation is less than 1% of the modulating signal’s bandwidth, and wideband otherwise. You can approximate the modulated signal’s bandwidth with the following equations.

BW ≈ 2•(Modulating Signal Bandwidth) for narrowband FM

BW ≈ 2•(Deviation+Modulating Signal Bandwidth) for wideband FM

The top trace below represents the modulating signal; the bottom trace represents the modulated carrier.

Phase Modulation (PM)

PM is similar to FM, but the phase of the carrier waveform is varied, rather than the frequency:

y(t)=sin[ωc t+d•m(t) ]

where m(t) is the modulating signal and d is the phase deviation.

Frequency-Shift Keying (FSK) Modulation

FSK is similar to FM, except the carrier frequency alternates between two preset values, the carrier frequency and the hop frequency. Sometimes the hop and carrier frequencies are called "Mark" and "Space," respectively. The rate at which the switching between these values occurs is determined by an internal timer or the signal on the rear-panel Ext Trig connector. Frequency changes are instantaneous and phase-continuous.

The internal modulating signal is a square wave with 50% duty cycle.

The top trace below represents the modulating signal; the bottom trace represents the modulated carrier.

Binary Phase Shift Keying (BPSK)

BPSK is similar to FSK, except it is the carrier’s phase, rather than its frequency, that switches between two values. The rate at which the switching between these values occurs is determined by an internal timer or the signal on the rear-panel Ext Trig connector. Phase changes are instantaneous.

The internal modulating signal is a square wave with 50% duty cycle.

Pulse Width Modulation (PWM)

PWM is only available for the Pulse waveform, and the pulse width varies according to the modulating signal. The amount by which the pulse width varies is called the width deviation, and it can be specified as a percentage of the waveform period (that is, duty cycle) or in units of time. For example, if you specify a pulse with 20% duty cycle and then enable PWM with a 5% deviation, the duty cycle varies from 15% to 25% under control of the modulating signal.

Additive Modulation (Sum)

The "Sum" feature adds the modulating signal to the carrier. For example, you can add controlled amounts of variable-bandwidth noise to a signal or create two-tone signals. The instrument's internal modulation generator can produce the same continuous waveform as the main generator, so the Sum function lets you to create many signals that would have required two instruments before.

The Sum feature increases the amplitude of the output signal by the amplitude of the modulating signal. This might cause the instrument to switch to a higher output-voltage range, resulting in a momentary signal loss. If this is a problem in your application, turn on the Range Hold function. If the voltage increase could damage your device under test, apply Voltage Limits.

Burst

You can configure the instrument to output a waveform with for a specified number of cycles, called a burst. You can use burst in one of two modes: N-Cycle Burst (also called "triggered burst") or Gated Burst.

An N-Cycle burst consists of a specific number of waveform cycles (1 to 1,000,000) and is always initiated by a trigger event. You can also set the burst count to "Infinite," which results in a continuous waveform once the instrument is triggered.

In the image below, the top trace is the sync output, and the bottom one is the main output.

Three-Cycle Burst Waveform

For bursts, the trigger source can be an external signal, an internal timer, the key, or a command from the remote interface. The input for external trigger signals is the rear-panel Ext Trig connector. This connector is referenced to chassis ground (not floating ground). When not used as an input, the Ext Trig connector can be configured as an output to enable the instrument to trigger other instruments at the same time that its internal trigger occurs.

An N-Cycle burst always begins and ends at the same point in the waveform, called the start phase.

In GATed burst mode, the output waveform is on or off, based on the signal at the rear-panel Ext Trig connector. Select this signal's polarity using BURSt:GATE:POLarity. When the gate signal is true, the instrument outputs a continuous waveform. When the gate signal goes false, the current waveform cycle is completed and the instrument stops and remains at the voltage level corresponding to the waveform's starting burst phase. For a noise waveform, the output stops immediately when the gate signal goes false.

Frequency Sweep

Frequency sweeping is similar to FM, but no modulating waveform is used. Instead, the instrument sets the output frequency based on either a linear or logarithmic function, or a list of up to 128 user-specified frequencies. A linear sweep changes the output frequency by a constant number of Hz per second, and a logarithmic sweep changes the frequency by a constant number of decades per second. Logarithmic sweeps let you cover wide frequency ranges where resolution at low frequencies could be lost with a linear sweep.

Frequency sweeps are characterized by a sweep time (during which the frequency changes smoothly from the start frequency to the stop frequency), a hold time (during which the frequency stays at the stop frequency), and a return time (during which the frequency returns smoothly and linearly to the start frequency). Trigger settings determine when the next sweep begins.

Frequency sweep diagram

Attributes of AC Signals

The most common AC signal is a sine wave. In fact, any periodic signal can be represented as the sum of different sine waves. The magnitude of a sine wave is usually specified by its peak, peak-to-peak, or root-mean-square (RMS) value. All of these measures assume that the waveform has zero offset voltage.

Sine Wave RMS picture

A waveform's peak voltage is the maximum absolute value of all of its points. The peak-to-peak voltage is the difference between the maximum and minimum. The RMS voltage equals the standard deviation of all waveform points; it also represents the one-cycle average power in the signal, minus the power in any DC component of the signal. Crest factor is the ratio of a signal’s peak value to its RMS value and varies according to waveshape. The table below shows several common waveforms with their respective crest factors and RMS values.

Crest factor table

If an average-reading voltmeter is used to measure the "DC voltage" of a waveform, the reading may not agree with the DC Offset setting. This is because the waveform may have a non-zero average value that would be added to the DC Offset.

You may occasionally see AC levels specified in "decibels relative to 1 milliwatt" (dBm). Since dBm represents a power level, you need to know the signal’s RMS voltage and the load resistance in order to make the calculation.

dBm = 10 x log10 (P / 0.001) where P = VRMS2 / RL

For a sine wave into a 50 Ω load, the following table relates dBm to voltage.

dBm | RMS Voltage | Peak-to-Peak Voltage
+23.98 dBm | 3.54 Vrms | 10.00 Vpp
+13.01 dBm | 1.00 Vrms | 2.828 Vpp
+10.00 dBm | 707 mVrms | 2.000 Vpp
+6.99 dBm | 500 mVrms | 1.414 Vpp
3.98 dBm | 354 mVrms | 1.000 Vpp
0.00 dBm | 224 mVrms | 632 mVpp
-6.99 dBm | 100 mVrms | 283 mVpp
-10.00 dBm | 70.7 mVrms | 200 mVpp
-16.02 dBm | 35.4 mVrms | 100 mVpp
-30.00 dBm | 7.07 mVrms | 20.0 mVpp
-36.02 dBm | 3.54 mVrms | 10.0 mVpp
-50.00 dBm | 0.707 mVrms | 2.00 mVpp
-56.02 dBm | 0.354 mVrms | 1.00 mVpp

For 75 Ω or 600 Ω loads, use the following conversions:

dBm (75 Ω) = dBm (50 Ω) – 1.76

dBm (600 Ω) = dBm (50 Ω) – 10.79

Signal Imperfections

For sine waves, common signal imperfections are easiest to describe and observe in the frequency domain, using a spectrum analyzer. Any output signal component with a frequency different from the fundamental (or "carrier") is considered to be distortion. Those imperfections can be categorized as harmonic distortion, non-harmonic spurious, or phase noise, and they are specified in decibels relative to the carrier level, or "dBc."

Harmonic Distortion

Harmonic components occur at integer multiples of the fundamental frequency and are usually created by non-linear components in the signal path. At low signal amplitudes, another possible source of harmonic distortion is the Sync signal, which is a square wave with many strong harmonic components that can couple into the main signal. Although Sync is highly isolated from the instrument's main signal outputs, coupling can occur in external cabling. For best results, use high-quality coaxial cables with double or triple shields. If Sync is not required, leave it unconnected or off.

Non-Harmonic Spurious

One source of non-harmonic spurious components (called "spurs") is the digital-to-analog converter (DAC) that converts the digital waveform values into voltage. Non-linearity in this DAC gives rise to harmonics that can be higher than the Nyquist frequency and will therefore be aliased to a lower frequency. For example, the fifth harmonic of 30 MHz (150 MHz) could create a spur at 100 MHz.

Another source of non-harmonic spurs is the coupling of unrelated signal sources (such as the embedded controller’s clocks) into the output signal. These spurs usually have constant amplitude and are most troublesome at signal amplitudes below 100 mVpp. For optimal signal purity at low amplitudes, keep the instrument’s output level relatively high and use an external attenuator.

Phase Noise

Phase noise results from small, instantaneous changes in the output frequency ("jitter"). On a spectrum analyzer, it appears as a rise in the apparent noise floor near the frequency of the output signal. The phase noise specification represents the amplitudes of the noise in 1 Hz bands located 1 kHz, 10 kHz, and 100 kHz away from a 30-MHz sine wave. Be aware that spectrum analyzers also have phase noise, so the levels you read may include analyzer phase noise.

Quantization Noise

Finite resolution in the waveform DAC causes voltage quantization errors. Assuming the errors are uniformly distributed over a range of ±0.5 least-significant bit, the equivalent noise level for standard waveforms is approximately -95 dBc. At this level, other sources of noise in the instrument dominate. Quantization noise can be of concern, though, in arbitrary waveforms that do not use the whole range of DAC codes (-32767 to +32767). Scale arbitrary waveforms to use the entire range, if possible.

Ground Loops

The signal-generation portion of the instrument is isolated from chassis (earth) ground. This helps eliminate ground loops in your system and also allows you to reference the output signal to voltages other than ground. The illustration below shows the instrument connected to a load through a coaxial cable. Any difference in ground potentials (VGND) will tend to drive current IGND through the shield of the cable, thus causing a voltage drop due to the shield’s impedance (ZSHIELD). This voltage (IGND x ZSHIELD) appears as an error in the load voltage. However, since the instrument is isolated, there is a high series impedance (typically >1 MΩ) in parallel with 50 nF) to oppose the flow of IGND and thereby minimize this effect.

At frequencies above a few kHz, a coaxial cable’s shield becomes inductive, rather than resistive, and the cable begins to act like a transformer. When this happens, voltage drops in the shield due to IGND tend to be offset by equal voltages in the center conductor, thereby reducing the effects of ground loops at higher frequencies. Coaxial cables with two or three braided shields are much better than those with single- braided or foil shields because they have lower resistance and therefore become transformers at lower frequencies.

To reduce errors due to ground loops, connect the instrument to the load using a high-quality coaxial cable and ground it at the load through the cable’s shield. If possible, make sure the instrument and the load are connected to the same electrical outlet to minimize further differences in ground potential.

Be aware that the outer shells of the Sync and Modulation In connectors are connected to those of the main output connector(s). Cables attached to Sync and/or Modulation In are therefore potential sources of ground loops. Also be aware that attempting to drive those connector shells to different voltages can cause high current to flow through the instrument, possibly causing damage.


Tutorial Animations

Animations

The following animations demonstrate how to perform various tasks on the instrument via the front panel:

Set up a Sine Wave

Set up a Burst

Set up Frequency Coupling


SCPI Programming Reference

This section describes the SCPI programming language for the instrument.

Introduction to SCPI Language

Internal Function Waveforms

Alphabetical List of SCPI Commands and Queries

Programming Examples

Command Quick Reference

Factory Reset State

SCPI Error Messages


Introduction to SCPI Language

Introduction to the SCPI Language

SCPI (Standard Commands for Programmable Instruments) is an ASCII-based instrument command language designed for test and measurement instruments. SCPI commands are based on a hierarchical structure, also known as a tree system. In this system, associated commands are grouped together under a common node or root, thus forming subsystems. A portion of the OUTPut subsystem is shown below to illustrate the tree system.

OUTPut:
SYNC {OFF|0|ON|1}

SYNC:
MODE {NORMal|CARRier}
POLarity {NORMal|INVerted}

OUTPut is the root keyword, SYNC is a second-level keyword, and MODE and POLarity are third-level keywords. A colon ( : ) separates a command keyword from a lower-level keyword.

Syntax Conventions

The format used to show commands is illustrated below:

[SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}

[SOURce[1|2]:]FREQuency:CENTer {<frequency>|MINimum|MAXimum|DEFault}

The command syntax shows most commands (and some parameters) as a mixture of upper- and lower-case letters. The upper-case letters indicate the abbreviated spelling for the command. For shorter program lines, you can send the abbreviated form. For better program readability, you can send the long form.

For example, in the above syntax statement, VOLT and VOLTAGE are both acceptable forms. You can use upper- or lower-case letters. Therefore, VOLTAGE, volt, and Volt are all acceptable. Other forms, such as VOL and VOLTAG, are not valid and will generate an error.

  • Braces ( { } ) enclose the parameter choices for a given command string. The braces are not sent with the command string.
  • A vertical bar ( | ) separates multiple parameter choices for a given command string. For example, {VPP|VRMS|DBM} in the above command indicates that you can specify "VPP", "VRMS", or "DBM". The bar is not sent with the command string.
  • Triangle brackets in the second example ( < > ) indicate that you must specify a value for the enclosed parameter. For example, the above syntax statement shows the <frequency> parameter enclosed in triangle brackets. The brackets are not sent with the command string. You must specify a value for the parameter (for example "FREQ:CENT 1000") unless you select another option shown in the syntax (for example "FREQ:CENT MIN").
  • Some syntax elements (for example nodes and parameters) are enclosed in square brackets ( [ ]). This indicates that the element is optional and can be omitted. The brackets are not sent with the command string. If you do not specify a value for an optional parameter, the instrument chooses a default value. In the examples above the "SOURce[1|2]" indicates that you may refer to source channel 1 either by "SOURce", or by "SOURce1", or by "SOUR1" or by "SOUR". In addition, since the whole SOURce node is optional (in brackets) you also may refer to channel 1 by entirely leaving out the SOURce node. This is because Channel 1 is the default channel for the SOURce language node. On the other hand, to refer to Channel 2, you must use either "SOURce2" or "SOUR2" in your program lines.

Command Separators

A colon ( : ) is used to separate a command keyword from a lower-level keyword. You must insert a blank space to separate a parameter from a command keyword. If a command requires more than one parameter, you must separate adjacent parameters using a comma as shown below:

APPL:SIN 455E3,1.15,0.0

In this example, the APPLy command is specifying a sine wave at a frequency of 455 KHz, with an amplitude of 1.15 volts, and a DC offset of 0.0 volts.

A semicolon ( ; ) is used to separate commands within the same subsystem, and can also minimize typing. For example, sending the following command string:

TRIG:SOUR EXT; COUNT 10

is the same as sending the following two commands:

TRIG:SOUR EXT
TRIG:COUNT 10

Using the MIN, MAX, and DEF Parameters

For many commands, you can substitute "MIN" or "MAX" in place of a parameter. In some cases you may also substitute "DEF". For example, consider the following command:

[SOURce[1|2]:]APPLy:DC [{<frequency>|DEF} [,{<amplitude>|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Instead of selecting a specific value for the <offset> parameter, you can substitute MIN to set the offset to its minimum value, MAX to set the offset to its maximum value. You can also specify DEF to set the default value for each parameter: <frequency>, <amplitude>, and <offset>.

Querying Parameter Settings

You can query the current value of most parameters by adding a question mark ( ? ) to the command. For example, the following command sets the trigger count to 10 readings:

TRIG:COUN 10

You can then query the count value by sending:

TRIG:COUN?

You can also query the minimum or maximum count allowed as follows:

TRIG:COUN? MIN
TRIG:COUN? MAX

SCPI Command Terminators

A command string sent to the instrument must terminate with a <new line> (<NL>) character. The IEEE-488 EOI (End-Or-Identify) message is interpreted as a <NL> character and can be used to terminate a command string in place of a <NL> character. A <carriage return> followed by a <NL> is also accepted. Command string termination will always reset the current SCPI command path to the root level.

Note

For every SCPI message that includes a query and is sent to the instrument, the instrument terminates the returned response with a <NL> or line-feed character (EOI). For example, if "DISP:TEXT?" is sent, the response is terminated with a <NL> after the string of data that is returned. If a SCPI message includes multiple queries separated by semicolons (for example "DISP?;DISP:TEXT?"), the returned response is again terminated by a <NL> after the response to the last query. In either case, the program must read this <NL> in the response before another command is sent to the instrument, or an error will occur.

IEEE-488.2 Common Commands

The IEEE-488.2 standard defines a set of common commands that perform functions such as reset, self-test, and status operations. Common commands always begin with an asterisk ( * ), are three characters in length, and may include one or more parameters. The command keyword is separated from the first parameter by a blank space. Use a semicolon ( ; ) to separate multiple commands as shown below:

*RST; *CLS; *ESE 32; *OPC?

SCPI Parameter Types

The SCPI language defines several data formats to be used in program messages and response messages.

Numeric Parameters

Commands that require numeric parameters will accept all commonly used decimal representations of numbers including optional signs, decimal points, and scientific notation. Special values for numeric parameters such as MIN, MAX, and DEF are also accepted. You can also send engineering unit suffixes with numeric parameters (e.g., M, k, m, or u). If a command accepts only certain specific values, the instrument will automatically round the input numeric parameters to the accepted values. The following command requires a numeric parameter for the frequency value:

[SOURce[1|2]:]FREQuency:CENTer {<frequency>|MINimum|MAXimum}

Note

Because the SCPI parser is case-insensitive, there is some confusion over the letter "M" (or "m"). For your convenience, the instrument interprets "mV" (or "MV") as millivolts, but "MHZ" (or "mhz") as megahertz. Likewise "MΩ" (or "mΩ") is interpreted as megohms. You can use the prefix "MA" for mega. For example, "MAV" is interpreted as megavolts.

Discrete Parameters

Discrete parameters are used to program settings that have a limited number of values (like IMMediate, EXTernal, or BUS). They may have a short form and a long form just like command keywords. You can mix upper- and lower-case letters. Query responses will always return the short form in all upper-case letters. The following command requires a discrete parameter for the voltage units:

[SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}

Boolean Parameters

Boolean parameters represent a single binary condition that is either true or false. For a false condition, the instrument will accept "OFF" or "0". For a true condition, the instrument will accept "ON" or "1". When you query a Boolean setting, the instrument will always return "0" or "1". The following command requires a Boolean parameter:

DISPlay {OFF|0|ON|1}

ASCII String Parameters

String parameters can contain virtually any set of ASCII characters. A string must begin and end with matching quotes; either with a single quote or a double quote. You can include the quote delimiter as part of the string by typing it twice without any characters in between. The following command uses a string parameter:

DISPlay:TEXT <quoted string>

For example, the following command displays the message "WAITING..." on the instrument's front panel (the quotes are not displayed).

DISP:TEXT "WAITING..."

You can also display the same message using single quotes.

DISP:TEXT 'WAITING...'

Using Device Clear

Device Clear is an IEEE-488 low-level bus message that you can use to return the instrument to a responsive state. Different programming languages and IEEE-488 interface cards provide access to this capability through their own unique commands. The status registers, the error queue, and all configuration states are left unchanged when a Device Clear message is received.

Device Clear performs the following actions:

  • If a measurement is in progress, it is aborted.
  • The instrument returns to the trigger "idle" state.
  • The instrument's input and output buffers are cleared.
  • The instrument is prepared to accept a new command string.

Note

The ABORt command is the recommended method to terminate an instrument operation.


Internal Function Waveforms

The following are the internal function waveforms.

  • SINusoid: a sine wave, no phase shift.

    Sine waveform
  • SQUare: a square wave, 50% duty cycle.

    Square wave with 50% duty cycle
  • RAMP: ramp, 100% symmetry.

    Ramp with 100% symmetry
  • NRAMp: negative ramp, 0% symmetry.

    NRAMp with 0% symmetry
  • TRIangle: ramp, 50% symmetry.

    Triangle with 50% symmetry
  • NOISe: gaussian noise; if NOISe is the internal function, it cannot also be the carrier.

    Noise waveform
  • PRBS: pseudo-random binary sequence modulation; if PRBS is the internal function, it cannot also be the carrier.

    PRBS waveform
  • ARBitrary: arbitrary waveform; default is exponential rise; if ARB is the internal function, it cannot also be the carrier.

    Arb waveform

See Also

AM Subsystem

FM Subsystem

PM Subsystem

PWM Subsystem

SUM Subsystem


Alphabetical List of SCPI Commands and Queries

ABORt

AM Subsystem

APPLy Subsystem

BPSK Subsystem

BURSt Subsystem

CALibration Subsystem

COMBine:FEED

DATA Subsystem

DISPlay Subsystem

FM Subsystem

FORMat:BORDer

FREQuency Subsystem

FSKey Subsystem

FUNCtion Subsystem

HCOPy Subsystem

IEEE-488.2 Common Commands

INITiate Subsystem

INPut_ATTenuation_STATe

LIST Subsystem

LXI Subsystem

MARKer Subsystem

MEMory Subsystem

MMEMory Subsystem

OUTPut Subsystem

PHASe Subsystem

PM Subsystem

PWM Subsystem

RATE Subsystem

ROSC Subsystem

SOURce Subsystem

STATus Subsystem

SUM Subsystem

SWEep Subsystem

SYSTem Subsystem

SYSTem: LAN Configuration

TRACk

TRIGger Subsystem

UNIT:ANGLe

UNIT:ARBitrary:ANGLe

VOLTage Subsystem


ABORt

Halts a sequence, list, sweep, or burst, even an infinite burst. Also causes trigger subsystem to return to idle state. If INITiate:CONTinuous is ON, instrument immediately proceeds to wait-for-trigger state.

Parameter | Typical Return
(none) | (none)
Halt the items listed above: ABORt
  • Halts any triggered action (triggered list, triggered sweep, triggered burst, triggered arbitrary waveform playback).
  • ABORt has no effect when instrument is in normal or modulated modes, except for sequenced arbitrary waveforms, lists, bursts, and sweeps. If instrument is running a sequence, list, burst, or sweep, ABORt restarts the stopped item with the current INIT and trigger conditions.
  • When ABORt occurs in list mode, the frequency goes back to the "normal" mode frequency until the first trigger occurs. After the first trigger, the first frequency in the list will be used.
  • If ABORt executed during sweep, sweep returns to starting sweep frequency.
  • ABORt always applies to both channels in a two-channel instrument.


AM Subsystem

The AM subsystem allows you to add amplitude modulation (AM) to a carrier waveform.

Example

To generate an amplitude modulation (AM) waveform:

  1. Configure carrier waveform: Use FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet to specify the carrier waveform's function, frequency, amplitude, and offset.
  2. Select mode of Amplitude Modulation: AM:DSSC
  3. Select modulation source (internal, external, CH1, or CH2): AM:SOURce. For an external source, you can skip steps 4 and 5 below.
  4. Select modulating waveform: AM:INTernal:FUNCtion
  5. Set modulating frequency: AM:INTernal:FREQuency
  6. Set modulation depth: AM[:DEPTh]
  7. Enable AM: AM:STATe:ON

The following code produces the oscilloscope image shown below.

FUNCtion SQU
FREQuency +1.0E+04
VOLTage +1
VOLTage:OFFset 0.0
AM:SOURce INT
AM:DSSC 0
AM:DEPTh +120
AM:INTernal:FUNCtion TRI
AM:INTernal:FREQ 5E+02
AM:STATe 1
OUTPut1 1

[SOURce[1|2]:]AM[:DEPTh] {<depth_in_percent>|MINimum|MAXimum}
[SOURce[1|2]:]AM[:DEPTh]? [{MINimum|MAXimum}]

Sets internal modulation depth ("percent modulation") in percent.

Parameter | Typical Return
0 to 120, default 100 | +5.000000000000000E+01
Set the internal modulation depth to 50%: AM:DEPT 50 Set the internal modulation depth to 120%: AM:DEPT MAX
  • Even at greater than 100% depth, the instrument will not exceed ±5 V peak on the output (into a 50 Ω load). To achieve modulation depth greater than 100%, output carrier amplitude may be reduced.
  • With AM:SOURce EXTernal, carrier waveform is modulated with an external waveform. The modulation depth is controlled by the ±5 V signal level (or the optional ±1 V signal level on the 33600 Series) on the rear-panel Modulation In connector. For example, if modulation depth (AM[:DEPTh]) is 100%, then when the modulating signal is at +5 V (or optionally +1 V on the 33600 Series), the output will be at the maximum amplitude. Similarly, a -5 V modulating signal (or optionally -1 V on the 33600 Series) produces output at minimum amplitude.

See Also

INPut:ATTenuation[:STATe]

[SOURce[1|2]:]AM:DSSC {ON|1|OFF|0}
[SOURce[1|2]:]AM:DSSC?

Selects Amplitude Modulation mode − Double Sideband Suppressed Carrier (ON) or AM modulated carrier with sidebands (OFF).

Parameter | Typical Return
{ON|1|OFF|0} | 0 (OFF) or 1 (ON)
Set AM to DSSC mode: AM:DSSC ON
  • The power-on default value is OFF.
  • In DSSC AM, zero modulation results in zero output signal, and increasing modulation input signal raises the amplitude of the sidebands in proportion to the amplitude of the modulating signal.
  • DSSC AM is useful for some digital modulation modes.
  • In "normal" AM, zero modulation results in a half-amplitude carrier wave signal being output. As modulation input signal rises, the carrier is amplitude modulated between 0 and 100% amplitude.
  • In DSSC, the AM[:DEPTh] setting applies, and scales the modulation signal from 0 to 120% modulation.

[SOURce[1|2]:]AM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]AM:INTernal:FREQuency? [{MINimum|MAXimum}]

Sets frequency of modulating waveform. The waveform chosen as modulating source will operate at that frequency, within waveform frequency limits.

Parameter | Typical Return
1 μHz to the maximum allowed for the internal function. Default 100 Hz | +1.000000000000000E+04
Set the modulating frequency to 10 kHz: AM:INT:FUNC 10000
  • When you select an arbitrary waveform as the modulating source, the frequency changes to the frequency of the arbitrary waveform, which is based on the sample rate and the number of points in the arbitrary waveform.
  • When using an arbitrary waveform for the modulating source, changing this parameter also changes the cached metadata representing the arbitrary waveform's sample rate. You can also change the modulating frequency of an arbitrary waveform with FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod, and FUNCtion:ARBitrary:SRATe. These commands and the modulation frequency command are directly coupled in order to keep the arbitrary waveform behaving exactly as it was last played. If you later turn modulation off and select that same arbitrary waveform as the current function, its sample rate (and corresponding frequency based upon the number of points) will be the same as it was when played as the modulation source.
  • If the internal function is TRIangle, UpRamp, or DnRamp, the maximum frequency is limited to 200 kHz on the 33500 Series or 800 kHz on the 33600 Series. If the internal function is PRBS, the frequency refers to bit rate and is limited as shown here.
  • This command should be used only with the internal modulation source (AM:SOURce INTernal).

[SOURce[1|2]:]AM:INTernal:FUNCtion <function>
[SOURce[1|2]:]AM:INTernal:FUNCtion?

Selects shape of modulating waveform.

Parameter | Typical Return
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, default SINusoid, default SINusoid. View internal function waveforms. | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS, or ARB
Select a sine wave as the modulating waveform. AM:INT:FUNC SIN
  • This command should be used only with the internal modulation source (AM:SOURce INTernal).
  • Pulse and DC cannot be carrier waveform for AM.


AM:SOURce

[SOURce[1|2]:]AM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]AM:SOURce?

[SOURce[1|2]:]BPSK:SOURce {INTernal|EXTernal}
[SOURce[1|2]:]BPSK:SOURce?

[SOURce[1|2]:]FM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]FM:SOURce?

[SOURce[1|2]:]FSKey:SOURce {INTernal|EXTernal}
[SOURce[1|2]:]FSKey:SOURce?

[SOURce[1|2]:]PM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]PM:SOURce?

[SOURce[1|2]:]PWM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]PWM:SOURce?

Selects the source of the modulating signal.

Parameter | Typical Return
{INTernal|EXTernal|CH1|CH2}, default INTernal. BPSK and FSKey cannot accept CH1 or CH2 | INT, EXT, CH1, or CH2
Select external modulation source: AM:SOUR EXT (could also substitute FM, BPSK, FSK, PM, or PWM for AM)
  • If you select EXTernal, the carrier waveform is modulated with an external waveform. Specifically:
  • AM: The modulation depth is controlled by the ±5 V signal level (or the optional ±1 V signal level on the 33600 Series) on the rear-panel Modulation In connector. For example, if modulation depth (AM[:DEPTh]) is 100%, then when the modulating signal is at +5 V (or optionally +1 V on the 33600 Series), the output will be at the maximum amplitude. Similarly, a -5 V modulating signal (or optionally -1 V on the 33600 Series) produces output at minimum amplitude.
  • FM: If you select the External modulating source, the deviation is controlled by the ±5 V signal level (optionally ±1 V on the 33600 Series) on the rear-panel Modulation In connector. For example, if the frequency deviation is 100 kHz, then a +5 V signal level (optionally +1 V on the 33600 Series) corresponds to a 100 kHz increase in frequency. Lower external signal levels produce less deviation and negative signal levels reduce the frequency below the carrier frequency.
  • PM: With the External modulating source, deviation is controlled by the ±5 V signal level (optionally ±1 V on the 33600 Series) on the rear-panel Modulation In connector. For example, if you have set the frequency deviation to 180 degrees, then a +5 V signal level (optionally ±1 V on the 33600 Series) corresponds to a +180 degree phase deviation. Lower external signal levels produce less deviation, and negative signal levels produce negative deviation.
  • Pulse as Selected Function: The pulse width or pulse duty cycle deviation is controlled by the ±5 V signal level (optionally ±1 V on the 33600 Series) present on the rear-panel Modulation In connector. For example, if you have set the pulse width deviation to 50 μs using the PWM:DEViation command, then a +5 V signal level (optionally +1 V on the 33600 Series) corresponds to a 50 μs width increase. Lower external signal levels produce less deviation.
  • With EXTernal source, the output phase (BPSK) or frequency (FSK) is determined by the signal level on the rear-panel Ext Trig connector. When a logic low is present, the carrier phase or carrier frequency is output. When a logic high is present, the phase shifted phase or hop frequency is output.
  • The maximum external BPSK rate is 1 MHz, and the maximum FSK rate is 1 MHz.
  • Note: the connector used for externally-controlled BPSK or FSK waveforms (Trig In) is not the same connector that is used for externally-modulated AM, FM, PM, and PWM waveforms (Modulation In). When used for BPSK or FSK, the Trig In connector does not have adjustable edge polarity and is not affected by the TRIGger[1|2]:SLOPe command.
  • With INTernal source, the rate at which output phase (BPSK) or frequency (FSKey) "shifts" between the carrier phase or frequency and the alternate phase or frequency is determined by the BPSK rate (BPSK:INTernal:RATE) or FSK rate (FSKey:INTernal:RATE).
  • A channel may not be its own modulation source.

See Also

INPut:ATTenuation[:STATe]

AM Subsystem

BPSK Subsystem

FM Subsystem

FSKey Subsystem

PM Subsystem

PWM Subsystem


AM:STATe

[SOURce[1|2]:]AM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]AM:STATe?

[SOURce[1|2]:]BPSK:STATe {ON|1|OFF|0}
[SOURce[1|2]:]BPSK:STATe?

[SOURce[1|2]:]FM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]FM:STATe?

[SOURce[1|2]:]FSKey:STATe {ON|1|OFF|0}
[SOURce[1|2]:]FSKey:STATe?

[SOURce[1|2]:]PM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PM:STATe?

[SOURce[1|2]:]PWM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PWM:STATe?

Enables or disables modulation.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Enable AM (could also substitute FM, BPSK, FSK, PM, or PWM): AM:STAT ON
  • To avoid multiple waveform changes, enable modulation after configuring the other modulation parameters.
  • Only one modulation mode may be enabled at a time.
  • The instrument will not enable modulation with sweep or burst enabled. When you enable modulation, the sweep or burst mode is turned off.
  • PWM is allowed only when pulse is the selected function.

See Also

AM Subsystem

BPSK Subsystem

FM Subsystem

FSKey Subsystem

PM Subsystem

PWM Subsystem


APPLy Subsystem

The APPLy subsystem allows you to configure entire waveforms with one command. The general form of an APPLy command is shown below:

[SOURce[1|2]:]APPLy:<function> [<frequency> [,<amplitude> [,<offset>]]]

For example,

APPLy:SIN 1e4,1,0.1

replaces the following commands:

FUNCtion SIN
FREQ 1e4
VOLT 1
VOLT:OFF 0.1
OUTP ON

Not only is APPLy shorter, it avoids settings conflicts that occur when sending commands individually. In addition, APPLy performs the following operations:

  • Sets trigger source to IMMediate (equivalent to TRIGger[1|2]:SOURce IMMediate).
  • Turns off any modulation, sweep, or burst mode currently enabled and places the instrument in continuous waveform mode.
  • Turns on the channel output (OUTPut ON) without changing output termination setting (OUTPut[1|2]:LOAD).
  • Overrides the voltage autorange setting and enables autoranging (VOLTage:RANGe:AUTO).

The instrument can generate eight types of waveforms: DC voltage, gaussian noise, PRBS, pulse, ramp/triangle wave, sine wave, square wave and arbitrary (user) waveform. Waveform-specific settings exist in the FUNCtion subsystem.

You can also query current output configuration (APPLy?).

General Remarks

Amplitude

  • Changing amplitude may briefly disrupt output at certain voltages due to output attenuator switching. The amplitude is controlled, however, so the output voltage will never exceed the current setting while switching ranges. To prevent this disruption, disable voltage autoranging using VOLTage:RANGe:AUTO OFF. The APPLy command automatically enables autoranging.
  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details.
  • Limits Due to Unit Selection: The amplitude limits are determined by the output units selected.
  • You cannot specify output amplitude in dBm if output termination is set to high impedance. The units are automatically converted to Vpp.

Commands and Queries

[SOURce[1|2]:]APPLy?

[SOURce[1|2]:]APPLy:ARBitrary [{<sample_rate>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:DC

[SOURce[1|2]:]APPLy:NOISe

[SOURce[1|2]:]APPLy:PRBS

[SOURce[1|2]:]APPLy:PULSe

[SOURce[1|2]:]APPLy:RAMP

[SOURce[1|2]:]APPLy:SINusoid

[SOURce[1|2]:]APPLy:SQUare

[SOURce[1|2]:]APPLy:TRIangle

[SOURce[1|2]:]APPLy?

Queries the output configuration.

Parameter | Typical Return
(none) | "SIN +5.000000000000000E+03, +3.0000000000000E+00, -2.5000000000000E+00"
Return the configuration for a 5 kHz, 3 V sine wave with a -2.5 VDC offset. APPLY?
  • The function, frequency, amplitude, and offset are returned as shown above. The amplitude, but not the offset, is returned as specified by VOLTage:UNIT.

[SOURce[1|2]:]APPLy:ARBitrary [{<sample_rate>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Outputs arbitrary waveform selected by FUNCtion: ARBitrary, using the specified sample rate, amplitude, and offset.

Parameter | Typical Return
<sample_rate> from 1 µSa/s to 250 MSa/s (33500 Series) or 1 GSa/s (33600 Series), default 40 kSa/s | (none)
<amplitude> from 1 mVpp to 10 Vpp into 50 Ω, 2 mVpp to 20 Vpp into an open circuit, default 100 mVpp into 50 Ω
<offset> is the DC offset voltage (default 0), from ±5 VDC into 50 Ω, or from ±10 VDC into an open circuit.
Output the arbitrary waveform selected using FUNCtion:ARBitrary: APPLy:ARBitrary 1 kHz, 5.0, -2.5 V

General

  • Setting a sample rate when not in the ARB mode will not change the frequency. For example, if the current function is sine, setting sample rate has no effect until the function changes to ARB.
  • High sample rates may affect the actual amplitude due to filter roll-off.

Options

  • See FUNCtion: ARBitrary for available arbitrary waveform options. With FUNCtion:ARBitrary, you may select a built-in arbitrary waveform or the waveform currently downloaded to volatile memory using MMEMory commands.

Offset Voltage

  • The relationship between offset voltage and output amplitude is shown below. Vmax is the maximum peak voltage for the selected output termination (5 V for a 50 Ω load or 10 V for a high-impedance load).

    |Voffset| < Vmax - Vpp/2

    If the specified offset voltage is not valid, the instrument will adjust it to the maximum DC voltage allowed with the specified amplitude. From the remote interface, a "Data out of range" error will also be generated.

  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details.

[SOURce[1|2]:]APPLy:DC [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Outputs a DC voltage.

Parameter | Typical Return
<frequency> not applicable to DC function. Must be specified as a placeholder; the value is remembered when you change to a different function. | (none)
<amplitude> not applicable to DC function. Must be specified as a placeholder; the value is remembered when you change to a different function.
<offset> is the DC offset voltage (default 0), from ±5 VDC into 50 Ω, or from ±10 VDC into an open circuit.
Output a DC voltage of -2.5 V: APPLy:DC DEF, DEF, -2.5 V
  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details. Changing the output termination setting does not change the voltage present at the output terminals of the instrument. This only changes the displayed values on the front panel and the values queried from the remote interface. The voltage present at the instrument's output depends on the load connected to the instrument. See OUTPut[1|2]:LOAD for details.

[SOURce[1|2]:]APPLy:NOISe [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Outputs gaussian noise with the specified amplitude and DC offset.

Parameter | Typical Return
<frequency> not applicable to noise function. Must be specified as a placeholder; the value is remembered when you change to a different function. | (none)
<amplitude> Desired output amplitude in Vpp, Vrms or dBm, as specified by VOLTage:UNIT.1 mVpp to 10 Vpp into 50 Ω, or twice that into an open circuit. If specified in Vpp, the peak to peak output will actually be output very rarely, due to gaussian nature of noise.
<offset> is the DC offset voltage (default 0), from ±5 VDC into 50 Ω, or from ±10 VDC into an open circuit.
Output gaussian noise bounded by 3 Vpp, with -2.5 V offset: APPL:NOIS 5 KHZ, 3.0 V, -2.5 V

Frequency

  • If you specify a frequency, it has no effect on the noise output, but the value is remembered when you change to a different function.
  • For information on changing noise bandwidth, see FUNCtion:NOISe:BANDwidth.

Offset Voltage

  • The relationship between offset voltage and output amplitude is shown below. Vmax is the maximum peak voltage for the selected output termination (5 V for a 50 Ω load or 10 V for a high-impedance load).

    |Voffset| < Vmax - Vpp/2

    If the specified offset voltage is not valid, the instrument will adjust it to the maximum DC voltage allowed with the specified amplitude.

    From the remote interface, a "Data out of range" error will also be generated.

  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details.

[SOURce[1|2]:]APPLy:PRBS [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Outputs a pseudo-random binary sequence with the specified bit rate, amplitude and DC offset.

The default waveform is a PN7 Maximum Length Shift Register generator.

Parameter | Typical Return
<frequency> in bits/s, default 1000 | (none)
<amplitude> Desired output amplitude in Vpp, Vrms or dBm, as specified by VOLTage:UNIT. 1 mVpp to 10 Vpp into 50 Ω, or twice that into an open circuit. Default is 100 mVpp into 50 Ω.
<offset> is the DC offset voltage (default 0), from ±5 VDC into 50 Ω, or from ±10 VDC into an open circuit.
Output pseudo-random bit sequence bounded by 3 Vpp, with -2.5 V offset: APPL:PRBS 5 KHZ, 3.0 V, -2.5 V

Frequency

  • PRBS is generated by a Maximum Length Sequence (MLS) generator (Linear Feedback Shift Register) which may be configured to several standard configurations. Default is PN7 at 1000 bits/second.
  • A PRBS waveform using polynomial PNx is generated by a shift register of x bits, and the output waveform begins with x sample periods of high output. Sample period is the reciprocal of the sample rate (FUNCtion:PRBS:BRATe), and the channel's Sync pulse indicates the waveform's start. For example, if the PRBS uses PN23 with sample rate 500 Hz, the output begins with 46 ms of high output (23 x 2 ms).
  • Unlike the APPLy:NOISe function, the APPLy:PRBS function operates with the Sync output enabled. The Sync function indicates the beginning of the Pseudo-random function sequence.

Offset Voltage

  • The relationship between offset voltage and output amplitude is shown below. Vmax is the maximum peak voltage for the selected output termination (5 V for a 50 Ω load or 10 V for a high-impedance load).

    |Voffset| < Vmax - Vpp/2

    If the specified offset voltage is not valid, the instrument will adjust it to the maximum DC voltage allowed with the specified amplitude. From the remote interface, a "Data out of range" error will also be generated.
  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details.

[SOURce[1|2]:]APPLy:PULSe [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Outputs a pulse wave with the specified frequency, amplitude, and DC offset. In addition, APPLy performs the following operations:

  • Preserves either the current pulse width setting (FUNCtion:PULSe:WIDTh) or the current pulse duty cycle setting (FUNCtion:PULSe:DCYCle).
  • Preserves the current transition time setting (FUNCtion:PULSe:TRANsition[:BOTH]).
  • May cause instrument to override the pulse width or edge time setting to comply with the specified frequency or period (FUNCtion:PULSe:PERiod).
Parameter | Typical Return
<frequency> in Hz, default 1 kHz | (none)
<amplitude> Desired output amplitude in Vpp, Vrms or dBm, as specified by VOLTage:UNIT. 1 mVpp to 10 Vpp into 50 Ω, or twice that into an open circuit. Default is 100 mVpp into 50 Ω.
<offset> is the DC offset voltage (default 0), from ±5 VDC into 50 Ω, or from ±10 VDC into an open circuit.
Output a 5 Vpp pulse wave at 1 kHz with a -2.5 V offset: APPL:PULS 1 kHz, 5.0 V, -2.5 V

Frequency

  • The APPLy command must be appropriate for the function. For example, APPL:PULS 300 MHz results in a "Data out of range" error. In that case, the frequency would be set to the instrument's maximum frequency for a pulse.

Offset Voltage

  • The relationship between offset voltage and output amplitude is shown below. Vmax is the maximum peak voltage for the selected output termination (5 V for a 50 Ω load or 10 V for a high-impedance load).

    |Voffset| < Vmax - Vpp/2

    If the specified offset voltage is not valid, the instrument will adjust it to the maximum DC voltage allowed with the specified amplitude. From the remote interface, a "Data out of range" error will also be generated.
  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details.

[SOURce[1|2]:]APPLy:RAMP [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:TRIangle [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Outputs a ramp wave or triangle wave with the specified frequency, amplitude, and DC offset. In addition, APPLy performs the following operations:

  • APPLy:RAMP overrides the current symmetry setting (FUNCtion:RAMP:SYMMetry), and sets 100% symmetry for the ramp waveform.
  • APPLy:TRIangle is simply a special case of APPLy:RAMP. It is equivalent to a ramp waveform with 50% symmetry.
Parameter | Typical Return
<frequency> in Hz, default 1 kHz | (none)
<amplitude> Desired output amplitude in Vpp, Vrms or dBm, as specified by VOLTage:UNIT. 1 mVpp to maximum allowed for the instrument model and waveform into 50 Ω, or twice that into an open circuit. Default is 100 mVpp into 50 Ω.
<offset> is the DC offset voltage (default 0), from ±5 VDC into 50 Ω, or from ±10 VDC into an open circuit.
Configure a 5 V ramp wave at 3 kHz with 0 V offset: APPL:RAMP 3 KHZ, 5.0 V, 0

Frequency

  • The APPLy command must be appropriate for the function. For example, the command APPL:RAMP 5 MHz results in a "Data out of range" error. In that case, the frequency would be set to 200 kHz, which is the maximum for a ramp.

Offset Voltage

  • The relationship between offset voltage and output amplitude is shown below. Vmax is the maximum peak voltage for the selected output termination (5 V for a 50 Ω load or 10 V for a high-impedance load).

    |Voffset| < Vmax - Vpp/2

    If the specified offset voltage is not valid, the instrument will adjust it to the maximum DC voltage allowed with the specified amplitude. From the remote interface, a "Data out of range" error will also be generated.
  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details.

[SOURce[1|2]:]APPLy:SINusoid [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Outputs a sine wave with the specified frequency, amplitude, and DC offset.

Parameter | Typical Return
<frequency> from 1 μHz to instrument's maximum frequency. Default 1 kHz. | (none)
<amplitude> Desired output amplitude in Vpp, Vrms or dBm, as specified by VOLTage:UNIT. 1 mVpp to maximum allowed for the instrument model and waveform into 50 Ω, or twice that into an open circuit. Default is 100 mVpp into 50 Ω.
<offset> is the DC offset voltage (default 0), from ±5 VDC into 50 Ω, or from ±10 VDC into an open circuit.
Output 3 Vpp sine wave at 5 kHz with -2.5 V offset. APPL:SIN 5 KHZ, 3.0 VPP, -2.5 V

Offset Voltage

  • The relationship between offset voltage and output amplitude is shown below. Vmax is the maximum peak voltage for the selected output termination (5 V for a 50 Ω load or 10 V for a high-impedance load).

    |Voffset| < Vmax - Vpp/2

    If the specified offset voltage is not valid, the instrument will adjust it to the maximum DC voltage allowed with the specified amplitude. From the remote interface, a "Data out of range" error will also be generated.
  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details.

[SOURce[1|2]:]APPLy:SQUare [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

Outputs a square wave with the specified frequency, amplitude, and DC offset. In addition, APPLy:SQUare overrides the current duty cycle setting (FUNCtion:SQUare:DCYCle), and sets a 50% duty cycle for the square wave.

Parameter | Typical Return
<frequency> from 1 μHz to instrument's maximum frequency. Default 1 kHz. | (none)
<amplitude> Desired output amplitude in Vpp, Vrms or dBm, as specified by VOLTage:UNIT. 1 mVpp to maximum allowed for the instrument model and waveform into 50 Ω, or twice that into an open circuit. Default is 100 mVpp into 50 Ω.
<offset> is the DC offset voltage (default 0), from ±5 VDC into 50 Ω, or from ±10 VDC into an open circuit.
Output 3 V square wave at 5 kHz with -2.5 V offset: APPL:SQU 5 KHZ, 3.0 V, -2.5 V

Frequency

  • The APPLy command must be appropriate for the function. For example, APPL:SQU 40 MHz results in a "Data out of range" error and the instrument sets the frequency to its maximum frequency for a square wave.

Offset Voltage

  • The relationship between offset voltage and output amplitude is shown below. Vmax is the maximum peak voltage for the selected output termination (5 V for a 50 Ω load or 10 V for a high-impedance load).

    |Voffset| < Vmax - Vpp/2

    If the specified offset voltage is not valid, the instrument will adjust it to the maximum DC voltage allowed with the specified amplitude. From the remote interface, a "Data out of range" error will also be generated.
  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details.


BPSK Subsystem

The BPSK subsystem allows you to modulate a waveform with Binary Phase Shift Keying (BPSK), a digital modulation format. In BPSK, the carrier waveform is phase shifted between two phase settings using an on/off keying. The source may be internal, using a square wave at a specified frequency, or external, using the external trigger input.

If the carrier function is an arbitrary waveform, then the phase shift only affects the position of sample transitions. This is different than shifting the phase of the overall arbitrary waveform.

Example

To generate a BPSK waveform:

  1. Configure carrier waveform: Use FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet to specify the carrier waveform's function, frequency, amplitude, and offset.
  2. Select modulation source (internal, external, CH1, or CH2): BPSK:SOURce. For an external source, skip steps 3 and 4 below.
  3. Select BPSK phase: BPSK[:PHASe]
  4. Set BPSK rate: BPSK:INTernal:RATE
  5. Enable BPSK Modulation: BPSK:STATe ON

The following code produces the oscilloscope image shown below.

FUNCtion SQU
FREQuency +1.0E+04
VOLTage +1.0
VOLTage:OFFset 0.0
BPSK:SOURce INT
BPSK:INTernal:RATE +3000
BPSK:PHASe +90
BPSK:STATe 1
OUTPut1 1

[SOURce[1|2]:]BPSK:INTernal:RATE {<modulating_frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]BPSK:INTernal:RATE? [{MINimum|MAXimum}]

Sets the rate at which the output phase "shifts" between the carrier and offset phase.

Parameter | Typical Return
1 mHZ to 1 MHz, default 10 Hz | +1.000000000000000E‑03
Set BPSK rate to 1 mHz: BPSK:INT:RATE MIN
  • The BPSK rate is used only when the INTernal source is selected (BPSK:SOURce INTernal) and is ignored when the EXTernal source is selected (BPSK:SOURce EXTernal).
  • The internal modulating waveform is a square wave with a 50% duty cycle.

[SOURce[1|2]:]BPSK[:PHASe] {<angle>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]BPSK[:PHASe]? [{MINimum|MAXimum}]

Sets the Binary Phase Shift Keying phase shift in degrees.

Parameter | Typical Return
0 to +360 degrees, default 180 | +1.800000000000000E+02
Set phase shift to 90 degrees: BPSK:PHAS 90


BURSt Subsystem

This section describes the BURSt subsystem.

Example

This summarizes the steps required to generate a burst.

  1. Configure the burst waveform: Use APPLy or the equivalent FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet commands to select the waveform's function, frequency, amplitude, and offset. You can select a sine, square, triangle, ramp, pulse, PRBS, or arbitrary waveform (noise is allowed only in the gated burst mode and DC is not allowed). For internally-triggered bursts, the minimum frequency is 2.001 mHz. For sine and square waveforms, frequencies above 6 MHz are allowed only with an "infinite" burst count.
  2. Select the "triggered" or "gated" burst mode: Select the triggered burst mode (called "N Cycle" on the front panel) or external gated burst mode using BURSt:MODE. If you are using gated mode, specify true-high or true-low logic with BURSt:GATE:POLarity.
  3. Set the burst count: Set the burst count (number of cycles per burst) to any value between 1 and 100,000,000 cycles (or infinite) using the BURSt:NCYCles command. Used in the triggered burst mode only. In PRBS, BURSt:NCYCles sets the number of bits of PRBS. Each burst starts at the sequence start.
  4. Set the burst period: Set the burst period (the interval at which internally-triggered bursts are generated) to any value from 1 μs to 8000 seconds using BURSt:INTernal:PERiod. Used only in the triggered burst mode with an internal trigger source.
  5. Set the burst starting phase: Set the starting phase of the burst from -360 to +360 degrees using BURSt:PHASe.
  6. Select the trigger source: Select the trigger source using the TRIGger[1|2]:SOURce command. Used in the triggered burst mode only.
  7. Enable the burst mode: After configuring the other burst parameters, enable burst mode (BURSt:STATe ON).

The following code produces the oscilloscope image shown below.

APPLy:SIN 1e5,3 VPP,0
BURS:MODE TRIG
BURS:NCYC 3
BURS:INT:PER 4.4e-5
BURS:PHAS 0
TRIG:SOUR IMM
BURS:STAT ON
OUTP 1

Burst Modes

There are two burst modes, described below. The instrument enables one burst mode at a time.

  • Triggered Burst Mode (default): The instrument outputs a waveform for a number of cycles (burst count) each time a trigger is received. After outputting the specified number of cycles, the instrument stops and waits for the next trigger. You can configure the instrument to use an internal trigger to initiate the burst or you can provide an external trigger by pressing the front panel [Trigger] key, by applying a trigger signal to the rear-panel Ext Trig connector, or by sending a software trigger command from the remote interface.
  • External Gated Burst Mode: The instrument output is either "on" or "off" based on the level of the external signal applied to the rear-panel Ext Trig connector. When this signal is true, the instrument outputs a continuous waveform. When this signal goes false, the current waveform cycle is completed and then the instrument stops while remaining at the voltage corresponding to the starting burst phase of the waveform.

The following table shows which modes are associated with which burst features.

 | Burst Mode BURSt:MODE | Burst Count BURSt:NCYCles | Burst Period BURSt:INTernal:PERiod | Burst Phase BURSt:PHASe | Trigger Source TRIGger[1|2]:SOURce
Triggered Burst Mode: Internal Trigger | TRIGgered | Available | Available | Available | IMMediate
Triggered Burst Mode: External Trigger | TRIGgered | Available | Not Used | Available | EXTernal, BUS
Gated Burst Mode: External Trigger | GATed | Not Used | Not Used | Available | Not Used

The difference between gated burst and gated output is that gated burst synchronously starts and stops using full waveform cycles, where gated output asynchronously turns instrument output on or off with an external trigger, independent of the waveform phase.

If the duty cycle is changed on a triggered bursted square wave with the trigger mode set to Timer, the current burst will finish and one more burst will be executed before the duty cycle of the burst changes.

[SOURce[1|2]:]BURSt:GATE:POLarity {NORMal|INVerted}
[SOURce[1|2]:]BURSt:GATE:POLarity?

Selects true-high (NORMal) or true-low (INVerted) logic levels on the rear-panel Ext Trig connector for an externally gated burst.

Parameter | Typical Return
{NORMal|INVerted}, default NORMal | NORM or INV
Select true-low logic for an externally gated burst: BURS:GATE:POL INV

[SOURce[1|2]:]BURSt:INTernal:PERiod {<seconds>|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:INTernal:PERiod? [{MINimum|MAXimum}]

Sets the burst period for internally-triggered bursts.

Parameter | Typical Return
1 µs to 8000 s, default 10 ms | +1.200000000000000E+01
Sets the burst period to 12 seconds: BURS:INT:PER 12
  • The burst period is the time between the starts of consecutive bursts.
  • This is used only when IMMediate triggering is enabled (TRIGger[1|2]:SOURce IMMediate). It is ignored when manual or external triggering is enabled (or with gated burst mode).
  • On the 33500 Series, burst period must satisfy the following formula:

    Burst Period ≥ (Burst Count / Waveform Frequency) + 1 μs.

    On the 33600 Series, burst period must satisfy the following formula:

    Burst Period ≥ (Burst Count / Waveform Frequency) + 500 ns, with a minimum Burst Period of 1 μs.
  • If the burst period is too short, the instrument will increase it as needed to continuously re-trigger the burst. From the remote interface, a "Settings conflict" error will also be generated.

[SOURce[1|2]:]BURSt:MODE {TRIGgered|GATed}
[SOURce[1|2]:]BURSt:MODE?

Selects the burst mode.

Parameter | Typical Return
{TRIGgered|GATed}, default TRIGgered | TRIG or GAT
Set gated burst mode BURS:MODE GATED
  • TRIGgered: the instrument outputs a waveform for a number of cycles (burst count) each time a trigger is received from the trigger source (TRIGger[1|2]:SOURce).
  • In GATed burst mode, the output waveform is on or off, based on the signal at the rear-panel Ext Trig connector. Select this signal's polarity using BURSt:GATE:POLarity. When the gate signal is true, the instrument outputs a continuous waveform. When the gate signal goes false, the current waveform cycle is completed and the instrument stops and remains at the voltage level corresponding to the waveform's starting burst phase. For a noise waveform, the output stops immediately when the gate signal goes false.
  • GATed: burst count, burst period, and trigger source are ignored (these are used for the triggered burst mode only). If a manual trigger is received (TRIGger[1|2] ), it is ignored and no error will be generated.

[SOURce[1|2]:]BURSt:NCYCles {<num_cycles>|INFinity|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:NCYCles? [{MINimum|MAXimum}]

Sets the number of cycles to be output per burst (triggered burst mode only).

Parameter | Typical Return
Whole number from 1 (default) to 100,000,000, limited as described below | +5.000000000000000E+01
Return number of cycles per burst: BURS:NCYC 50
  • With TRIGger[1|2]:SOURce IMMediate, burst count must be less than the product of the maximum burst period (8000 s) and the waveform frequency, as shown below.

    Burst Count < (Maximum Burst Period)(Waveform Frequency)
  • The increase the burst period up to its maximum value to accommodate the burst count (but the waveform frequency will not be changed). From the remote interface, a "Settings conflict" error will also be generated.
  • When gated burst mode is selected, the burst count is ignored. However, if you change the burst count while in the gated mode, the instrument remembers the new count and used it when the triggered mode is selected.

[SOURce[1|2]:]BURSt:PHASe {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:PHASe? [{MINimum|MAXimum}]

Sets the starting phase angle for the burst.

Parameter | Typical Return
-360 to +360 degrees, -2p to +2p radians, or -(period) to +(period), as specified by UNIT:ANGLe. Default 0. | +6.0000000000000E+01
Set starting burst phase to 60 degrees: UNIT:ANGLE DEG BURS:PHAS 60
  • Note that BURSt:PHASe is used instead of output phase, and when burst is enabled, the output phase is set to 0.
  • For sine, square, and ramp, 0 degrees is the point at which the waveform crosses 0 V (or DC offset) in a positive-going direction. For arbitrary waveforms, 0 degrees is the first waveform point. Start phase has no effect on noise.
  • For arbitrary waveforms on the 33500 Series, BURSt:PHASe is only available if the waveform is 1,000,000 points or less.
  • Start phase also used in gated burst mode. When the gate signal goes false, the current waveform cycle finishes, and output remains at the voltage level of the starting burst phase.

[SOURce[1|2]:]BURSt:STATe {ON|1|OFF|0}
[SOURce[1|2]:]BURSt:STATe?

Enables or disables burst mode.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Enable burst mode: BURS:STAT ON
  • Output phase is set to 0 when burst is enabled.
  • To avoid multiple waveform changes, enable the burst mode after configuring the other burst parameters.
  • The instrument will not allow the burst mode to be enabled at the same time that sweep or any modulation mode is enabled. When you enable burst, the sweep or modulation mode is turned off.


CALibration Subsystem

The CALibration subsystem is used to calibrate the instrument.

Commands and Queries

CALibration[:ALL]?

CALibration:COUNt?

CALibration:SECure:CODE <new_code>

CALibration:SECure:STATe {ON|1|OFF|0} [,<code>]
CALibration:SECure:STATe?

CALibration:SETup <step>
CALibration:SETup?

CALibration:STORe

CALibration:STRing "<string>"
CALibration:STRing?

CALibration:VALue <value>
CALibration:VALue?

CALibration[:ALL]?

Performs a calibration using the calibration value (CALibration:VALue). The instrument must be unlocked (CALibration_SECure_STATe OFF,<code>) to calibrate.

Parameter | Typical Return
(none) | +0 (pass) or +1 (fail)
Calibrate using the current value: CAL?
  • CALibration:SETup should always precede the CALibration? query.
  • Increments the instrument’s calibration count (CALibration:COUNt?).
  • Modifies the volatile version of the calibration constants. Use CALibration:STORe to save these constants in nonvolatile memory at end of calibration.

CALibration:COUNt?

Returns the number of calibrations performed. Read and record the initial count when you receive your instrument from the factory.

Parameter | Typical Return
(none) | +117
Return the calibration count: CAL:COUN?
  • Because the value increments for each calibration point (each CALibration:ALL?), a complete calibration adds many counts.
  • You can display count regardless of whether instrument is secured.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.

CALibration:SECure:CODE <new_code>

Sets the security code to prevent unauthorized calibrations.

Parameter | Typical Return
Unquoted string up to 12 characters Must start with letter (A-Z) May contain letters, numbers (0-9) and underscores | (none)
Set new security code: CAL:SEC:CODE MY_CODE_272
  • The factory default security codes vary by model:

    Models | Security Code
    33521A and 33522A | AT33520A
    335XXB | AT33500
    33600 Series | AT33600
  • To change code: unsecure calibration memory with the old code, and then set new code.
  • If you forget the security code, see Unsecure Instrument Without Security Code.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.

CALibration:SECure:STATe {ON|1|OFF|0} [,<code>]
CALibration:SECure:STATe?

Unsecures or secures the instrument for calibration. To calibrate, you must unsecure the instrument with the code (CALibration:SECure:CODE).

Parameter | Typical Return
{ON|1|OFF|0}, default ON <code> is an unquoted string up to 12 characters | 0 (OFF) or 1 (ON)
Unsecure calibration: CAL:SEC:STAT OFF,MY_CODE_272 Secure calibration: CAL:SEC:STAT ON
  • The <code> is optional to secure the instrument, but must be correct if provided.
  • Front panel and remote interface calibration use same code. If you secure the instrument from one interface, use the same code to unsecure it from the other interface.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.

CALibration:SETup <step>
CALibration:SETup?

Configures the calibration step (default 1) to be performed. The instrument must be unlocked (CALibration_SECure_STATe OFF,<code>) to calibrate. See Calibration Security for details.

Parameter | Typical Return
Whole number, default 1 | +16
Prepare for calibration step 5: CAL:SET 5
  • This setting is non-volatile; it will not be changed by power cycling or *RST.

CALibration:STORe

Takes calibration constants in volatile memory (CALibration:ALL?), and places them in nonvolatile memory, where they will not be changed by power cycle or *RST. Do this at the end of calibration to avoid losing changes.

Parameter | Typical Return
(none) | (none)
Store calibration constants into non-volatile memory: CAL:STOR

CALibration:STRing "<string>"
CALibration:STRing?

Stores a message of up to 40 characters in calibration memory. Common messages include last calibration date, calibration due date, or contact information for calibration department. The instrument must be unlocked (CALibration_SECure_STATe OFF,<code>) to store this string.

Parameter | Typical Return
Quoted string up to 40 characters May contain letters, numbers, spaces, and other common characters. | "LAST CAL OCT 31 2011, DUE OCT 31 2012" (If no string stored, returns "")
CAL:STR "FOR CAL HELP, CALL JOE AT EXT 1234"
  • May be stored only from remote interface, with instrument unsecured (CALibration:SECure:STATe OFF).
  • You can read the message from the front panel or remote interface, regardless of whether the instrument is secured.
  • Storing a calibration message overwrites the previous message.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.

CALibration:VALue <value>
CALibration:VALue?

Specifies the value of the known calibration signal.

Parameter | Typical Return
Numeric, default 0.0 | +2.37000000E-002
Specify calibration value 0.0237: CAL:VAL 2.37E-2
  • This setting is non-volatile; it will not be changed by power cycling or *RST.


COMBine:FEED

[SOURce[1|2]:]COMBine:FEED {CH1|CH2|NONE}
[SOURce[1|2]:]COMBine:FEED?

Enables or disables the combining of both channels' outputs on a two-channel instrument into a single channel connector. The "SOURce" keyword (default, SOURce1) specifies the base channel, and <source> specifies the channel to be combined with the base channel.

Parameter | Typical Return
{CH1|CH2|NONE}, default NONE | CH1, CH2, or NONE
Set the COMBine:FEED source for base Channel 1 to be Channel 2: COMB:FEED CH2
  • COMBine:FEED allows digital data from both channels to be added together to create the output signal on the output DAC for the base channel.
  • Only one channel may operate in COMBine:FEED mode at a time
  • Unlike the Modulation and SUM commands, COMBine:FEED can add two modulated signals.
  • COMBine:FEED can generate quadrature modulated signals from the two channels to be added together into a single connector.
  • To use COMBine:FEED, first configure all parameters on the individual channels.
  • The signals to be combined may have a fixed phase offset between the channels.
  • You can use COMBine:FEED to add noise from a second channel to a modulated signal on the base channel.
  • If COMBine:FEED would cause the combined output to exceed either the instrument's output rating or the programmed limits, the instrument will set COMBine:FEED to NONE and report a settings conflict error.
  • Signals are combined in digital form. When two signals of significantly different amplitudes are combined, the lower amplitude signal may have reduced resolution proportional to the ratio of the two amplitudes.
  • Changing the function amplitude or sum amplitude of the master or combined channel will not change the amplitude or offset of any other function or channel. If changing the function amplitude or sum amplitude of the master or combined channel would result in exceeding either the output rating or the programmed limits, the amplitude value will be clipped and a settings conflict error will be reported.
  • Changing the channel offset of the master or combined channel will not change the amplitude or offset of any other function or channel. If changing channel offset of the master or combined channel would result in exceeding either the output rating or the programmed limits, the amplitude value will be clipped and the instrument will report a settings conflict error.
  • If turning limits on or adjusting programmed limits would result in a limit being lower than a signal maximum or higher than a signal minimum, the limits will not be turned on or adjusted, and the instrument will report a settings conflict error.


DATA Subsystem

The DATA subsystem manages user-defined arbitrary waveforms:

  • [SOURce[1|2]:]DATA:ARBitrary2:FORMat {AABB|ABAB} - specifies the order for bytes in a dual arbitrary waveform file (requires optional IQ player).
  • [SOURce[1|2]:]DATA:ARBitrary[1|2] <arb_name>, {<binary_block>|<value>, <value>, . . .} - downloads arbitrary waveform normalized values to waveform memory
  • [SOURce[1|2]:]DATA:ARBitrary[1|2]:DAC <arb_name>, {<binary_block>|<value>, <value>, . . .} - downloads arbitrary waveform DAC codes to waveform memory
  • [SOURce[1|2]:]DATA:ATTRibute:AVERage? [<arb_name>] - returns arithmetic average of all data points for an arbitrary waveform or sequence
  • [SOURce[1|2]:]DATA:ATTRibute:CFACtor? [<arb_name>]ATA:ATTRibute:CFACtor? - returns crest factor of all data points in an arbitrary waveform or sequence
  • [SOURce[1|2]:]DATA:ATTRibute:POINts? [<arb_name>] - returns number of data points for arbitrary waveform or sequence
  • [SOURce[1|2]:]DATA:ATTRibute:PTPeak? [<arb_name>] - returns peak-to-peak value of all data points in an arbitrary waveform or sequence
  • [SOURce[1|2]:]DATA:SEQuence <block_descriptor> - combines previously loaded arbitrary waveforms into a sequence
  • [SOURce[1|2]:]DATA:VOLatile:CATalog? - returns the contents of volatile waveform memory, including arbitrary waveforms and sequences
  • [SOURce[1|2]:]DATA:VOLatile:CLEar - clears volatile waveform memory
  • [SOURce[1|2]:]DATA:VOLatile:FREE? - returns number of points available (free) in volatile memory

Examples

The following example uses DATA commands to set up an arbitrary waveform sequence.

The DATA:SEQuence command shown below is an example of a definite-length block. The "#3" at the beginning indicates that the next three digits will indicate how many characters are in the block. The "164" immediately following indicates that there are 164 characters in the string that follows.

Note that the long DATA:SEQuence command splits across lines for readability purposes.

Note also that the quotation marks in the DATA:SEQuence command are optional.

*CLS
*RST

MMEM:LOAD:DATA "INT:\BUILTIN\HAVERSINE.arb"
MMEM:LOAD:DATA "INT:\BUILTIN\CARDIAC.arb"
MMEM:LOAD:DATA "INT:\BUILTIN\GAUSSIAN.arb"

DATA:SEQuence #3164"testSeq","INT:\BUILTIN\HAVERSINE.arb",0,repeat,highAtStartGoLow,30,
"INT:\BUILTIN\CARDIAC.arb",0,repeat,maintain,10,
"INT:\BUILTIN\GAUSSIAN.arb",0,repeat,maintain,10
FUNC:ARB "testSeq"

FUNC ARB
OUTPUT1 ON

This sequence runs the Haversine waveform 30 times and then runs the Cardiac and Gaussian waveforms 10 times each. The Haversine waveform forces the marker high at the start of each run and then sets it low at the marker point. The other two waveforms maintain the marker setting.

Format for <arb_name>

Many DATA commands use the name of an arbitrary waveform. The following rules apply:

  • <arb_name> must match:
  • A waveform already loaded into waveform memory
  • A waveform existing in INTERNAL or USB mass memory
  • See MMEMory:LOAD:DATA[1|2], DATA:ARBitrary, or DATA:ARBitrary:DAC for valid formats for <arb_name>.

[SOURce[1|2]:]DATA:ARBitrary2:FORMat {AABB|ABAB}

(Applies only to instruments with the optional IQ player capability.)

Specifies whether the format for data points in DATA:ARB2 and DATA:ARB2:DAC commands is interleaved (ABAB) or all of channel 1 followed by all of channel 2 (AABB).

Note

You may spell out the keyword ARBitrary2, but you must abbreviate it as ARB2. You cannot abbreviate it as ARB.

Parameter | Typical Return
{AABB|ABAB} | AABB or ABAB
Specify an interleaved data format for dual arbitrary waveform data: DATA:ARB2:FORM ABAB
  • The SOURce keyword is ignored for this command.
  • If you wish to have a 3 DAC count signal on channel 1 and a 4 DAC count signal on channel 2, the AABB format would dictate that the data must be sent as 3, 3, 3, 3, 3, 3, 3, 3, 4, 4, 4, 4, 4, 4, 4, 4. The ABAB format would dictate the order 3, 4, 3, 4, 3, 4, 3, 4, 3, 4, 3, 4, 3, 4, 3, 4.

[SOURce[1|2]:]DATA:ARBitrary[1|2] <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ARBitrary[1|2]:DAC <arb_name>, {<binary_block>|<value>, <value>, . . .}

Downloads integer values representing DAC codes (DATA:ARBitrary[1|2]:DAC) or floating point values (DATA:ARBitrary[1|2]) into waveform volatile memory as either a list of comma separated values or binary block of data. The DAC codes go from -32,768 to +32,767 on both the 33500 Series and 33600 Series.

Note

The optional [1|2] after the ARBitrary keyword indicates whether the data to be downloaded contains one (default) or two channels of data.

To use dual arbitrary waveform files (single files containing two channels of arbitrary waveform data), you must have the optional IQ Player.)

Parameter | Typical Return
<arb_name> An unquoted string of up to 12 characters. | (none)
<binary_block> integer values from -32767 to +32767 or floating point values from -1.0 to +1.0 in Definite Length Arbitrary Block format (details below). From 8 to 1M or 16M samples per waveform, depending on the model and options.

Definite-length block data allows any type of device-dependent data to be transmitted as a series of 8-bit binary data bytes. This is particularly useful for transferring large quantities of data or 8-bit extended ASCII codes.
<value> comma separated list of integer values from -32,767 to +32,767 or floating point values from -1.0 to +1.0. From 8 to 65,536 points.

Download a comma separated list of nine waveform points into waveform memory:
DATA:ARB:DAC myArb, 32767, 24576, 16384, 8192, 0, -8192, -16384, -24576, - 32767

Download nine waveform points into waveform memory as a binary block. The <PMT> specifies what terminates the binary data. It can be a Line Feed character, or the last byte of your_binary_data can assert the End or Identify.
DATA:ARB myArb, #236<36 bytes of your_binary_data><PMT>

Download a comma separated list of nine waveform points into waveform memory:
DATA:ARB myArb, 1, .75, .50, .25, 0, -.25, -.50, -.75, -1

Download eight waveform points of a dual arbitrary waveform into waveform memory as a comma separated list of DAC codes. There are 16 values in all, eight for each of two channels. Note that the data is interleaved (ABAB), so the positive values are all on channel 1, and the negative values are all on channel 2:
DATA:ARB2:FORM ABAB
DATA:ARB2:DAC myArb, 30000, -10000, 29000, -9000, 27000, -7000, 24000, -4000, 27000, -7000, 29000, -9000, 30000, -10000, 29000, -9000

Download the same examples as above, but in AABB format:
DATA:ARB2:FORM AABB
DATA:ARB2:DAC myArb, 30000, 29000, 27000, 24000, 27000, 29000, 30000, 29000, -10000, -9000, -7000, -4000, -7000, -9000, -10000, -9000
  • Each data point is either a 16-bit integer from -32,767 and +32,767 or a 32-bit floating point value from -1.0 to +1.0. Therefore, the total number of bytes is always two times or four times the number of data points in the waveform. For example, 16,000 bytes are required to download a waveform with 8,000 points as integers, but 32,000 bytes are required to download the same waveform as floating point values.
  • The values -32767 and +32767 or -1.0 to +1.0 correspond to the peak values of the waveform (if the offset is 0 V). For example, if you set the output amplitude to 10 Vpp, +32767 corresponds to +5 V and -32767 corresponds to -5 V.
  • Use FORMat:BORDer to select the byte order for block mode binary transfers.
  • Use DATA:ARB2:FORMat to specify whether dual arbitrary waveforms are interleaved or sequential (channel 1 followed by channel 2).
  • Specifying a waveform that is already loaded generates a "Specified arb waveform already exists" error. Deleting an existing waveform requires clearing all of the waveform memory with DATA:VOLatile:CLEar.
  • The total available sample size for all waveforms loaded per channel is either 1 MSa or 16 MSa (33500 Series) or 4 MSa or 64 MSa (33600 Series), depending on model and options. A new waveform may be limited by waveforms already loaded.
Regardless of what options may be installed, the maximum waveform size for the embedded waveform editor is 1 MSa.

[SOURce[1|2]:]DATA:ATTRibute:AVERage? [<arb_name>]

Returns the arithmetic mean of all data points for the specified arbitrary waveform INTERNAL or USB memory, or loaded into waveform memory.

Parameter | Typical Return
<arb_name> is any valid file name. If omitted, the default <arb_name> is the arbitrary waveform currently active (selected with FUNCtion:ARBitrary). | +2.47199927E‑002
Return the mean of all points stored in "SINC". DATA:ATTR:AVER? "INT:\BuiltIn\SINC.arb"
  • Querying a waveform that does not exist generates a "Specified arb waveform does not exist" error.
  • <arb_name> can be a file name (put in memory by MMEMory:LOAD:DATA[1|2]) or a name generated from DATA:ARBitrary or DATA:ARBitrary:DAC.

[SOURce[1|2]:]DATA:ATTRibute:CFACtor? [<arb_name>]

Returns the crest factor of all data points for the specified arbitrary waveform segment in INTERNAL or USB memory, or loaded into waveform memory.

Parameter | Typical Return
<arb_name> is any valid file name. If omitted, the default <arb_name> is the arbitrary waveform currently active (selected with FUNCtion:ARBitrary). | +1.72513640E+000
Return crest factor of all data points stored in "NEG_RAMP". DATA:ATTR:CFAC? "INT:\BuiltIn\NEG_RAMP.arb"
  • Crest factor is the ratio of the peak value to the RMS value of the waveform.
  • Querying a waveform that does not exist generates a "Specified arb waveform does not exist" error.
  • <arb_name> can be a file name (put in memory by MMEMory:LOAD:DATA[1|2]) or a name generated from DATA:ARBitrary or DATA:ARBitrary:DAC.

[SOURce[1|2]:]DATA:ATTRibute:POINts? [<arb_name>]

Returns the number of points in the specified arbitrary waveform segment in INTERNAL or USB memory, or loaded into waveform memory.

Parameter | Typical Return
<arb_name> is any valid file name. If omitted, the default <arb_name> is the arbitrary waveform currently active (selected with FUNCtion:ARBitrary). | +250
Returns the number of data points in "EXP_RISE": DATA:ATTR:POIN? "INT:\BuiltIn\EXP_RISE.arb"
  • <arb_name> can be a file name (put in memory by MMEMory:LOAD:DATA[1|2]) or a name generated from DATA:ARBitrary or DATA:ARBitrary:DAC.

[SOURce[1|2]:]DATA:ATTRibute:PTPeak? [<arb_name>]

Calculates the peak-to-peak value of all data points for the specified arbitrary waveform segment in INTERNAL or USB memory, or loaded into waveform memory.

Parameter | Typical Return
Any valid file name. If omitted, the default <arb_name> is the arbitrary waveform currently active (selected with FUNCtion:ARBitrary). | +1.00000000E+000
Return the peak-to-peak value for "EXP_FALL": DATA:ATTR:PTP? "INT:\BuiltIn\EXP_FALL.arb"
  • <arb_name> must match:
  • A waveform already loaded into waveform memory
  • A waveform existing in INTERNAL or USB mass memory
  • See MMEMory:LOAD:DATA[1|2], DATA:ARBitrary, or DATA:ARBitrary:DAC for valid formats for <arb_name>.
  • Arbitrary Waveform Limitations: For arbitrary waveforms, amplitude is limited if the waveform data points do not span the full range of the output DAC (Digital-to-Analog Converter). For example, the built-in "Sinc" waveform does not use the full range of values, so its maximum amplitude is limited to 6.087 Vpp (into 50 Ω).
  • <arb_name> can be a file name (put in memory by MMEMory:LOAD:DATA[1|2]) or a name generated from DATA:ARBitrary or DATA:ARBitrary:DAC.

[SOURce[1|2]:]DATA:SEQuence <block_descriptor>

Defines a sequence of waveforms already loaded into waveform memory via MMEMory:LOAD:DATA[1|2] or DATA:ARBitrary. The MMEMory:LOAD:DATA[1|2] command can also load a sequence file that automatically loads the associated arbitrary waveforms and includes the amplitude, offset, sample rate, and filter setup.

Parameter | Typical Return
IEEE Definite Length Arbitrary Block, described below. | (none)
(see example)
  • Even arbitrary waveforms with millions of points may be insufficient for applications requiring special sequencing or the repetition of waveforms dependent upon time or external events. Sequencing arbitrary waveforms allows you to arrange and conditionally repeat waveforms. This allows you to use less memory and to achieve greater application flexibility.

    • Definite-length block data allows any type of device-dependent data to be transmitted as a series of 8-bit binary data bytes. This is particularly useful for transferring large quantities of data or 8-bit extended ASCII codes.

  • <block_descriptor> is of the format #<n><n digits><sequence name>,<arb name1>,<repeat count1>,<play control1>,<marker mode1>, <marker point1>, <arb name2>,<repeat count2>,<play control2>,<marker mode2>, <marker point2>, and so on, where:
  • <n>specifies the number of digits used to indicate the size of the block.
  • <n digits> is one or more digits hat specifies the number of data bytes to come.
  • <sequence name> is an optionally quoted string that specifies the name of sequence that contains the arbitrary waveforms specified in the following parameters.
  • <arb name> is an optionally quoted string that specifies the name of the arbitrary waveform that was loaded with the MMEM:LOAD:DATA[1|2] or DATA:ARBitrary commands.
  • <repeat count> is an optionally quoted string that specifies the number of times to repeat the waveform. This value can range from 1 to 1E6 or infinite. This will only be recognized in the hardware if Play Control is set to "repeat".
  • <play control> is an optionally quoted string that specifies how the arbitrary waveform is to be played in the sequence:
  • once- play once
  • onceWaitTrig- play once and then wait for trigger. Triggers will not be accepted until the play of the specified segment has completed.
  • repeat- repeat number of times specified by repeat count
  • repeatInf- repeat until stopped (infinite)
  • repeatTilTrig - repeat until triggered then advance

    With small waveforms, it may take a few cycles after the trigger is received to switch to the next waveform. This is because the samples in the sample buffer must be cleared.
  • <marker mode> is an optionally quoted string that specifies how the marker behaves in the arbitrary waveform:
  • maintain- maintain current marker state at start of segment
  • lowAtStart- force marker low at start of segment
  • highAtStart- force marker high at start of segment
  • highAtStartGoLow- force marker high at start of segment and then low at marker position
  • <marker point> a number specifying the marker location in the arbitrary waveform. This value must be between 4 and the number of points in the arbitrary waveform minus 3.
  • If you specify an arbitrary waveform that has not been loaded, a "Specified arb waveform does not exist" error is generated.

Example of DATA:SEQuence command

The following command constructs a sequence (named mySequence) of three segments (A.arb, B.arb, and C.arb) that were previously loaded from the USB drive using MMEMory:LOAD:DATA[1|2]. The sequence plays A once, and B five times. It then plays C repeatedly while waiting for a trigger to advance, and finally ends with A. Each segment has the <marker point> set to 10.

The command is shown on multiple lines for readability purposes only.

DATA:SEQ #3158"mySequence","USB:\A.arb",0,once,lowAtStart,10,"USB:\B.arb",5,repeat,highAtStart,10,
"USB:\C.arb",0,repeatTilTrig,maintain,10,"USB:\A.arb",0,once,lowAtStart,10

Many text editors let you count the number of bytes in the block simply by highlighting a text string. In this example, the size is 158, which requires 3 digits to represent – hence the #3158 header.

Using this approach requires you to pre-load all of the arbitrary waveforms and set the amplitude and offset (or high and low levels), sample rate, and filter. See MMEM:LOAD:DATA to combine all that information into a single file rather than creating a block transfer with multiple SCPI commands.

[SOURce[1|2]:]DATA:VOLatile:CATalog?

Returns the contents of volatile waveform memory, including arbitrary waveforms and sequences.

Parameter | Typical Return
(none) | "INT:\BUILTIN\EXP_RISE.ARB","USB:\XYZ\A.ARB","USB:\XYZ\B.ARB","USB:\xyz\xyz.seq"
Return the contents of volatile waveform memory assuming waveforms A.arb, B.arb, and C.arb were previously loaded on channel 1 via a sequence file on USB:\xyz\xyz.seq: DATA:VOL:CAT?

[SOURce[1|2]:]DATA:VOLatile:CLEar

Clears waveform memory for the specified channel and reloads the default waveform.

Parameter | Typical Return
(none) | (none)
Clear contents of waveform memory on channel 1 and reload default waveform: DATA:VOL:CLE

[SOURce[1|2]:]DATA:VOLatile:FREE?

Returns number of points available (free) in volatile memory. Each arbitrary waveform loaded into volatile memory consumes space allocated in 128-point blocks, so a waveform of 8 to 128 points consumes one such block, a waveform of 129 to 256 points consumes two blocks, and so on.

The standard instrument includes memory for 1 million points per channel (33500 Series) or 4 million points per channel (33600 Series). You may also extend the size of the memory up to 16M (33500 Series) or 64M points (33600 Series).

Parameter | Typical Return
(none) | +382956
Return number of bytes of free volatile memory: DATA:VOL:FREE?


DISPlay Subsystem Introduction

DISPlay Subsystem

The DISPlay subsystem controls the instrument's display.

Example

The following program turns off the instrument's display and then shows a message that indicates people should not touch the instrument.

DISP OFF
DISP:TEXT "Test running. Please do not touch."

Commands

The DISPlay subsystem includes the following commands.

  • DISPlay {ON|1|OFF|0} - enables or disables display
  • DISPlay:FOCus - selects the channel displayed "in front" on a two-channel instrument
  • DISPlay:TEXT "<string>" - displays text message on display
  • DISPlay:TEXT:CLEar - clears text messages from display
  • DISPlay:UNIT:ARBRate {SRATe|FREQuency|PERiod} - selects the arbitrary waveform rate units
  • DISPlay:UNIT:PULse {WIDTh|DUTY} - selects the method for specifying pulse widths
  • DISPlay:UNIT:RATE {FREQuency|PERiod} - selects the rate units for sine, square, ramp, pulse, and triangle waves
  • DISPlay:UNIT:SWEep {STARtstop|CENTerspan} - selects the method for specifying sweep ranges
  • DISPlay:UNIT:VOLT {AMPLitudeoff|HIGHlow} - selects the method for specifying voltage ranges
  • DISPlay:VIEW {STANdard|TEXT|GRAPh|DUAL} - selects the view shown on the display

DISPlay {ON|1|OFF|0}
DISPlay?

Disables or enables the front panel display. When disabled, the front panel display turns black, and all annunciators are disabled. However, the screen remains on.

Parameter | Typical Return
{ON|1|OFF|0}, default ON | 0 (OFF) or 1 (ON)
Turn display off: DISP OFF
  • Disabling the display improves command execution speed from the remote interface and provides basic security.
  • Sending DISPlay:TEXT <string> overrides the display state. You can display a message with the display disabled.
  • The display is enabled when power is cycled, or when you return to local (front panel) operation by pressing the front panel [Local] key.

DISPlay:FOCus {CH1|CH2}

Selects the channel that is displayed "in front" on a two-channel instrument.

Parameter | Typical Return
{CH1|CH2} Default CH1 | CH1 or CH2
Bring channel 2 to the front: DISP:FOCus CH2

DISPlay:TEXT "<string>"
DISPlay:TEXT?

Displays a text message on the front panel display.

Parameter | Typical Return
Quoted string of up to 40 standard keyboard characters, default "". | "Test running. Do not touch."
Show message on display: DISP:TEXT "Test in progress..."
  • Sending DISPlay:TEXT <string> overrides the display state. You can display a message with the display disabled.
  • While a message is displayed, information relating to the current instrument operation is not sent to the front panel display.
  • The display text is unaffected by *RST. It is cleared at power-on.

DISPlay:TEXT:CLEar

Clears the text message from the front panel display.

Parameter | Typical Return
(none) | (none)
Clear message on display: DISP:TEXT:CLE
  • With DISPlay ON, DISP:TEXT:CLEar returns the display to its normal mode.
  • With DISPlay OFF, DISP:TEXT:CLEar clears the message and the display remains disabled. To enable the display, send DISPplay ON or press the front panel [Local] key.
  • The display text is unaffected by *RST. It is cleared at power-on.

DISPlay:UNIT:ARBRate {SRATe|FREQuency|PERiod}

Specifies whether the rate units for arbitrary waveforms are samples per second, (SRATe), Hz (FREQ) or seconds (PER).

Parameter | Typical Return
{SRATe|FREQuency|PERiod} Default SRATe | SRAT, FREQ, or PER
Set the unit for arbitrary waveforms to seconds: DISP:UNIT:ARBR PER
  • The frequency and period of an arbitrary waveform refer to the time that it takes to run through the entire waveform once. For example, a waveform of 200 samples running at 1 MSa/s would have a period of 0.0002 s and a frequency of 5000 Hz.

DISPlay:UNIT:PULse {WIDTh|DUTY}

Selects the method for specifying pulse duration. You can specify either the width or the duty cycle.

Parameter | Typical Return
{WIDTh|DUTY} Default WIDTh | WIDT or DUTY
Specify pulse width as a percentage (duty cycle): DISP:UNIT:PULS DUTY

DISPlay:UNIT:RATE {FREQuency|PERiod}

Specifies whether the rate units for sine, square, ramp, pulse, and triangle waves are Hz (FREQ) or seconds (PER).

Parameter | Typical Return
{FREQuency|PERiod} Default FREQuency | FREQ or PER
Set the units to Hz: DISP:UNIT:RATE FREQ

DISPlay:UNIT:SWEep {STARtstop|CENTerspan}

Selects the method for specifying sweep frequency range. You can specify the range as start and stop values or as a span around a center value.

Parameter | Typical Return
{STARtstop|CENTerspan} Default STARtstop | STAR or CENT
The following examples both specify a sweep from 10 to 500 Hz: DISP:UNIT:SWE STAR FREQ:STAR 10 FREQ:STOP 500 DISP:UNIT:SWE CENT FREQ:SPAN 490 FREQ:CENT 255
  • To sweep up in frequency, set a positive frequency span; to sweep down, set a negative frequency span.

DISPlay:UNIT:VOLT {AMPLitudeoff|HIGHlow}

Selects the method for specifying voltage ranges. You can specify a voltage range as an amplitude and an offset or as high and low values.

Parameter | Typical Return
{AMPLitudeoff|HIGHlow} Default: AMPLitudeoff | AMPL or HIGH
The following examples both specify a waveform voltage from 1 to 4 V: DISP:UNIT:VOLT HIGH VOLT:LOW 1 VOLT:HIGH 4 DISP:UNIT:VOLT:AMPL VOLT 3 VOLT OFFS 2.5

DISPlay:VIEW {STANdard|TEXT|GRAPh|DUAL}

Selects the screen layout.

Parameter | Typical Return
{STANdard|TEXT|GRAPh|DUAL} Default STANdard | STAN, TEXT, GRAP, or DUAL
Select the large graph display: DISP:VIEW GRAP
  • The STANdard, TEXT, GRAPh, and DUAL keywords correspond to the Standard View, Large Text, Large Graph, and CH1/CH2 softkeys on the [System] > System Setup > Screen Layout menu.


FM Subsystem

This summarizes the steps required to generate a frequency modulation (FM) waveform.

  1. Configure carrier waveform: Use FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet to specify the carrier waveform's function, frequency, amplitude, and offset.
  2. Select modulation source (internal, external, CH1, or CH2): FM:SOURce. For an external modulation source, skip steps 3 and 4.
  3. Select modulating waveform: FM:INTernal:FUNCtion
  4. Set modulating frequency: FM:INTernal:FREQuency
  5. Set peak frequency deviation: FM:DEViation
  6. Enable FM: FM:STATe:ON

The following code produces the oscilloscope image shown below.

FUNCtion SQU
FREQuency +4.0E+05
VOLTage +1.0
VOLTage:OFFset 0.0
FM:SOURce INT
FM:DEViation +3.5e5
FM:INTernal:FREQuency +5e4
FM:INTernal:FUNCtion RAMP
FM:STATe 1
OUTP 1

[SOURce[1|2]:]FM[:DEViation] {<peak_deviation_in_Hz>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FM[:DEViation]? [{MINimum|MAXimum}]

Sets the peak frequency deviation in Hz. This value represents the peak variation in frequency of the modulated waveform from the carrier frequency.

Parameter | Typical Return
1 μHz to 15.05 (limited to 150 kHz for RAMP); default 100 Hz | +1.000000000000000E+03
Set peak frequency deviation to 1 kHz: FM:DEV 1000 Set peak frequency deviation to 1 μHz: FM:DEV MIN
  • The deviation cannot exceed the carrier frequency. If you attempt to set a deviation that exceeds the carrier frequency (with FM enabled), the instrument will adjust the deviation to the maximum value allowed for that carrier frequency. From the remote interface, a "Settings conflict" error will also be generated.
  • The carrier frequency plus the deviation cannot exceed the selected function's maximum frequency plus 100 kHz. If you attempt to set the deviation to an invalid value, the instrument adjusts it to the maximum value allowed with the present carrier frequency. The remote interface also generates a "Data out of range" error.
  • If the deviation causes the carrier waveform to exceed a frequency boundary for the current duty cycle (square waveform only), the instrument will adjust the duty cycle to the maximum value allowed with the present carrier frequency. From the remote interface, a "Settings conflict" error will also be generated.
  • If you select the External modulating source, the deviation is controlled by the ±5 V signal level (optionally ±1 V on the 33600 Series) on the rear-panel Modulation In connector. For example, if the frequency deviation is 100 kHz, then a +5 V signal level (optionally +1 V on the 33600 Series) corresponds to a 100 kHz increase in frequency. Lower external signal levels produce less deviation and negative signal levels reduce the frequency below the carrier frequency.

[SOURce[1|2]:]FM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FM:INTernal:FREQuency? [{MINimum|MAXimum}]

Sets the frequency of the modulating waveform. The modulating source waveform operates at that frequency, within the frequency limits of that waveform.

Parameter | Typical Return
1 μHz to the maximum allowed for the internal function. Default 10 Hz | +1.000000000000000E+04
Set the modulating frequency to 10 kHz: FM:INT:FREQ 10000
  • When you select an arbitrary waveform as the modulating source, the frequency changes to the frequency of the arbitrary waveform, which is based on the sample rate and the number of points in the arbitrary waveform.
  • When using an arbitrary waveform for the modulating source, changing this parameter also changes the cached metadata representing the arbitrary waveform's sample rate. You can also change the modulating frequency of an arbitrary waveform with FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod, and FUNCtion:ARBitrary:SRATe. These commands and the modulation frequency command are directly coupled in order to keep the arbitrary waveform behaving exactly as it was last played. If you later turn modulation off and select that same arbitrary waveform as the current function, its sample rate (and corresponding frequency based upon the number of points) will be the same as it was when played as the modulation source.
  • If the internal function is TRIangle, UpRamp, or DnRamp, the maximum frequency is limited to 200 kHz on the 33500 Series or 800 kHz on the 33600 Series. If the internal function is PRBS, the frequency refers to bit rate and is limited as shown here.
  • This command should be used only with the internal modulation source (FM:SOURce INTernal).

[SOURce[1|2]:]FM:INTernal:FUNCtion <function>
[SOURce[1|2]:]FM:INTernal:FUNCtion?

This command selects the shape of the modulating waveform.

Parameter | Typical Return
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, default SINusoid View internal function waveforms. | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS, or ARB
Select a sine wave as the modulating waveform. FM:INT:FUNC SIN
  • This command should be used only with the internal modulation source (FM:SOURce INTernal).
  • Some combinations of carrier and internal function are not allowed: PRBS carrier and PRBS internal function, ARB carrier and ARB internal function.
  • You can use noise as the modulating waveform, but you cannot use noise, pulse, or DC as the carrier.


FORMat:BORDer

FORMat:BORDer {NORMal|SWAPped}
FORMat:BORDer?

Sets the byte order used in binary data point transfers in the block mode.

Parameter | Typical Return
{NORMal|SWAPped}, default NORMal | NORM or SWAP
Set SWAPped order: FORM:BORD SWAP
  • NORMal: most-significant byte (MSB) of each data point is first. Use this setting if you are using the Keysight IO Libraries.
  • SWAPped: least-significant byte (LSB) of each data point is first. Most computers use this.


FREQuency Subsystem

The FREQuency subsystem sets the instrument's output frequency. In two-channel instruments, the channels' frequencies may be coupled in various ways.

FREQuency:COUPle[:STATe] {ON|OFF|ONCE} enables or disables coupling, or using the ONCE, one channel's is copied to the other, but not coupled to it.

FREQuency:COUPle:MODE {OFFSet|RATio} specifies the frequency coupling mode.

FREQuency:MODE allows you to specify a frequency mode to use, including a sweep, frequency list, or fixed frequency.

Example

The remaining FREQuency commands are used to generate a sweep, as summarized below:

  1. Select the waveform shape, amplitude and offset: Use APPLy or the equivalent FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet commands to select the function, frequency, amplitude, and offset. You can select any non-arbitrary waveform.
  2. Set frequency boundaries of the sweep: FREQuency:STARt and FREQuency:STOP, or FREQuency:CENTer and FREQuency:SPAN.
  3. Select sweep mode (linear or logarithmic): SWEep:SPACing
  4. Set sweep time in seconds: SWEep:TIME
  5. Select sweep trigger source: TRIGger[1|2]:SOURce
  6. Set frequency at which signal on front panel Sync connector goes low during sweep (optional): MARKer:FREQuency

[SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency? [{MINimum|MAXimum}]

Sets the output frequency. This command is paired with FUNCtion:PULSe:PERiod; whichever one is executed last overrides the other.

Parameter | Typical Return
1 μHz to maximum instrument frequency. Default 1 kHz. | +1.000000000000000E+03
Set output frequency to 60 Hz: FREQ 60
  • Function Limitations: The frequency limits are function dependent, as shown in the above table. If you send a command specifying a frequency that is not in the appropriate range for the current function, an error will occur. For example, if the current function is "ramp" and you send the command FREQ 20 MHZ, a "Data out of range" error is generated and the frequency is set to 200 kHz (33500 Series) or 800 kHz (33600 Series), which is the maximum for a ramp waveform.

[SOURce[1|2]:]FREQuency:CENTer {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:CENTer? [{MINimum|MAXimum}]

Sets the center frequency. Used with frequency span for a frequency sweep.

Parameter | Typical Return
1 μHz to maximum instrument frequency, Default 550 Hz | +1.000000000000000E+03
Set sweep center frequency to 1 kHz: FREQ:CENT 1000
  • The following equation shows how center frequency is limited by span frequency.

    Center Frequency (max) = Max. Frequency for waveform - (Span/2)
  • The following equation shows how center frequency relates to start and stop frequencies.

    Center Frequency = |(Stop Frequency - Start Frequency)|/2

[SOURce[1|2]:]FREQuency:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]FREQuency:COUPle[:STATe]?

Enables/disables frequency coupling between channels in a two-channel instrument.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Turn on the frequency couple state: FREQ:COUP ON
  • Specifying ON starts frequency coupling as specified by FREQuency:COUPle:MODE.
  • If the current offset or ratio, combined with the current frequency settings, would cause either frequency to exceed instrument specifications, the instrument will generate an error and the exceeded frequency will clip at its maximum or minimum value.
  • If setting mode to RATIO and setting RATIO to 1.0 still exceeds the specifications of either channel (for example, channel 1 is a 3 MHz sine and channel 2 is a ramp, which cannot go that high), an error message will be generated and FREQuency:COUPle will be turned OFF.

[SOURce[1|2]:]FREQuency:COUPle:MODE {OFFSet|RATio}
[SOURce[1|2]:]FREQuency:COUPle:MODE?

Sets the type of frequency coupling between frequency coupled channels; OFFSet specifies a constant frequency offset between channels; RATio specifies a constant ratio between the channels' frequencies.

Parameter | Typical Return
{OFFSet|RATio}, default RATio with ratio 1.0 | OFFS or RAT
Set frequency coupling mode to OFFSet: FREQ:COUP:MODE OFFS
  • Power-on default for frequency coupling is OFF.
  • Specifying SOURce1 or SOURce2 is irrelevant; either syntax sets the same coupling mode for both channels.

[SOURce[1|2]:]FREQuency:COUPle:OFFSet {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:COUPle:OFFSet?

Sets the offset frequency when an instrument is in frequency coupled mode OFFSet.

Parameter | Typical Return
A number between plus and minus the instrument's maximum frequency for the waveform; default 0. | +7.650000000000000E+05
Set frequency of channel 2 to 10.245 MHz above frequency of channel 1: FREQ:COUP:OFFS 10.245 MHZ Set frequency of channel 1 to 350 kHz above frequency of channel 2: SOUR2:FREQ:COUP:OFFS 350 KHZ Set frequency of channel 1 to 455 kHz below frequency of channel 2: SOUR2:FREQ:COUP:OFFS -455 KHZ
  • The SOURce channel (SOURce1 or SOURce2) is used as the reference channel and the OFFSet is applied to the other channel. For example, suppose the instrument is in FREQ:COUPLE:STATE ON and in FREQ:COUPLE:MODE OFFSET (frequency offset mode active), and channel 1 is currently operating at 1.0 MHz. The command SOURce1:FREQuency:COUPle:OFFSet 500 will cause channel 1 to remain at 1.0 MHz, and channel 2 to be set to 1.5 MHz. As the frequency of either channel is changed, the frequency of the other channel will change to maintain the 500 kHz offset.
  • If the frequency coupling would cause either channel to exceed instrument frequency specifications for the present functions, the command will result in an error, and the frequency will be set to its maximum or minimum limit for that channel.
  • Frequency coupling is not valid with arbitrary waveforms, but you can couple the sample rate of arbitrary waveforms.

[SOURce[1|2]:]FREQuency:COUPle:RATio <ratio>
[SOURce[1|2]:]FREQuency:COUPle:RATio?

Sets offset ratio between channel frequencies in frequency coupled mode RATio.

Parameter | Typical Return
0.001 to 1000, default 1 | +7.500000000000000E-01
Set frequency of channel 2 to twice the frequency of channel 1: FREQ:COUP:RAT 2.0 Set frequency of channel 1 to 3.14 times the frequency of channel 2: SOUR2:FREQ:COUP:RAT 3.14
  • The SOURce channel (SOURce1 or SOURce2) is used as the reference channel and the RATIO is applied to the other channel. For example, suppose the instrument is in FREQuency:COUPle ON and FREQuency:COUPle:MODE RATio. Furthermore, suppose channel 1 is currently operating at 2 kHz, and channel 2 is at 10 kHz. The command SOURce1:FREQuency:COUPle:RATio 2.5 will cause channel 1 to remain at 2 kHz, and Channel 2 to be set to 5 kHz. As the frequency of either channel is changed, the frequency of the other channel will change to maintain the 2.5 ratio.
  • If the frequency coupling would cause either channel to exceed instrument frequency specifications for the present functions, the command will result in an error, and the frequency will be set to its maximum or minimum limit for that channel.
  • Frequency coupling is not valid with arbitrary waveforms, but you can couple the sample rate of arbitrary waveforms.

[SOURce[1|2]:]FREQuency:MODE {CW|LIST|SWEep|FIXed}
[SOURce[1|2]:]FREQuency:MODE?

Sets the type of frequency mode as a continuous wave at a fixed frequency (CW or FIXed), a frequency sweep (SWEep), or a frequency list (LIST).

Parameter | Typical Return
{CW|LIST|SWEep|FIXed}, default CW | CW, LIST, SWE, or FIX
Set frequency mode to LIST: FREQ:MODE LIST
  • If the mode is set to list, use LIST:FREQuency to specify the frequency list.

[SOURce[1|2]:]FREQuency:SPAN {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:SPAN? [{MINimum|MAXimum}]

Sets frequency span (used in conjunction with the center frequency) for a frequency sweep.

Parameter | Typical Return
± instrument's maximum frequency for the waveform, default 900 Hz | +1.000000000000000E+02
Set sweep frequency span to 100 kHz: FREQ:SPAN 100 KHZ
  • The following equation shows the limitation for the maximum frequency span:

    Frequency Span (max) = (Max. Frequency for the chosen waveform - Center Frequency) X 2
  • The following equation shows the relationship between the span and the start/stop frequencies.

    Frequency Span = Stop Frequency - Start Frequency
  • To sweep up in frequency, set a positive frequency span; to sweep down, set a negative frequency span.

[SOURce[1|2]:]FREQuency:STARt {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:STARt? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:STOP {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:STOP? [{MINimum|MAXimum}]

Sets the start and stop frequencies for a frequency sweep.

Parameter | Typical Return
± instrument's maximum frequency for the waveform, default 100 Hz | +1.000000000000000E+02
Set sweep start and stop frequency to 100 Hz and 1 kHz, respectively: FREQ:STAR 100 FREQ:STOP 1000


FSKey Subsystem

The FSKey subsystem configures a frequency-shift keying (FSK) waveform.

Example

This summarizes the steps required to generate an FSK waveform.

  1. Use FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet commands to select the function, frequency, amplitude, and offset of the carrier waveform.
  2. Select modulation source (internal, external, CH1, or CH2): FSK:SOURce. For an external modulation source, skip steps 3 and 4.
  3. Select alternate ("hop") frequency: FSK:FREQuency
  4. Set FSK rate: FSK:INTernal:RATE
  5. Enable FSK Modulation: FSK:STATe ON

The following code produces the oscilloscope image shown below.

FUNCtion SQU
FREQuency +1e6
VOLTage +1.0
VOLTage:OFFset 0.0
FSKey:SOURce INT
FSKey:FREQuency +5e5
FSKey:INTernal:RATE +8e4
FSKey:STATe 1
OUTPut1 1

[SOURce[1|2]:]FSKey:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FSKey:FREQuency? [{MINimum|MAXimum}]

Sets the FSK alternate (or "hop") frequency.

Parameter | Typical Return
1 μHz to maximum instrument frequency for the waveform, default 100 Hz | +1.000000000000000E‑06
Set hop frequency to 10 kHz: FSK:FREQ 10000 Set hop frequency to 1 μHz: FSK:FREQ MIN

[SOURce[1|2]:]FSKey:INTernal:RATE {<rate_in_Hz>|MINimum|MAXimum}
[SOURce[1|2]:]FSKey:INTernal:RATE? [{MINimum|MAXimum}]

Sets the rate at which output frequency "shifts" between the carrier and hop frequency.

Parameter | Typical Return
0.125 mHz to 1 MHz, default 10 Hz | +1.000000000000000E+01
Set FSK rate to 10 kHz: FSK:INT:RATE 10000 Set FSK rate to 1 mHz: FSK:INT:RATE MIN
  • The FSK rate is used only with the internal source (FSK:SOURce INTernal).
  • The modulating waveform is a square wave with a 50% duty cycle.
FSKey Subsystem


FUNCtion Subsystem

The FUNCtion subsystem configures the instrument's output function:

  • [SOURce[1|2]:]FUNCtion <function> - output waveform
  • [SOURce[1|2]:]FUNCtion:ARBitrary {<filename>} - arbitrary waveform (.arb/barb) or sequence (.seq) that has previously been loaded into volatile memory with MMEMory:LOAD:DATA[1|2].
  • [SOURce[1|2]:]FUNCtion:ARBitrary:ADVance {TRIGger|SRATe} - method for advancing to next arbitrary waveform data point.
  • FUNCtion:ARBitrary:BALance[:STATe] {ON|1|OFF|0} - (IQ Player option only) state (on/off) for dual arbitrary waveform channel balancing
  • FUNCtion:ARBitrary:BALance:GAIN {<percent>|MINimum|MAXimum|DEFine} - (IQ Player option only) gain balance ratio for dual arbitrary waveforms
  • FUNCtion:ARBitrary:BALance:OFFSet{1|2} {<volts>|MINimum|MAXimum|DEFault} - (IQ Player option only) offset for individual channels of dual arbitrary waveforms
  • [SOURce[1|2]:]FUNCtion:ARBitrary:FILTer {NORMal|STEP|OFF} - filter for arbitrary waveform
  • [SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency {<frequency>|MINimum|MAXimum|DEFault} - frequency of arbitrary waveform
    [SOURce[1|2]:]FUNCtion:ARBitrary:PERiod {<period>|MINimum|MAXimum}DEFault} - period of arbitrary waveform
  • [SOURce[1|2]:]FUNCtion:ARBitrary:POINts? - number of points (samples) in the current arbitrary waveform
  • [SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak {<voltage>|MINimum|MAXimum|DEFault} - peak-to-peak voltage for an arbitrary waveform
  • FUNCtion:ARBitrary:SKEW[:STATe] {ON|1|OFF|0} - (IQ Player option only) state (on/off) for dual arbitrary waveform skew
  • FUNCtion:ARBitrary:SKEW:TIME [{<time>|MINimum|MAXimum|DEFault}] - (IQ Player option only) skew time in seconds
  • [SOURce[1|2]:]FUNCtion:ARBitrary:SRATe {<sample_rate>|MINimum|MAXimum|DEFault} - sample rate for arbitrary waveform
  • [SOURce[1|2]:]FUNCtion:ARBitrary:SYNChronize - restarts arbitrary waveforms at first sample simultaneously on both waveforms
  • [SOURce[1|2]:]FUNCtion:NOISe:BANDwidth {<bandwidth>|MINimum|MAXimum|DEFault} - bandwidth for NOISe waveform
  • [SOURce[1|2]:]FUNCtion:PRBS:BRATe {<bit_rate>| MINimum|MAXimum|DEFault} - bit rate for pseudo-random binary sequence (PRBS)
  • [SOURce[1|2]:]FUNCtion:PRBS:DATA <sequence_type> - sequence type for PRBS
  • [SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault} - edge transition time for both edges of PRBS
  • [SOURce[1|2]:]FUNCtion:PULSe:DCYCle {<percent>|MINimum|MAXimum|DEFault} - pulse duty cycle for pulse
  • [SOURce[1|2]:]FUNCtion:PULSe:HOLD {WIDTh|DCYCle} - whether pulse width or duty cycle is held constant as other parameters vary
  • [SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault} - period for a pulse
  • [SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing {<seconds>|MINimum|MAXimum|DEFault}
    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling {<seconds>|MINimum|MAXimum|DEFault}
    [SOURce[1|2]:]FUNCtion:PULSe:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}     - edge time for pulse
  • [SOURce[1|2]:]FUNCtion:PULSe:WIDTh {<seconds>|MINimum|MAXimum|DEFault} - pulse width
  • [SOURce[1|2]:]FUNCtion:RAMP:SYMMetry {<percent>|MINimum|MAXimum|DEFault} - symmetry percentage for ramp
  • [SOURce[1|2]:]FUNCtion:SQUare:DCYCle {<percent>|MINimum|MAXimum} - duty cycle percentage for square
  • [SOURce[1|2]:]FUNCtion:SQUare:PERiod {<seconds>|MINimum|MAXimum|DEFault} - period for square

[SOURce[1|2]:]FUNCtion <function>
[SOURce[1|2]:]FUNCtion?

Selects the output function.

Parameter | Typical Return
{SINusoid|SQUare|TRIangle|RAMP|PULSe|PRBS|NOISe|ARB|DC}, default SINusoid | SIN, SQU, TRI, RAMP, PULS, PRBS, NOIS, ARB, or DC
Set output on channel 2 to sine: SOUR2:FUNC SIN
  • The selected waveform (other than an arbitrary waveform) is output using the previously selected frequency, amplitude, and offset voltage settings. Arbitrary waveforms are played according to the settings specified in the arbitrary waveform file. Brand new arbitrary waveforms inherit the current arbitrary waveform settings.
  • NOISe generates white gaussian noise with adjustable bandwidth and crest factor about 3.5.
  • PRBS generates pseudo-random noise using Linear Feedback Shift Register (LFSR) user selectable methods.
  • ARB generates the arbitrary waveform currently selected by FUNCtion:ARBitrary.
  • Function Limitations: If you change to a function whose maximum frequency is less than that of the current function, the frequency is adjusted to the maximum for the new function. For example, if you change a high frequency sine wave to the ramp function, the instrument will adjust the output frequency to 200 kHz (the upper limit for ramps)From the remote interface, a "Settings conflict" error will also be generated.
  • Amplitude Limitations: If you change to a function whose maximum amplitude is less than that of the current function, the amplitude is adjusted to the maximum for the new function. This may occur when the output units are Vrms or dBm due to the differences in crest factor for the various output functions For example, if you change a 5 Vrms square wave (into 50 Ω) to a sine wave, the instrument will adjust the amplitude to 3.536 Vrms (the upper limit for sine in Vrms). The remote interface will also generate a "Settings conflict" error.

[SOURce[1|2]:]FUNCtion:ARBitrary {<filename>}
[SOURce[1|2]:]FUNCtion:ARBitrary?

Selects an arbitrary waveform (.arb/.barb) or sequence (.seq) that has previously been loaded into volatile memory for the channel specified with MMEMory:LOAD:DATA[1|2] or DATA:ARBitrary. Several waveforms can be in volatile memory simultaneously.

Parameter | Typical Return
See MMEMory:LOAD:DATA[1|2], for valid <filename> formats. | "INT:\MyArb103.arb"
Select an arbitrary waveform in memory on channel 2: FUNC:ARB "INT:\MyArb103.arb" Load an arbitrary waveform from the internal drive into volatile memory. Then select and play the waveform: MMEM:LOAD:DATA "INT:\BUILTIN\Sinc.arb" FUNCtion:ARBitrary "INT:\BUILTIN\Sinc.arb" FUNCtion ARB
  • The <filename> should match the filename used to load the arbitrary waveform or sequence into volatile memory with MMEMory:LOAD:DATA[1|2], DATA:ARBitrary, DATA:ARBitrary:DAC, or DATA:SEQuence.
  • When you store an arbitrary waveform segment or sequence (MMEMory:STORe:DATA[1|2]), the instrument's current settings (voltage values, sample rate, filter type, and so on) are stored in the segment or sequence file. When you play the file for the first time with FUNCtion:ARBitrary, these settings are loaded and override the instrument's current settings. If you have manually edited a segment or sequence file such that the instrument settings have been removed, the instrument settings will not be changed when you execute FUNCtion:ARBitrary.
  • When you store an arbitrary waveform segment or sequence (MMEMory:STORe:DATA[1|2]), the instrument's current settings (voltage values, sample rate, filter type, and so on) are stored in the segment or sequence file. When you play the file for the first time with FUNCtion:ARBitrary, these settings are loaded and override the instrument's current settings. If you have manually edited a segment or sequence file such that the instrument settings have been removed, the instrument settings will not be changed when you execute FUNCtion:ARBitrary.

[SOURce[1|2]:]FUNCtion:ARBitrary:ADVance {TRIGger|SRATe}
[SOURce[1|2]:]FUNCtion:ARBitrary:ADVance?

Specifies the method for advancing to the next arbitrary waveform data point for the specified channel.

Parameter | Typical Return
{TRIGger|SRATe}, default TRIG | TRIG or SRAT
Set advance method to trigger: FUNC:ARB:ADV TRIG
  • TRIGger causes instrument to advance to next data point with each trigger received and forces TRIGger[1|2]:SOURce to EXTernal.
  • SRATe causes instrument to advance to next data point at the sample rate set by FUNCtion:ARBitrary:SRATe.

[SOURce[1|2]:]FUNCtion:ARBitrary:FILTer {NORMal|STEP|OFF}
[SOURce[1|2]:]FUNCtion:ARBitrary:FILTer?

Specifies the filter setting for an arbitrary waveform.

Parameter | Typical Return
{NORMal|STEP|OFF}, default STEP | NORMal, STEP, or OFF
Set filter to NORMal: FUNCtion:ARBitrary:FILTer NORM
  • NORMal filters the data points with the filter that provides the flattest frequency response. This effectively smoothes the signal, but sharp transitions will have preshoot and overshoot.
  • STEP filters the data points in a way that effectively smoothes the signal while minimizing the preshoot and overshoot. However, this setting has a narrower bandwidth than the NORMal setting.
  • OFF steps from point to point at the sample rate. Moves between data points are accomplished as quickly as possible with no smoothing. If the <mode> is set to OFF, the instrument uses a filter whose bandwidth limit restricts the maximum sample rate for the arbitrary waveform to 62.5 MSa/s (33500 Series) or 250 MSa/s (33600 Series).
  • To use this command on the 33600 Series, you must set FUNCtion:ARBitrary:FILTer to OFF.

[SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency? {MINimum|MAXimum}

[SOURce[1|2]:]FUNCtion:ARBitrary:PERiod {<period>|MINimum|MAXimum}DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:PERiod? {MINimum|MAXimum}

Sets the frequency or period for the arbitrary waveform.

Parameter | Typical Return
<frequency> (Hz): Limited by the number of waveform points; default based on 40 kSa/s sample rate. | +1.000000000000000E+03
<period> (seconds): Limited by the number of waveform points; default based on 40 kSa/s sample rate. | +1.000000000000000E‑03
Set arbitrary waveform frequency to 1000 Hz. FUNC:ARB:FREQ 1000
  • With FUNCtion:ARBitrary:FILTer OFF, the arbitrary waveform sample rate is limited to 1/4 of the maximum sample rate.
  • The <frequency> ranges from 1 µHz to 31.25 MHz on the 33500 Series or 250 MHz on the 33600 Series. Frequency is also limited by the Filter setting. With FUNCtion:ARBitrary:FILTer OFF, the arbitrary waveform sample rate is limited to 62.5 MSa/s. Therefore, frequency is also reduced to 7.8125 MHz for an eight point waveform (33500 Series) or one-quarter of that for a 32-point waveform (33600 Series).
  • The arbitrary waveform sample rate and frequency are not coupled to SOUR:FREQ, which applies to only non-arbitrary waveforms.
  • The arbitrary waveform plays at a speed specified by the sample rate. When setting the frequency or period of an arbitrary waveform, the instrument changes the sample rate based on the number of points in the waveform and the new frequency or period setting. The new frequency or period may be altered slightly to meet the restrictions of Sample Rate resolution and the number of points. In other words, frequency will be recalculated from the new sample rate and number of points to ensure compatibility between the coupled parameters. This is due to math resolution of 15 digits in combination with a sample rate that can also be 15 digits.
  • Changing the number of points in the waveform, or changing the sample rate with FUNCtion:ARBitrary:SRATe, changes the frequency and period settings.

[SOURce[1|2]:]FUNCtion:ARBitrary:POINts?

Returns the number of points in the currently selected arbitrary waveform.

Parameter | Typical Return
(none) | +100000
Return the number of points in the current arbitrary waveform on channel 1: FUNC:ARB:POIN?
  • The maximum number of points depends on the instrument's memory, which is based on the model and options.

[SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak? [{MINimum|MAXimum}]

Sets peak to peak voltage.

Parameter | Typical Return
10 VDC into 50 Ω, 20 VDC into an open circuit; default 100 mV | +4.000000000000000E+00
Set peak to peak voltage to 4 V: FUNC:ARBitrary:PTPeak 4
  • Limits Due to Amplitude: You can set the voltage levels to a positive or negative value with the restrictions shown below. Vpp is the maximum peak-to-peak amplitude for the selected output termination (10 Vpp into 50 Ω or 20 Vpp into an open circuit).

    Vhigh – Vlow£ Vpp (max) and Vhigh, Vlow£ Vpp (max)/2
  • Differences between remote and front panel operation:
  • Remote Interface: Setting the high or low level from the remote interface can change the high level or low level to achieve the desired setting. In this case either a "Data out of range" or "Settings conflict" error will occur. If the high level is set below the low level, the instrument will set the low level 1 mV less than the high level. If the high level is set below the LOW limit or the instrument output specifications, the low level will be set to the LOW limit or instrument output specification and the high level will be set 1 mV above the low level. A similar set of rules applies if the low level is set incorrectly.
  • Similarly, the low level can be set above the high level from the remote interface. In this case the instrument will set the high level 1 mV larger than the low level. If the low level is set higher than the HIGH limit or the instrument output specifications, the high level will be set to the HIGH limit or instrument output specification and the low level will be set 1 mV below the high level.
  • Front Panel: Setting the high or low level from the front panel may clip that level setting in order to achieve the desired level setting, and a "Data out of range" error will be generated. The high level cannot be set below the low level from the front panel.
  • Setting the high and low levels also sets the waveform amplitude and offset. For example, if you set the high level to +2 V and the low level to -3 V, the resulting amplitude is 5 Vpp, with a -500 mV offset.
  • Limits Due to Output Termination: If you change the output termination setting, the displayed voltage levels will be adjusted (and no error will be generated). For example, if you set the high level to +100 mVDC and then change the output termination from 50 Ω to "high impedance", the amplitude displayed on the front panel will double to +200 mVDC. If you change from "high impedance" to 50 Ω, the displayed amplitude will be halved. Changing the output termination setting does not change the voltage present at the output terminals of the instrument. This only changes the displayed values on the front panel and the values queried from the remote interface. The voltage present at the instrument's output depends on the load connected to the instrument. See OUTPut[1|2]:LOAD for details.
  • Limits due to voltage limits: If the voltage limits are enabled, the level settings are checked against the specified limits (VOLTage:LIMit:HIGH, VOLTage:LIMit:LOW) before a change in level is executed. If a change in output level would exceed a LIMIT setting, the level is clipped to the maximum (or minimum) value allowed that will not exceed the LIMit setting and a "Settings conflict" error will be generated.
  • Limits due to Output Coupling: If two channels are coupled, limitations of setting the levels of both channels will be checked before a change in level is executed. In this case, if a change in level would exceed a LIMIT setting, or instrument output specifications for either channel, the level is clipped to the maximum (or minimum) allowable value and a "Settings conflict" error will be generated.
  • To invert the waveform relative to the offset voltage, use OUTPut[1|2]:POLarity.

[SOURce[1|2]:]FUNCtion:ARBitrary:SRATe {<sample_rate>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:SRATe? {MINimum|MAXimum}

Sets the sample rate for the arbitrary waveform.

Parameter | Typical Return
1 µSa/s to 250 MSa/s (33500 Series) or 1 GSa/s (33600 Series), default 40 kSa/s. Limited to 62.5 MSa/s (33500 Series) or 250 MSa/s (33600 Series) if FUNCtion:ARBitrary:FILTer is OFF. | +1.000000000000000E+04
Set sample rate to 10 kSa/s: FUNC:ARB:SRAT 1e4
  • The sample rate and frequency parameter are not coupled when playing an arbitrary waveform segment. The concept of frequency does not apply for arbitrary waveform sequences.
  • Setting a sample rate when not in the ARB mode will not change the frequency. For example, if the current function is sine, setting sample rate has no effect until the function changes to ARB.
  • The maximum sample rate depends on the filter applied to the arbitrary waveform. See FUNCtion:ARBitrary:FILTer for details.

[SOURce[1|2]:]FUNCtion:ARBitrary:SYNChronize

Causes two independent arbitrary waveforms to synchronize to first point of each waveform (two-channel instruments only).

Parameter | Typical Return
(none) | (none)
Load an internal Haversine waveform into channel 1 and a custom waveform from a USB drive into channel 2. Set both sample rates to 100 kSa/s and then synchronize both channels to the first point of each waveform: MMEM:LOAD:DATA "Int:\Builtin\HAVERSINE.arb" FUNC:ARB "Int:\Builtin\HAVERSINE.ARB" FUNC ARB FUNC:ARB:SRATE 1E+05 MMEM:LOAD:DATA2 "USB:\MyFiles\TestDUT3.arb" SOUR2:FUNC:ARB "USB:\MyFiles\TestDUT3.arb" SOUR2:FUNC ARB SOUR2:FUNC:ARB:SRAT 1E+05 FUNC:ARB:SYNC
  • This command stops and restarts the arbitrary waveforms on both channels at whatever sample rates they happen to be set.
  • If the two arbitrary waveforms have the same number of points and sample rate, they will remain synchronized over multiple repetitions; otherwise, they will only be synchronized at the beginning and after numbers of repetitions that happen to be multiples of the number of points in both waveforms. For example, if you synchronize an 8-point waveform and a 10-point waveform, they will re-synchronize after 40, 80, and 120 repetitions.
  • This functionality is similar to using burst mode, but it operates in continuous wave mode.
  • This command also works with burst, sweep, and modulation, when trying to synchronize two arbitrary waveforms.

[SOURce[1|2]:]FUNCtion:NOISe:BANDwidth {<bandwidth>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:NOISe:BANDwidth? [{MINimum|MAXimum}]

Sets bandwidth of noise function.

Parameter | Typical Return
1 mHz to instrument's maximum frequency, default 100 kHz | +6.000000000000000E+03
Set bandwidth to 20 kHz: FUNC:NOISe:BWIDth 20000
  • The Noise function produces white gaussian noise with a Crest Factor of 4.6.
  • The noise bandwidth is continuously adjustable to place more noise energy in the frequency range from 0 Hz to the specified noise bandwidth frequency.

[SOURce[1|2]:]FUNCtion:PRBS:BRATe {<bit_rate>| MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PRBS:BRATe? [{MINimum|MAXimum}]

Sets the pseudo-random binary sequence (PRBS) bit rate.

Parameter | Typical Return
1 mbit/s to maximum allowed for the instrument, default 1000 bit/s | +1.920000000000000E+04
Set bit rate to 19,200 bits per second FUNC:PRBS:BRATe 19200
  • A PRBS waveform using polynomial PNx is generated by a shift register of x bits, and the output waveform begins with x sample periods of high output. Sample period is the reciprocal of the sample rate (FUNCtion:PRBS:BRATe), and the channel's Sync pulse indicates the waveform's start. For example, if the PRBS uses PN23 with sample rate 500 Hz, the output begins with 46 ms of high output (23 x 2 ms).
  • The bit rate is independent of the data sequence length.

[SOURce[1|2]:]FUNCtion:PRBS:DATA <sequence_type>
[SOURce[1|2]:]FUNCtion:PRBS:DATA?

Sets the pseudo-random binary sequence (PRBS) type. Setting the sequence type sets the length and feedback values as shown below.

Parameter | Typical Return
33500 Series: {PN7|PN9|PN11|PN15|PN20|PN23} 33600 Series: PN3 through PN32 (all 30 possible values from 3 to 32) Value after PN corresponds to maximum shift register length in bits. Default is PN7. | PN# (PN3 through PN9) or PN## (PN10 through PN32), where each # is one digit.
Set data format to PN23: FUNC:PRBS:DATA PN23
  • SYNC output may be active during a PRBS function, unlike the NOISe function. The SYNC output marks the first data bit of a PRBS waveform.
  • A PRBS waveform using polynomial PNx is generated by a shift register of x bits, and the output waveform begins with x sample periods of high output. Sample period is the reciprocal of the sample rate (FUNCtion:PRBS:BRATe), and the channel's Sync pulse indicates the waveform's start. For example, if the PRBS uses PN23 with sample rate 500 Hz, the output begins with 46 ms of high output (23 x 2 ms). The polynomials are shown below.

    Sequence Type | Polynomial | Length
    PN3 | x3 + x2 + 1 | 3
    PN4 | x4 + x3 + 1 | 4
    PN5 | x5 + x3 + 1 | 5
    PN6 | x6 + x5 + 1 | 6
    PN7 | x7 + x6 + 1 | 7
    PN8 | x8 + x6 + x5 + x4 + 1 | 8
    PN9 | x9 + x5 + 1 | 9
    PN10 | x10 + x7 + 1 | 10
    PN11 | x11 + x9 + 1 | 11
    PN12 | x12 + x6 + x4 + x1 + 1 | 12
    PN13 | x13 + x4 + x3 + x1 + 1 | 13
    PN14 | x14 + x5 + x3 + x1 + 1 | 14
    PN15 | x15 + x14 + 1 | 15
    PN16 | x16 + x15 + x13 + x4 + 1 | 16
    PN17 | x17 + x14 + 1 | 17
    PN18 | x18 + x11 + 1 | 18
    PN19 | x19 + x6 + x2 + x1 + 1 | 19
    PN20 | x20 + x17 + 1 | 20
    PN21 | x21 + x19 + 1 | 21
    PN22 | x22 + x21 + 1 | 22
    PN23 | x23 + x18 + 1 | 23
    PN24 | x24 + x23 + x22 + x17 + 1 | 24
    PN25 | x25 + x22 + 1 | 25
    PN26 | x26 + x6 + x2 + x1 + 1 | 26
    PN27 | x27 + x5 + x2 + x1 + 1 | 27
    PN28 | x28 + x25 + 1 | 28
    PN29 | x29 + x27 + 1 | 29
    PN30 | x30 + x6 + x4 + x1 + 1 | 30
    PN31 | x31 + x28 + 1 | 31
    PN32 | x32 + x22 + x2 + x1 + 1 | 32

[SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH]? [{MINimum|MAXimum}]

Sets PRBS transition edge time on both edges of a PRBS transition.

Parameter | Typical Return
33500 Series: 8.4 ns (default) to 1 μsec, limited as described below 33600 Series: 2.9 ns up to 4 Vpp, and 3.3 ns above 4Vpp to 1 μsec; limited as described below | +1.000000000000000E‑08
Set edge time to 10 ns for the leading and trailing edges (two methods): FUNC:PRBS:TRAN 10 ns FUNC:PRBS:TRAN .000000010
  • The default "BOTH" keyword is optional and allows simultaneous control of the leading and trailing edges of the PRBS waveform.
  • The edge time applies to both the rising and falling edges, and represents the time between the 10% and 90% thresholds of each edge.
  • The specified edge time must fit within the specified period. The instrument will limit the edge time as needed to accommodate the specified bit rate. From the remote interface, a "Settings conflict" error will also be generated.

[SOURce[1|2]:]FUNCtion:PULSe:DCYCle {<percent>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:DCYCle? [{MINimum|MAXimum}]

Sets pulse duty cycle.

Parameter | Typical Return
0 to 100, limited as described below; default 10 | +5.000000000000000E+01
Set duty cycle to 50%: FUNC:PULS:DCYC 50
  • The FUNCtion:PULSe:DCYCle and FUNCtion:PULSe:WIDTh commands affect the same parameter. In some applications, it is natural to adjust pulse width directly (in seconds); in others, adjusting duty cycle seems more natural. When frequency is adjusted, if pulse width was most recently adjusted as duty cycle on the front panel, then duty cycle will be kept constant as frequency or period changes. However, if pulse width was the last setting, then pulse width will be kept constant as frequency or period changes. See FUNCtion:PULSe:HOLD.
  • The pulse duty cycle is defined as:

    Duty Cycle = 100 x Pulse Width ÷ Period

    Pulse width is the time from the 50% threshold of a pulse's rising edge to the 50% threshold of the next falling edge.
  • The pulse duty cycle range is 0 percent to 100 percent. However, the pulse duty cycle is limited by minimum pulse width and edge time restrictions, which prevent you from setting exactly 0 percent or 100 percent. For example, for a 1 kHz pulse waveform, you are typically restricted to pulse duty cycles in the range 0.002 percent to 99.998 percent. This is limited by the minimum pulse width of 16 ns on the 33500 Series or 5 ns up to 4 Vpp and 8 ns up to 10 Vpp on the 33600 Series.
  • Restrictions Based on Pulse Width: The specified pulse duty cycle must conform to the following restrictions determined by the minimum pulse width. The instrument will adjust pulse duty cycle as needed to accommodate the specified period. From the remote interface, a "Settings conflict" error will also be generated.

Duty Cycle ³ 100(Minimum Pulse Width/ Period)

and

Duty Cycle £ 100 (1 – Minimum Pulse Width/ Period)

On the 33500 Series, the minimum pulse width is 16 ns. On the 33600 Series, the minimum pulse width is 5 ns up to 4 Vpp and 8 ns up to 10 Vpp.

  • Restrictions Based On and Affecting Edge Time: The specified pulse duty cycle may affect the edge time. The edge time is adjusted first, and then the duty cycle is adjusted to accommodate the specified period, conforming to the following restriction. From the remote interface, a "Settings conflict" error will also be generated.

Duty Cycle ³ [(0.8 x Leading Edge Time) + (0.8 x Trailing Edge Time) ]/ Period x 100

and

Duty Cycle £ [1 – [(0.8 x Leading Edge Time) + (0.8 x Trailing Edge Time) ]/ Period] x 100

[SOURce[1|2]:]FUNCtion:PULSe:HOLD {WIDTh|DCYCle}
[SOURce[1|2]:]FUNCtion:PULSe:HOLD?

Sets the pulse waveform parameter (either pulse width or duty cycle) to be held constant as other parameters are varied.

Parameter | Typical Return
{WIDTh|DCYCle}, default WIDTh | WIDT or DCYC
Set the instrument to hold duty cycle for pulse waveforms: FUNC:PULS:HOLD DCYC
  • WIDTh: the instrument holds the pulse width setting (in seconds) constant as the period is varied. If a command to set a duty cycle value is received, the duty cycle is converted to the equivalent pulse width. If pulse width modulation (PWM) is turned on, the pulse width and width deviation are held as the period is varied. Duty cycle deviation commands are converted to width deviations.

    Minimum width and edge time restrictions apply. May cause a change in the selected edge times, pulse width, or both.
  • DCYCle: the instrument holds the pulse duty cycle setting (in percent) constant as the period is varied. If a command to set a pulse width value is received, the width is converted to the equivalent duty cycle. If pulse width modulation (PWM) is turned on, the pulse duty cycle and the duty cycle deviation are held as the period is varied. Width deviation commands are converted to duty cycle deviation values.

    Minimum width and edge time restrictions apply. May cause a change in the selected edge times, duty cycle, or both.

Note

The FUNCtion:PULSe:HOLD command does not limit period settings. The pulse width or duty cycle may be adjusted if necessary to accommodate a new period setting.

[SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:PERiod? [{MINimum|MAXimum}]

Sets the period for pulse waveforms. This command is paired with the FREQuency command; the one executed last overrides the other, as frequency and period specify the same parameter.

Parameter | Typical Return
From reciprocal of instrument's maximum frequency up to 1,000,000 s. Default 1 ms | +2.000000000000000E‑07
Set the period to 500 ms: FUNC:PULS:PER .5 or FUNC:PULS:PER 500 ms
  • The specified period must be greater than the sum of the pulse width and the edge time. The instrument will adjust edge time and pulse width as needed to accommodate the specified period. From the remote interface, a "Settings conflict" error will also be generated. The edge time is minimized first, and then the width (or duty cycle) is adjusted as shown below.

    Period ³ [Pulse Width + ((Lead Edge Time + Trail Edge Time) * 0.625)]
  • This command affects the period (and frequency) for all waveform functions (not just pulse). For example, if you select a period using FUNCtion:PULSe:PERiod and then change the output function to sine wave, the specified period will be used for the new function.
  • Function Limitations: If you change to a function whose minimum period exceeds the value set by this command, the period is adjusted to the new function's minimum pulse. For example, if you set a period of 2 µs and then change to the ramp function, the instrument adjusts the period to 5 µs (the minimum for ramps). From the remote interface, a "Settings conflict" error will also be generated.

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling? [{MINimum|MAXimum}]

Sets the pulse edge time on the leading, trailing, or both edges of a pulse.

Parameter | Typical Return
33500 Series: 8.4 ns (default) to 1 μsec, limited as described below 33600 Series: 2.9 ns up to 4 Vpp, and 3.3 ns above 4 Vpp, to 1 μsec; limited as described below | +1.000000000000000E‑08
Set leading edge time to 10 ns (two methods): FUNC:PULS:TRAN:LEADing 10 ns FUNC:PULS:TRAN:LEADing .000000010
  • The leading edge time applies to rising edge, and represents the time from the 10% threshold to the 90% threshold of the edge; the trailing edge represents the time from the 90% threshold to the 10% threshold.
  • The specified edge time must fit within the specified pulse width and period. The instrument will limit the edge time to accommodate the specified pulse width or duty cycle. From the remote interface, a "Settings conflict" error will also be generated.

[SOURce[1|2]:]FUNCtion:PULSe:WIDTh {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:WIDTh? [{MINimum|MAXimum}]

Sets pulse width.

Parameter | Typical Return
16 ns (33500 Series), 5 ns (33600 Series up to 4 Vpp), or 8 ns (33600 Series up to 10 Vpp) up to approximately 1,000,000 s, limited as described below; default 100 µs | +5.000000000000000E‑03
Set pulse width to 5 ms (two methods): FUNC:PULS:WIDT 5 ms FUNC:PULS:WIDT .005
  • The FUNCtion:PULSe:DCYCle and FUNCtion:PULSe:WIDTh commands affect the same parameter. In some applications, it is natural to adjust pulse width directly (in seconds); in others, adjusting duty cycle seems more natural. When frequency is adjusted, if pulse width was most recently adjusted as duty cycle on the front panel, then duty cycle will be kept constant as frequency or period changes. However, if pulse width was the last setting, then pulse width will be kept constant as frequency or period changes. See FUNCtion:PULSe:HOLD.
  • Pulse width is the time from the 50% threshold of a pulse's rising edge to the 50% threshold of the next falling edge.
  • The specified pulse width must be less than the difference between the period and the minimum pulse width as shown below. The instrument will adjust pulse edge time first and then limit pulse width as needed to accommodate the period. From the remote interface, a "Settings conflict" error will also be generated.

    Pulse Width £ Period – Wmin
  • The specified pulse width must also be less than the difference between the period and the edge time as shown below. The instrument will adjust pulse edge time first and then limit pulse width as needed to accommodate the period. From the remote interface, a "Settings conflict" error will also be generated.

    Pulse Width £ [Period - ((Leading Edge Time + Trailing Edge Time) * 0.625)]
  • The pulse width must also be greater than the total time of one edge as shown below.

    Pulse Width ³ [(Leading Edge Time + Trailing Edge Time) * 0.625]

[SOURce[1|2]:]FUNCtion:RAMP:SYMMetry {<percent>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:RAMP:SYMMetry? [{MINimum|MAXimum}]

Sets the symmetry percentage for ramp waves.

Parameter | Typical Return
0 to 100, default 100 | +5.000000000000000E+01
Set symmetry to 50%: FUNC:RAMP:SYMM 50
  • Symmetry represents the amount of time per cycle that the ramp wave is rising (assuming that the waveform polarity is not inverted).

    • Symmetry 0%

    Symmetry 100%
  • For ramp waveforms, the APPLy:RAMP command overrides the current symmetry setting and selects 100%. To set a symmetry other than 100%, select the ramp waveform output with the FUNCtion RAMP command, then use FUNCtion:RAMP:SYMMetry to set the symmetry.
  • The symmetry setting is remembered when you change from ramp wave to another function. When you return to the ramp wave function, the previous symmetry is used.
  • When ramp is the modulating waveform for AM, FM, PM, or PWM, the symmetry setting does not apply. The instrument always uses a ramp waveform with 100% symmetry.

[SOURce[1|2]:]FUNCtion:SQUare:DCYCle {<percent>|MINimum|MAXimum}
[SOURce[1|2]:]FUNCtion:SQUare:DCYCle? [{MINimum|MAXimum}]

Sets duty cycle percentage for square wave.

Parameter | Typical Return
0.01 to 99.99, subject to limitation of 16 ns minimum pulse width; default 50 | +5.000000000000000E+01
Set duty cycle to 30%: FUNC:SQU:DCYC 30 Sets the duty cycle to its minimum value: FUNC:SQU:DCYC MIN
  • Duty cycle represents the amount of time per cycle that the square wave is at a high level (assuming normal polarity).
  • For square waveforms, APPLy:SQUare replaces the current duty cycle setting with 50%. To set a duty cycle other than 50%, select the square wave with FUNCtion SQUare, then use FUNCtion:SQUare:DCYCle.
  • The duty cycle setting is remembered when you change from square wave to another function. When you return to square wave, the previous duty cycle is used.
  • Limits Due to Frequency: As frequency is increased, minimum and maximum duty cycle limits are adjusted to maintain a minimum pulse width of 16 ns (33500 Series), 5 ns (33600 Series up to 4 Vpp), or 8 ns (33600 Series up to 10 Vpp). For example, at 1 MHz the minimum duty cycle on the 33500 Series is 1.60% and maximum duty cycle is 98.40%. At 10 MHz, the minimum duty cycle is 16.00% and the maximum duty cycle is 84.00%.
  • If you select a square waveform as the modulating waveform for AM, FM, PM, or PWM, the instrument always uses a square wave with 50% duty cycle.

[SOURce[1|2]:]FUNCtion:SQUare:PERiod {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:SQUare:PERiod? [{MINimum|MAXimum}]

Sets period for square wave.

Parameter | Typical Return
From reciprocal of maximum square wave frequency to 1,000,000 s, default 1 ms | +5.000000000000000E‑01
Set period to 500 ms (two methods): FUNC:SQUare:PER .5 FUNC:SQUare:PER 500 ms
  • Function Limitations: If you change to a function whose minimum period exceeds the value set by this command, the period is adjusted to the new function's minimum pulse. For example, if you set a period of 2 µs and then change to the ramp function, the instrument adjusts the period to 5 µs (the minimum for ramps). From the remote interface, a "Settings conflict" error will also be generated. From the remote interface, a "Settings conflict" error will also be generated.

The commands shown below all require the IQ player option.

FUNCtion:ARBitrary:BALance[:STATe] {ON|1|OFF|0}
FUNCtion:ARBitrary:BALance[:STATe]?

(IQ Player option only)

Enables or disables channel balancing for dual arbitrary waveforms (FUNCtion:ARBitrary:BALance:GAIN and FUNCtion:ARBitrary:BALance:OFFSet).

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)

Load an arbitrary waveform from the USB drive and set up the balance gain (channel 2 down by 1.02%) and balance offsets (120 mV for channel 1 and -38 mV for channel 2):

FUNC:ARB "USB:\qam32.barb"
FUNC:ARB:BAL:GAIN 1.02
FUNC:ARB:BAL:OFFS1 0.12
FUNC:ARB:BAL:OFFS2 -0.038
FUNC:ARB:BAL ON
  • This feature can be used to compensate for minor variations in the load impedances on the two channels, or for minor differences between the two channels of information in the original dual arbitrary waveform file.
  • When the <state> is on, both channels must stay on the same amplifier range.
  • This setting is stored as part of the instrument state, and it is affected by *RST.

FUNCtion:ARBitrary:BALance:GAIN {<percent>|MINimum|MAXimum|DEFine}
FUNCtion:ARBitrary:BALance:GAIN? [{MINimum|MAXimum}]

(IQ Player option only)

Sets the gain balance ratio for dual arbitrary waveforms.

Parameter | Typical Return
-30 to +30 | +1.02000000E+000

Load an arbitrary waveform from the USB drive and set up the balance gain (channel 2 down by 1.02%) and balance offsets (120 mV for channel 1 and -38 mV for channel 2):

FUNC:ARB "USB:\qam32.barb"
FUNC:ARB:BAL:GAIN 1.02
FUNC:ARB:BAL:OFFS1 0.12
FUNC:ARB:BAL:OFFS2 -0.038
FUNC:ARB:BAL ON
  • Both channels must stay on the same amplifier range.
  • A value of 0 means that both channels use their current amplitude. A positive value means that the amplitude of channel 2 is pushed down, while the amplitude of channel 1 remains constant, a negative value pushes channel 1 down while holding channel 2 constant. See the following table for examples.

    <percent> Channel 1
    Amplitude %     		Channel 2
    Amplitude %
    -20 | 80 | 100
    -10 | 90 | 100
    0 | 100 | 100
    10 | 100 | 90
    20 | 100 | 80
  • This command is enabled by FUNCtion:ARBitrary:BALance ON.
  • This setting is stored as part of the instrument state, and it is affected by *RST.

FUNCtion:ARBitrary:BALance:OFFSet{1|2} {<volts>|MINimum|MAXimum|DEFault}
FUNCtion:ARBitrary:BALance:OFFSet{1|2}? [MINimum|MAXimum]

(IQ Player option only)

Specifies the offset (in volts) added to the dual arbitrary waveform offset for the specified channel.

Parameter | Typical Return
A floating point value, limited by the dual arbitrary waveform amplitude. | +1.00000000E+000

Load an arbitrary waveform from the USB drive and set up the balance gain (channel 2 down by 1.02%) and balance offsets (120 mV for channel 1 and -38 mV for channel 2):

FUNC:ARB "USB:\qam32.barb"
FUNC:ARB:BAL:GAIN 1.02
FUNC:ARB:BAL:OFFS1 0.12
FUNC:ARB:BAL:OFFS2 -0.038
FUNC:ARB:BAL ON
  • Both channels must stay on the same amplifier range.
  • This command is enabled by FUNCtion:ARBitrary:BALance ON.
  • This setting is stored as part of the instrument state, and it is affected by *RST.

FUNCtion:ARBitrary:SKEW[:STATe] {ON|1|OFF|0}
FUNCtion:ARBitrary:SKEW[:STATe]?

(IQ Player option only)

Enables or disables skew time compensation (FUNCtion:ARBitrary:SKEW:TIME). This is always OFF for modulated signals, sweeps, lists, and bursts.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Set the skew time to compensate for channel 1 being behind channel 2 by 140 picoseconds: FUNCtion:ARBitrary:SKEW:TIME 1.4e-10 FUNCtion:ARBitrary:SKEW ON
  • Skew compensation is typically determined empirically, using an oscilloscope and then set one time. That one-time setup will then be valid until the DUT or test equipment configuration changes.
  • The value specified by this command is not stored in the instrument state. It is stored in non-volatile memory and is not affected by *RST.

FUNCtion:ARBitrary:SKEW:TIME [{<time>|MINimum|MAXimum|DEFault}]
FUNCtion:ARBitrary:SKEW:TIME? [{MINimum|MAXimum}]

(IQ Player option only)

Sets a small time difference between the channels to compensate for minor variations in timing at the connector output plane or at the device under test (DUT). Note than FUNC:ARB:SKEW[:STATe] OFF for modulated signals, sweeps, lists, and bursts.

Parameter | Typical Return
A floating point value in the range of ±4 ns. Default 0. | +1.40000000E‑010
Set the skew time to compensate for channel 1 being behind channel 2 by 140 picoseconds: FUNCtion:ARBitrary:SKEW:TIME 1.4e-10 FUNCtion:ARBitrary:SKEW ON
  • Channels may exhibit slight timing variations at the output connector plane due to variations in internal circuitry between the two channels. They may exhibit slight timing variations at the device under test (DUT) due to variations in signal paths, including such things as switches and cable lengths.
  • A positive value delays channel 2, and a negative value delays channel 1.
  • The value specified by this command is not stored in the instrument state. It is stored in non-volatile memory and is not affected by *RST.


HCOPy Subsystem

The HCOPy subsystem produces screen images ("screen shots") of the front panel display.

Example

The following example captures and returns the front panel display image in BMP format.

HCOP:SDUM:DATA:FORM BMP
HCOP:SDUM:DATA?

HCOPy:SDUMp:DATA?

Returns the front panel display image ("screen shot")

Parameter | Typical Return
(none) | (A definite-length binary block containing the image.) Definite-length block data allows any type of device-dependent data to be transmitted as a series of 8-bit binary data bytes. This is particularly useful for transferring large quantities of data or 8-bit extended ASCII codes.
Capture and return the display image: HCOP:SDUM:DATA?
  • The image format (PNG or BMP) is specified by HCOPy:SDUMp:DATA:FORMat.

HCOPy:SDUMp:DATA:FORMat {PNG|BMP}
HCOPy:SDUMp:DATA:FORMat?

Specifies the image format for images returned by HCOPy:SDUMp:DATA?.

Parameter | Typical Return
{PNG|BMP}, default PNG | PNG or BMP
Set the display image format to BMP HCOP:SDUM:DATA:FORM BMP


IEEE-488 Common Commands

This subsystem contains commands and queries associated with the IEEE-488 standards:

*CLS - Clear status

*ESE <enable_value> - Event status enable

*ESR? - Event status register query

*IDN? - Instrument identification

*OPC - Set operation complete bit

*OPC? - Wait for current operation to complete

*OPT? - Show installed options

*PSC {0|1} - Power-on status clear

*RCL {0|1|2|3|4} - Recall instrument state

*RST - Reset instrument to factory defaults

*SAV {0|1|2|3|4} - Save instrument state

*SRE <enable_value> - Service request enable (enable bits in enable register of Status Byte Register group

*STB? - Read status byte

*TRG - Trigger command

*TST? - Self-test

*WAI - Wait for all pending operations to complete

Registers

Some of the IEEE-488 commands are associated with various registers in the instrument. These registers are described below.

Standard Event Register

The following table describes the Standard Event Register.

    Bit Number | Bit Name | Decimal Value | Definition
0 | Operation Complete | 1 | All commands before and including *OPC have been executed.
1 | (not used) | 2 | (Reserved for future use)
2 | Query Error | 4 | The instrument tried to read the output buffer but it was empty. Or, a new command line was received before a previous query has been read. Or, both the input and output buffers are full.
3 | Device-Specific Error | 8 | A device-specific error, including a self-test error, calibration error or other device-specific error occurred. See Error Messages.
4 | Execution Error | 16 | An execution error occurred. Error Messages
5 | Command | 32 | A command syntax error occurred. Error Messages
6 | (not used) | 64 | (Reserved for future use)
7 | Power On | 128 | Power has been cycled since the last time the event register was read or cleared.

Status Byte Register

The following table describes the Status Byte Register.

Bit Number | Bit Name | Decimal Value | Definition
0 | (not used) | 1 | (Reserved for future use)
1 | (not used) | 2 | (Reserved for future use)
2 | Error Queue | 4 | One or more errors in the Error Queue. Use SYSTem:ERRor? to read and delete errors.
3 | Questionable Data Summary | 8 | One or more bits are set in the Questionable Data Register (bits must be enabled, see STATus:QUEStionable:ENABle ).
4 | Message Available | 16 | Data is available in the instrument's output buffer.
5 | Standard Event Summary | 32 | One or more bits are set in the Standard Event Register (bits must be enabled, see *ESE).
6 | Master Summary | 64 | One or more bits are set in the Status Byte Register and may generate a Request for Service (RQS). Bits must be enabled using *SRE.
7 | Operation Register | 128 | One or more bits are set in the Operation Status Register. Bits are enabled using STATus:OPERation:ENABle.

*CLS

Clear Status Command. Clears the event registers in all register groups. Also clears the error queue.

Parameter | Typical Return
(none) | (none)
Clear event register bits and error queue: *CLS

*ESE <enable_value>
*ESE?

Event Status Enable Command and Query. Enables bits in the enable register for the Standard Event Register group. The selected bits are then reported to bit 5 of the Status Byte Register.

Parameter | Typical Return
Decimal sum of the bits in the register (table below), default 0. For example, to enable bit 2 (value 4), bit 3 (value 8), and bit 7 (value 128), the decimal sum would be 140 (4 + 8 + 128). Default 0. | +48
Enable bit 4 (value 16) and bit 5 (value 32) in the enable register: *ESE 48
  • Use *PSC to control whether the Standard Event enable register is cleared at power on. For example, *PSC 0 preserves the enable register contents through power cycles.
  • *CLS does not clear enable register, does clear event register.

*ESR?

Standard Event Status Register Query. Queries the event register for the Standard Event Register group. Register is read-only; bits not cleared when read.

Parameter | Typical Return
(none) | +24
Read the event register (bits 3 and 4 are set). *ESR
  • Any or all conditions can be reported to the Standard Event summary bit through the enable register. To set the enable register mask, write a decimal value to the register using *ESE.
  • Once a bit is set, it remains set until cleared by this query or *CLS.

*IDN?

Identification Query. Returns instrument’s identification string.

Parameter | Typical Return
(none) | Keysight Technologies,33522B,XXXXXXXXXX,0.179-1.19-8.88-52-00
Return the instrument's identification string: *IDN?
  • Identification string contains four comma separated fields:
    • Manufacturer name
    • Model number
    • Serial number
    • Revision code
  • Identification string is in the following format for the 33500 Series instruments:

    Keysight Technologies,[Model Number],[10-char Serial Number],A.aaa-B.bb-C.cc-DD-EE

    A.aaa

    = Firmware revision

    B.bb

    = Front panel FW revision

    C.cc

    = Power supply controller FW revision

    DD

    = FPGA revision

    EE

    = PCBA revision

  • Identification string is in the following format for the 33600 Series instruments:

    Keysight Technologies,[Model Number],[Serial Number],A.aa.aa-B.bb-CC-DD-EE

    A.aa.aa

    = Firmware revision

    B.bb

    = Front panel FW revision

    CC

    = Main board revision

    DD

    = FPGA revision

    EE

    = PCBA revision

*OPC

Sets "Operation Complete" (bit 0) in the Standard Event register at the completion of the current operation.

Parameter | Typical Return
(none) | (none)
Set Operation Complete bit: *OPC
  • The purpose of this command is to synchronize your application with the instrument.
  • Used in triggered sweep, triggered burst, list, or arbitrary waveform sequence modes to provide a way to poll or interrupt the computer when the *TRG or INITiate[:IMMediate] is complete.
  • Other commands may be executed before Operation Complete bit is set.
  • The difference between *OPC and *OPC? is that *OPC? returns "1" to the output buffer when the current operation completes. This means that no further commands can be sent after an *OPC? until it has responded. In this way an explicit polling loop can be avoided. That is, the IO driver will wait for the response.

*OPC?

Returns 1 to the output buffer after all pending commands complete.

Parameter | Typical Return
(none) | 1
Return 1 when all previous commands complete: *OPC?
  • The purpose of this command is to synchronize your application with the instrument.
  • Other commands cannot be executed until this command completes.
  • The difference between *OPC and *OPC? is that *OPC? returns "1" to the output buffer when the current operation completes. This means that no further commands can be sent after an *OPC? until it has responded. In this way an explicit polling loop can be avoided. That is, the IO driver will wait for the response.

*OPT?

Returns a quoted string identifying any installed options.

Parameter | Typical Return
(none) | "0,MEM,SEC,IQP"
Returns installed options (example: standard timebase, extended memory, security, IQ player) *OPT?

*PSC {0|1}
*PSC?

Power-On Status Clear. Enables (1) or disables (0) clearing of two specific registers at power on:

  • Standard Event enable register (*ESE).
  • Status Byte condition register (*SRE).
  • Questionable Data Register
  • Standard Operation Register
Parameter | Typical Return
{0|1}, default 1 | 0 or 1
Disables power-on clearing of affected registers: *PSC 0
  • This setting is non-volatile through a power-cycle. If it therefore useful for GPIB connection as follows:

    *PSC 0 to disable enable clearing
    *ESE 128 to enable power-on event
    *SRE 32 to enable a SRQ on std event

    This short program now provides a GPIB SRQ signal when the unit is turned on.

*RCL {0|1|2|3|4}
*SAV {0|1|2|3|4}

Recalls (*RCL) or saves (*SAV) instrument state in specified non-volatile location. Previously stored state in location is overwritten (no error is generated).

For 33600 Series instruments, the state files associated with *SAV and *RCL are saved in files called STATE_0.STA through STATE_4.STA. These files are located in the Settings directory of internal memory. You can manage these files using MMEMory commands.

Parameter | Typical Return
{0|1|2|3|4} | (none)
Recall state from location 1: *RCL 1
  • The instrument has five non-volatile storage locations to store instrument states. Location 0 holds the instrument power down state. Use locations 1, 2, 3, and 4 to store other states. You can configure the instrument to recall the power-down state when power is restored (MEM:STAT:REC:AUTO).
  • State storage "remembers" the selected function (including arbitrary waveforms), frequency, amplitude, DC offset, duty cycle, symmetry, as well as any modulation parameters in use. Also remembers front panel display state (DISP).
  • When shipped from the factory, locations 1 through 4 are empty, and location 0 has power-on state.
  • From the remote interface only, you can use location 0 to store a fifth instrument state (you cannot store to this location from the front panel). However, location 0 is overwritten when power is cycled.
  • You can assign a user-defined name to each of locations 0 through 4.
  • States stored in memory are not affected by *RST.
  • If you delete an arbitrary waveform from non-volatile memory after storing the instrument state, the waveform data is lost and the instrument will not output the waveform when the state is recalled; it will output the built-in "exponential rise" instead.
  • The front panel uses MMEMory subsystem for state storage.

*RST

Resets instrument to factory default state, independent of MEMory:STATe:RECall:AUTO setting.

Parameter | Typical Return
(none) | (none)
Reset the instrument: *RST
  • Does not affect stored instrument states, stored arbitrary waveforms, or I/O settings; these are stored in non-volatile memory.
  • Aborts a sweep or burst in progress.

*SRE <enable_value>
*SRE?

Service Request Enable. This command enables bits in the enable register for the Status Byte Register group.

Parameter | Typical Return
Decimal sum of the bits in the register (table below), default 0. For example, to enable bit 2 (value 4), bit 3 (value 8), and bit 7 (value 128), the decimal sum would be 140 (4 + 8 + 128). Default 0. | +24
Enable bits 3 and 4 in the enable register: *SRE 24
  • To enable specific bits, specify the decimal value corresponding to the binary-weighted sum of the bits in the register. The selected bits are summarized in the "Master Summary" bit (bit 6) of the Status Byte Register. If any of the selected bits change from 0 to 1, the instrument generates a Service Request signal.
  • *CLS clears the event register, but not the enable register.
  • *PSC (power-on status clear) determines whether Status Byte enable register is cleared at power on. For example, *PSC 0 preserves the contents of the enable register through power cycles.
  • Status Byte enable register is not cleared by *RST.

*STB?

Read Status Byte Query. This command queries the condition register for the Status Byte Register group.

Parameter | Typical Return
(none) | +40
Read condition register (with bits 3 and 5 set): *STB?
  • Similar to a Serial Poll, but processed like any other instrument command. Register is read-only; bits not cleared when read.
  • Returns same result as a Serial Poll, but "Master Summary" bit (bit 6) is not cleared by *STB?.
  • Power cycle or *RST clears all bits in condition register.
  • Returns a decimal value that corresponds to the binary-weighted sum of all bits set in the register. For example, with bit 3 ( value 8) and bit 5 (value 32) set (and corresponding bits enabled), the query returns +40.

*TRG

Trigger Command. Triggers a sweep, burst, arbitrary waveform advance, or LIST advance from the remote interface if the bus (software) trigger source is currently selected (TRIGger[1|2]:SOURce BUS).

Parameter | Typical Return
(none) | (none)
Send immediate trigger to initiate a burst: BURS:STAT ON BURS:MODE TRIG TRIG:SOUR BUS *TRG

*TST?

Self-Test Query. Performs a complete instrument self-test. If test fails, one or more error messages will provide additional information. Use SYSTem:ERRor? to read error queue.

Parameter | Typical Return
(none) | +0 (pass) or +1 (one or more tests failed)
Perform self-test: *TST?
  • A power-on self-test occurs when you turn on the instrument. This limited test assures you that the instrument is operational.
  • A complete self-test (*TST?) takes approximately 15 seconds. If all tests pass, you have high confidence that the instrument is fully operational.
  • Passing *TST displays "Self-Test Passed" on the front panel. Otherwise, it displays "Self-Test Failed" and an error number. See Service and Repair - Introduction for instructions on contacting support or returning the instrument for service.

*WAI

Configures the instrument to wait for all pending operations to complete before executing any additional commands over the interface.

Parameter | Typical Return
(none) | (none)
Wait until all pending operations complete. *WAI
  • For example, you can use this with the *TRG command to ensure that the instrument is ready for a trigger:

    *TRG;*WAI;*TRG


Enable Register

Registers

The instrument uses three different type of registers to enable, flag and track instrument features.

  • An enable register defines which bits in the event register will be reported to the Status Byte register group. You can write to or read from an enable register.
  • A condition register continuously monitors the state of the instrument. The bits in the condition register are updated in real time and the bits are not latched or buffered.
  • An event register is a read-only register that latches the various events from the condition register. There is no buffering in this register; while an event bit is set, subsequent events corresponding to that bit are ignored.


INITiate Subsystem

The INITiate subsystem controls how the instrument moves from the "idle" state to the "wait for trigger" state. You may do this one channel at a time, or for both channels with the "ALL" keyword.

Example

This program uses INITiate[1|2][:IMMediate] with TRIGger[1|2]:SOURce and TRIGger[1|2]:COUNt. The TRIG:SOUR EXT command configures the channel for external triggering, and TRIG:COUNT sets the trigger count to 10. The INITiate command places the instrument in the "wait-for-trigger" state. The trigger will occur when the rear-panel Ext Trig line is pulsed (high by default). The channel will return to idle after the trigger count of 10 has been satisfied. Another INIT command would then be necessary to restart the acceptance of triggers from the external trigger input line.

INIT:CONT OFF
TRIG:SOUR EXT
TRIG:COUNT 10
INIT

INITiate[1|2]:CONTinuous {ON|1|OFF|0}
INITiate[1|2]:CONTinuous?

INITiate:CONTinuous:ALL {ON|1|OFF|0}

Specifies whether the trigger system for one or both channels (ALL) always returns to the "wait-for-trigger" state (ON) or remains in the "idle" state (OFF), ignoring triggers until INITiate:IMMediate is issued.

Parameter | Typical Return
{ON|1|OFF|0}, default ON | 0 (OFF) or 1 (ON)
Configure both channels for continuous trigger: INIT:CONT:ALL ON
  • Once the channel is triggered, it leaves the wait-for-trigger state and enters the "action-in-progress" state (for example, burst-in-progress or sweep-in-progress). The action-in-progress state can be lengthy, and during this state triggers are ignored (will not count against number of triggers specified by TRIGger[1|2]:COUNt).
  • With INIT:CONT ON, the trigger count is meaningless because there is no way to distinguish the completion of one trigger count from the first trigger of the next trigger count. If you need counted triggers, you must set INIT:CONT OFF.

INITiate[1|2][:IMMediate]

INITiate[:IMMediate]:ALL

Changes state of triggering system for both channels (ALL) from "idle" to "wait-for-trigger" for the number of triggers specified by TRIGger[1|2]:COUNt.

  • Once the channel is triggered, it leaves the wait-for-trigger state and enters the "action-in-progress" state (for example, burst-in-progress or sweep-in-progress). The action-in-progress state can be lengthy, and during this state triggers are ignored (will not count against number of triggers specified by TRIGger[1|2]:COUNt).
Parameter | Typical Return
(none) | (none)
Change both channels to the wait-for-trigger state: INIT:IMM:ALL
  • The trigger system is armed by INITiate[:IMMediate]. Once the trigger count is satisfied, the trigger system returns to idle state and ignores further triggers. The triggered function will be left in whatever state is achieved with the count of triggers. Rearming the trigger system with another INITiate[:IMMediate] allows further triggers to apply.
  • Use ABORt to return instrument to idle.
  • If the specified channel has INIT:CONT set ON, INITiate[1|2]:IMMediate and INIT[:IMMediate]:ALL have no effect on the trigger system and error -213 will be generated.


INPut:ATTenuation[:STATe] {ON|1|OFF|0}INPut:ATTenuation[:STATe]?

INPut:ATTenuation[:STATe] {ON|1|OFF|0}
INPut:ATTenuation[:STATe]?

Specifies whether the modulation input on the 33600 Series works with signals up to the 5 V level (ON) or the 1 V level (OFF).

Parameter | Typical Return
{ON|1|OFF|0}, default ON | 0 (OFF) or 1 (ON)
Specify that the modulation input is to work with signals up to 5 V: INP:ATT ON
  • You can set this from the front panel modulation parameters screen if the modulation source is set to External.


LIST Subsystem

Configures list of frequencies to be output by instrument. This permits faster frequency change to a predetermined list of frequencies. You may advance frequencies by either an external trigger, an internal trigger, or a BUS trigger. List is initiated by FREQuency:MODE LIST.

LIST_DWELl - sets amount of time each frequency in list is generated.

LIST_FREQuency - Specify up to 128 frequencies as a list (frequencies may also be read from or saved to a file using MMEMory:LOAD:LIST[1|2] and MMEMory:STORe:LIST.

LIST_FREQuency_POINts - Returns number of points in a frequency list.

For LIST programming example, see Create a List of Frequencies.

[SOURce[1|2]:]LIST:DWELl {<seconds>|MINimum|MAXimum}
[SOURce[1|2]:]LIST:DWELl? [{MINimum|MAXimum}]

Sets dwell time, the amount of time each frequency in a frequency list is generated.

Parameter | Typical Return
1 µs to 1000 s, default 1 s | +1.200000000000000E+01
Set dwell time for channel 1 to 12 s: LIST:DWEL 12
  • The instrument generates each frequency in a frequency list for the specified dwell time, when TRIGger[1|2]:SOURce is IMMediate.

[SOURce[1|2]:]LIST:FREQuency <freq1>[, <freq2>, etc.]
[SOURce[1|2]:]LIST:FREQuency?

Specifies frequency values in a frequency list.

Parameter | Typical Return
List of 1 to 128 frequencies, each 1 μHz to maximum instrument frequency (up to 200 kHz for triangle and ramp). Default list: 100 Hz, 1000 Hz, and 550 Hz. | 2.17800000E+006,3.14000000E+003, 6.28318000E+006
Set channel 1 frequency list to three frequency values: LIST:FREQ 2.718E6, 3.14E3, 6.28318E6
  • This command overwrites the previous list with the new list.

[SOURce[1|2]:]LIST:FREQuency:POINts? [{MINimum|MAXimum}]

Returns number of frequencies in current frequency list.

Parameter | Typical Return
[{MINimum|MAXimum}] | +17
Return number of entries in the channel 1 frequency list: LIST:FREQ:POIN?
  • The default list has three frequencies: 100 Hz, 1000 Hz, and 550 Hz.
  • MINimum is 1, MAXimum is 128.


LXI Subsystem

The LXI subsystem supports LAN eXtensions for Instrumentation (LXI) functionality.

LXI:IDENtify[:STATE] {ON|1|OFF|0}
LXI:IDENtify[:STATE]?

Turns the LXI Identify Indicator on the display on or off.

Parameter | Typical Return
{ON|1|OFF|0} | 0 (OFF) or 1 (ON)
Turn on the LXI Identify Indicator: LXI:IDEN ON
  • The LXI Identify indicator helps you identify the device associated with the LAN address.
  • A *RST turns LXI Identify Indicator off.
  • Pressing the LOCAL key turns off the LXI Identify Indicator.

LXI:MDNS:ENABle {ON|1|OFF|0}
LXI:MDNS:ENABle?

Disables or enables the Multicast Domain Name System (mDNS).

Parameter | Typical Return
{ON|1|OFF|0}, default ON | 0 (OFF) or 1 (ON)
Turn mDNS ON: LXI:MDSN:ENAB ON
  • Setting is enabled after SYSTem:SECurity:IMMediate, *RST, power-on, or LAN reset.

LXI:MDNS:HNAMe[:RESolved]?

Returns the resolved (unique) mDNS hostname in the form <mDNS Hostname>-N. The N is an integer appended if necessary to make the name unique. The desired name may be truncated, if necessary, to make room for the appended integer.

Parameter | Typical Return
(none) | "A-335xxx-00107", where xxx is the last three characters of the model number, and 00107 is the last five digits of the serial number.
Return the resolved mDNS hostname: LXI:MDNS:HNAMe:RESolved?

LXI:MDNS:SNAMe:DESired <name>
LXI:MDNS:SNAMe:DESired?

Sets the desired mDNS service name.

Parameter | Typical Return
Quoted string of up to 63 characters, default is Keysight <Model_Name> Arbitrary Waveform Generator - <Serial_Number>". | "Keysight 33xxxx Arbitrary Waveform Generator - 99999", where xxxx is the last four characters of the model number, and 99999 is the last five digits of the serial number.
Set the mDNS service name to "Waveform Generator": LXI:MDNS:SNAM:DES "Waveform Generator"
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Setting is set to default value after SYSTem:SECurity:IMMediate.

LXI:MDNS:SNAMe[:RESolved]?

Returns the resolved (unique) mDNS service name in the form <Desired mDNS Service Name>(N). The N is an integer appended if necessary to make the name unique. The desired name may be truncated, if necessary, to make room for the appended integer.

Parameter | Typical Return
(none) | "Keysight 33xxxx Arbitrary Waveform Generator - 99999", where xxxx is the last four characters of the model number, and 99999 is the last five digits of the serial number.
Return resolved mDNS service name: LXI:MDNS:SNAMe:RESolved?
  • The resolved mDNS service name is the desired service name (LXI:MDNS:SNAMe:DESired), possibly with "(N)" appended, where N is an integer, only if it is necessary to make the name unique.

LXI:RESet

Resets LAN settings to a known operating state, beginning with DHCP. If DHCP fails, it uses AutoIP. It also clears the WebUI password, if set.

Parameter | Typical Return
(none) | (none)
Reset the LAN settings: LXI:RES
  • Depending on your network, the LAN interface may take several seconds to restart after this command is sent.
  • If the LAN interface or specific LAN services (VXI-11, sockets, and so on) have been disabled by SYSTem:COMMunicate:ENABle, you must separately re-enable the interface or services and cycle power on the instrument for the LAN to be operational.

LXI:RESTart

Restarts the LAN with the current settings as specified by the SYSTem:COMM:LAN commands.

Parameter | Typical Return
(none) | (none)
Restart the LAN interface: LXI:REST
  • Depending on your network, the LAN interface may take several seconds to restart after this command is sent.
  • If the LAN interface or specific LAN services (VXI-11, sockets, and so on) have been disabled by SYSTem:COMMunicate:ENABle, you must separately re-enable the interface or services and cycle power on the instrument for the LAN to be operational.


MARKer Subsystem

The MARKer subsystem configures the point within an arbitrary waveform, sweep, or burst at which the front panel Sync signal goes low.

Commands and Queries

  • [SOURce[1|2]:]MARKer:CYCle {<cycle_num>|MINimum|MAXimum|DEFault} - cycle of a burst at which Sync signal goes low
  • [SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault} - frequency at which Sync signal goes low
  • [SOURce[1|2]:]MARKer:POINt {<sample_number>|MINimum|MAXimum} - point in an arbitrary waveform at which Sync signal goes low

If and only if the SYNC:MODE is set to MARKer, each of these commands causes sync/marker to transition to high at start of burst, sweep, or arbitrary waveform. OUTPut:SYNC:POLarity may reverse this.

[SOURce[1|2]:]MARKer:CYCle {<cycle_num>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]MARKer:CYCLe? [{MINimum|MAXimum}]

Sets the marker cycle number at which the front panel Sync signal goes low in a burst mode operation. OUTPut:SYNC:POLarity may reverse this.

Parameter | Typical Return
Whole number from 2 to number of cycles in the burst plus one (NCYCles+1), default 2 | +2.000000000000000E+03
Set the marker cycle to 2000: MARK:CYCL 2000
  • This is valid only if burst is enabled and OUTP:SYNC:MODE is MARKer.
  • With burst enabled, the marker cycle must be less than or equal to the number of cycles in the burst plus one. Attempting to set the marker cycle outside this range will set marker cycle equal to middle of burst. From the remote interface, a "Settings conflict" error will also be generated.

[SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]MARKer:FREQuency? [{MINimum|MAXimum}]

Sets the marker frequency at which the front panel Sync signal goes low during a sweep. OUTPut:SYNC:POLarity may reverse this.

Parameter | Typical Return
Any frequency between start and stop frequency, default 500 Hz | +2.000000000000000E+03
Set marker frequency to 2 kHz: MARK:FREQ 2000
  • This is valid only if sweep is enabled and OUTP:SYNC:MODE is MARKer.
  • When sweep is enabled, marker frequency must be between start frequency and stop frequency. Attempting to set the marker cycle outside this range will set marker frequency to start frequency or frequency (whichever is closer). From the remote interface, a "Settings conflict" error will also be generated.

[SOURce[1|2]:]MARKer:POINt {<sample_number>|MINimum|MAXimum}
[SOURce[1|2]:]MARKer:POINt? [{MINimum|MAXimum}]

Sets the sample number at which the front panel Sync signal goes low within the active arbitrary waveform. OUTPut:SYNC:POLarity may reverse this.

Parameter | Typical Return
Whole number from 4 to number of samples in waveform, minus 3; default is midpoint of arbitrary waveform | +1.000000000000000E+01
Set marker point to 10th sample in waveform: MARK:POIN 10
  • Command only sets marker point in currently active arbitrary waveform (FUNCtion:ARBitrary), not in a sequence.
  • Command is valid only under these conditions:
  • OUTPut:SYNC:MODE set to MARK, FUNC set to ARB, FREQuency:MODE set to CW
  • OUTPut:SYNC:MODE set to CARR, FUNC set to ARB, BURSt ON.
  • OUTPut:SYNC:MODE set to CARR, FUNC set to ARB, FREQuency:MODE set to SWEEP
  • OUTPut:SYNC:MODE set to MARK, internal modulation active, and either FUNCtion set to ARB or a modulating waveform's internal function is set to ARB
  • OUTPut:SYNC:MODE set to MARK, external modulation active, and FUNCtion set to ARB


MEMory Subsystem

The MEMory subsystem works with instrument state files that are saved to (*SAV) and recalled from (*RCL) non-volatile storage locations numbered 0 through 4.

For 33600 Series instruments, the state files associated with *SAV and *RCL are saved in files called STATE_0.STA through STATE_4.STA. These files are located in the Settings directory of internal memory. You can manage these files using MMEMory commands.

Example

MEM:STAT:DEL 3
*SAV 3
MEM:STAT:VAL? 3
MEM:STAT:NAME 3,PATS_STATE
MEM:STAT:CAT?

Commands and Queries

  • MEMory:NSTates? - return total number of state storage memory locations
  • MEMory:STATe:CATalog? - list the names associated with all five state storage locations
  • MEMory:STATe:DELete {0|1|2|3|4|} - delete the contents of a state storage location
  • MEMory:STATe:NAME {0|1|2|3|4} [,<name>] - assign a custom name to a state storage locations
  • MEMory:STATe:RECall:AUTO {ON|1|OFF|0} - specify whether the power-down state is recalled from location 0 on power-on
  • MEMory:STATe:VALid? {0|1|2|3|4} - determine whether a storage location contains a valid state

MEMory:NSTates?

Returns the total number of memory locations available for state storage (always +5, including memory location 0).

Parameter | Typical Return
(none) | +5
Return number of state storage locations: MEM:NST?

MEMory:STATe:CATalog?

Returns the names assigned to locations 0 through 4.

Parameter | Typical Return
(none) | "AUTO_RECALL","STATE_1","STATE_2","STATE_3","STATE_4"
Return location names: MEM:STAT:CAT?
  • Default names are "AUTO_RECALL", "STATE_1", "STATE_2", "STATE_3", and "STATE_4".
  • You can name location 0, but the name is overwritten when power is cycled and a new power-down state is stored there.

MEMory:STATe:DELete {0|1|2|3|4|}

Deletes a state storage location.

Parameter | Typical Return
{0|1|2|3|4|} | (none)
Delete the contents of storage location 1: MEM:STAT:DEL 1
  • Default names are "AUTO_RECALL", "STATE_1", "STATE_2", "STATE_3", and "STATE_4".
  • Although you may delete the state in location 0, the instrument will be restored to its power-down state at the next power up.
  • Attempting to recall a state from an empty location generates an error.

MEMory:STATe:NAME {0|1|2|3|4} [,<name>]
MEMory:STATe:NAME? {0|1|2|3|4}

Names a storage location.

Parameter | Typical Return
An unquoted string of up to 12 characters. The first character must be a letter (A-Z). Others can be letters, numbers (0-9), or underscores ("_"). If name omitted, factory default name is used. | TEST_RACK_1
Rename location 1: MEM:STAT:NAME 1,TEST_RACK_1
  • Default names are "AUTO_RECALL", "STATE_1", "STATE_2", "STATE_3", and "STATE_4".
  • You can name location 0, but the name is overwritten when power is cycled and a new power-down state is stored there.
  • May assign same name to different locations.
  • Deleting a storage location's contents (MEMory:STATe:DELete) resets associated name to factory default ("AUTO_RECALL", "STATE_1", "STATE_2", "STATE_3", or "STATE_4").
  • State names are unaffected by *RST.

MEMory:STATe:RECall:AUTO {ON|1|OFF|0}
MEMory:STATe:RECall:AUTO?

Disables or enables automatic recall of instrument state in storage location "0" at power on.

Parameter | Typical Return
{ON|1|OFF|0}, default ON | 0 (OFF) or 1 (ON)
Disable automatic recall of power-down state: MEM:STAT:REC:AUTO OFF
  • OFF is equivalent to Factory Reset (*RST) on power-up.

MEMory:STATe:VALid? {0|1|2|3|4}

Indicates whether a valid state is currently stored in a storage location.

Parameter | Typical Return
{0|1|2|3|4} | 0 (no valid state stored) or 1 (valid state stored)
Return state of memory location 3: MEM:STAT:VAL 3?
  • Use this before sending *SAV to avoid accidentally overwriting a state.


MMEMory Subsystem

The MMEMory subsystem manages the file system in the instrument or on an external USB file system. The file system can store and load several file formats.

The "INT:\" flash memory file system inside the instrument is always present. If a USB file storage device (sometimes called a flash drive, thumb drive, or jump drive) is plugged into the front panel USB port, it appears as "USB:\" to the instrument.

Example

The following code produces the sequence shown below. Note that the long DATA:SEQuence command splits across lines for readability purposes.

FUNC:ARB:SRATE 10E3
FUNC:ARB:FILTER OFF
FUNC:ARB:PTPEAK 10
DATA:ARB dc_ramp, 0.1, 0.1, 0.1, 0.1, 0.1, 0.2, 0.4, 0.6, 0.8, 1.0
DATA:ARB dc5v, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0
DATA:ARB dc2_5v, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5, 0.5
DATA:ARB dc0v, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0
DATA:SEQuence #3128"seqExample","dc_ramp",0,once,highAtStart,5,"dc5v",2,repeat,maintain,5,
"dc2_v",2,repeat,lowAtStart,5,"dc0v",2,repeat,maintain,5
FUNC:ARB dc_ramp
MMEM:STORE:DATA "INT:\dc_ramp.arb"
FUNC:ARB dc5v
MMEM:STORE:DATA "INT:\dc5v.arb"
FUNC:ARB dc2_5v
MMEM:STORE:DATA "INT:\dc2_5.arb"
FUNC:ARB dc0v
MMEM:STORE:DATA "INT:\dc0v.arb"
FUNC:ARB seqExample
MMEM:STORE:DATA "INT:\seqExample.seq"
DATA:VOL:CLEAR <--- erase all waveforms to show LOAD will restore all waveforms
MMEM:LOAD:DATA "INT:\seqExample.seq"
FUNC ARB
FUNC:ARB "INT:\seqExample.seq"
OUTPUT ON

The seqExample.seq file is as shown below:

File Format:1.10
Sample Rate:10000.000000
High Level:5.000000
Low Level:0.000000
Filter:"off"
Header:Arb Name, Repeat Count, Play Control,Marker Mode, Marker Point
dc_ramp.arb,1,"once","highAtStart",5
dc5v.arb,2,"repeat","maintain",5
dc2_5v.arb,2,"repeat","lowAtStart",5
dc0v.arb,2,"repeat","maintain",5

Commands and Queries

The MMEMory subsystem includes the following commands and queries.

MMEMory:CATalog[:ALL]? [<folder>] - lists available and used space and files on Mass Memory device

MMEMory:CATalog:DATA:ARBitrary? [<folder>] - lists arbitrary waveforms and sequences on Mass Memory device

MMEMory:CATalog:STATe? [<folder>] - lists available and used space and state (*.sta) files present on Mass Memory device

MMEMory:CDIRectory <folder> - changes to a directory
MMEMory:CDIRectory?

MMEMory:COPY <file1>,<file2> - copies a file on Mass Memory device

MMEMory:COPY:SEQuence <source>,<destination> - copies a sequence and its associated arbitrary waveforms on Mass Memory device

MMEMory:DELete <file> - removes files from Mass Memory device

MMEMory:DOWNload:DATA <binary_block> - downloads data from the host computer to instrument's Mass Memory

MMEMory:DOWNload:FNAMe <filename> - specifies file name for downloading data from the computer to instrument's Mass Memory

MMEMory:LOAD:ALL <filename> - loads instrument state file

MMEMory:LOAD:DATA[1|2] <filename> - loads arbitrary waveform from file

MMEMory:LOAD:LIST[1|2] <filename> - loads frequency list from file

MMEMory:LOAD:STATe <filename> - loads saved instrument state from file

MMEMory:MDIRectory <folder> - makes a new directory (folder)

MMEMory:MOVE <file1>,<file2> - moves a file on Mass Memory device

MMEMory:RDIRectory <folder> - removes a directory

MMEMory:STORe:ALL <filename> - saves instrument state file

MMEMory:STORe:DATA[1|2] <filename> - saves arbitrary waveform to file

MMEMory:STORe:LIST[1|2] <filename> - saves active frequency list to file

MMEMory:STORe:STATe <filename> - stores instrument state to file

MMEMory:UPLoad? <filename> - uploads contents of a file from instrument to host computer

Folder and file formats

Many MMEMory commands refer to folders and files. These have specific structures, described below.

Format for a <folder>

  • The format for <folder> is "<drive>:<path>", where <drive> can be INTernal or USB, and <path> is an absolute folder path.
  • INTernal specifies the internal flash file system. USB specifies a front panel USB storage device.
  • Absolute paths begin with "\" or "/" and start at the root folder of <drive>.
  • The folder name specified in <path> cannot exceed 240 characters.
  • The specified folder must exist and cannot be marked hidden or system.
  • If <drive>:<path> is omitted, the folder specified by MMEMory:CDIRectory is used.
  • If <drive> is omitted:
  • The path is treated as a relative path and appended to the folder specified by MMEMory:CDIRectory.
  • Absolute paths are NOT allowed.

Format for a <file>

  • The format for <file1> and <file2> is "[<drive>:<path>]<file_name>", where <drive> can be INTernal or USB, and <path> must be an absolute folder path.
  • INTernal specifies the internal flash file system. USB specifies a front panel USB storage device.
  • If <drive>:<path> is omitted, the folder specified by MMEMory:CDIRectory is used.
  • Absolute paths begin with "\" or "/" and start at the root folder of <drive>.
  • Folder and file names cannot contain the following characters: \ / : * ? " < > |
  • The combination of folder and file name cannot exceed 240 characters.
  • The source file and folder and the destination folder must exist and cannot be marked hidden or system.
  • If the destination file exists, it is overwritten, unless marked as hidden or system.
  • If <drive> is omitted:
  • The path is treated as a relative path and appended to the folder specified by MMEMory:CDIRectory.
  • Absolute paths are NOT allowed.

Mass Memory (MMEMory) and State Storage

The front panel uses the MMEM subsystem, not the MEM subsystem, to save states. If you save a state with the front panel, you can still access it with SCPI. However, a state saved into the MEM subsystem via SCPI using *SAV cannot be retrieved from the front panel.

For example, configure the instrument as desired and insert a USB drive into the front panel. Then enter the following commands. If you do not have a USB drive change "USB:\" to "INT:\" to use the instrument's internal flash drive instead.

MMEMory:CDIRectory "USB:\"
MMEMory:MDIRerctory "States"
MMEMory:STORe:STATE "USB:\States\State1"

To return to this state at any time:

MMEMory:LOAD:STATE "USB:\States\State1"

You can also recall a state file from the front panel by pressing [System] > Store/Recall.

MMEMory:CATalog[:ALL]? [<folder>]

Returns a list of all files in the current mass storage directory, including internal storage and the USB drive.

Parameter | Typical Return
Any valid folder name; defaults to folder selected by MMEMory:CDIRectory | +1000000000,+327168572, "command.exe,,375808", "MySetup.sta,STAT,8192", "MyWave.csv,ASC,11265"
List all files in the folder MyData on the front panel USB storage device: MMEM:CAT? "USB:\MyData"
  • The catalog takes the following form:

    <mem_used>,<mem_free>{,"<file listing>"}

    The instrument returns two numeric values and a string for each file in the folder. The first numeric value indicates the number of bytes of storage used on the drive. The second indicates the number of bytes of storage available. Each <file listing> is in the format "<file_name>,<file_type>,<file_size>" (the quotation marks are also returned), where <file_name> is the name of the file including file extension, if any; <file_type> is either STAT for STATe (.sta) files, ASC for DATA (.csv) files, FOLD for folders, or null for all other file extensions; <file_size> is the size of the file in bytes.
  • If no files exist, only <mem_used>,<mem_free> is returned.
  • Because the instrument uses a small amount of space in the flash file system for internal use, the <mem_used> value will not be zero even if no user files exist on the drive.

MMEMory:CATalog:DATA:ARBitrary? [<folder>]

Returns a list of all the arbitrary sequence (.seq) files and folders, as well as arbitrary waveform (.arb/.barb) files in a folder.

Parameter | Typical Return
Any valid folder name; defaults to folder selected by MMEMory:CDIRectory | (see below)

The following query lists all arbitrary waveform and sequence files in the BuiltIn directory of internal memory.

MMEM:CAT:DATA:ARBitrary? "INT:\BuiltIn"

Typical Response:
96256,1019770880,"EXP_RISE.arb,ARB,1868","EXP_FALL.arb,ARB,2064",
"SINC.arb,ARB,1897","CARDIAC.arb,ARB,2410","NEG_RAMP.arb,ARB,1908",
"HAVERSINE.arb,ARB,374","GAUSSIAN.arb,ARB,587","LORENTZ.arb,ARB,1254",
"D_LORENTZ.arb,ARB,1373"
  • The instrument returns two numeric values and a string for each .seq and .arb/.barb file in the selected folder. The first numeric value indicates the number of bytes of storage used on the drive. The second indicates the number of bytes of storage available. Each <file listing> is in the format "<filename>,<file_type>,<file_size>" (the quotation marks are also returned), where <filename> is the name of the file including file extension, if any; <file_type> is FOLD for folders, ARB for arb segments, or SEQUENCE for arb sequence files; <file_size> is the size of the file in bytes.
  • If no .seq, .arb, or .barb files exist, only <mem_used>,<mem_free> is returned.
  • Because the instrument uses a small amount of space in the flash file system for internal use, the <mem_used> value will not be zero even if no user files exist on the drive.

MMEMory:CATalog:STATe? [<folder>]

Lists all state files (.sta file extension) in a folder.

Parameter | Typical Return
Any valid folder name; defaults to folder selected by MMEMory:CDIRectory | +1000000000,+327168572,"MySetup.sta,STAT,8192"
List all state files in MyData folder on front panel USB drive. MMEM:CAT:STAT? "USB:\MyData"
  • Format for returned catalog:

    <mem_used>,<mem_free>{,"<file listing>"}
  • The instrument returns two numeric values and a string for each state file in the selected folder. The first numeric value indicates the number of bytes of storage used on the drive. The second indicates the number of bytes of storage available. Each <file listing> is in the format "<file_name>,<file_type>,<file_size>" (the quotes are also returned), where <file_name> is the name of the file including file extension, if any; <file_type> is STAT for STATe (.sta) files; <file_size> is the size of the file in bytes.
  • If no state files exist, only <mem_used>,<mem_free> is returned.
  • Because the instrument uses a small amount of space in the flash file system for internal use, the <mem_used> value will not be zero even if no user files exist on the drive.

MMEMory:CDIRectory <folder>
MMEMory:CDIRectory?
MMEMory:MDIRectory <folder>
MMEMory:RDIRectory <folder>

MMEMory:CDIRectory selects the default folder for the MMEMory subsystem commands. This folder must exist and is used when folder or file names do not include a drive and folder name.

MMEMory:MDIRectory makes a new directory (folder) on the mass storage medium.

MMEMory:RDIRectory removes a directory (folder) on the mass storage medium.

Parameter | Typical Return
Any directory name, including the mass storage unit specifier, default INT:\ | "INT:\"
Make and remove a new directory named "test" on the internal mass memory system: MMEM:MDIR "test" MMEM:RDIR "test" Return the default folder for MMEMory subsystem commands: MMEM:CDIR?
  • The instrument resets the default folder to the internal flash file system root directory ("INT:\") after *RST.
  • You can only remove an empty folder (no files). Otherwise, the instrument generates a "Directory not empty" error.

MMEMory:COPY <file1>,<file2>

Copies <file1> to <file2>. The file names must include any file extension.

Parameter | Typical Return
Both files can be any valid file name | (none)
Copy the state file MyFreqMeas.sta from the root directory to the folder "Backup" on the internal flash file system. MMEM:COPY "INT:\MySetup.sta","INT:\Backup"
  • To copy a file to a file of the same name in a different folder, you can specify just the <drive> and/or <path> for <destination>.

MMEMory:COPY:SEQuence <source>,<destination>

Copies a sequence from <source> to <destination>. The file names must include any file extension. Use the extension .seq for text format.

Parameter | Typical Return
<source> and <destination> may be any valid sequence file name. | (none)
Copy the sequence file MySequence.seq and all associated segment files specified in the sequence file from internal drive to the folder "Backup" on internal storage. MMEM:COPY:SEQ "INT:\MySequence.seq","INT:\Backup"
  • The format for <source> and <destination> is "[[<drive>:]<path>]<file_name>", where <drive> can be INTernal or USB, and <path> is a file path.
  • INTernal specifies the internal flash file system. USB specifies a front panel USB storage device.
  • If <drive> is specified, <path> is interpreted as an absolute path. Absolute paths begin with "\" or "/" and start at the root folder of <drive>.
  • If <drive> is omitted, <path> is relative to the folder specified by MMEMory:CDIRectory. Relative paths must not begin with "\" or "/".
  • Folder and file names cannot contain the following characters: \ / : * ? " < > |
  • The combination of folder and file name cannot exceed 240 characters.
  • The source file and folder and the destination folder must exist and cannot be marked hidden or system.
  • If the destination file exists, it is overwritten, unless marked as hidden or system.
  • To copy a sequence file to a sequence file of the same name in a different folder, you can specify just the <drive> and/or <path> for <destination>.

MMEMory:DELete <file>

Deletes a file. To delete a folder, use MMEMory:RDIRectory.

Parameter | Typical Return
Any valid file name, including file extension. | (none)
Delete the indicated file from the root directory of the internal flash file system: MMEM:DEL "INT:\MySetup.sta"
  • You may also use wildcards with this command. For example, MMEM:DEL "INT:\MYDATA\*.csv" will erase all of the CSV files in the specified directory.

MMEMory:DOWNload:DATA <binary_block>

Downloads data from the host computer to a file in the instrument. The filename must have been previously specified by MMEMory:DOWNload:FNAMe.

The data in <binary_block> is written to the select file, and any data previously stored in the file is lost.

Parameter | Typical Return
Any IEEE-488 definite or indefinite block | (none)
Writes the word "Hello" to the file "\Myfile" on internal storage. MMEM:DOWN:FNAM "INT:\Myfile" MMEM:DOWN:DATA #15Hello

MMEMory:DOWNload:FNAMe <filename>

Creates or opens the specified filename prior to writing data to that file with MMEMory:DOWNload:DATA.

Parameter | Typical Return
Any valid file name | (none)
Write the word "Hello" to the file "\Myfile" on the internal flash file system: MMEM:DOWN:FNAM "INT:\Myfile"MMEM:DOWN:DATA #15Hello

MMEMory:LOAD:ALL <filename>

MMEMory:STORe:ALL <filename>

Loads or saves a complete instrument setup, using a named file on the mass storage.

Parameter | Typical Return
Any valid file name on current mass storage directory | (none)

Store instrument setup to file named "completeSetup.all" on internal storage:
MMEM:STOR:ALL "INT:\completeSetup.all"

Load a complete instrument setup from the file in internal mass memory.
MMEM:LOAD:ALL "INT:\completeSetup.all"
  • These commands allow you to duplicate instrument conditions from some previous time.
  • This command loads the current instrument setup (such as is used by *SAV and *RCL).
  • Instrument setup files used by these commands contain much more than the state files used by *SAV and *RCL. They also contain stored states and arbitrary waveforms, GPIB and LAN parameters, number format, beep on/off, display options, and help language.
  • If the destination file exists, it is overwritten, unless marked as hidden or system.

MMEMory:LOAD:DATA[1|2] <filename>

Loads the specified arb segment(.arb/.barb) or arb sequence (.seq) file in INTERNAL or USB memory into volatile memory for the specified channel.

Parameter | Typical Return
Any valid file name, as described below. | (none)
Load an arbitrary waveform segment from the internal drive into volatile memory for channel 1 and selects it for use. MMEM:LOAD:DATA "Int:\Builtin\HAVERSINE.arb" FUNC:ARB "Int:\Builtin\HAVERSINE.ARB"
  • If a sequence file (.seq) is specified, all the arbitrary waveforms defined in the file are loaded.
  • If the waveform referenced by <filename> has already been loaded, the instrument will generate error number +786, "Specified arb waveform already exists". Deleting an existing waveform requires clearing the waveform non-volatile memory with DATA:VOLatile:CLEar.

MMEMory:LOAD:LIST[1|2] <filename>

MMEMory:STORe:LIST[1|2] <filename>

Loads or stores a frequency list file (.lst).

Parameter Typical Return
Any valid file name on the mass memory device

(none)

Store the current frequency list to a LIST file on internal storage:
MMEM:STOR:LIST "INT:\FreqList.lst"

Load a LIST file on the internal storage mass memory system (file named FreqList.lst).
MMEM:LOAD:LIST "INT:\FreqList.lst"
  • A frequency list controls frequency in FREQ:MODE LIST, rapidly changing to the next frequency in the list when a trigger event is received.
  • A frequency list file contains a comma-separated sequence of ASCII numbers, with the first number representing the number of frequencies in the list:

3, 100.000000, 1000.000000, 550.000000

  • If the destination file exists, it is overwritten, unless marked as hidden or system.

MMEMory:LOAD:STATe <filename>

MMEMory:STORe:STATe <filename>

Stores the current instrument state to a state file. The file name optionally includes the folder name and the .sta file extension.

Parameter | Typical Return
Any valid file name on the current directory | (none)
Store the current instrument state to the state file MyFreqMeas.sta in the root directory of the internal flash file system. MMEM:STOR:STAT "INT:\MySetup" Load the instrument state from MySetup.sta in the root directory of the internal storage. MMEM:LOAD:STAT "INT:\MySetup.sta"

MMEMory:MOVE <file1>,<file2>

Moves and/or renames <file1> to <file2>. The file names must include the file extension.

Parameter | Typical Return
Both files may be any valid file name | (none)

Move the state file MySetup.sta from the currently selected default directory to the folder "Backup" on the internal flash file system;
MMEM:MOVE "MySetup.sta","INT:\Backup"

Rename the arbitrary waveform arbMonday on the USB drive to the name arbTuesday.
MMEM:MOVE "USB:\arbMonday", "USB:\arbTuesday"
  • To simply rename a file, specify the same folder for <file1> and <file2>.
  • To move a file to a file of the same name in a different folder, you can specify just the <drive>:<path> for <file2>.

MMEMory:STORe:DATA[1|2] <filename>

Stores the specified arb segment(.arb/.barb) or arb sequence (.seq) data in the channel specified volatile memory (default, channel 1) in INTERNAL or USB memory.

Parameter | Typical Return
Any valid file name | (none)
Store an arbitrary sequence loaded in volatile memory on channel 1 to the internal drive. MMEM:STOR:DATA "INT:\Sequence1.seq"
  • When you store an arbitrary waveform segment or sequence (MMEMory:STORe:DATA[1|2]), the instrument's current settings (voltage values, sample rate, filter type, and so on) are stored in the segment or sequence file. When you play the file for the first time with FUNCtion:ARBitrary, these settings are loaded and override the instrument's current settings. If you have manually edited a segment or sequence file such that the instrument settings have been removed, the instrument settings will not be changed when you execute FUNCtion:ARBitrary.
  • If the destination file exists, it is overwritten, unless marked as hidden or system.
  • If an arbitrary waveform sequence file (.seq) is specified, all the arbitrary waveform segment file names associated with the sequence are stored in the file.
  • Command will error if the specified arbitrary waveform segment or arbitrary waveform sequence is not found in volatile memory.

MMEMory:UPLoad? <filename>

Uploads the contents of a file from the instrument to the host computer.

Parameter | Typical Return
Any valid file name | IEEE 488.2 definite-length block
The following command uploads the contents of the state file "Myfile.sta" in the root directory of the internal flash file system to the host computer: MMEM:UPL? "INT:\Myfile.sta"


OUTPut Subsystem

The OUTPut subsystem controls the front panel channel output and Sync connectors and the rear-panel Ext Trig connector:

  • OUTPut[1|2] {ON|1|OFF|0} - front panel channel output connector state
  • OUTPut[1|2]:LOAD {<ohms>|INFinity|MINimum|MAXimum|DEFault} - output termination impedance
  • OUTPut[1|2]:MODE {NORMal|GATed} - channel output mode
  • OUTPut[1|2]:POLarity {NORMal|INVerted} - output waveform polarity
  • OUTPut:SYNC {ON|1|OFF|0} - front panel Sync connector state
  • OUTPut[1|2]:SYNC:MODE? - sync signal mode
  • OUTPut[1|2]:SYNC:POLarity {NORMal|INVerted} - sync waveform polarity
  • OUTPut:SYNC:SOURce {CH1|CH2} - channel used to drive sync signal
  • OUTPut:TRIGger {ON|1|OFF|0} - rear-panel Ext Trig connector state
  • OUTPut:TRIGger:SLOPe {POSitive|NEGative} - "trigger out" polarity
  • OUTPut:TRIGger:SOURce {CH1|CH2} - channel for driving output trigger

OUTPut[1|2] {ON|1|OFF|0}
OUTPut[1|2]?

Enables or disables the front panel output connector.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Enable output connector for channel 1: OUTP ON
  • When output is enabled, the front panel channel output key is illuminated.
  • The APPLy commands override current OUTPut setting and enable the channel output connector.
  • If excessive external voltage is applied to the front panel channel output connector, an error message appears and output is disabled. To re-enable output, remove overload from the output connector and send OUTPut ON.
  • OUTPut changes the state of the channel output connector by switching the output relay, without zeroing output voltage. Therefore, output may glitch for about a millisecond until signal stabilizes. Minimize glitching by first minimizing amplitude (VOLTage MIN) and setting offset to 0 (VOLTage:OFFSet 0) before changing output state.
  • This command also toggles the output impedance between 50 Ω (ON) and high (>1MΩ) impedance (OFF).

OUTPut[1|2]:LOAD {<ohms>|INFinity|MINimum|MAXimum|DEFault}
OUTPut[1|2]:LOAD? [{MINimum|MAXimum}]

Sets expected output termination. Should equal the load impedance attached to the output.

Parameter | Typical Return
1 Ω to 10 kΩ, default 50 Ω | +5.000000000000000E+02
Set output impedance to 300 Ω: OUTP:LOAD 300 Set output impedance to "high impedance": OUTP:LOAD INF
  • The specified value is used for amplitude, offset, and high/low level settings.
  • The instrument has a fixed series output impedance of 50 Ω to the front panel channel connectors. If the actual load impedance differs from the value specified, the displayed amplitude and offset levels will be incorrect. The load impedance setting is simply a convenience to ensure that the displayed voltage matches the expected load.
  • If you change the output termination setting, the displayed output amplitude, offset, and high/low levels are adjusted (with no error generated). If the amplitude is 10 Vpp and you change the output termination setting from 50 Ω to "high impedance" (OUTPut[1|2]:LOAD INF), the displayed amplitude doubles to 20 Vpp. Changing from "high impedance" to 50 Ω halves the displayed amplitude. The output termination setting does not affect the actual output voltage; it only changes the values displayed and queried from the remote interface. Actual output voltage depends on the connected load.
  • You cannot specify output amplitude in dBm if output termination is set to high impedance. The units are automatically converted to Vpp. See VOLT:UNIT for details.
  • You cannot change the output termination setting with voltage limits enabled; the instrument cannot know which output termination settings the voltage limits apply to. To change the output termination setting, disable voltage limits, set the new termination value, adjust voltage limits, and re-enable voltage limits.
  • If INF (high impedance) is selected, the query returns 9.9E+37.

OUTPut[1|2]:MODE {NORMal|GATed}
OUTPut[1|2]:MODE?

Enables (GATed) or disables (NORMal) gating of the output waveform signal on and off using the trigger input.

Parameter | Typical Return
{NORMal|GATed}, default NORMal | GAT or NORM
Enable gated output: OUTP:MODE GAT
  • The effect of gating is independent of waveform phase or timing of any sort. When trigger input is asserted, the output signal is generated. When trigger is not asserted, the waveform continues to be generated internally, but it is not routed to channel output connector.
  • Gating does not change channel output termination (does not operate output on/off relay).

OUTPut[1|2]:POLarity {NORMal|INVerted}
OUTPut[1|2]:POLarity?

Inverts waveform relative to the offset voltage.

Parameter | Typical Return
{NORMal|INVerted}, default NORMal | NORM or INV
Set output polarity to INVerted: OUTP:POL INV
  • NORMal: waveform goes in one direction at the beginning of the cycle;

    INVerted: waveform goes in other.
  • As shown below, the waveform is inverted relative to the offset voltage. The offset voltage remains unchanged when the waveform is inverted.

    With and without offset voltage
  • The Sync signal associated with an inverted waveform is not inverted.

OUTPut:SYNC {ON|1|OFF|0}
OUTPut:SYNC?

Disables or enables the front panel Sync connector.

Parameter | Typical Return
{ON|1|OFF|0}, default ON | 0 (OFF) or 1 (ON)
Disable front panel Sync connector: OUTP:SYNC OFF
  • Disabling the Sync signal reduces output distortion at lower amplitudes.
  • For more details on the Sync signal for each waveform function, see Sync Output Signal.
  • When Sync is disabled, the output level on the Sync connector is a logic "low."
  • Inverting a waveform (OUTPut[1|2]:POLarity INV) does not invert the Sync signal.

OUTPut[1|2]:SYNC:MODE {NORMal|CARRier|MARKer}
OUTPut[1|2]:SYNC:MODE?

Specifies normal Sync behavior (NORMal), forces Sync to follow the carrier waveform (CARRier), or indicates marker position (MARKer).

Parameter | Typical Return
{NORMal|CARRier|MARKer}, default NORMal | NORM, CARR, or MARK
Set output sync mode to CARRier: OUTPut:SYNC:MODE CARR
  • The following table details the command's behavior:

    <mode> | Sync Behavior | Conditions
    NORMal | Sync follows envelope of burst signal. | When BURSt is on
    Sync follows envelope of sweep signal. | When SWEep is on
    Sync follows modulating signal. | When modulating and modulation source is internal
    Sync follows FUNC signal. | All other conditions
    CARRier | Sync follows current SOURce:MARKer:POINt setting. | When BURSt or SWEep is on and FUNC is ARB
    Sync follows FUNC signal while burst is on. | When BURSt is on and FUNC is not ARB
    Sync follows FUNC signal. | All other conditions
    MARKer Sync follows current SOURce:MARKer:POINt setting.

    When in CW mode and FUNC is ARB

    When modulating, modulation source is internal, and FUNC is ARB or <modulation>:INT:FUNC is ARB

    When modulating, modulation source is external, and FUNC is ARB

    Sync follows current SOURce:MARKer:CYCLe setting. | When BURST is on
    Sync follows current SOURce:MARKer:FREQuency setting. | When SWEEP is on
    Sync follows modulating signal. | When modulating, modulation source is not external, FUNC is not ARB, and INT:FUNC is not ARB
    Sync follows FUNC signal. | All other conditions

OUTPut[1|2]:SYNC:POLarity {NORMal|INVerted}
OUTPut[1|2]:SYNC:POLarity?

Sets the desired output polarity of the Sync output to trigger external equipment that may require falling or rising edge triggers.

Parameter | Typical Return
{NORMal|INVerted}, default NORMal | NORM or INV
Set the instrument's output sync connector to normal behavior: OUTP:SYNC:POL NORM
  • NORMal: voltage on Sync output connector is near zero, and rises when a Sync event occurs. Voltage stays high (approximately 3.3 V into high impedance) until Sync signal is de-asserted, when it falls back to near zero.
  • INVerted: opposite of NORMal.
  • The Sync signal may be derived from either channel in a two-channel instrument (OUTPut:SYNC:SOURce), and from several operating modes of the Sync signal (OUTPut:SYNC:MODE).

OUTPut:SYNC:SOURce {CH1|CH2}
OUTPut:SYNC:SOURce?

Sets the source for the Sync output connector.

Parameter | Typical Return
{CH1|CH2}, default CH1 | CH1 or CH2
Set sync source to channel 2: OUTP :SYNC:SOUR CH2

OUTPut:TRIGger {ON|1|OFF|0}
OUTPut:TRIGger?

Disables or enables the "trigger out" signal for sweep and burst modes.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Enable trigger out signal: OUTP:TRIG ON
  • When enabled, a pulse with the specified edge direction (OUTPut:TRIGger:SLOPe) is output from the rear-panel Ext Trig connector at the beginning of the burst or sweep.
  • In triggered burst mode:
  • With TRIGger[1|2]:SOURce IMMediate, instrument outputs square wave with 50% duty cycle from the Ext Trig connector. The waveform period equals the burst period (BURSt:INTernal:PERiod).
  • With TRIGger[1|2]:SOURce EXTernal or BURSt:MODE GAT, the instrument disables "trigger out." The rear-panel Ext Trig connector cannot be used for both operations simultaneously (an externally-triggered waveform uses the same connector to trigger sweep or burst).
  • With TRIGger[1|2]:SOURce BUS, the instrument outputs a pulse (>1 μs pulse width on the 33500 Series and 100 ns on the 33600 Series) from the Ext Trig connector at the beginning of each sweep or burst.
  • In frequency sweep mode:
  • With TRIGger[1|2]:SOURce IMMediate, the instrument outputs a square wave with a 50% duty cycle (the rising edge is the sweep trigger) from the Ext Trig connector. Waveform period equals to the sweep time (SWEep:TIME).
  • With TRIGger[1|2]:SOURce EXTernal, instrument disables the "trigger out" signal. The rear-panel Ext Trig connector cannot be used for both operations simultaneously (an externally-triggered sweep uses the same connector to trigger the sweep).
  • With TRIGger[1|2]:SOURce BUS, the instrument outputs a pulse (>1 μs pulse width on the 33500 Series and 100 ns on the 33600 Series) from the Ext Trig connector at the beginning of each sweep or burst.

OUTPut:TRIGger:SLOPe {POSitive|NEGative}
OUTPut:TRIGger:SLOPe?

Selects whether the instrument uses the rising edge or falling edge for the "trigger out" signal.

Parameter | Typical Return
{POSitive|NEGative}, default POSitive | POS or NEG
Set trigger slope to NEGative (falling edge): OUTP:TRIG:SLOP NEG
  • POSitive outputs a rising edge pulse; NEGative outputs a falling edge pulse.
  • When enabled using OUTPut:TRIGger, a pulse with the specified edge direction is output from the rear-panel Trig Out connector at the beginning of a sweep or burst.

OUTPut:TRIGger:SOURce {CH1|CH2}
OUTPut:TRIGger:SOURce?

Selects the source channel used by trigger output on a two-channel instrument. The source channel determines what output signal to generate on the trigger out connector.

Parameter | Typical Return
{CH1|CH2}, default CH1 | CH1 or CH2
Set output trigger source to CH2: OUTP:TRIG:SOUR CH2
  • In a two-channel instrument, either channel may be source channel for the trigger output, but channel 2 is not valid for dual arbitrary (IQ) waveforms.
OUTPut Subsystem


PHASe Subsystem

The PHASe subsystem allows you to adjust the waveform phase; this is useful in channel-to-channel and channel-to-Sync applications. This subsystem also allows you to use the 10 MHz Out and 10 MHz In rear-panel connectors to synchronize multiple instruments.

  • [SOURce[1|2]:]PHASe {<angle>|MINimum|MAXimum|DEFault} - sets phase offset of output waveform (not available for arbitrary waveforms or noise)
  • [SOURce[1|2]:]PHASe:ARBitrary {<angle>|MINimum|MAXimum} - sets the offset for the currently selected arbitrary waveform
  • [SOURce[1|2]:]PHASe:MODulation {<angle>|MINimum|MAXimum} - sets the phase of the internal modulation source when modulating by the internal source
  • [SOURce[1|2]:]PHASe:REFerence - sets new zero-phase reference point without changing instrument output
  • [SOURce[1|2]:]PHASe:SYNChronize - synchronizes phase of both internal channels on a two-channel instrument.
  • [SOURce[1|2]:]PHASe:UNLock:ERRor:STATe {ON|1|OFF|0} - specifies whether instrument generates an error upon losing phase-lock

[SOURce[1|2]:]PHASe {<angle>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PHASe? [{MINimum|MAXimum}]

Sets waveform's phase offset angle.

Parameter | Typical Return
-360 to +360 degrees, -2p to +2p radians, or -(period) to +(period), as specified by UNIT:ANGLe. Default 0. | +1.5000000000000E+01
Set channel 1 phase offset to 15 degrees: UNIT:ANGL DEG PHAS 15
  • Phase offset is independent of burst phase (BURSt:PHASe).
  • This command does not modify channel's primary phase generator; it simply adds phase offset.
  • This command also useful for modifying phase relationship between channels in a two-channel instrument and between the channel and its sync signal.
  • In a two-channel instrument, use PHASe:SYNChronize to synchronize the phases of the two internal channels. Each channel will retain its current phase offset, but the two channels will have a common reference point so the channel-to-channel phase difference will be known.
  • When synchronizing the phase of multiple instruments (ROSC commands), the phase command allows adjustment of the phase relationship between the instruments.

[SOURce[1|2]:]PHASe:ARBitrary {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]PHASe:ARBitrary?

Sets the offset for the currently selected arbitrary waveform in either degrees, radians, seconds or samples. The default units of the <angle> parameter are set by UNIT:ARBitrary:ANGLe.

This command applies only to the 33600 Series and arbitrary waveforms of at least 64 samples.

Parameter | Typical Return
From -360 to 360 (DEGree) From -2π to 2π (RADian) From -arbitrary waveform period to +arbitrary waveform period (SECond) From -(number of samples-1) to +(number of samples - 1) (SAMPle) | +3.000000000000000E+01
UNIT:ARB:ANGL DEG PHAS:ARB 30
  • This parameter affects the phase of the currently selected arbitrary waveform only. For other functions, see [SOURce[1|2]:]PHASe.
  • This parameter affects the phase of the arbitrary in normal continuous mode, modulation mode, and sweep mode. In burst mode, the arbitrary waveform phase is controlled by [SOURce[1|2]BURSt:PHASe.
  • When an arbitrary waveform is loaded into memory, its initial phase is zero; it does not inherit the phase of the currently selected arbitrary waveform. Each arbitrary waveform retains its own phase setting while in memory.
  • The phase of the arbitrary waveform is defined with respect to all the points in the arbitrary waveform record. For example, setting the arbitrary phase to 180 degrees on a 64-sample arbitrary waveform will rotate the play of the waveform such that it will begin (as indicated by the sync signal) with the 33rd sample and end with the 32nd.

[SOURce[1|2]:]PHASe:MODulation {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]PHASe:MODulation?

Sets the phase of the internal modulation source when modulating by the internal source with shape SIN, SQU, RAMP, NRAMp, or TRI. This command applies to the 33600 Series only.

This command applies only to the 33600 Series and arbitrary waveforms of at least 64 samples.

Parameter | Typical Return
From -360 to 360 (DEGree) From -2π to 2π (DEGree) From -arbitrary waveform period to +arbitrary waveform period (SECond) | +3.000000000000000E+01
Set the modulation phase to 30 degrees: UNIT:ANGL DEG PHAS:MOD 30
  • The default units of the <angle> parameter are set by UNIT:ANGLe.

[SOURce[1|2]:]PHASe:REFerence

Simultaneously removes the offset set by PHASe and adjusts the primary phase generator by an amount equivalent to the PHASe setting. This retains the phase relationship set with another instrument while realigning the sync signal with the output.

Parameter | Typical Return
(none) | (none)
Reset the zero-phase reference point for channel 1: PHAS:REF
  • The primary purpose of this command is to establish a zero-point between two connected instruments. For channel-to-channel operation on a two-channel instrument, use PHASe:SYNChronize.
  • Setting a new zero-phase reference point means that the value subsequently returned by a PHASe? query command is reset to "0", but the output waveform itself does not change.

[SOURce[1|2]:]PHASe:SYNChronize

Simultaneously resets all phase generators in the instrument, including the modulation phase generators, to establish a common, internal phase zero reference point. This command does not affect PHASe setting of either channel; it simply establishes phase difference between channels as the sum of SOUR1:PHAS and SOUR2:PHAS instead of an arbitrary amount.

Parameter | Typical Return
(none) | (none)
Reset all phase generators: PHAS:SYNC
  • SOURce1 and SOURce2 mean nothing for this command.
  • This command breaks the phase relation with another instrument, because it resets the phase generators.
  • In single channel instruments, this synchronizes the main channel with the internal modulation generator.

  • You can synchronize the phase between the primary signal and the SUM signal by sending [SOURce[1|2]:]PHASe:SYNChronize after setting the functions for the primary signal and the SUM signal. Otherwise, the phase between the two signals is arbitrary.

[SOURce[1|2]:]PHASe:UNLock:ERRor:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PHASe:UNLock:ERRor:STATe?

Enables or disables the generation of an error if the phase-lock is ever lost by the instrument timebase. The instrument uses one timebase for both channels.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Enable the generation of phase-lock errors: PHASe:UNLock:ERRor:STATe ON
  • SOURce1 and SOURce2 mean nothing for this command.
  • If the phase-lock is lost and the error is enabled, a "Reference phase-locked loop is unlocked" error is generated.
  • Volatile setting, lost on power cycle.
  • A faulty reference signal applied to the 10 MHz In connector may generate many error messages.


PM Subsystem

The PM subsystem allows you to phase modulate a waveform.

This summarizes the steps required to generate a phase modulated waveform.

  1. Configure carrier waveform: Use FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet to specify the carrier waveform's function, frequency, amplitude, and offset.
  2. Select modulation source (internal, external, CH1 or CH2): PM:SOURce. For an external modulation source, skip steps 3 and 4.
  3. Set modulating waveform: PM:INTernal:FUNCtion
  4. Set modulating frequency: PM:INTernal:FREQuency
  5. Set phase deviation: PM:DEViation
  6. Enable PM: PM:STATe:ON

The following code produces the oscilloscope image shown below.

FUNCtion SQU
FREQuency +1.0E+04
VOLTage +1.0
VOLTage:OFFset 0.0
PM:SOURce INT
PM:DEViation +90
PM:INTernal:FREQuency +2500
PM:INTernal:FUNCtion RAMP
PM:STATe 1
OUTPut1 1

[SOURce[1|2]:]PM:DEViation {<deviation in degrees>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PM:DEViation? [{MINimum|MAXimum}]

Sets the phase deviation in degrees. This value represents the peak variation in phase of the modulated waveform from the carrier waveform.

Parameter | Typical Return
0 to 360, default 180 | +9.000000000000000E+01
Set phase deviation to ± 90 degrees PM:DEV 90
  • With the External modulating source, deviation is controlled by the ±5 V signal level (optionally ±1 V on the 33600 Series) on the rear-panel Modulation In connector. For example, if you have set the frequency deviation to 180 degrees, then a +5 V signal level (optionally ±1 V on the 33600 Series) corresponds to a +180 degree phase deviation. Lower external signal levels produce less deviation, and negative signal levels produce negative deviation.

[SOURce[1|2]:]PM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PM:INTernal:FREQuency? [{MINimum|MAXimum}]

Sets the frequency of the modulating waveform. The waveform chosen as the modulating source will operate at that frequency, within the frequency limits of that waveform.

Parameter | Typical Return
1 μHz to the maximum allowed for the internal function. Default 10 Hz. | +1.000000000000000E‑06
Set modulating frequency to 10 kHz: PM:INT:FREQ 10000 Set modulating frequency to 1 μHz: PM:INT:FREQ MIN
  • When you select an arbitrary waveform as the modulating source, the frequency changes to the frequency of the arbitrary waveform, which is based on the sample rate and the number of points in the arbitrary waveform.
  • When using an arbitrary waveform for the modulating source, changing this parameter also changes the cached metadata representing the arbitrary waveform's sample rate. You can also change the modulating frequency of an arbitrary waveform with FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod, and FUNCtion:ARBitrary:SRATe. These commands and the modulation frequency command are directly coupled in order to keep the arbitrary waveform behaving exactly as it was last played. If you later turn modulation off and select that same arbitrary waveform as the current function, its sample rate (and corresponding frequency based upon the number of points) will be the same as it was when played as the modulation source.
  • If the internal function is TRIangle, UpRamp, or DnRamp, the maximum frequency is limited to 200 kHz on the 33500 Series or 800 kHz on the 33600 Series. If the internal function is PRBS, the frequency refers to bit rate and is limited as shown here.
  • This command should be used only with the internal modulation source (PM:SOURce INTernal).

[SOURce[1|2]:]PM:INTernal:FUNCtion <function>
[SOURce[1|2]:]PM:INTernal:FUNCtion?

Selects shape of modulating waveform.

Parameter | Typical Return
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, default SINusoid View internal function waveforms. | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS, or ARB
Select a sine wave as the modulating waveform: PM:INT:FUNC SIN
  • This command should be used only with the internal modulation source (PM:SOURce INTernal).
  • You can use noise as the modulating waveform, but you cannot use noise, pulse, or DC as the carrier.
PM Subsystem


PWM Subsystem

The PWM subsystem allows you to perform pulse width modulation (PWM) on a pulse waveform.

Example

This summarizes the steps required to generate a PWM waveform.

  1. Configure a pulse carrier waveform: Use FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet to specify the carrier waveform's function, frequency, amplitude, and offset.
  2. Select modulation source (internal, external, CH1, or CH2): PWM:SOURce. For an external modulation source, skip steps 3 and 4.
  3. Select modulating waveform: PWM:INTernal:FUNCtion
  4. Set modulating frequency: PWM:INTernal:FREQuency
  5. Set pulse width or duty cycle deviation: PWM:DEViation or PWM:DEViation:DCYCle
  6. Enable PWM: PWM:STATe:ON

The following code produces the oscilloscope image shown below.

FUNCtion PULS
FREQuency +5000.0
VOLTage +1.0
VOLTage:OFFS +0.0
PWM:DEViation +5.0E-05
PWM:DEViation:DCYCle +25.0
PWM:INTernal:FREQuency +1000.0
PWM:INTernal:FUNCtion RAMP
PWM:STATe 1
OUTPut1 1

[SOURce[1|2]:]PWM:DEViation {<deviation>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:DEViation? [{MINimum|MAXimum}]

Sets pulse width deviation; the ± variation in width (in seconds) from the pulse width of the carrier pulse waveform.

Parameter | Typical Return
0 to 500,000 (seconds); default 10 μs | +1.000000000000000E+00
Set pulse width deviation to 1 s: PWM:DEV 1 Set pulse width deviation to 0 s: PWM:DEV MIN
  • The deviation is a ± deviation, so if the pulse width is 10 ms and the deviation is 4 ms, the width can vary from 6 to 14 ms.
  • The pulse width deviation cannot exceed the current pulse width, and is also limited by the minimum pulse width (Wmin):

Width Deviation < Pulse Width – Wmin

and

Width Deviation < Period – Pulse Width – Wmin

  • The pulse width deviation is limited by the current edge time setting.

Width Deviation < Pulse Width – (0.8 x Leading Edge Time) – (0.8 x Trailing Edge Time)

and

Width Deviation < Period – Pulse Width – (0.8 x Leading Edge Time) – (0.8 x Trailing Edge Time)

  • If you select the External modulating source (PWM:SOURce EXTernal), the deviation is controlled by the ±5 V signal level (optionally ±1 V on the 33600 Series) present on the rear-panel Modulation In connector. For example, if you have set the width deviation to 10 μs, then a +5 V signal level (optionally +1 V on the 33600 Series) corresponds to a 10 μs deviation. Lower external signal levels produce less deviation. Negative signal levels produce negative deviation.

[SOURce[1|2]:]PWM:DEViation:DCYCle {<deviation_in_pct>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:DEViation:DCYCle? [{MINimum|MAXimum}]

Sets duty cycle deviation in percent of period. This is the peak variation in duty cycle from the underlying pulse waveform. For example, if duty cycle is 10% and duty cycle deviation is 5%, the duty cycle of the modulated waveform will vary from 5% to 15%.

Parameter | Typical Return
Duty cycle in percent of period, from 0 to 50; default 1 | +5.000000000000000E+00
Set pulse width deviation to 5%: PWM:DEV:DCYC 5
  • Duty cycle deviation cannot exceed pulse duty cycle.
  • Duty cycle deviation also limited by minimum pulse width (Wmin):

Duty Cycle Deviation < Duty Cycle – 100 x Wmin ÷ Period

and

Duty Cycle Deviation < 100 – Duty Cycle – 100 x Wmin ÷ Period

where Wmin = 16 ns on the 33500 Series and 5 ns up to 4 Vpp or 8 ns up to 10 Vpp on the 33600 Series.

  • Duty cycle deviation limited by edge time.

Duty Cycle Dev < Duty Cycle – (80 x Leading Edge Time) ÷ Period – (80 x Trailing Edge Time) ÷ Period

and

Duty Cycle Dev < 100 – Duty Cycle – (80 x Leading Edge Time) ÷ Period – (80 x Trailing Edge Time) ÷ Period

  • With PWM:SOURce EXTernal, deviation is controlled by the ±5 V signal level (optionally ±1 V on the 33600 Series) on rear-panel Modulation In connector. For example, with duty cycle deviation of 5 percent, a +5 V signal level (optionally +1 V on the 33600 Series) corresponds to 5% deviation, an additional 5% of period added to the pulse duty cycle. Lower external signal levels produce less deviation, and negative signal levels reduce the duty cycle.

[SOURce[1|2]:]PWM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:INTernal:FREQuency? [{MINimum|MAXimum}]

Selects frequency at which output pulse width shifts through its pulse width deviation. The waveform used as the modulating source will operate at that frequency, within frequency limits of that waveform.

Parameter | Typical Return
1 μHz to the maximum allowed for the internal function. Default 10 Hz | +1.000000000000000E+02
Set internal PWM frequency to 100 Hz: PWM:INT:FREQ 100
  • When you select an arbitrary waveform as the modulating source, the frequency changes to the frequency of the arbitrary waveform, which is based on the sample rate and the number of points in the arbitrary waveform.
  • When using an arbitrary waveform for the modulating source, changing this parameter also changes the cached metadata representing the arbitrary waveform's sample rate. You can also change the modulating frequency of an arbitrary waveform with FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod, and FUNCtion:ARBitrary:SRATe. These commands and the modulation frequency command are directly coupled in order to keep the arbitrary waveform behaving exactly as it was last played. If you later turn modulation off and select that same arbitrary waveform as the current function, its sample rate (and corresponding frequency based upon the number of points) will be the same as it was when played as the modulation source.
  • If the internal function is TRIangle, UpRamp, or DnRamp, the maximum frequency is limited to 200 kHz on the 33500 Series or 800 kHz on the 33600 Series. If the internal function is PRBS, the frequency refers to bit rate and is limited as shown here.
  • This command should be used only with the internal modulation source (PWM:SOURce INTernal).

[SOURce[1|2]:]PWM:INTernal:FUNCtion <function>
[SOURce[1|2]:]PWM:INTernal:FUNCtion?

Selects shape of the internal modulating waveform.

Parameter | Typical Return
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, default SINusoid View internal function waveforms. | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS, or ARB
Select a sine wave as the modulating waveform shape: PWM:INT:FUNC SIN
  • This command should be used only with the internal modulation source (PWM:SOURce INTernal).
PWM Subsystem


RATE Subsystem

The RATE subsystem allows you to couple the outputs' sample rates on a two-channel instrument by specifying the following items:

  • [SOURce[1|2]:]RATE:COUPle[:STATe] {ON|1|OFF|0}
  • [SOURce[1|2]:]RATE:COUPle:MODE {OFFSet|RATio}
  • [SOURce[1|2]:]RATE:COUPle:OFFSet {<sample_rate>|MINimum|MAXimum|DEFault}
  • [SOURce[1|2]:]RATe:COUPle:RATio {<ratio>|MINimum|MAXimum}

[SOURce[1|2]:]RATE:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]RATE:COUPle[:STATe]?

Enables or disables sample rate coupling between channels, or allows one-time copying of one channel's sample rate into the other channel.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Turn on sample rate coupled state: RATE:COUP ON
  • The ON value starts sample rate coupling in the mode specified by RATE:COUPle:MODE.
  • If the current offset or ratio, combined with the current sample rate settings, would cause either sample rate to exceed instrument specifications, the instrument will generate an error and the exceeded sample rate will clip at its maximum or minimum value.
  • If setting mode to RATIO and setting RATIO to 1.0 still exceeds the specifications of either channel, an error message will be generated and the RATE:COUPle[:STATe] will not be turned ON.
  • Both channels must be configured for FUNCtion ARB in order to enable sample rate coupling.

[SOURce[1|2]:]RATE:COUPle:MODE {OFFSet|RATio}
[SOURce[1|2]:]RATE:COUPle:MODE?

Sets type of sample rate coupling to either a constant sample rate offset (OFFSet) or a constant ratio (RATio) between the channels' sample rates.

Parameter | Typical Return
{OFFSet|RATio}, default RATio | OFFS or RAT
Set the sample rate coupling mode to OFFSet. RATE:COUP:MODE OFFSet
  • The default RATio is 1.
  • The default sample rate coupling is OFF.
  • The SOURce[1|2] keyword is ignored; the setting applies to both channels.

[SOURce[1|2]:]RATE:COUPle:OFFSet {<sample_rate>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]RATE:COUPle:OFFSet?

Sets sample rate offset when a two-channel instrument is in sample rate coupled mode OFFSet.

Parameter | Typical Return
Valid values depend on FUNCtion:ARBitrary:FILTer setting. For NORMal and STEP, the range is between ±250 MSa/s (33500 Series) or ±1 GSa/s (33600 Series). For OFF, the range is between ±62.5 MSa/s (33500 Series) or ±250 MSa/s (33600 Series). In any case, default is 0. | +8.000000000000000E+02
Set sample rate offset of channel 2 to 10.3 kSa/s higher than sample rate of channel 1. RATE:COUPle:OFFSet 10300 Sets the sample rate offset of channel 1 to 45 kSa/s below the sample rate of channel 2. SOUR2:RATE:COUP:OFFS -45000
  • When specifying OFFSet or RATio, the SOURce channel (SOURce1 or SOURce2) is used as the reference channel and the offset or ratio is applied to the other channel. For example, suppose RATE:COUPle[:STATe] is ON and RATE:COUPle:MODE is OFFSet. Furthermore, suppose channel 1 is operating at 2 kSa/s, and channel 2 is at 10 kSa/s. The command SOUR1:RATE:COUP:OFFS 2.5 causes Channel 1 to remain at 2 Sa/s, and Channel 2 to be set to 4.5 Sa/s. As one channel's sample rate changes, the other channel's sample rate changes to maintain the specified coupling.
  • If the sample rate coupling would cause either channel to exceed sample rate specifications for the present functions, the command will result in an error, and the sample rate will be set to its maximum or minimum limit for the channel.

[SOURce[1|2]:]RATe:COUPle:RATio {<ratio>|MINimum|MAXimum}
[SOURce[1|2]:]RATe:COUPle:RATio? [{MINimum|MAXimum}]

Sets offset ratio between channel sample rates when a two-channel instrument is in sample rate coupled mode RATio.

Parameter | Typical Return
0.001 to 1000, default 1 | +7.500000000000000E-1
Set channel 2's sample rate to twice that of channel 1. SOUR1:RATE:COUP:RATio 2 Set channel 1's sample rate to 3.14 times that of channel 2. SOUR2:RATE:COUPle:RAT 3.14
  • When specifying OFFSet or RATio, the SOURce channel (SOURce1 or SOURce2) is used as the reference channel and the offset or ratio is applied to the other channel. For example, suppose the instrument is coupled in RATio mode. Furthermore, suppose channel 1 is operating at 2 kSa/s, and channel 2 is at 10 kSa/s. The command SOUR1:RAT:COUP:RAT 2.5 causes Channel 1 to remain at 2 kSa/s, and Channel 2 to be set to 5 kSa/s. As one channel's sample rate changes, the other channel's sample rate changes to maintain the specified coupling.
  • If the sample rate coupling would cause either channel to exceed sample rate specifications for the present functions, the command will result in an error, and the sample rate will be set to its maximum or minimum limit for the channel.


ROSCillator Subsystem

The external 10 MHz reference input BNC connector, both the shell and center pin, on the rear panel of the instrument is isolated up to ±42 Vpk from chassis. The shell of this BNC connector is isolated from the rest of the instrument. Internal circuitry will attempt to keep the isolated voltage to within ±42 Vpk to chassis. Attempts to float this input beyond ±42 Vpk from chassis may destroy the instrument and cause a hazard that could result in personal injury or death.

The instrument 10 MHz output is chassis referenced.

The ROSCillator subsystem controls use of the 10 MHz reference oscillator and external reference oscillator input. The reference oscillator is the primary clock for all waveform synthesis. All waveforms are phase-locked to the reference oscillator, which therefore controls output signal frequency and phase.

  • ROSCillator:SOURce {INTernal|EXTernal} - selects internal or external reference oscillator source
  • ROSCillator:SOURce:AUTO {ON|OFF} - disables or enables automatic selection of reference oscillator signal source
  • ROSCillator:SOURce:CURRent? - returns INT or EXT to indicate current reference oscillator source

ROSC:SOURce sets ROSCillator:SOURce:AUTO to OFF, and ROSCillator:SOURce:AUTO ON overrides ROSC:SOURce. The more recent command (of these two) takes priority.

ROSCillator:SOURce INTernal uses the instrument's internal oscillator as the reference oscillator. This may be either standard Temperature Compensated Crystal Oscillator (TCXO) or the optional Ovenized Crystal Oscillator (OCXO).

See *OPT? for details on determining whether OCXO is installed. If an external 10 MHz reference signal is on the rear-panel 10 MHz In connector, the instrument uses the external signal. An icon also appears at the top right corner of the display to indicate the reference source change.

ROSCillator:SOURce {INTernal|EXTernal}
ROSCillator:SOURce?

Selects the source for the reference oscillator used as the frequency/phase reference for signals generated by the instrument.

Parameter | Typical Return
{INTernal|EXTernal}, default INT | INT or EXT
Use the external reference oscillator source: ROSC:SOUR EXT
  • EXTernal: instrument uses signal on the rear-panel 10 MHz In connector as reference, and generates an error if this signal is absent or the instrument cannot lock to it. In such error cases, instrument output continues, but the frequency will be unstable.
  • INTernal: instrument uses the internal reference oscillator and ignores the signal at the 10 MHz In connector.

ROSCillator:SOURce:AUTO {ON|OFF}
ROSCillator:SOURce:AUTO?

Disables or enables automatic selection of the reference oscillator.

Parameter | Typical Return
{ON|OFF}, default ON | ON or OFF
Select reference source automatically: ROSC:SOUR:AUTO ON
  • ON: the instrument preferentially selects a 10 MHz signal from the rear-panel 10 MHz In connector.
  • OFF: the instrument selects the reference oscillator based on the ROSC:SOURce setting.

ROSCillator:SOURce:CURRent?

Indicates which reference oscillator signal is currently in use when ROSC:SOURce:AUTO is ON.

Parameter | Typical Return
(none) | INT (internal) or EXT (10 MHz connector on rear panel)
Determine reference signal source: ROSC:SOUR:CURR?
  • INT refers to the basic internal TCXO or the optional ovenized OCXO oscillator, whichever is installed.


SOURce Subsystem

The SOURce keyword is optional in many commands that set parameters for a source or output channel.

Example

The SOURce keyword and the channel number are optional in the [SOURce[1|2]:]AM[:DEPTh]? query, and if it is omitted, the source defaults to channel 1. The following table shows how various forms of the query are interpreted.

Parameter | Typical Return
AM:DEPTh? | returns the modulation depth of channel 1
SOUR1:AM:DEPTh? | returns the modulation depth of channel 1
SOUR2:AM:DEPTh? | returns the modulation depth of channel 2 (two-channel instruments only)

Subsystems Using the Optional SOURce Keyword

Because SOURce subsystem commands are often used without the SOURce keyword, these commands are listed by their individual subsystems, below:

AM

APPLy

BPSK

BURSt

DATA

FM

FREQuency

FSKey

FUNCtion

LIST

MARKer

PHASe

PM

PWM

ROSCillator

SUM

SWEep

VOLTage

Commands Using the Optional SOURce Keyword

The following commands, which are not part of any subsystem, also have the optional SOURce keyword:

COMBine:FEED

TRACk


STATus Subsystem Introduction

The instrument's SCPI status system records various instrument conditions and states in several register groups.

In this subsystem, an event is something that occurred, even though it may not still be occurring. A condition is something that is currently present. A condition will appear in the event register, but the event register is read destructive; it is cleared (set to 0) when read.

The STATus commands manipulate bits in two of the enable registers. You can:

  • Enable bits in the Questionable Data enable register (STATus:QUEStionable:ENABle <enable_value>). Query: STATus:QUEStionable:ENABle?
  • Enable bits in the Operation enable register (STATus:OPERation:ENABle <enable_value>). Query: STATus:OPERation:ENABle?
  • Clear all bits in the Questionable Data enable register and the Standard Operation enable register (STATus:PRESet).

The STATus queries accesses information about the status bits in the Questionable Data registers, including:

  • The binary-weighted sum of all bits enabled in the Questionable Data condition register (STATus:QUEStionable:CONDition?)
  • The binary-weighted sum of all bits enabled in the Questionable Data event register (STATus:QUEStionable[:EVENt]?)
  • The binary-weighted sum of all bits enabled in the Questionable Data enable register (STATus:QUEStionable:ENABle <enable_value>).

The STATus queries also allow you to access information about the status bits in the Operation registers, including:

  • The binary-weighted sum of all bits enabled in the Operation condition register (STATus:OPERation:CONDition?).
  • The binary-weighted sum of all bits enabled in the Operation event register (STATus:OPERation[:EVENt]?).

Standard Operation Register Group

The following table describes the Standard Operation Register group.

Bit Number | Bit Name | Decimal Value | Definition
0 | Calibrating | 1 | The instrument is performing a calibration.
1 | Self-test | 2 | A self-test is running.
2 | (Reserved) | 4 | (Reserved for future use)
3 | Channel 1 Initiated | 8 | Channel is initiated and outputting the desired waveform. In INIT[1|2]:CONT OFF, this bit is set after receiving an INIT and not cleared until channel goes to IDLE ( trigger count satisfied and not busy.) This bit is 0 if the channel is in INIT[1|2]:CONT ON mode.
4 | Channel 2 Initiated | 16
5 | Waiting for Trigger, Channel 1 | 32 | Instrument is waiting for a trigger. In INIT[1|2]:CONT OFF, this bit is set after receiving an INIT and while waiting for a trigger. It is cleared after receiving the trigger. This bit is 0 if the channel is in INIT[1|2]:CONT ON mode.
6 | Waiting for Trigger, Channel 2 | 64
7 | (Reserved) | 128 | (Reserved for future use)
8 | Configuration Changed Event | 256 | This bit is always 0 in the condition register, as it reflects an event, not a condition.
9 | (Reserved) | 512 | (Reserved for future use)
10 | Instrument Locked | 1024 | If a remote interface (USB or LAN) has a lock (SYSTem:LOCK:REQuest?), this bit will be set. When a remote interface releases the lock (SYSTem:LOCK:RELease), this bit will be cleared.
11 | (Reserved) | 2048 | (Reserved for future use)
12 | (Reserved) | 4096 | (Reserved for future use)
13 | Global Error | 8192 | This is set if any remote interface has an error in its error queue, and cleared otherwise.
14-15 | (Reserved) | 16,384 - 32,768 | (Reserved for future use)

Questionable Data Register Group

The following table describes the Questionable Data Register group.

Bit Number | Bit Name | Decimal Value | Definition
0 | Channel 1 Voltage Overload | 1 | Voltage overload on channel 1 output connector. The output has been disabled.
1 | Channel 2 Voltage Overload | 2 | Voltage overload on channel 2 output connector. The output has been disabled.
2 | (Reserved) | 4 | (Reserved for future use)
3 | (Reserved) | 8 | (Reserved for future use)
4 | (Reserved) | 16 | (Reserved for future use)
5 | Loop Unlocked | 32 | Function generator has lost phase lock. Frequency accuracy will be affected.
6 | (Reserved) | 64 | (Reserved for future use)
7 | (Reserved) | 128 | (Reserved for future use)
8 | Calibration Error | 256 | Error occurred during calibration, calibration is unsecured, or calibration memory has been lost
9 | External Reference | 512 | External timebase has been detected.
10-15 | (Reserved) | 1024 - 32,768 | (Reserved for future use)

STATus:OPERation:CONDition?

Queries the condition register for the Standard Operation Register group. Register is read-only; bits not cleared when read.

Parameter | Typical Return
(none) | +32
Read the condition register (bit 5 is set): STAT:OPER:COND?
  • The condition register bits reflect the current condition. If a condition goes away, the corresponding bit is cleared .
  • *RST clears this register, other than those bits where the condition still exists after *RST.
  • The command reads the condition register and returns a decimal value equal to the binary-weighted sum of all bits set in the register. For example, if bit 5 (decimal value = 32) and bit 9 (decimal value = 512) are set, the command will return +544.

STATus:OPERation:ENABle <enable_value>
STATus:OPERation:ENABle?

Enables bits in the enable register for the Standard Operation Register group. The selected bits are then reported to the Status Byte as the standard operation summary bit.

Parameter | Typical Return
Sum of the bits' decimal values in the register. | +256
Enable bit 8 (decimal value 256) in the enable register: STAT:OPER:ENAB 256
  • Use <enable_value> to specify which bits are reported to the Status Byte. The specified value corresponds to the binary-weighted sum of the register bits to enable. For example, to enable bit 5 (value 32) and bit 9 (value 512), the decimal value would be 544.
  • *CLS does not clear the enable register, but does clear the event register.
  • This register is cleared at power-on unless *PSC is set to 0.

See Also

*STB?

STATus:OPERation[:EVENt]?

Queries the event register for the Standard Operation Register group. This is a read-only register; the bits are cleared when you read the register.

Parameter | Typical Return
(none) | +32
Read event register: STAT:OPER:EVEN?
  • A set bit remains set until cleared by reading the event register or *CLS.
  • *RST does not affect this register.
  • Query reads the event register and returns a decimal value equal to the binary-weighted sum of all bits set in the register. For example, if bit 5 ( value 32) and bit 9 (value 512) are set, the command returns +544.

STATus:PRESet

Clears Questionable Data enable register and Standard Operation enable register.

Parameter | Typical Return
(none) | (none)
Clear enable register bits: STAT:PRES

STATus:QUEStionable:CONDition?

Queries the condition register for the Questionable Data Register group.

Parameter | Typical Return
(none) | +512
Read the condition register (bit 9 is set): STAT:QUES:COND?
  • The Questionable Data register group provides information about the instrument's quality or integrity.
  • Any or all conditions can be reported to the Questionable Data summary bit through the enable register.
  • Register is read-only; bits not cleared when read.
  • The condition register bits reflect the current condition. If a condition goes away, the corresponding bit is cleared.
  • *RST clears the condition register.
  • The query reads the condition register and returns a decimal value equal to the binary-weighted sum of all bits set in the register. For example, if bit 12 (decimal value = 4096) is set, the query returns "+4096".

STATus:QUEStionable:ENABle <enable_value>
STATus:QUEStionable:ENABle?

Enables bits in the enable register for the Questionable Data Register group. The selected bits are then reported to the Status Byte.

Parameter | Typical Return
Decimal value equal to the sum of the bit decimal values in the register. | +512
Enable bit 9 (value 512) in the enable register: STAT:QUES:ENAB 512
  • Use <enable_value> to specify which bits are reported to the Status Byte. The specified value corresponds to the binary-weighted sum of the register bits to enable. For example, to enable bit 5 (value 32) and bit 9 (value 512), the decimal value would be 544.
  • Enable register cleared by:
    • STATus:Questionable:ENABle 0
    • STATus:PRESet
    • Power cycle (unless *PSC is set to 0)
  • *CLS does not clear enable register but it does clear event register.
  • *RST does not affect this register.
  • The Query reads the enable register and returns a decimal value equal to the binary-weighted sum of all bits set in the register. For example, if bit 0 (value 1) and bit 1 ( value 2) are enabled, the query returns +3.

STATus:QUEStionable[:EVENt]?

Queries the event register for the Questionable Data Register group. This is a read-only register; the bits are cleared when you read the register.

Parameter | Typical Return
(none) | +512
Read the event register (bit 9 set): STAT:QUES?
  • Once a bit is set, it remains set until cleared by this query or *CLS.
  • *RST, STATus:PRESet, and *PSC have no effect on this register.
  • Query reads the event register and returns a decimal value equal to the binary-weighted sum of all bits set in the register. For example, if bit 1 (value 2) and bit 9 ( value 512) are set, the query returns "+514".


SUM Subsystem Introduction

The SUM subsystem adds a modulation source signal to a channel's primary signal. This allows you to generate a two-tone signal on one channel, or to add noise to a primary signal. The SUM function uses the same secondary sources as used by the modulation subsystems.

Only one modulation or SUM function may be active on a channel at a time, so you cannot add noise to an FM signal using only one channel. For this operation, use COMBine:FEED, which combines both channels of a two-channel instrument into one channel output connector.

When signals are SUMmed:

  • Their peak amplitude may not exceed the instrument's output rating.
  • No other internal or external modulation is possible on that channel.

You can synchronize the phase between the primary signal and the SUM signal by sending [SOURce[1|2]:]PHASe:SYNChronize after setting the functions for the primary signal and the SUM signal. Otherwise, the phase between the two signals is arbitrary.

When the source is the other channel, there is a noticeable delay (as much as 350 ns) relative to the carrier even after PHAS:SYNC. Use the Combine feature for the other channel whenever possible.

Example

To create a SUM waveform:

  1. Configure carrier waveform: Use FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet to specify the carrier waveform's function, frequency, amplitude, and offset.
  2. Select the summing source: The instrument accepts an internal or external modulation source (EXT, Channel 1, or Channel 2). Select the modulation source with SUM:SOURce. For an external modulation source, skip steps 3 and 4.
  3. Configure the summing waveform: Use FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet commands to configure the summing waveform.
  4. Set the amplitude percentage to sum: SUM:AMPLitude.
  5. Enable SUM Modulation: SUM:STATe:ON.
  6. If using the other channel of a two-channel instrument, synchronize the channels: PHASe:SYNChronize.

The following code produces the oscilloscope image shown below.

SOURce1:FUNCtion RAMP
SOURce1:FREQuency +2000.0
SOURce1:VOLTage +1.0
SOURce1:VOLTage:OFFS +0.0
SOURce1:FUNCtion:RAMP:SYMMetry +50.0
SOURce2:FUNCtion SQU
SOURce2:FREQuency +4000.0
SOURce2:VOLTage +1.0
SOURce2:VOLTage:OFFS +0.0
SOURce1:SUM:AMPLitude +50.0
SOURce1:SUM:SOURce CH2
SOURce1:SUM:STATe 1
SOURce1:PHASe:SYNC
OUTPut1 1
OUTPut2 1

[SOURce[1|2]:]SUM:AMPLitude {<amplitude>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SUM:AMPLitude? [{MINimum|MAXimum}]

Sets internal modulation depth (or "percent modulation") in percent.

Parameter | Typical Return
Desired SUM signal amplitude in percent of carrier amplitude, from 0 to 100; default 0.1 | +3.200000000000000E+00
Set the internal SUM signal amplitude to 1.0% of the signal amplitude: SUM:AMPL 1.0 PHAS:SYNC Set the internal sum signal amplitude on channel 2 to 0.15% of the signal amplitude: SOUR2:SUM:AMPL 0.15

  • You can synchronize the phase between the primary signal and the SUM signal by sending [SOURce[1|2]:]PHASe:SYNChronize after setting the functions for the primary signal and the SUM signal. Otherwise, the phase between the two signals is arbitrary.

  • Summed output cannot exceed ±5 V peak output (into a 50 Ω load).
  • If you select the External SUM source (SUM:SOURce EXTernal), the carrier waveform is added to the external waveform. The summing signal is the ±5 V signal level (optionally ±1 V on the 33600 Series) on the rear-panel Modulation In connector. For example, if you have the carrier amplitude of a sine wave set to 4 Vpp and set the Sum Amplitude to 20% (resulting in a maximum sum contribution of 800 mVpp) using SUM:AMPLitude, then when the EXT signal is at +5 V (optionally +1 V on the 33600 Series), the additive signal output will be at the maximum amplitude of 4.8 Vpp. When the modulating signal is at -5 V (optionally -1 V on the 33600 Series), the additive signal will be at the minimum amplitude of -4.8 Vpp. A modulation input of 0 V would result in a signal equal to the carrier amplitude.

[SOURce[1|2]:]SUM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SUM:INTernal:FREQuency? [{MINimum|MAXimum}]

Sets the frequency of the summing waveform when internal sum source is selected (SUM:SOURce:INTernal). The modulating source waveform operates at that frequency, within the frequency limits of that waveform.

Parameter | Typical Return
1 μHz to the maximum allowed for the internal function. Default 100 Hz | +1.000000000000000E‑06
The following command sets the summing frequency to 10 kHz on Channel 2: SOUR2:SUM:INT:FREQ 10000 SOUR2:PHAS:SYNC The following command sets the summing frequency to 1 μHz on Channel 1: SUM:INT:FREQ MIN PHAS:SYNC

  • You can synchronize the phase between the primary signal and the SUM signal by sending [SOURce[1|2]:]PHASe:SYNChronize after setting the functions for the primary signal and the SUM signal. Otherwise, the phase between the two signals is arbitrary.

  • When you select an arbitrary waveform as the modulating source, the frequency changes to the frequency of the arbitrary waveform, which is based on the sample rate and the number of points in the arbitrary waveform.
  • When using an arbitrary waveform for the modulating source, changing this parameter also changes the cached metadata representing the arbitrary waveform's sample rate. You can also change the modulating frequency of an arbitrary waveform with FUNCtion:ARBitrary:FREQuency, FUNCtion:ARBitrary:PERiod, and FUNCtion:ARBitrary:SRATe. These commands and the modulation frequency command are directly coupled in order to keep the arbitrary waveform behaving exactly as it was last played. If you later turn modulation off and select that same arbitrary waveform as the current function, its sample rate (and corresponding frequency based upon the number of points) will be the same as it was when played as the modulation source.
  • If the internal function is TRIangle, UpRamp, or DnRamp, the maximum frequency is limited to 200 kHz on the 33500 Series or 800 kHz on the 33600 Series. If the internal function is PRBS, the frequency refers to bit rate and is limited as shown here.

[SOURce[1|2]:]SUM:INTernal:FUNCtion <function>
[SOURce[1|2]:]SUM:INTernal:FUNCtion?

Selects the summing waveform (the waveform added to the primary waveform).

Parameter | Typical Return
{SINusoid|SQUare|RAMP|NRAMp|TRIangle|NOISe|PRBS|ARB}, default SINusoid | SIN, SQU, RAMP, NRAM, TRI, NOIS, PRBS, or ARB
Select a sine wave as the summing waveform shape for channel 2: SOUR2:SUM:INT:FUNC SIN

  • You can synchronize the phase between the primary signal and the SUM signal by sending [SOURce[1|2]:]PHASe:SYNChronize after setting the functions for the primary signal and the SUM signal. Otherwise, the phase between the two signals is arbitrary.

  • This command is applicable only with internal sum source (SUM:SOURce INTernal).
  • You cannot use SUM when DC is the carrier.
  • An arbitrary waveform may not simultaneously be a carrier and a sum waveform.

The following table shows which carriers can be associated with which internal functions.

Modulating Signal
Carrier | Sine | Square | Tri / Ramp | Noise | PRBS | Arb | External
Sine | • | • | • | • | • | • | •
Square/Pulse | • | • | • | • | • | • | •
Ramp/Triangle | • | • | • | • | • | • | •
Gaussian Noise | • | • | • |  | • | • | •
PRBS | • | • | • | • |  | • | •
Arbitrary | • | • | • | • | • |  | •
Sequenced Arbitrary | • | • | • | • | • |  | •

[SOURce[1|2]:]SUM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]SUM:SOURce?

Selects source of summing signal.

Parameter | Typical Return
{INTernal|EXTernal|CH1|CH2}, default INTernal | INT, EXT, CH1, or CH2
Set the sum source to EXTernal: SUM:SOUR EXT

  • You can synchronize the phase between the primary signal and the SUM signal by sending [SOURce[1|2]:]PHASe:SYNChronize after setting the functions for the primary signal and the SUM signal. Otherwise, the phase between the two signals is arbitrary.

  • SUM:SOURce EXTernal: carrier waveform is summed with external waveform. The amplitude and polarity of the sum signal is determined by the ±5 V signal level on the rear-panel Modulation In connector (optionally ±1 V on the 33600 Series). For example, if you have set the SUM Amplitude to 2.0 Vpp using SUM:AMPLitude, then when EXT signal is at +5 V, the sum signal will be at 2 Vpp. When the modulating signal is at -5 V, the sum signal will be at full amplitude and opposite polarity.

[SOURce[1|2]:]SUM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]SUM:STATe?

Disables or enables SUM function.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Enable SUM SUM:STAT ON

  • You can synchronize the phase between the primary signal and the SUM signal by sending [SOURce[1|2]:]PHASe:SYNChronize after setting the functions for the primary signal and the SUM signal. Otherwise, the phase between the two signals is arbitrary.

  • To avoid multiple waveform changes, enable SUM after you have configured the other sum parameters.
  • Only one modulation mode may be enabled at a time.
  • The instrument will not allow SUM to be enabled when sweep or burst is enabled. When you enable SUM, the sweep or burst mode is turned off.
  • With SUM:STATe ON, the sum amplitude plus the carrier amplitude may not exceed either the programmed limits or the instrument's output rating. If setting SUM:STATe ON would cause either the output rating or the limits to be exceeded, SUM:STATe will be set OFF and the instrument will report a settings conflict error.


SWEep Subsystem Introduction

To generate a frequency sweep:

  1. Select the waveform shape, amplitude and offset: Use APPLy or the equivalent FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet commands to select the function, frequency, amplitude, and offset. You can select a sine, square, ramp, pulse, or arbitrary waveform (noise, PRBS, and DC are not allowed).
  2. Select sweep's frequency boundaries: FREQuency:STARt and FREQuency:STOP , or FREQuency:CENTer and FREQuency:SPAN
  3. Select linear or logarithmic sweep mode: SWEep:SPACing
  4. Set sweep time: SWEep:TIME
  5. Set sweep hold and return times: SWEep:HTIMe and SWEep:RTIMe
  6. Select sweep trigger source: TRIGger[1|2]:SOURce
  7. Set the marker frequency (optional): MARKer:FREQuency
  8. Enable sweep: SWEep:STATe ON

The following code produces the waveform shown below.

SOURce1:FUNCtion SINE
SOURce1:FREQuency +2.0E+03
SOURce1:FREQuency:STARt +2.0E+03
SOURce1:FREQuency:STOP +6.0E+03
SOURce1:VOLTage +1.0
SOURce1:VOLTage:OFFS +0.0
SOURce1:SWEep:TIME +5.0E-03
TRIGger1:SOURce IMM
SOURce1:FREQuency:MODE SWE
OUTPut1 1

[SOURce[1|2]:]SWEep:HTIMe {<hold_time>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:HTIMe? [{MINimum|MAXimum}]

Sets number of seconds the sweep holds (pauses) at the stop frequency before returning to the start frequency.

Parameter | Typical Return
0 to 3600, default 0 | +3.400000000000000E+00
Set sweep hold time to 3.4 seconds: SWE:HTIM 3.4

[SOURce[1|2]:]SWEep:RTIMe {<return_time>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:RTIMe? [{MINimum|MAXimum}]

Sets number of seconds the sweep takes to return from stop frequency to start frequency.

Parameter | Typical Return
0 to 3600, default 0 | +5.600000000000000E+00
Set sweep return time to 5.6 s: SWE:RTIM 5.6
  • The return sweep is always a linear sweep, regardless of the setting of SWEep:SPACing.

[SOURce[1|2]:]SWEep:SPACing {LINear|LOGarithmic}
[SOURce[1|2]:]SWEep:SPACing?

Selects linear or logarithmic spacing for sweep.

Parameter | Typical Return
{LINear|LOGarithmic}, default LIN | LIN or LOG
Set logarithmic sweep spacing: SWE:SPAC LIN
  • LINear: output frequency varies linearly (from start frequency to stop frequency) during sweep.
  • LOGarithmic: output frequency varies logarithmically (from start frequency to stop frequency) during sweep.

[SOURce[1|2]:]SWEep:STATe {ON|1|OFF|0}
[SOURce[1|2]:]SWEep:STATe?

Enables or disables the sweep.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Enable sweep: SWE:STAT ON

[SOURce[1|2]:]SWEep:TIME {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:TIME? [{MINimum|MAXimum}]

Sets time (seconds) to sweep from start frequency to stop frequency.

Parameter | Typical Return
1 ms to 250,000 s for linear sweep, up to 500 s for logarithmic sweep; default 1 s | +2.500000000000000E+01
Set sweep time to 25 s: SWE:TIME 25
  • The number of discrete frequency points in the sweep is calculated based on the sweep time.
SWEep Subsystem Introduction


SYSTem Subsystem Introduction

SYSTem Subsystem

The SYSTem subsystem manages instrument state storage, power-down recall, error conditions, self test, front panel display control and remote interface configuration.

Note

The instrument uses LAN port 5024 for SCPI Telnet sessions, and port 5025 for SCPI Socket sessions.
  • SYSTem:BEEPer[:IMMediate] - issues a single beep
  • SYSTem:BEEPer:STATe {ON|1|OFF|0} - disables or enables beeper
  • SYSTem:CLICk:STATe - disables or enables keypress click
  • SYSTem:COMMunicate:ENABle {ON|1|OFF|0}, <interface> - disables or enables GPIB, USB, LAN interface, and remote services
  • SYSTem:COMMunicate:GPIB:ADDRess <address> - assigns instrument's GPIB (IEEE-488) address
  • SYSTem:DATE <yyyy>, <mm>, <dd> - sets system clock date
  • SYSTem:ERRor? - reads and clears one error from error queue
  • SYSTem:LICense:CATalog? - lists installed, licensed options
  • SYSTem:LICense:DELete "<option_name>" - deletes a license
  • SYSTem:LICense:DELete:ALL - deletes all licenses
  • SYSTem:LICense:DESCription? "<option_name>" - returns description of a licensed option
  • SYSTem:LICense:ERRor? - lists errors generated during license installation
  • SYSTem:LICense:ERRor:COUNt? - returns number of errors generated during license installation
  • SYSTem:LICense:INSTall "<file>" - installs licenses from a file or folder
    SYSTem:LICense:INSTall? "<option>" - indicates whether a license is installed
  • SYSTem:LOCK:NAME? - returns current I/O interface
  • SYSTem:LOCK:OWNer? - returns interface that has the lock
  • SYSTem:LOCK:RELease - releases lock and decrements lock count by 1
  • SYSTem:LOCK:REQuest? - requests lock of current interface
  • SYSTem:SECurity:IMMediate - sanitizes user-accessible instrument memory
  • SYSTem:TIME <hh>, <mm>, <ss> - sets system clock time
  • SYSTem:VERSion? - returns version of SCPI used by instrument

SYSTem:BEEPer[:IMMediate]

Issues a single beep.

Parameter | Typical Return
(none) | (none)
Issue a single beep: SYST:BEEP
  • Sending a programmed beep may be useful for program development and troubleshooting.
  • This command overrides the current beeper state (the SYSTem:BEEPer:STATe ). This means that you can issue a single beep even if the beeper is turned off.

SYSTem:BEEPer:STATe {ON|1|OFF|0}
SYSTem:BEEPer:STATe?

Disables or enables the beeper tone heard when an error is generated from the front panel or remote interface.

Parameter | Typical Return
{ON|1|OFF|0}, default ON | 0 (OFF) or 1 (ON)
Disable beeper state: SYST:BEEP:STAT OFF
  • Turning off the beeper does not disable the front panel key click.
  • A beep is always emitted (even with beep state OFF) when SYSTem:BEEPer is sent.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.

SYSTem:CLICk:STATe {ON|1|OFF|0}
SYSTem:CLICk:STATe?

Disables or enables the click heard when a front panel key or softkey is pressed.

Parameter | Typical Return
{ON|1|OFF|0}, default ON | 0 (OFF) or 1 (ON)
Disable keyboard click: SYST:CLIC:STAT OFF
  • This command does not affect the beeper that indicates errors.
  • This setting is non-volatile; it is not changed by power cycling or a Factory Reset (*RST).

SYSTem:COMMunicate:ENABle {ON|1|OFF|0}, <interface>
SYSTem:COMMunicate:ENABle? <interface>

Disables or enables the GPIB, USB, or LAN remote interface. Also disables or enables available remote services such as Sockets, Telnet, VXI11, and the built-in Web Interface.

Parameter | Typical Return
{ON|1|OFF|0}, default ON for all interfaces | 0 (OFF) or 1 (ON)
{GPIB|USB|LAN|SOCKets|TELNet|VXI11|WEB}
Disable the USB interface: SYST:COMM:ENAB OFF,USB Returns the state of the USB interface: SYST:COMM:ENAB? USB

Note

When you disable or re-enable any interface or LAN service, you must cycle power to activate the new setting.
  • If you disable the LAN interface, all associated LAN services will not be started when you power on the instrument.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • SYSTem:SECurity:IMMediate enables all interfaces.

SYSTem:COMMunicate:GPIB:ADDRess <address>
SYSTem:COMMunicate:GPIB:ADDRess?

Assigns instrument's GPIB (IEEE-488) address, which is displayed at power-on. Each device on the GPIB interface must have a unique address.

Parameter | Typical Return
0 to 30, default 10 | +15
Set GPIB address to 15: SYST:COMM:GPIB:ADDR 15
  • Your computer’s GPIB interface card address must not conflict with any instrument on the interface bus.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • SYSTem:SECurity:IMMediate sets GPIB address to 10.
  • Must cycle power for this command to take effect.

SYSTem:DATE <yyyy>, <mm>, <dd>
SYSTem:DATE?

Sets system clock date.

Parameter | Typical Return
<yyyy> 2000 to 2100 <mm> 1 to 12 <dd> 1 to 31 | +2011,+7,+26
Set system date to July 26, 2011: SYST:DAT 2011,7,26

SYSTem:ERRor?

Reads and clears one error from error queue.

Parameter | Typical Return
(none) | -113,"Undefined header"
Read and clear first error in error queue: SYST:ERR?
  • Up to 20 command syntax or hardware errors can be stored in each interface-specific error queue (one each for GPIB, USB, VXI-11, and Telnet/Sockets.)
  • Error retrieval is first-in-first-out (FIFO), and errors are cleared as you read them. The instrument beeps once each time an error is generated (unless disabled by SYSTem:BEEPer:STATe OFF).
  • If more than 20 errors have occurred, the last error stored in the queue (the most recent error) is replaced with -350,"Error queue overflow". No additional errors are stored until you remove errors from the queue. If no errors have occurred when you read the error queue, the instrument responds with +0,"No error".
  • The error queue is cleared by the *CLS and when power is cycled. It is not cleared by *RST.
  • Errors have the following format (the error string may contain up to 255 characters).

    <error code>,<error string>

    Where:

    <error code> = a three-digit code, sometimes preceded by a dash

    <error string> = a quoted ASCII string up to 255 characters

Licensed Options

The following commands are associated with licensed options. The licensed options are named as shown below.

Option Code | Description
ARB | Arbitrary waveforms
BW30 | Increase bandwidth to 30 MHz (33500 Series)
BW120 | Increase bandwidth to 120 MHz (33600 Series)
IQP | IQ Player (2-channel instruments only)
MEM | 16 MSa Arb Memory (33500 Series) or 64 MSa Arb Memory (33600 Series)
SEC | Enable NISPOM & File Security

SYSTem:LICense:CATalog?

Returns a comma separated list of installed, licensed options.

Parameter | Typical Return
(none) | "SEC","IQP","MEM"
Return currently licensed options: SYST:LIC:CAT?
  • Only those installed options that require a license are returned.

SYSTem:LICense:DELete "<option_name>"

Deletes a license.

Exercise caution before executing this command. The only way to undo a license deletion is to re-install the license.

Parameter | Typical Return
{ARB|BW30|BW120|IQP|MEM|SEC} | (none)
Delete license for IQ Player: SYST:LIC:DEL "IQP"
  • Valid option names are double quoted strings representing the installed licensed options. They can be easily identified using SYSTem:LICense:CATalog?.

SYSTem:LICense:DELete:ALL

Deletes all licenses.

Exercise caution before executing this command. The only way to undo a license deletion is to re-install the license.

Parameter | Typical Return
(none) | (none)
Delete all licenses: SYST:LIC:DEL:ALL

SYSTem:LICense:DESCription? "<option_name>"

Returns a description of specified option, regardless of whether it is currently licensed.

Parameter | Typical Return
See list of licensed options | "Extended Memory Option: 16 MSa/channel waveform memory"
Return description for option 002: SYST:LIC:DESC? "MEM"
  • Option names are quoted strings representing options that may be licensed. Installed licensed items can be identified with SYSTem:LICense:CATalog?.

SYSTem:LICense:ERRor?

Returns a string of all the errors produced by SYSTem:LICense:INSTall.

Parameter | Typical Return
(none) | #279File: MyFile.lic<CR><LF>[Ignored - The license file is not formatted correctly.]<CR><LF>
Return the license installation error string: SYST:LIC:ERR?
  • String can be up to 2096 characters.
  • Returns a definite-length block containing multi-line ASCII text, including carriage returns and line feeds.

SYSTem:LICense:ERRor:COUNt?

Returns the number of license errors generated by SYSTem:LICense:INSTall.

Parameter | Typical Return
(none) | +0
Return number of license errors: SYST:LIC:ERR:COUN?

SYSTem:LICense:INSTall "<file>"
SYSTem:LICense:INSTall? "<option>"

This command installs all licenses from a specified file or from all license files in the specified folder. They query returns 0 or 1 to indicate whether the specified license is installed.

Parameter Typical Return

<folder> may be any valid folder name. Default is root directory of a front panel USB storage device.
<file> may be any valid license file name
<option> is one of the licensed options

0 (license not installed) or 1 (license installed)
Install licenses from a file:
SYST:LIC:INSTALL "USB:\33522B_LICENSE071.lic"
  • License files must have a ".lic" file extension.
  • The format for <file> is "[<drive>:<path>]<file_name>", where <drive> can be INTernal or USB, and <path> must be an absolute folder path.
  • INTernal specifies the internal flash file system. USB specifies a front panel USB storage device.
  • If <drive>:<path> is omitted, the folder specified by the MMEMory:CDIRectory command is used.
  • Absolute paths begin with "\" or "/" and start at the root folder of <drive>.
  • Folder and file names cannot contain the following characters: \ / : * ? " < > |
  • The combination of folder and file name cannot exceed 240 characters.
  • The specified folder must exist and cannot be marked hidden or system.

SYSTem:LOCK:NAME?

Returns the current I/O interface (the I/O interface in use by the querying computer).

Parameter | Typical Return
(none) | "LAN169.254.149.35"
See Interface Locking Examples
  • After using this command to determine the name of the interface that you are using, use SYSTem:LOCK:OWNer? to determine which interface, if any, has the lock.
  • Returns "USB", "VXI11", "GPIB", or "LAN <IP Address>" indicating the I/O interface being used by the querying computer.

SYSTem:LOCK:OWNer?

Returns the I/O interface that currently has a lock.

Parameter | Typical Return
(none) | "LAN169.254.149.35"
See Interface Locking Examples
  • When a lock is active, Bit 10 in the Standard Operation Register will be set (STATus:OPERation:CONDition?). When the lock is released on all I/O interfaces, this bit will be cleared.
  • Returns "USB", "VXI11", "GPIB", or "LAN <IP Address>" indicating the I/O interface that currently has a lock. If no interfaces have a lock, "NONE" is returned.

SYSTem:LOCK:RELease

Decrements the lock count by 1 and may release the I/O interface from which the command is executed.

Parameter | Typical Return
(none) | (none)
See Interface Locking Examples
  • When a lock is active, Bit 10 in the Standard Operation Register will be set (STATus:OPERation:CONDition?). When the lock is released on all I/O interfaces, this bit will be cleared.

SYSTem:LOCK:REQuest?

Requests a lock of the current I/O interface. This allows you to lock the instrument's configuration or cooperatively share the instrument with other computers.

Parameter | Typical Return
(none) | 0 (denied) or 1 (granted)
See Interface Locking Examples
  • Lock requests can be nested; each request increases lock count by 1. For every request, you will need a release ( SYSTem:LOCK:RELease) from the same I/O interface.
  • Locks are handled at the I/O interface level (USB, LAN, etc.) and you are responsible for all coordination between threads and/or programs on that interface.
  • When a request is granted, only I/O sessions from the present interface will be allowed to change the state of the instrument. You can only query the instrument state from other I/O interfaces.
  • LAN sessions locks are automatically released when a LAN disconnect is detected.
  • Granting a lock sets Bit 10 in the Standard Operation Register (STATus:OPERation:CONDition?).

Interface Locking Examples

The following series of commands illustrates usage.

Initial State = unlocked, Count = 0

<FROM USB> SYST:LOCK:REQ? returns 1 (request successful)

State = locked, Count = 1

<FROM LAN> SYST:LOCK:REQ? returns 0 because USB has lock

State = locked, Count = 1

<FROM USB> SYST:LOCK:REQ? returns 1 (request successful)

State = locked, Count = 2

<FROM USB> SYST:LOCK:REL

State = locked, Count = 1

<FROM USB> SYST:LOCK:REL

State = unlocked, Count = 0

Note that for each successful lock request, a lock release is required. Two requests require two releases.

SYSTem:SECurity:IMMediate

Sanitizes all user-accessible instrument memory. This command complies with requirements in chapter 8 of the National Instrument Security Program Operating Manual (NISPOM).

Parameter | Typical Return
(none) | (none)
Sanitize all user-accessible instrument memory: SYST:SEC:IMM

Caution

This command is recommended for customers, such as military contractors, who must comply with NISPOM. Excessive use of this command may cause premature failure of the flash memory.

This command destroys all user-defined state information, user-defined arbitrary waveforms, and user-defined I/O settings such as the IP address.
  • Typically used before removing an instrument from a secure area.
  • Initializes all instrument settings to their Factory Reset (*RST) values.

SYSTem:TIME <hh>, <mm>, <ss>
SYSTem:TIME?

Sets system clock time.

Parameter | Typical Return
<hh> 0 to 23 <mm> 0 to 59 <ss> 0 to 60 | 20,15,30.000
Set system Time to 20:15:30 (8:15:30 PM) SYST:TIM 20,15,30
  • This time is used for file timestamps in the Mass Memory (MMEMory) system.

SYSTem:VERSion?

Returns version of the SCPI (Standard Commands for Programmable Instruments) that the instrument complies with. Cannot be determined from front panel.

Parameter | Typical Return
(none) | 1994.0
Return the SCPI version: SYST:VERS?


LAN Configuration

Configures instrument for remote operation via the local area network (LAN).

Note

The instrument uses LAN port 5024 for SCPI Telnet sessions, and port 5025 for SCPI Socket sessions.

Dot Notation Details

Dot-notation addresses ("nnn.nnn.nnn.nnn" where "nnn" is a byte value from 0 to 255) must be expressed with care, as most PC web software interprets byte values with leading zeros as octal (base 8) numbers. For example, "192.168.020.011" is actually equivalent to decimal "192.168.16.9" because ".020" is interpreted as "16" expressed in octal, and ".011" as "9". To avoid confusion, use only decimal values from 0 to 255, with no leading zeros.

SYSTem:COMMunicate:LAN:CONTrol?

Reads the initial Control connection port number for Sockets communications. This connection is used to send and receive commands and queries.

Parameter | Typical Return
(none) | 5000 (0 if the interface does not support sockets)
Return the Control connection port number: SYST:COMM:LAN:CONT?

  • Use the Control socket connection to send a Device Clear to the instrument or to detect pending Service Request (SRQ) events. The Device Clear command is "DCL".

SYSTem:COMMunicate:LAN:DHCP {ON|1|OFF|0}
SYSTem:COMMunicate:LAN:DHCP?

Disables or enables instrument's use of DHCP. The acronym DHCP stands for Dynamic Host Configuration Protocol, a protocol for assigning dynamic IP addresses to networked devices. With dynamic addressing, a device can have a different IP address every time it connects to the network.

ON: instrument tries to obtain an IP address from a DHCP server. If a DHCP server is found, it assigns a dynamic IP address, Subnet Mask, and Default Gateway to the instrument.

OFF or DHCP unavailable: instrument uses the static IP address, Subnet Mask, and Default Gateway during power-on.

Note

If you change this setting, you must send SYSTem:COMMunicate:LAN:UPDate to activate the new setting.

Parameter | Typical Return
{ON|1|OFF|0}, default ON | 0 (OFF) or 1 (ON)
Disable DHCP: SYST:COMM:LAN:DHCP OFF SYST:COMM:LAN:UPDate
  • Most corporate LANs have a DHCP server.
  • If DHCP LAN address not assigned by DHCP server, static IP is assumed after approximately two minutes.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Enabled when the instrument is shipped from the factory or after SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:DNS[1|2] "<address>"
SYSTem:COMMunicate:LAN:DNS[1|2]? [{CURRent|STATic}]

Assigns static IP addresses of Domain Name System (DNS) servers. A primary and a secondary server address may be assigned. Contact your LAN administrator for details. If DHCP is available and enabled, DHCP will auto-assign the DNS server addresses. These auto-assigned DNS server addresses take precedence over the static DNS addresses assigned with this command.

Note

If you change this setting, you must send SYSTem:COMMunicate:LAN:UPDate to activate the new setting.

Parameter | Typical Return
Command: "nnn.nnn.nnn.nnn", default "0.0.0.0" Query: {CURRent|STATic}, default CURRent | "198.105.232.4"
Set a static primary DNS address: SYST:COMM:LAN:DNS "198.105.232.4" SYST:COMM:LAN:UPD
  • CURRent: read address currently being used by the instrument.
  • STATic: read static address from non-volatile memory. This address is used if DHCP is disabled or unavailable.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Set to "0.0.0.0" by SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:DOMain?

Returns the domain name of the LAN to which the instrument is connected.

Parameter | Typical Return
(none) | "example.com"
Return domain name being used by instrument: SYST:COMM:LAN:DOM?
  • If Dynamic domain name System (DNS) is available on your network and your instrument uses DHCP, the domain name is registered with the Dynamic DNS service at power-on.
  • A null string ("") indicates that no domain name is assigned.

SYSTem:COMMunicate:LAN:GATeway "<address>"
SYSTem:COMMunicate:LAN:GATeway? [{CURRent|STATic}]

Assigns a default gateway for the instrument. The specified IP Address sets the default gateway which allows the instrument to communicate with systems that are not on the local subnet. Thus, this is the default gateway where packets are sent which are destined for a device not on the local subnet, as determined by the Subnet Mask setting. If DHCP is enabled (SYSTem:COMMunicate:LAN:DHCP ), the specified default gateway is not used. However, if the DHCP server fails to assign a valid IP address, the currently configured default gateway will be used. Contact your LAN administrator for details.

Note

If you change this setting, you must send SYSTem:COMMunicate:LAN:UPDate to activate the new setting.

Parameter | Typical Return
Command: "nnn.nnn.nnn.nnn", default "0.0.0.0" Query: {CURRent|STATic}, default CURRent | "198.105.232.1"
Set default gateway address: SYST:COMM:LAN:GATEWAY "198.105.232.1" SYST:COMM:LAN:UPD
  • CURRent: read address currently being used by the instrument.
  • STATic: read static address from non-volatile memory. This address is used if DHCP is disabled or unavailable.
  • Set to "0.0.0.0" when instrument is shipped from factory or after SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:HOSTname "<name>"
SYSTem:COMMunicate:LAN:HOSTname? [{CURRent|STATic}]

Assigns a hostname to the instrument. A hostname is the host portion of the domain name, which is translated into an IP address. If Dynamic Domain Name System (DNS) is available on your network and your instrument uses DHCP, the hostname is registered with the Dynamic DNS service at power-on. If DHCP is enabled (SYSTem:COMMunicate:LAN:DHCP ), the DHCP server can change the specified hostname.

Note

If you change this setting, you must send SYSTem:COMMunicate:LAN:UPDate to activate the new setting.

Parameter | Typical Return
String of up to 15 characters. Must start with letter (A-Z) May contain letters, numbers (0-9), or dashes ("-") | "LAB1-33522A"
Define a hostname: SYST:COMM:LAN:HOST "LAB1" SYST:COMM:LAN:UPD
  • Set to "A-33521A-nnnnn" or "A-33522A-nnnnn", where nnnnn is the last five digits of the instrument's serial number, when the instrument is shipped from the factory or after SYSTem:SECurity:IMMediate.
  • If no hostname exists, a null string ( "" ) is returned.

SYSTem:COMMunicate:LAN:IPADdress "<address>"
SYSTem:COMMunicate:LAN:IPADdress? [{CURRent|STATic}]

Assigns a static Internet Protocol (IP) address for the instrument. If DHCP is enabled (SYSTem:COMMunicate:LAN:DHCP), the specified static IP address is not used. Contact your LAN administrator for details.

Note

If you change this setting, you must send SYSTem:COMMunicate:LAN:UPDate to activate the new setting.

Parameter | Typical Return
Command: "nnn.nnn.nnn.nnn", default "0.0.0.0" Query: {CURRent|STATic}, default CURRent | "169.254.149.35"
Set a static IP address: SYST:COMM:LAN:IPAD "169.254.149.35" SYST:COMM:LAN:UPD
  • CURRent: read address currently being used by the instrument.
  • STATic: read static address from non-volatile memory. This address is used if DHCP is disabled or unavailable.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Set to "169.254.5.21" when the instrument is shipped from the factory or after SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:MAC?

Reads the instrument's Media Access Control (MAC) address.

Note

Your LAN administrator may need the MAC address to assign a static IP address for this device.

Parameter | Typical Return
(none) | "0030D3001041"
Return the MAC address: SYST:COMM:LAN:MAC?
  • The MAC address is also known as the link-layer address, the Ethernet (station) address, LANIC ID, or Hardware Address. This is an unchangeable 48-bit address assigned by the manufacturer to each unique Internet device.
  • The instrument's MAC address is set at the factory and cannot be changed.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.

SYSTem:COMMunicate:LAN:SMASk "<mask>"
SYSTem:COMMunicate:LAN:SMASk? [{CURRent|STATic}]

Assigns a subnet mask for the instrument. The instrument uses the subnet mask to determine whether a client IP address is on the same local subnet. When a client IP address is on a different subnet, all packets must be sent to the Default Gateway. Contact your LAN administrator for details.

Note

If you change this setting, you must send SYSTem:COMMunicate:LAN:UPDate to activate the new setting.

Parameter | Typical Return
Command: "nnn.nnn.nnn.nnn", default "0.0.0.0" Query: {CURRent|STATic}, default CURRent | "255.255.0.0"
Set the subnet mask: SYST:COMM:LAN:SMAS "255.255.255.0" SYST:COMM:LAN:UPD
  • If DHCP is enabled (SYSTem:COMMunicate:LAN:DHCP ), the specified subnet mask is not used. However, if the DHCP server fails to assign a valid IP address, the instrument uses the AutoIP subnet mask.
  • A value of "0.0.0.0" or "255.255.255.255" indicates that subnetting is not being used.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • The subnet mask is set to "255.255.0.0" when the instrument is shipped from the factory or after a SYSTem:SECurity:IMMediate command.
  • CURRent: read address currently being used by the instrument.
  • STATic: read static address from non-volatile memory. This address is used if DHCP is disabled or unavailable.

SYSTem:COMMunicate:LAN:TELNet:PROMpt "<string>"
SYSTem:COMMunicate:LAN:TELNet:PROMpt?

Sets the command prompt seen when communicating with the instrument via Telnet.

Parameter | Typical Return
String of up to 15 characters | "Command>"
Set the command prompt: SYST:COMM:LAN:TELN:PROM "Command>"
  • A Telnet session is typically started from a host computer shell:

    telnet <IP_address> <port>

    For example: telnet 169.254.4.10 5024

    To exit a Telnet session, press <Ctrl-D>.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • This is set to "33521A> " (model 33521A), "33522A> " (model 33522A), "33500> " (other 33500 Series models), or "33600> " (33600 Series models) when the instrument is shipped from the factory or after SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:TELNet:WMESsage "<string>"
SYSTem:COMMunicate:LAN:TELNet:WMESsage?

Sets welcome message seen when communicating with instrument via Telnet.

Parameter | Typical Return
String of up to 63 characters | "Welcome to the Telnet Session"
Define a welcome message: SYST:COMM:LAN:TELN:WMES "Welcome to the Telnet Session"
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • This is set to "Welcome to Keysight's 33521A Waveform Generator" (model 33521A), "Welcome to Keysight's 33522A Waveform Generator" (model 33522A), "Welcome to Keysight's 33500-Series Waveform Generator" (other 33500 Series models), or "Welcome to Keysight's 33600-Series Waveform Generator" (33600 Series models) when the instrument is shipped from the factory or after SYSTem:SECurity:IMMediate.

SYSTem:COMMunicate:LAN:UPDate

Stores any changes made to the LAN settings into non-volatile memory and restarts the LAN driver with the updated settings.

Parameter | Typical Return
(none) | (none)
(see below)
  • This command must be sent after changing the settings for DHCP, DNS, gateway, hostname, IP address, subnet mask, WINS.
  • Make all changes to the LAN settings before sending this command.

Example

The following example configures the instrument to use statically assigned LAN settings.

SYST:COMM:LAN:DHCP OFF
SYST:COMM:LAN:DNS "198.105.232.4"
SYST:COMM:LAN:DNS2 "198.105.232.5"
SYST:COMM:LAN:GATEWAY "198.105.232.1"
SYST:COMM:LAN:HOST "LAB1-33522A"
SYST:COMM:LAN:IPAD "198.105.232.101"
SYST:COMM:LAN:SMAS "255.255.255.0"
SYST:COMM:LAN:WINS "198.105.232.4"
SYST:COMM:LAN:WINS "198.105.232.5"
SYST:COMM:LAN:UPD

The following example configures the instrument back to use DHCP.

SYST:COMM:LAN:DHCP ON
SYST:COMM:LAN:UPD

SYSTem:COMMunicate:LAN:WINS[1|2] "<address>"
SYSTem:COMMunicate:LAN:WINS[1|2]? [{CURRent|STATic}]

Assigns the static IP addresses of the Windows Internet Name System (WINS) servers. A primary and a secondary server address may be assigned. Contact your LAN administrator for details. If DHCP is available and enabled, DHCP will auto-assign the WINS server addresses. These auto-assigned WINS server addresses take precedence over the static WINS addresses assigned with this command.

Note

If you change this setting, you must send SYSTem:COMMunicate:LAN:UPDate to activate the new setting.

Parameter | Typical Return
Command: "nnn.nnn.nnn.nnn", default "0.0.0.0" Query: {CURRent|STATic}, default CURRent | "198.105.232.4"
Set a static primary WINS address: SYST:COMM:LAN:WINS "198.105.232.4" SYST:COMM:LAN:UPD
  • The assigned WINS addresses are used if DHCP is disabled or unavailable. Otherwise, the WINS server addresses are auto-assigned by DHCP.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Set to "0.0.0.0" (no servers) after SYSTem:SECurity:IMMediate.
  • CURRent: read address currently being used by the instrument.
  • STATic: read static address from non-volatile memory. This address is used if DHCP is disabled or unavailable.


TRACk

[SOURce[1|2]:]TRACk {ON|OFF|INVerted}
TRACk?

Causes channels 1 and 2 of a two-channel instrument to output the same signal, or an inverted polarity signal.

Parameter | Typical Return
{ON|OFF|INVerted} | ON, OFF, or INV
Set channel 2 to output a signal identical to that of channel 1: TRACk ON
  • Causes all settings of the named channel to be copied to the other channel with exceptions noted below. This does include frequency list settings and any arbitrary waveforms loaded in memory.
  • With the INVerted option, the tracking channel's amplitude will be inverted, forming a signal similar to a differential output between Channel 1 and Channel 2. DC Offset is not inverted.
  • When TRACk is ON, voltage limits on both channels apply. If voltage limits on either channel would prevent the other channel's setup from being applied, the instrument will generate a settings conflict error and channel tracking will remain OFF.
  • When TRACk is ON, changes to either channel are reflected in both channels. When TRACk is changed from ON or INV to OFF, the channels will remain in their present setup (frequency, amplitude, and so on), but you may now change one channel without affecting the other channel.
  • Voltage limits may be adjusted in tracking mode, but cannot be set in violation of the current signal.
  • Turning tracking ON sets COMBine:FEED to NONE, turns off FREQuency:COUPle, VOLTage:COUPle, and RATE:COUPle.
  • TRACK is not allowed if the internal modulation source for the channel being tracked is the other channel.
  • The OUTPut:SYNC:SOURce is set to the channel being tracked.


TRIGger Subsystem Introduction

The rear-panel external trigger BNC connector is chassis referenced.

Configures triggering for sequence, list, burst, and sweep:

TRIGger[1|2] - immediate trigger

TRIGger[1|2]:COUNt {<number>MINimum|MAXimum|DEFault} - trigger count

TRIGger[1|2]:DELay {<seconds>|MINimum|MAXimum} - trigger delay

TRIGger[1|2]:LEVel {<level>|MINimum|MAXimum} - trigger level

TRIGger[1|2]:SLOPe {POSitive|NEGative} - slope of trigger signal at the rear-panel Ext Trig connector

TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS} - source (internal, external, timer, or bus) from which instrument accepts trigger

TRIGger[1|2]:TIMer {<seconds>|MINimum|MAXimum} - timer used when TRIGger[1|2]:SOURce is TIMer.

TRIGger[1|2]

Forces immediate trigger to initiate sequence, sweep, list, or burst.

Parameter | Typical Return
(none) | (none)
Send an immediate trigger on channel 2: TRIG
  • Can be used with IMMediate, EXTernal, TIMer, or BUS trigger source (TRIGger[1|2]:SOURce). For example, you can use TRIGger to issue an immediate trigger while waiting for an external trigger.
  • Intended as an override. For general, software controlled triggering, use *TRG.

TRIGger[1|2]:COUNt {<number>MINimum|MAXimum|DEFault}
TRIGger[1|2]:COUNt? [{MINimum|MAXimum}]

Sets trigger count.

Parameter | Typical Return
1 to 1,000,000; default, 1 | 10000
Set channel 2 trigger count to 10000: TRIG2:COUN 10000
  • Can be used with IMMediate, EXTernal, TIMer, or BUS trigger source (TRIGger[1|2]:SOURce).
  • Applies only when INITiate[1|2]:CONTinuous is OFF.

TRIGger[1|2]:DELay {<seconds>|MINimum|MAXimum}
TRIGger[1|2]:DELay? [{MINimum|MAXimum}]

Sets trigger delay, (time from assertion of trigger to occurrence of triggered event).

Parameter | Typical Return
0 to 1000 s, in resolution of 4 ns; default 0 | +1.050000000000000E-01
Set channel 1 trigger delay to 105 ms: TRIG:DEL 105e-3
  • Can be used with IMMediate, EXTernal, TIMer, or BUS trigger source (TRIGger[1|2]:SOURce).

TRIGger[1|2]:LEVel {<level>|MINimum|MAXimum}
TRIGger[1|2]:LEVel? [{MINimum|MAXimum}]

Sets the output trigger level and input trigger threshold in volts. The trigger threshold is one-half of the trigger level.

Parameter | Typical Return
0.9 to 3.8 V | +3.300000000000000E+00
Set the trigger level to 2 V: TRIG:LEV 2

TRIGger[1|2]:SLOPe {POSitive|NEGative}
TRIGger[1|2]:SLOPe?

Specifies polarity of trigger signal on rear-panel Trig In connector for any externally-triggered mode.

Parameter | Typical Return
{POSitive|NEGative}, default POS (rising edge) | POS or NEG
Set trigger slope to falling edge: TRIG:SLOP NEG

TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}
TRIGger[1|2]:SOURce?

Selects the trigger source for sequence, list, burst or sweep. The instrument accepts an immediate or timed internal trigger, an external hardware trigger from the rear-panel Ext Trig connector, or a software (bus) trigger.

Parameter | Typical Return
{IMMediate|EXTernal|TIMer|BUS}, default IMMediate | IMM, EXT, TIM, BUS
Select external trigger source (trigger each time a low-true TTL pulse is received on the rear-panel trigger input): TRIG:SOUR EXT

In triggered burst mode:

  • The instrument outputs a waveform of the specified number of cycles (burst count) when a trigger is received. After the specified number of cycles have been output, the instrument stops and waits for next trigger.
  • IMMediate (internal): the instrument outputs continuously when burst mode is enabled. The rate at which the burst is generated is determined by BURSt:INTernal:PERiod.
  • EXTernal: the instrument accepts a hardware trigger at the rear-panel Ext Trig connector. The instrument outputs one burst of the specified number of cycles each time Ext Trig receives a level transition with the proper polarity (TRIGger[1|2]:SLOPe). External trigger signals during a burst are ignored.
  • BUS (software): the instrument initiates one burst each time a bus trigger (*TRG) is received. The front panel [Trigger] key is illuminated when the instrument is waiting for a bus trigger.
  • EXTernal or BUS: burst count and burst phase remain in effect, but burst period is ignored.
  • TIMer: trigger events are spaced by a timer, with the first trigger as soon as INIT occurs.

In frequency sweep mode:

    • IMMediate (internal): the instrument outputs continuously when the sweep is enabled. The period at which the sweep is generated is the sweep time (SWEep:TIME) plus 1 ms.
    • EXTERNAL: the instrument accepts a hardware trigger at the rear-panel Ext Trig connector. The instrument initiates one sweep each time Trig In receives a TTL pulse of proper edge polarity (TRIGger[1|2]:SLOPe). The trigger period must be at least sweep time (SWEep:TIME) plus 1 ms.
    • BUS (software): the instrument initiates one sweep each time a bus trigger (*TRG) is received. The front panel [Trigger] key is illuminated when the instrument is waiting for a bus trigger.
  • APPLy sets trigger source to IMMediate.
  • To ensure synchronization with BUS source, send *WAI (wait) so the instrument waits for all pending operations to complete before executing any additional commands. For example, the following command string guarantees that the first trigger is accepted and the operation is executed before second trigger is recognized.

    TRIG:SOUR BUS;*TRG;*WAI;*TRG;*WAI
  • Use *OPC? or *OPC to determine when the sweep or burst is complete. The *OPC? query returns 1 to the output buffer when the sweep or burst is complete. The *OPC command sets the Operation Complete bit (bit 0) in the Standard Event register when the sweep or burst is complete.

TRIGger[1|2]:TIMer {<seconds>|MINimum|MAXimum}
TRIGger[1|2]:TIMer? [{MINimum|MAXimum}]

Sets timer used when TRIGger[1|2]:SOURce is TIMer.

Parameter | Typical Return
1 µs to 8,000 s | +3.000000000000000E-01
Set trigger timer to 300 ms on channel 2: TRIG2:TIM 0.3
  • In triggered burst mode (BURSt:MODE TRIG), this command supersedes BURSt:INTernal:PERiod.


UNIT:ANGLe

UNIT:ANGLe {DEGree|RADian|SECond|DEFault}
UNIT:ANGLe?

Specifies the angle units that displayed on the screen and used for specifying angles. The selected units are used for setting the starting phase for a burst (BURSt:PHASe) and for setting the phase offset (PHASe). The associated queries are also affected.

Parameter | Typical Return
{DEGree|RADian|SECond|DEFault}, default DEGree | DEG, RAD, or SEC
Set angle units to radians: UNIT:ANGL RAD
  • The SECond option is only available for the 33600 Series.
  • The setting may be overridden by adding units to numeric parameter in command. For example, PHASE 90 DEG specifies 90 degrees, regardless of this setting.
  • The front panel display always shows degrees, regardless of the UNIT:ANGLe setting.


UNIT:ARBitrary:ANGLe {DEGree|RADian|SECond|SAMPle|DEFault}UNIT:ARBitrary:ANGLe?

UNIT:ARBitrary:ANGLe {DEGree|RADian|SECond|SAMPle|DEFault}
UNIT:ARBitrary:ANGLe?

Sets the units for specifying arbitrary waveform phase. The front panel will display the phase parameter in the selected units.

Parameter | Typical Return
{DEGree|RADian|SECond|SAMPle|DEFault}, default DEGree | DEG, RAD, SEC, or SAMP
Set the arbitrary waveform angle units to samples: UNIT:ARB:ANGL SAMP
  • The SECond and SAMPle options are only available for the 33600 Series models.
  • You can also specify units by adding units to the numeric parameter: ARB:PHAS 10 DEG.


VOLTage Subsystem Introduction

The VOLTage subsystem sets parameters related to output voltage.

Example

The following is a typical procedure using the VOLTage subsystem.

  1. Select the waveform shape, amplitude and offset: Use APPLy or the equivalent FUNCtion, FREQuency, VOLTage, and VOLTage:OFFSet commands to select the function, frequency, amplitude, and offset.
  2. Set units for output amplitude: VOLTage:UNIT
  3. Set output amplitude: VOLTage
  4. Set DC offset voltage: VOLTage:OFFSet
  5. Set high and low voltage level: VOLTage:HIGH and VOLTage:LOW
  6. Select output voltage limits to protect device under test (DUT): VOLTage:LIMit:HIGH, VOLTage:LIMit:LOW, and VOLTage:LIMit:STATe
  7. Select status of auto-ranging for all output functions: VOLTage:RANGe:AUTO
  8. Set voltage coupling to lock amplitude and offset of the channels together (2-channel instruments only): VOLTageLCOUPle[:STATe]

This example demonstrates the procedure outlined above:

SOURce1:FUNCtion SQU
SOURce1:FREQuency +1.0E+06
SOURce1:VOLTage +0.5
SOURce1:VOLTage:OFFSet +0.5
SOURce1:FUNCtion:SQUare:PERiod +1.0E-06
SOURce1:FUNCtion:PULSe:PERiod +1.0E-06
SOURce1:VOLTage:LIMit:LOW +0.0
SOURce1:VOLTage:LIMit:HIGH +1.0
SOURce1:VOLTage:LIMit:STATe 1
OUTP1 ON
SOURce2:FUNCtion SIN
SOURce2:FREQuency +1.0E+06
SOURce2:VOLTage +2.0
SOURce2:VOLTage:OFFSet +0.0
SOURce2:VOLTage:LIMit:LOW -1.0
SOURce2:VOLTage:LIMit:HIGH +1.0
SOURce2:VOLTage:LIMit:STATe 1
OUTP2 ON

[SOURce[1|2]:]VOLTage {<amplitude>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage? [{MINimum|MAXimum}]

Sets output amplitude.

Parameter | Typical Return
1 mVpp to maximum allowed for waveform and model, default 100 mVpp | +5.0000000000000E+00
Set output amplitude to 5 Vpp: VOLT 5 Vpp
  • The relationship between offset voltage and output amplitude is shown below. Vmax is the maximum peak voltage for the selected output termination (5 V for a 50 Ω load or 10 V for a high-impedance load).

    |Voffset| < Vmax - Vpp/2

    If the specified offset voltage is not valid, the instrument will adjust it to the maximum DC voltage allowed with the specified amplitude. From the remote interface, a "Data out of range" error will also be generated.
  • Differences between remote and front panel operation:
  • Remote Interface: Setting amplitude from the remote interface can change the offset in order to achieve the desired amplitude. The instrument will generate either a "Data out of range" or "Settings conflict" error. If the specified offset voltage is not valid, the instrument adjusts it to the maximum allowed with the specified amplitude.
  • Front Panel: Setting amplitude from the front panel will not change the offset setting. If the specified amplitude is not valid, the instrument clips it to the maximum amplitude allowed with the current offset and generates a "Data out of range" error.
  • Limits Due to Output Termination: If the amplitude is 10 Vpp and you change the output termination setting from 50 Ω to "high impedance" (OUTPut[1|2]:LOAD INF), the displayed amplitude doubles to 20 Vpp. Changing from "high impedance" to 50 Ω halves the displayed amplitude. The output termination setting does not affect the actual output voltage; it only changes the values displayed and queried from the remote interface. Actual output voltage depends on the connected load.
  • Limits due to Output Coupling:
  • Differences between remote and front panel operation: If two channels are coupled, both channels' amplitude limitations will be checked before a change in amplitude is executed. If a change in output amplitude would exceed a LIMIT for either channel, or exceed the instrument's output specifications for either channel:
  • Remote interface: The instrument will first adjust the offset, then if necessary, the amplitude of that channel to comply with the voltage limits or specification. The instrument will generate either a "Data out of range" or "Settings conflict" error.
  • Front panel: The instrument will clip the amplitude value to the maximum value with the current offset setting. A "Data out of range" error will be generated.
  • Specifying Voltage Units: You can set the output amplitude in Vpp, Vrms, or dBm by specifying the units as part of the VOLTage command VOLT 3.0 VRMS.

Use VOLTage:UNIT to specify output units for all subsequent commands.

You cannot specify output amplitude in dBm if output termination is set to high impedance. The units are automatically converted to Vpp.

  • Limits Due to Units Selection: Amplitude limits are sometimes determined by the output units selected. This may occur when the units are Vrms or dBm due to the differences in various functions' crest factors. For example, if you change a 5 Vrms square wave (into 50 Ω) to a sine wave, the instrument will adjust the amplitude to 3.536 Vrms (the upper limit for sine in Vrms). The remote interface will also generate a "Settings conflict" error.
  • Arbitrary Waveform Limitations: For arbitrary waveforms, amplitude is limited if the waveform data points do not span the full range of the output DAC (Digital-to-Analog Converter). For example, the built-in "Sinc" waveform does not use the full range of values, so its maximum amplitude is limited to 6.087 Vpp (into 50 Ω).

  • Changing amplitude may briefly disrupt output at certain voltages due to output attenuator switching. The amplitude is controlled, however, so the output voltage will never exceed the current setting while switching ranges. To prevent this disruption, disable voltage autoranging using VOLTage:RANGe:AUTO OFF. The APPLy command automatically enables autoranging.

  • You can also set the amplitude (with an associated offset voltage) by specifying a high level (VOLTage:HIGH) and low level (VOLTage:LOW). For example, if you set the high level to +2 V and the low level to -3 V, the resulting amplitude is 5 Vpp, with a -500 mV offset.
  • To output a DC voltage level, select the DC voltage function (FUNCtion DC) and then set the offset voltage (VOLTage:OFFSet). Valid values are between ±5 VDC into 50 Ω or ±10 VDC into an open circuit. While the instrument is in DC mode, setting amplitude has no effect.

[SOURce[1|2]:]VOLTage:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]VOLTage:COUPle[:STATe]?

Enables or disables the maintaining of the same amplitude, offset, range, load, and units on both channels of a two-channel instrument. The command applies to both channels; the SOURce keyword is ignored.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Enable voltage coupling: VOLT:COUP ON

[SOURce[1|2]:]VOLTage:HIGH {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:HIGH? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LOW {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LOW? [{MINimum|MAXimum}]

Set the waveform's high and low voltage levels.

Parameter | Typical Return
±5 VDC into 50 Ω, as long as HIGH is at least 1 mV greater than LOW. Defaults: HIGH +50 mV, LOW -50 mV. | +4.000000000000000E+00
Set high voltage level to 4 V: VOLT:HIGH 4
  • Limits Due to Amplitude: You can set the voltage levels to a positive or negative value with the restrictions shown below. Vpp is the maximum peak-to-peak amplitude for the selected output termination (10 Vpp into 50 Ω or 20 Vpp into an open circuit).

    Vhigh – Vlow£ Vpp (max) and Vhigh, Vlow£ Vpp (max)/2
  • Differences between remote and front panel operation:
  • Remote Interface: Setting the high or low level from the remote interface can change the high level or low level to achieve the desired setting. In this case either a "Data out of range" or "Settings conflict" error will occur. If the high level is set below the low level, the instrument will set the low level 1 mV less than the high level. If the high level is set below the LOW limit or the instrument output specifications, the low level will be set to the LOW limit or instrument output specification and the high level will be set 1 mV above the low level. A similar set of rules applies if the low level is set incorrectly.
  • Front Panel: Setting the high or low level from the front panel may clip that level setting in order to achieve the desired level setting, and a "Data out of range" error will be generated. The high level cannot be set below the low level from the front panel.
  • Setting the high and low levels also sets the waveform amplitude and offset. For example, if you set the high level to +2 V and the low level to -3 V, the resulting amplitude is 5 Vpp, with a -500 mV offset.
  • Limits Due to Output Termination: If the amplitude is 10 Vpp and you change the output termination setting from 50 Ω to "high impedance" (OUTPut[1|2]:LOAD INF), the displayed amplitude doubles to 20 Vpp. Changing from "high impedance" to 50 Ω halves the displayed amplitude. The output termination setting does not affect the actual output voltage; it only changes the values displayed and queried from the remote interface. Actual output voltage depends on the connected load.
  • Limits due to VOLTage:LIMit:STATe: If voltage limits are enabled, the level settings are checked against the specified limits (VOLTage:LIMit:HIGH, VOLTage:LIMit:LOW) before a level change is executed. If an output level change would exceed a LIMIT setting, the level is clipped to the maximum (or minimum) value allowed that will not exceed the LIMit setting and a "Settings conflict" error will be generated.
  • Limits due to Output Coupling: If two channels are coupled, limitations are checked on both channels before a change in level is executed. If a change in level would exceed a LIMIT setting or exceed the instrument's output specifications for either channel, the level is clipped to the maximum (or minimum) value allowed that will not exceed the LIMit setting and a "Settings conflict" error will be generated.
  • To invert the waveform relative to the offset voltage, use OUTPut[1|2]:POLarity.

[SOURce[1|2]:]VOLTage:LIMit:HIGH {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LIMit:HIGH? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LIMit:LOW {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LIMit:LOW? {MINimum|MAXimum}?

Sets the high and low limits for output voltage.

Parameter | Typical Return
±5 VDC into 50 Ω, as long as HIGH is at least 1 mV greater than LOW. Defaults: HIGH +50 mV, LOW -50 mV. | +5.0000000000000E+00
Set channel 1 output high limit to 5 V: VOLT:LIMIT:HIGH 5.0 VOLT:LIMIT:STATE ON
  • For voltage limits to be in effect, VOLTage:LIMit:STATe must be ON. If this is the case, and the high limit is set below the high value of the signal or the low limit is set above the low value of the signal, the relevant limit will be clipped to the high or low value of the signal. The instrument will generate either a "Data out of range" or "Settings conflict" error.
  • The high limit sets the highest output voltage allowed to be set, including DC Offset and peak amplitude. It is set in reference to the current OUTPUT[1|2]:LOAD setting. If the specified LOAD impedance is not present at the instrument's output, then the output limit may not represent the actual voltages at the output connector. For example, if the output impedance is set to 50 Ω, but the actual load is high impedance, then the actual output peak voltage may be up to twice the specified limit voltage.
  • Specifying Voltage Units: You can set the output limit voltage only in volts.
  • When VOLTage:COUPle[:STATe] is ON, and VOLTage:LIMit:STATe is ON, voltage limit settings on both channels affect maximum amplitude and offset voltage settings on both channels. The most restrictive combination of high and low limits from either channel is used.

[SOURce[1|2]:]VOLTage:LIMit:STATe {ON|1|OFF|0}
[SOURce[1|2]:]VOLTage:LIMit:STATe?

Enables or disables output amplitude voltage limits.

Parameter | Typical Return
{ON|1|OFF|0}, default OFF | 0 (OFF) or 1 (ON)
Set and enable ±2.5 V output limits on channel 1: VOLT:LIM:HIGH 2.5 VOLT:LIM:LOW -2.5 VOLT:LIM:STAT ON
  • When this is turned ON, if the present settings of amplitude and offset exceed the limits, then the limits will be disabled. The instrument will generate either a "Settings conflict" error.
  • When VOLTage:COUPle[:STATe] is ON, and VOLTage:LIMit:STATe is ON, voltage limit settings on both channels affect maximum amplitude and offset voltage settings on both channels. The most restrictive combination of high and low limits from either channel is used.
  • Limits are set in reference to the current setting of OUTPut[1|2]:LOAD. If the specified LOAD impedance is not present at the instrument's output, then the output limit may not represent the actual voltages at the output connector. For example, if the output impedance is set to 50 Ω, but the actual load is high impedance, then the actual output peak voltage may be up to twice the specified limit voltage.

[SOURce[1|2]:]VOLTage:OFFSet {<offset>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:OFFSet? [{MINimum|MAXimum}]

Sets DC offset voltage.

Parameter | Typical Return
± 5 VDC into 50 Ω, default 0 | +1.0000000000000E-01
Set offset voltage to 100 mV: VOLT:OFFS 100 mV
  • The relationship between offset voltage and output amplitude is shown below.

    |Voffset| < Vmax - Vpp/2
  • Differences between remote and front panel operation:
  • Remote Interface: Setting the offset from the remote interface can change the amplitude in order to achieve the desired offset setting. The instrument will generate either a "Data out of range" or "Settings conflict" error.
  • Front Panel: Setting the offset from the front panel will not change the amplitude in order to achieve the desired offset setting. If the specified offset is not valid, the instrument will clip it to the maximum offset allowed with the current amplitude and generate a "Data out of range" error.
  • Limits Due to Output Termination: The offset range depends on the output termination setting. For example, if you set offset to 100 mVDC and then change output termination from 50 Ω to "high impedance," the offset voltage displayed on the front panel doubles to 200 mVDC (no error is generated). If you change from "high impedance" to 50 Ω, the displayed offset voltage will be halved. See OUTPut[1|2]:LOAD for details. Changing the output termination setting does not change the voltage present at the output terminals of the instrument. This only changes the displayed values on the front panel and the values queried from the remote interface. The voltage present at the instrument's output depends on the load connected to the instrument. See OUTPut[1|2]:LOAD for details.
  • Limits due to Output Coupling: If two channels are coupled, limitations of setting offset will be checked on both channels before a change in offset is executed. If a change in offset would exceed a LIMIT setting, or exceed the instrument's output specifications for either channel:
  • Remote Interface: First the amplitude and then if necessary, the offset of that channel will be adjusted to comply with the voltage limits or specification. The instrument will generate either a "Data out of range" or "Settings conflict" error.
  • Front panel: The offset value is clipped to the maximum value allowed that will not exceed the LIMit setting, and a "Data out of range" error will be generated.
  • Arbitrary Waveform Limitations: For arbitrary waveforms, amplitude is limited if the waveform data points do not span the full range of the output DAC (Digital-to-Analog Converter). For example, the built-in "Sinc" waveform does not use the full range of values, so its maximum amplitude is limited to 6.087 Vpp (into 50 Ω).

  • Changing amplitude may briefly disrupt output at certain voltages due to output attenuator switching. The amplitude is controlled, however, so the output voltage will never exceed the current setting while switching ranges. To prevent this disruption, disable voltage autoranging using VOLTage:RANGe:AUTO OFF. The APPLy command automatically enables autoranging.

  • Setting the high and low levels also sets the waveform amplitude and offset. For example, if you set the high level to +2 V and the low level to -3 V, the resulting amplitude is 5 Vpp, with a -500 mV offset.
  • To output a DC voltage level, select the DC voltage function (FUNCtion DC) and then set the offset voltage (VOLTage:OFFSet). Valid values are between ±5 VDC into 50 Ω or ±10 VDC into an open circuit. While the instrument is in DC mode, setting amplitude has no effect.

[SOURce[1|2]:]VOLTage:RANGe:AUTO {OFF|0|ON|1|ONCE}
[SOURce[1|2]:]VOLTage:RANGe:AUTO?

Disables or enables voltage autoranging for all functions. Selecting ONCE performs an immediate autorange and then turns autoranging OFF

Parameter | Typical Return
{OFF|0|ON|1|ONCE}, default ON | 0 (OFF) or 1 (ON)
Turn voltage autoranging OFF: VOLT:RANG:AUTO 0
  • In the default mode, autoranging is enabled and the instrument automatically selects the optimal settings for the output waveform generator and attenuator.
  • With autoranging disabled (OFF), the instrument uses the instrument's current gain and attenuator settings.
  • The APPLy command overrides the voltage autorange setting and automatically enables autoranging (ON).
  • Disabling autoranging eliminates momentary disruptions caused by attenuator switching while changing amplitude. However, the amplitude and offset accuracy and resolution (and waveform fidelity) may be adversely affected when reducing the amplitude below the expected range change.
  • If a VOLTage:COUPle[:STATe] is ON, changing this setting on either channel changes it on both.

[SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}
[SOURce[1|2]:]VOLTage:UNIT?

Selects the units for output amplitude.

Parameter | Typical Return
{VPP|VRMS|DBM}, default VPP | VPP, VRMS, or DBM
Set output amplitude units to Vrms: VOLT:UNIT VRMS
  • Does not affect offset voltage (VOLTage:OFFSet), high level (VOLTage:HIGH) or low level (VOLTage:LOW). They all use units of volts.
  • The instrument uses the current units selection for both front panel and remote interface operations. For example, if you select "VRMS" from the remote interface (VOLTage:UNIT VRMS), the units are displayed as "VRMS" on the front panel.
  • Command applies to VOLTage? query results.
  • Output units for amplitude cannot be set to dBm if the output termination is set to "high impedance." The units are automatically converted to Vpp.
  • Arbitrary waveform sequences do not accept units of Vrms or dBm.
  • Unless you specify the units as part of either the VOLTage command or one of the APPLy commands, the VOLTage:UNIT command takes precedence. For example, if you select VOLTage:UNIT VRMS and do not include units with an APPLy command, the <amplitude> in the APPLy command will be in "Vrms".


Programming Examples

These programming examples help you get started with common tasks.

Configure a Sine Wave

Configure a Square Wave

Configure a Ramp Wave

Configure a Pulse Wave

Create a List of Frequencies

Configure an Arbitrary Waveform


Configure a Sine Wave

This section describes the configuration of a sine wave function.

Description

A sine wave has amplitude, offset, and phase relative to sync pulse. Its amplitude and offset can also be set using high and low voltage values.

Example

The following waveform can be set up with the series of SCPI commands, where high and low can be used in place of SOUR:VOLT and SOUR:VOLT:OFFS.

The following commands produce the sine wave shown above.

FUNCtion SIN
FREQuency +1.0E+05
VOLTage:HIGH +2.0
VOLTage:LOW +0.0
OUTPut ON
PHASe +90.0

Remarks

  • Although period can be adjusted from the front panel, there is no SOUR:FUNC:SIN:PER or SOUR:PER command that can be used in addition to SOUR:FREQ.


Configure a Square Wave

Description

A square wave has amplitude, offset, and phase relative to sync pulse. It also has duty cycle and period. Its amplitude and offset can also be set using high and low voltage values.

Example

The following waveform can be set up with the series of SCPI commands, where high and low can be used in place of SOUR:VOLT and SOUR:VOLT:OFFS.

The following commands produce the square wave shown above.

FUNC SQU
FUNC:SQU:DCYC +20.0
FREQ +1.0E+04
VOLT:HIGH +4.0
VOLT:LOW +0.0
OUTP 1

Remarks

  • For Square Wave, if you change SOUR:FREQ, the SOUR:FUNC:SQU:PER will change. For example, SOUR:FREQ +2.0E+03 is equivalent to SOUR:FUNC:SQU:PER +5.0E-04.


Configure a Ramp Wave

Description

A ramp wave has amplitude, offset, and phase relative to sync pulse. It also has symmetry for creating triangular and other similar waveforms. Its amplitude and offset can also be set using high and low voltage values.

Example

The following waveform can be set up with the series of SCPI commands, where high and low can be used in place of SOUR:VOLT and SOUR:VOLT:OFFS.

The following commands produce the ramp wave shown above.

FUNCtion RAMP
FUNCtion:RAMP:SYMMetry 25
FREQ +1.0E+03
VOLTage +2.0
VOLTage:OFFSet +1.0
OUTP 1

Remarks

  • Ramp frequency is limited to 200 kHz.
  • Although period can be adjusted from the instrument's front panel, there is no SOUR:FUNC:RAMP:PER or SOUR:PER command that can be used in addition to SOUR:FREQ.


Configure a Pulse Wave

Description

A pulse wave has amplitude, offset, and phase relative to sync pulse. It also adds edge slope, period, and duty cycle (or pulse width, depending on the FUNC:PULSe:HOLD configuration). Its amplitude and offset can also be set using high and low voltage values.

Example

The following waveform can be set up with the series of SCPI commands, where high and low can be used in place of SOUR:VOLT and SOUR:VOLT:OFFS.

The following commands produce the pulse wave shown above.

FUNC PULS
FUNC:PULS:TRAN:LEAD 4E-8
FUNC:PULS:TRAN:TRA 1E-6
FUNC:PULS:WIDT 3E-6
FREQ 2E5
VOLT 3
OUTP ON

Remarks

  • You can use FUNC:PULS:PER instead of FREQ. These commands are paired; changing one changes the other.
  • Pulse can be specified by width or duty cycle, which are also coupled. Use FUNCtion:PULSe:HOLD DCYC to specify that duty cycle is held constant value as frequency or period changes. Use FUNCtion:PULSe:HOLD WIDTh to specify that pulse width is held constant as frequency or period changes.


Create a List of Frequencies

Description

The LIST commands set the instrument's output frequency according to entries in a frequency list, which allows fast changing to frequencies in a list of up to 128 frequencies. The frequencies to be used are entered using the LIST:FREQuency command, or they may be read from a file using MMEMory:LOAD:LIST[1|2].

Examples

The following code demonstrates the LIST:FREQuency method.

FUNCtion SQU
TRIGger:SOURce IMMediate
FREQuency:MODE LIST
LIST:DWELl +5.0E-03
LIST:FREQuency +1.0E+03,+3.0E+03,+7.0E+03
VOLTage +1.0
OUTPut 1

The results of this code are shown below.


Configure an arbitrary waveform

This section describes the configuration of an arbitrary waveform.

Description

A user-created arbitrary waveform has amplitude, offset, sample rate, and filter type. These can be set when the arbitrary waveform file (.arb or .barb extension) is loaded into waveform memory. The beginning of a typical arbitrary waveform is shown below; note that amplitude and offset are represented by high and low voltage values:

File Format:1.10
Checksum:0
Channel Count:1
Sample Rate:20000.000000
High Level:2.000000
Low Level:0.000000
Marker Point:50
Data Type:"short"
Filter:"off"
Data Points:100
Data:
23259
23114

The 23259 and 23114 lines after the Data: line are ASCII DAC codes representing the first two waveform data values. If the waveform's DAC codes do not range from -32767 to + 32767, the output amplitude is asymmetric.

In firmware revisions 1.12 and before, the instrument did not update waveform metadata (sample rate, voltage range, and filter setting) when switching from one arbitrary waveform to another. The new arbitrary waveform adopted the metadata of the waveform already in memory. Therefore, an arbitrary waveform designed to play at one voltage range, sample rate, and filter setting (as specified in the waveform’s metadata) was changed to another set of metadata. After firmware revision 1.12, arbitrary waveforms load any metadata present in the arbitrary waveform file, so that they play the way they previously played.

Built-in waveforms make few or no changes when loaded into waveform memory. They play according to the instrument’s current configuration. For example, see the beginning of Haversine.arb, shown below.

Copyright: Keysight Technologies, 2010
File Format:1.0
Channel Count:1
Data Points:40
Data:
0
202
802

Because of the missing metadata, the current settings for voltage range, sample rate, and filter setup are used.

Example

The following code loads and modifies a built-in arbitrary waveform.

FUNCtion ARB
VOLTage +3
VOLTage:OFFSet +1
FUNC:ARB:SRAT 1E5
FUNCtion:ARBitrary "INT:\BUILTIN\EXP_RISE.ARB"
OUTPut 1

The waveform resulting from these commands is shown below.


Command Quick Reference

Keysight Trueform Series Command Quick Reference

See the Syntax Conventions for SCPI.

APPLy Commands

[SOURce[1|2]:]APPLy?

[SOURce[1|2]:]APPLy:ARBitrary [{<sample_rate>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:DC [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:NOISe [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:PRBS [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:PULSe [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:RAMP [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:SINusoid [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:SQUare [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

[SOURce[1|2]:]APPLy:TRIangle [{<frequency>|MIN|MAX|DEF} [,{<amplitude>|MIN|MAX|DEF} [,{<offset>|MIN|MAX|DEF}]]]

DATA Commands

[SOURce[1|2]:]DATA:ARBitrary2:FORMat {AABB|ABAB}

[SOURce[1|2]:]DATA:ARBitrary[1|2] <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ARBitrary[1|2]:DAC <arb_name>, {<binary_block>|<value>, <value>, . . .}

[SOURce[1|2]:]DATA:ATTRibute:AVERage? [<arb_name>]

[SOURce[1|2]:]DATA:ATTRibute:CFACtor? [<arb_name>]

[SOURce[1|2]:]DATA:ATTRibute:POINts? [<arb_name>]

[SOURce[1|2]:]DATA:ATTRibute:PTPeak? [<arb_name>]

[SOURce[1|2]:]DATA:SEQuence <block_descriptor>

[SOURce[1|2]:]DATA:VOLatile:CATalog?

[SOURce[1|2]:]DATA:VOLatile:CLEar

[SOURce[1|2]:]DATA:VOLatile:FREE?

Arrow to top

Output Configuration Commands

[SOURce[1|2]:]FUNCtion <function>
[SOURce[1|2]:]FUNCtion?

FREQUENCY CONTROL

[SOURce[1|2]:]FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:CENTer {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:CENTer? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:COUPle:MODE {OFFSet|RATio}
[SOURce[1|2]:]FREQuency:COUPle:MODE?

[SOURce[1|2]:]FREQuency:COUPle:OFFSet {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:COUPle:OFFSet?

[SOURce[1|2]:]FREQuency:COUPle:RATio <ratio>
[SOURce[1|2]:]FREQuency:COUPle:RATio?

[SOURce[1|2]:]FREQuency:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]FREQuency:COUPle[:STATe]?

[SOURce[1|2]:]FREQuency:MODE {CW|LIST|SWEep|FIXed}
[SOURce[1|2]:]FREQuency:MODE?

[SOURce[1|2]:]FREQuency:SPAN {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:SPAN? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:STARt {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:STARt? [{MINimum|MAXimum}]

[SOURce[1|2]:]FREQuency:STOP {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FREQuency:STOP? [{MINimum|MAXimum}]

FREQUENCY LIST MODE

[SOURce[1|2]:]LIST:DWELl {<seconds>|MINimum|MAXimum}
[SOURce[1|2]:]LIST:DWELl? [{MINimum|MAXimum}]

[SOURce[1|2]:]LIST:FREQuency <freq1>[, <freq2>, etc.]
[SOURce[1|2]:]LIST:FREQuency?

[SOURce[1|2]:]LIST:FREQuency:POINts? [{MINimum|MAXimum}]

MMEMory:LOAD:LIST[1|2] <filename>

MMEMory:STORe:LIST[1|2] <filename>

Arrow to top

VOLTAGE

[SOURce[1|2]:]VOLTage {<amplitude>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]VOLTage:COUPle[:STATe]?

[SOURce[1|2]:]VOLTage:HIGH {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:HIGH? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LOW {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LOW? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LIMit:HIGH {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LIMit:HIGH? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:LIMit:LOW {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:LIMit:LOW? {MINimum|MAXimum}?

[SOURce[1|2]:]VOLTage:LIMit:STATe {ON|1|OFF|0}
[SOURce[1|2]:]VOLTage:LIMit:STATe?

[SOURce[1|2]:]VOLTage:OFFSet {<offset>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]VOLTage:OFFSet? [{MINimum|MAXimum}]

[SOURce[1|2]:]VOLTage:RANGe:AUTO {OFF|0|ON|1|ONCE}
[SOURce[1|2]:]VOLTage:RANGe:AUTO?

[SOURce[1|2]:]VOLTage:UNIT {VPP|VRMS|DBM}
[SOURce[1|2]:]VOLTage:UNIT?

SQUARE WAVE

[SOURce[1|2]:]FUNCtion:SQUare:DCYCle {<percent>|MINimum|MAXimum}
[SOURce[1|2]:]FUNCtion:SQUare:DCYCle? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:SQUare:PERiod {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:SQUare:PERiod? [{MINimum|MAXimum}]

RAMP

[SOURce[1|2]:]FUNCtion:RAMP:SYMMetry {<percent>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:RAMP:SYMMetry? [{MINimum|MAXimum}]

NOISE

[SOURce[1|2]:]FUNCtion:NOISe:BANDwidth {<bandwidth>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:NOISe:BANDwidth? [{MINimum|MAXimum}]

PRBS

[SOURce[1|2]:]FUNCtion:PRBS:BRATe {<bit_rate>| MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PRBS:BRATe? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PRBS:DATA <sequence_type>
[SOURce[1|2]:]FUNCtion:PRBS:DATA?

[SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PRBS:TRANsition[:BOTH]? [{MINimum|MAXimum}]

ARBITRARY WAVEFORM

[SOURce[1|2]:]FUNCtion:ARBitrary {<filename>}
[SOURce[1|2]:]FUNCtion:ARBitrary?

[SOURce[1|2]:]FUNCtion:ARBitrary:ADVance {TRIGger|SRATe}
[SOURce[1|2]:]FUNCtion:ARBitrary:ADVance?

[SOURce[1|2]:]FUNCtion:ARBitrary:FILTer {NORMal|STEP|OFF}
[SOURce[1|2]:]FUNCtion:ARBitrary:FILTer?

[SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:FREQuency? {MINimum|MAXimum}

[SOURce[1|2]:]FUNCtion:ARBitrary:PERiod {<period>|MINimum|MAXimum}DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:PERiod? {MINimum|MAXimum}

[SOURce[1|2]:]FUNCtion:ARBitrary:POINts?

[SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak {<voltage>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:PTPeak? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:ARBitrary:SRATe {<sample_rate>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:ARBitrary:SRATe? {MINimum|MAXimum}

FUNCtion:ARBitrary:BALance[:STATe] {ON|1|OFF|0} (IQ Player option only)
FUNCtion:ARBitrary:BALance[:STATe]? (IQ Player option only)

FUNCtion:ARBitrary:BALance:GAIN {<percent>|MINimum|MAXimum|DEFine} (IQ Player option only)
FUNCtion:ARBitrary:BALance:GAIN? [{MINimum|MAXimum}] (IQ Player option only)

FUNCtion:ARBitrary:BALance:OFFSet{1|2} {<volts>|MINimum|MAXimum|DEFault} (IQ Player option only)
FUNCtion:ARBitrary:BALance:OFFSet{1|2}? [MINimum|MAXimum] (IQ Player option only)

FUNCtion:ARBitrary:SKEW[:STATe] {ON|1|OFF|0} (IQ Player option only)
FUNCtion:ARBitrary:SKEW[:STATe]? (IQ Player option only)

FUNCtion:ARBitrary:SKEW:TIME [{<time>|MINimum|MAXimum|DEFault}] (IQ Player option only)
FUNCtion:ARBitrary:SKEW:TIME? [{MINimum|MAXimum}] (IQ Player option only)

[SOURce[1|2]:]FUNCtion:ARBitrary:SYNChronize

[SOURce[1|2]:]RATE:COUPle[:STATe] {ON|1|OFF|0}
[SOURce[1|2]:]RATE:COUPle[:STATe]?

[SOURce[1|2]:]RATE:COUPle:MODE {OFFSet|RATio}
[SOURce[1|2]:]RATE:COUPle:MODE?

[SOURce[1|2]:]RATE:COUPle:OFFSet {<sample_rate>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]RATE:COUPle:OFFSet?

[SOURce[1|2]:]RATe:COUPle:RATio {<ratio>|MINimum|MAXimum}
[SOURce[1|2]:]RATe:COUPle:RATio? [{MINimum|MAXimum}]

Arrow to top

OUTPUT

OUTPut[1|2] {ON|1|OFF|0}
OUTPut[1|2]?

OUTPut[1|2]:LOAD {<ohms>|INFinity|MINimum|MAXimum|DEFault}
OUTPut[1|2]:LOAD? [{MINimum|MAXimum}]

OUTPut[1|2]:MODE {NORMal|GATed}
OUTPut[1|2]:MODE?

OUTPut[1|2]:POLarity {NORMal|INVerted}
OUTPut[1|2]:POLarity?

OUTPut:SYNC {ON|1|OFF|0}
OUTPut:SYNC?

OUTPut[1|2]:SYNC:MODE {NORMal|CARRier|MARKer}
OUTPut[1|2]:SYNC:MODE?

OUTPut[1|2]:SYNC:POLarity {NORMal|INVerted}
OUTPut[1|2]:SYNC:POLarity?

OUTPut:SYNC:SOURce {CH1|CH2}
OUTPut:SYNC:SOURce?

OUTPut:TRIGger {ON|1|OFF|0}
OUTPut:TRIGger?

OUTPut:TRIGger:SLOPe {POSitive|NEGative}
OUTPut:TRIGger:SLOPe?

OUTPut:TRIGger:SOURce {CH1|CH2}
OUTPut:TRIGger:SOURce?

Pulse Configuration Commands

[SOURce[1|2]:]FUNCtion:PULSe:DCYCle {<percent>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:DCYCle? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:HOLD {WIDTh|DCYCle}
[SOURce[1|2]:]FUNCtion:PULSe:HOLD?

[SOURce[1|2]:]FUNCtion:PULSe:PERiod {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:PERiod? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition[:BOTH] {<seconds>|MINimum|MAXimum|DEFault}

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:LEADing? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:TRANsition:TRAiling? [{MINimum|MAXimum}]

[SOURce[1|2]:]FUNCtion:PULSe:WIDTh {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FUNCtion:PULSe:WIDTh? [{MINimum|MAXimum}]

Arrow to top

Modulation Commands

AM

[SOURce[1|2]:]AM[:DEPTh] {<depth_in_percent>|MINimum|MAXimum}
[SOURce[1|2]:]AM[:DEPTh]? [{MINimum|MAXimum}]

[SOURce[1|2]:]AM:DSSC {ON|1|OFF|0}
[SOURce[1|2]:]AM:DSSC?

[SOURce[1|2]:]AM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]AM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]AM:INTernal:FUNCtion <function>
[SOURce[1|2]:]AM:INTernal:FUNCtion?

[SOURce[1|2]:]AM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]AM:SOURce?

[SOURce[1|2]:]AM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]AM:STATe?

FM

[SOURce[1|2]:]FM[:DEViation] {<peak_deviation_in_Hz>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FM[:DEViation]? [{MINimum|MAXimum}]

[SOURce[1|2]:]FM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]FM:INTernal:FUNCtion <function>
[SOURce[1|2]:]FM:INTernal:FUNCtion?

[SOURce[1|2]:]FM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]FM:SOURce?

[SOURce[1|2]:]FM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]FM:STATe?

BPSK Commands

[SOURce[1|2]:]BPSK:SOURce {INTernal|EXTernal}
[SOURce[1|2]:]BPSK:SOURce?

[SOURce[1|2]:]BPSK:STATe {ON|1|OFF|0}
[SOURce[1|2]:]BPSK:STATe?

[SOURce[1|2]:]BPSK:INTernal:RATE {<modulating_frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]BPSK:INTernal:RATE? [{MINimum|MAXimum}]

[SOURce[1|2]:]BPSK[:PHASe] {<angle>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]BPSK[:PHASe]? [{MINimum|MAXimum}]

Arrow to top

PM

[SOURce[1|2]:]PM:DEViation {<deviation in degrees>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PM:DEViation? [{MINimum|MAXimum}]

[SOURce[1|2]:]PM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]PM:INTernal:FUNCtion <function>
[SOURce[1|2]:]PM:INTernal:FUNCtion?

[SOURce[1|2]:]PM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]PM:SOURce?

[SOURce[1|2]:]PM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PM:STATe?

FSK

[SOURce[1|2]:]FSKey:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]FSKey:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]FSKey:INTernal:RATE {<rate_in_Hz>|MINimum|MAXimum}
[SOURce[1|2]:]FSKey:INTernal:RATE? [{MINimum|MAXimum}]

[SOURce[1|2]:]FSKey:SOURce {INTernal|EXTernal}
[SOURce[1|2]:]FSKey:SOURce?

[SOURce[1|2]:]FSKey:STATe {ON|1|OFF|0}
[SOURce[1|2]:]FSKey:STATe?

PWM

[SOURce[1|2]:]PWM:DEViation {<deviation>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:DEViation? [{MINimum|MAXimum}]

[SOURce[1|2]:]PWM:DEViation:DCYCle {<deviation_in_pct>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:DEViation:DCYCle? [{MINimum|MAXimum}]

[SOURce[1|2]:]PWM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PWM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]PWM:INTernal:FUNCtion <function>
[SOURce[1|2]:]PWM:INTernal:FUNCtion?

[SOURce[1|2]:]PWM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]PWM:SOURce?

[SOURce[1|2]:]PWM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PWM:STATe?

SUM

[SOURce[1|2]:]SUM:AMPLitude {<amplitude>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SUM:AMPLitude? [{MINimum|MAXimum}]

[SOURce[1|2]:]SUM:INTernal:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SUM:INTernal:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]SUM:INTernal:FUNCtion <function>
[SOURce[1|2]:]SUM:INTernal:FUNCtion?

[SOURce[1|2]:]SUM:SOURce {INTernal|EXTernal|CH1|CH2}
[SOURce[1|2]:]SUM:SOURce?

[SOURce[1|2]:]SUM:STATe {ON|1|OFF|0}
[SOURce[1|2]:]SUM:STATe?

Arrow to top

Frequency Sweep

[SOURce[1|2]:]SWEep:HTIMe {<hold_time>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:HTIMe? [{MINimum|MAXimum}]

[SOURce[1|2]:]SWEep:RTIMe {<return_time>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:RTIMe? [{MINimum|MAXimum}]

[SOURce[1|2]:]SWEep:SPACing {LINear|LOGarithmic}
[SOURce[1|2]:]SWEep:SPACing?

[SOURce[1|2]:]SWEep:STATe {ON|1|OFF|0}
[SOURce[1|2]:]SWEep:STATe?

[SOURce[1|2]:]SWEep:TIME {<seconds>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]SWEep:TIME? [{MINimum|MAXimum}]

Burst Mode

[SOURce[1|2]:]BURSt:GATE:POLarity {NORMal|INVerted}
[SOURce[1|2]:]BURSt:GATE:POLarity?

[SOURce[1|2]:]BURSt:INTernal:PERiod {<seconds>|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:INTernal:PERiod? [{MINimum|MAXimum}]

[SOURce[1|2]:]BURSt:MODE {TRIGgered|GATed}
[SOURce[1|2]:]BURSt:MODE?

[SOURce[1|2]:]BURSt:NCYCles {<num_cycles>|INFinity|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:NCYCles? [{MINimum|MAXimum}]

[SOURce[1|2]:]BURSt:PHASe {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]BURSt:PHASe? [{MINimum|MAXimum}]

[SOURce[1|2]:]BURSt:STATe {ON|1|OFF|0}
[SOURce[1|2]:]BURSt:STATe?

Marker

[SOURce[1|2]:]MARKer:CYCle {<cycle_num>|MINimum|MAXimum|DEFault}

[SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault}

[SOURce[1|2]:]MARKer:POINt {<sample_number>|MINimum|MAXimum}

Trigger Setup

TRIGger[1|2]

TRIGger[1|2]:COUNt {<number>MINimum|MAXimum|DEFault}
TRIGger[1|2]:COUNt? [{MINimum|MAXimum}]

TRIGger[1|2]:DELay {<seconds>|MINimum|MAXimum}
TRIGger[1|2]:DELay? [{MINimum|MAXimum}]

TRIGger[1|2]:LEVel {<level>|MINimum|MAXimum}
TRIGger[1|2]:LEVel? [{MINimum|MAXimum}]

TRIGger[1|2]:SLOPe {POSitive|NEGative}
TRIGger[1|2]:SLOPe?

TRIGger[1|2]:SOURce {IMMediate|EXTernal|TIMer|BUS}
TRIGger[1|2]:SOURce?

TRIGger[1|2]:TIMer {<seconds>|MINimum|MAXimum}
TRIGger[1|2]:TIMer? [{MINimum|MAXimum}]

Arrow to top

State Storage

MEMory:NSTates?

MEMory:STATe:CATalog?

MEMory:STATe:DELete {0|1|2|3|4|}

MEMory:STATe:NAME {0|1|2|3|4} [,<name>]
MEMory:STATe:NAME? {0|1|2|3|4}

MEMory:STATe:RECall:AUTO {ON|1|OFF|0}
MEMory:STATe:RECall:AUTO?

MEMory:STATe:VALid? {0|1|2|3|4}

Mass Memory

MMEMory:CATalog[:ALL]? [<folder>]

MMEMory:CATalog:DATA:ARBitrary? [<folder>]

MMEMory:CATalog:STATe? [<folder>]

MMEMory:CDIRectory <folder>
MMEMory:CDIRectory?

MMEMory:COPY <file1>,<file2>

MMEMory:COPY:SEQuence <source>,<destination>

MMEMory:DELete <file>

MMEMory:DOWNload:DATA <binary_block>

MMEMory:DOWNload:FNAMe <filename>

MMEMory:LOAD:ALL <filename>

MMEMory:LOAD:DATA[1|2] <filename>

MMEMory:LOAD:LIST[1|2] <filename>

MMEMory:LOAD:STATe <filename>

MMEMory:MDIRectory <folder>

MMEMory:MOVE <file1>,<file2>

MMEMory:RDIRectory <folder>

MMEMory:STORe:ALL <filename>

MMEMory:STORe:DATA[1|2] <filename>

MMEMory:STORe:LIST[1|2] <filename>

MMEMory:STORe:STATe <filename>

MMEMory:UPLoad? <filename>

Display

DISPlay {ON|1|OFF|0}
DISPlay?

DISPlay:TEXT "<string>"
DISPlay:TEXT?

DISPlay:TEXT:CLEar

DISPlay:UNIT:ARBRate {SRATe|FREQuency|PERiod}

DISPlay:UNIT:PULse {WIDTh|DUTY}

DISPlay:UNIT:RATE {FREQuency|PERiod}

DISPlay:UNIT:SWEep {STARtstop|CENTerspan}

DISPlay:UNIT:VOLT {AMPLitudeoff|HIGHlow}

DISPlay:VIEW {STANdard|TEXT|GRAPh|DUAL}

Screen Shots

HCOPy:SDUMp:DATA?

HCOPy:SDUMp:DATA:FORMat {PNG|BMP}
HCOPy:SDUMp:DATA:FORMat?

Arrow to top

LXI

LXI:IDENtify[:STATE] {ON|1|OFF|0}
LXI:IDENtify[:STATE]?

LXI:MDNS:ENABle {ON|1|OFF|0}
LXI:MDNS:ENABle?

LXI:MDNS:HNAMe:RESolved?

LXI:MDNS:SNAMe:DESired <name>
LXI:MDNS:SNAMe:DESired?

LXI:MDNS:SNAMe[:RESolved]?

LXI:RESet

LXI:RESTart

Remote Interface Configuration

SYSTem:COMMunicate:ENABle {ON|1|OFF|0}, <interface>
SYSTem:COMMunicate:ENABle? <interface>

SYSTem:COMMunicate:GPIB:ADDRess <address>
SYSTem:COMMunicate:GPIB:ADDRess?

SYSTem:COMMunicate:LAN:CONTrol?

SYSTem:COMMunicate:LAN:DHCP {ON|1|OFF|0}
SYSTem:COMMunicate:LAN:DHCP?

SYSTem:COMMunicate:LAN:DNS[1|2] "<address>"
SYSTem:COMMunicate:LAN:DNS[1|2]? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:DOMain?

SYSTem:COMMunicate:LAN:GATeway "<address>"
SYSTem:COMMunicate:LAN:GATeway? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:HOSTname "<name>"
SYSTem:COMMunicate:LAN:HOSTname? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:IPADdress "<address>"
SYSTem:COMMunicate:LAN:IPADdress? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:MAC?

SYSTem:COMMunicate:LAN:SMASk "<mask>"
SYSTem:COMMunicate:LAN:SMASk? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:TELNet:PROMpt "<string>"
SYSTem:COMMunicate:LAN:TELNet:PROMpt?

SYSTem:COMMunicate:LAN:TELNet:WMESsage "<string>"
SYSTem:COMMunicate:LAN:TELNet:WMESsage?

SYSTem:COMMunicate:LAN:UPDate

SYSTem:COMMunicate:LAN:WINS[1|2] "<address>"
SYSTem:COMMunicate:LAN:WINS[1|2]? [{CURRent|STATic}]

System

SYSTem:BEEPer[:IMMediate]

SYSTem:BEEPer:STATe {ON|1|OFF|0}
SYSTem:BEEPer:STATe?

SYSTem:CLICk:STATe{ON|1|OFF|0}
SYSTem:CLICk:STATe?

SYSTem:DATE <yyyy>, <mm>, <dd>
SYSTem:DATE?

SYSTem:ERRor?

SYSTem:LICense:CATalog?

SYSTem:LICense:DELete "<option_name>"

SYSTem:LICense:DELete:ALL

SYSTem:LICense:DESCription? "<option_name>"

SYSTem:LICense:ERRor?

SYSTem:LICense:ERRor:COUNt?

SYSTem:LICense:INSTall "<file>"
SYSTem:LICense:INSTall? "<option>"

SYSTem:LOCK:NAME?

SYSTem:LOCK:OWNer?

SYSTem:LOCK:RELease

SYSTem:LOCK:REQuest?

SYSTem:SECurity:IMMediate

SYSTem:TIME <hh>, <mm>, <ss>
SYSTem:TIME?

SYSTem:VERSion?

Arrow to top

Phase

[SOURce[1|2]:]PHASe {<angle>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]PHASe? [{MINimum|MAXimum}]

[SOURce[1|2]:]PHASe:ARBitrary {<angle>|MINimum|MAXimum}

[SOURce[1|2]:]PHASe:MODulation {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]PHASe:MODulation?

[SOURce[1|2]:]PHASe:REFerence

[SOURce[1|2]:]PHASe:SYNChronize

[SOURce[1|2]:]PHASe:UNLock:ERRor:STATe {ON|1|OFF|0}
[SOURce[1|2]:]PHASe:UNLock:ERRor:STATe?

Reference oscillator

ROSCillator:SOURce {INTernal|EXTernal}
ROSCillator:SOURce?

ROSCillator:SOURce:AUTO {ON|OFF}
ROSCillator:SOURce:AUTO?

ROSCillator:SOURce:CURRent?

Calibration

CALibration[:ALL]?

CALibration:COUNt?

CALibration:SECure:CODE <new_code>

CALibration:SECure:STATe {ON|1|OFF|0} [,<code>]
CALibration:SECure:STATe?

CALibration:SETup <step>
CALibration:SETup?

CALibration:STORe

CALibration:STRing "<string>"
CALibration:STRing?

CALibration:VALue <value>
CALibration:VALue?

IEEE-488

*CLS

*ESE <enable_value>

*ESE?

*ESR?

*IDN?

*OPC

*OPC?

*OPT?

*PSC {0|1}
*PSC?

*RCL {0|1|2|3|4}

*RST

*SAV {0|1|2|3|4}

*SRE <enable_value>
*SRE?

*STB?

*TRG

*TST?

*WAI

Arrow to top

Status

STATus:OPERation:CONDition?

STATus:OPERation:ENABle <enable_value>
STATus:OPERation:ENABle?

STATus:OPERation[:EVENt]?

STATus:PRESet

STATus:QUEStionable:CONDition?

STATus:QUEStionable:ENABle <enable_value>
STATus:QUEStionable:ENABle?

STATus:QUEStionable[:EVENt]?

Miscellaneous

ABORt

[SOURce[1|2]:]PHASe:ARBitrary {<angle>|MINimum|MAXimum}
[SOURce[1|2]:]PHASe:ARBitrary?

[SOURce[1|2]:]COMBine:FEED {CH1|CH2|NONE}
[SOURce[1|2]:]COMBine:FEED?

FORMat:BORDer {NORMal|SWAPped}
FORMat:BORDer?

INITiate[1|2]:CONTinuous {ON|1|OFF|0}
INITiate[1|2]:CONTinuous?

INITiate:CONTinuous:ALL {ON|1|OFF|0}

INITiate[1|2][:IMMediate]

INITiate[:IMMediate]:ALL

[SOURce[1|2]:]MARKer:CYCle {<cycle_num>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]MARKer:CYCLe? [{MINimum|MAXimum}]

INPut:ATTenuation[:STATe] {ON|1|OFF|0}
INPut:ATTenuation[:STATe]?

[SOURce[1|2]:]MARKer:FREQuency {<frequency>|MINimum|MAXimum|DEFault}
[SOURce[1|2]:]MARKer:FREQuency? [{MINimum|MAXimum}]

[SOURce[1|2]:]MARKer:POINt {<sample_number>|MINimum|MAXimum}
[SOURce[1|2]:]MARKer:POINt? [{MINimum|MAXimum}]

[SOURce[1|2]:]TRACk {ON|OFF|INVerted}
TRACk?

UNIT:ANGLe {DEGree|RADian|SECond|DEFault}
UNIT:ANGLe?

UNIT:ARBitrary:ANGLe {DEGree|RADian|SECond|SAMPle|DEFault}
UNIT:ARBitrary:ANGLe?

Arrow to top


Factory Reset State

The following tables show factory default settings. Parameters marked with a bullet (•) are non-volatile, and are not affected by power cycling or *RST. Other parameters are volatile and reset to the indicated values at power-on or after *RST.

Note

The power-on/reset state may differ from that shown below if you have enabled power-on state recall mode from the [System] menu. See Instrument State Storage.
Output Channel Configuration
Function | Sine
Tracking | Off
Frequency | 1 kHz
Frequency Mode | CW
Frequency Couple State | OFF
Frequency Couple Mode | Ratio
Frequency Couple Ratio | 1
Frequency Couple Offset | 0
Amplitude | 100 mVpp
Offset | 0 VDC
Voltage Couple State | OFF
Voltage Limit State | OFF
Voltage Limit High | 5 V
Voltage Limit Low | -5 V
Voltage Unit | VPP
Voltage Range | AUTO
State | OFF
Load | 50 Ω
Polarity | Normal
Mode (Normal vs. Gated) | Normal
Sync Polarity | Normal
Sync Mode | Normal
Output Channel Configuration
Sync State | ON
Sync Source | CH1
Trigger Source | CH1
Trigger Slope | Positive
Trigger State | OFF
Noise
Bandwidth | 100 kHz
PRBS
Data | PN7
Bit Rate | 1 kbps
Transition | 8.4E-09
Pulse
Duty Cycle | 10%
Period | 1 ms
Leading/Trailing Edge | 10 ns
Width | 0.1 ms
Ramp
Symmetry | 100
Square
Duty Cycle | 50%
Period | 1 ms
Arbitrary Waveforms
Arb | Exponential Rise
Filter | STEP
Sample Rate | 40 kSa/sec
Advance | SRATE
Marker Point | Mid point of arb
Amplitude Modulation
State | OFF
Modulation Source | Internal
Internal Function | Sine
Internal Frequency | 100 Hz
Depth | 100%
DSSC | OFF
Frequency Modulation
State | OFF
Modulation Source | Internal
Internal Function | Sine
Internal Frequency | 10 Hz
Deviation | 100 Hz
FSK Modulation
State | OFF
Modulation Source | Internal
Internal Rate | 10 Hz
Frequency | 100 Hz
Phase Modulation
State | OFF
Modulation Source | Internal
Function | Sine
Frequency | 10 Hz
Deviation | 180 degrees
BPSK Modulation
State | OFF
Modulation Source | Internal
Internal Rate | 10 Hz
Phase | 180 degrees
Pulse Width Modulation
State | OFF
Modulation Source | Internal
Function | Sine
Frequency | 10 Hz
Deviation | 1% or 1E-5 sec, depending on how specified
SUM
State | OFF
Source | Internal
Function | Sine
Frequency | 100 Hz
Sum Amplitude | 0.10%
Phase Control
Phase Adjust | 0 degrees
Unlock Error State | OFF
Units | degrees
Reference Oscillator
Source Auto | ON
Source | Internal
Burst
State | OFF
Gate Polarity | Normal
Mode | Triggered
Cycles | 1
Period | 10 ms
Phase | 0 degrees
Marker Cycle | 2
Sweep
State | OFF
Spacing | Linear
Start Freq | 100 Hz
Stop Freq | 1 kHz
Center Freq | 550 Hz
Span | 900 Hz
Marker Freq | 500 Hz
Sweep Time | 1 sec
Hold Time | 0 sec
Return Time | 0 sec
List
Frequency | 100, 1000, 550 Hz
Points | 3
Dwell | 1 sec
Trigger
Delay | 0 sec
Slope | Positive
Source | Immediate
Timer | 1 sec
Init Continuous | ON
Count | 1
Channel Independent Trigger Configuration
Init Continuous All | ON
Miscellaneous
Format Byte Order | Normal
Combine Feed | NONE
The following items do not relate to channel configuration.
Display
State | ON
Text ""
Hcopy Format | PNG
Remote Interface Communication
GPIB Address • | 10
DHCP • | Enabled
IP Address static • | 169.254.5.21
Subnet Mask static • | 255.255.0.0
Gateway static • | 0.0.0.0
DNS primary server • | 0.0.0.0
DNS secondary server • | 0.0.0.0
Hostname static • | "A-33xxxx-nnnnn" or "A-33xxxx-nnnnn", where xxxx is the last three digits of the model number, and nnnnn is the last 5 digits of the instrument's serial number
Telnet Prompt • | 33xxxx>, where xxxx is the last four digits of the model number.
Telnet Welcome Message • | Welcome to Keysight's 33xxxx Waveform Generator, where xxxx is the last four digits of the model number.
WINS primary server • | 0.0.0.0
WINS secondary server • | 0.0.0.0
System
Beep State | ON
Power Down Recall • | OFF
LXI
Identify | OFF
Calibration
Calibration State | Secured

Note

The instrument uses LAN port 5024 for SCPI Telnet sessions, and port 5025 for SCPI Socket sessions.


SCPI Error Messages

The instrument returns error messages in accord with the SCPI standard.

  • Up to 20 command syntax or hardware errors can be stored in each interface-specific error queue (one each for GPIB, USB, VXI-11, and Telnet/Sockets.) Errors appear in the error queue of the I/O session that caused the error.
  • The instrument beeps once each time an error is generated (unless disabled by SYSTem:BEEPer:STATe OFF). The front panel ERROR annunciator turns on when one or more errors are in the error queue.
  • A special global error queue holds all power-on and hardware-related errors (for example, overtemperature).
  • Error retrieval is first-in-first-out (FIFO), and errors are cleared as you read them. Once you have read all interface-specific errors, the errors in the global error queue are retrieved. When you have read all errors from the global error queue, the ERROR annunciator turns off.
  • If more than 20 errors have occurred, the last error stored in the queue (the most recent error) is replaced with -350,"Error queue overflow". No additional errors are stored until you remove errors from the queue. If no errors have occurred when you read the error queue, the instrument responds with +0,"No error".
  • The front panel reports errors from all I/O sessions and the global error queue. To read the error queue from the front panel, press the [System] button, then the Help softkey. Then select "View remote command error queue" in the Help menu.
  • Error conditions are also summarized in the Status Byte Register. See Status Subsystem Introduction for details
  • The interface-specific error queues are cleared by power cycles and *CLS. The error queue is not cleared by *RST.
  • SCPI:

SYSTem:ERRor? Read and clear one error from the queue

Errors have the following format (the error string may contain up to 255 characters):

-113,"Undefined header"

Arrow to top

-315 Configuration memory lost; due to firmware revision change

-315 Configuration memory lost; memory corruption detected

-314 Save/recall memory lost; due to firmware revision change

-314 Save/recall memory lost; memory corruption detected

-313 Calibration memory lost

-313 Calibration memory lost; due to firmware revision change

-313 Cannot read file; due to corrupt data

-313 Cannot read file; due to file revision change

-313 Invalid number of channels for operation

-310 System error; internal software error

-310 System error; out of memory

-310 System error; software initialization failed

-292 Referenced name does not exist

-257 File name error;

access denied

drive name missing or not recognized

file or folder already exists

file too large

folder is default folder

folder not empty

invalid character in name

not a folder name

path is a folder name

path name missing

path too long

relative path not allowed

unknown file extension

Arrow to top

-256 File or folder name not found

-254 Media full

-252 Missing media

-250 Mass storage error: file read/write error

-241 Hardware missing

-241 Hardware missing; Command not valid in one channel instrument.

-240 Hardware error; GPIB interface failed

-230 Data corrupt or stale

-222 Data out of range;

AM depth

amplitude

arb frequency

arb period

burst count

burst count limited by length of burst

burst period

burst period limited by length of burst

cannot combine channel with itself. Combine disabled

duty cycle

duty cycle limited by frequency

FM deviation

FM deviation limited by maximum frequency

FM deviation limited by minimum frequency

frequency

frequency in burst mode

frequency in FM

high level limited by high soft limit

high level limited by low level

high level limited by low soft limit

high limit value limited by high signal level

large period limits minimum pulse width

low level limited by high level

low level limited by high soft limit

low level limited by low soft limit

low limit value limited by low signal level

marker confined to burst cycles

marker confined to sweep span

offset

period

PRBS edge time

PRBS edge time limited by bit rate

pulse duty cycle limited by period

pulse edge at maximum

pulse edge at minimum

pulse edge time

pulse edge time limited by duty cycle

pulse edge time limited by period

pulse edge time limited by width

pulse frequency

pulse period

pulse width

pulse width limited by period

PWM deviation

PWM deviation limited by pulse parameters

ramp frequency

ramp Symmetry

Sample rate

sample rate clipped to lower limit

sample rate clipped to upper limit

square edge time

square edge time limited by duty cycle

square edge time limited by period

square edge time limited by width

square period

square width

sum amplitude limited by channel or combine amplitudes

sum amplitude value clipped to lower limit

sweep time

Track exceeds limits on channel 1. Tracking disabled

Track exceeds limits on channel 2. Tracking disabled

trigger count clipped to lower limit

trigger count clipped to upper limit

trigger delay

trigger delay clipped to lower limit

trigger delay clipped to upper limit

trigger delay limited by length of burst

trigger level clipped to lower limit (33600 Series only)

trigger level clipped to upper limit (33600 Series only)

trigger level (33600 Series only)

trigger timer clipped to lower limit

trigger timer clipped to upper limit

trigger timer limited by length of burst

user frequency

USER setting only valid for channel 1

value clipped to dwell time's lower limit

value clipped to dwell time's upper limit

value clipped to lower limit

value clipped to sweep time's lower limit

value clipped to upper limit

value limited due to coupling

-222 List Data out of range; Arb frequency : Mode is changed to Normal (33600 Series only)

-222 List Data out of range; Pulse frequency : Mode is changed to Normal

-222 List Data out of range; Ramp frequency : Mode is changed to Normal

-222 List Data out of range; Sine frequency : Mode is changed to Normal

-222 List Data out of range; Square frequency : Mode is changed to Normal

-222 List Data out of range; User frequency : Mode is changed to Normal

Arrow to top

-221 Setting the advance mode to trigger forced the trigger source to external.

-221 Setting the Arb Filter OFF changed the maximum sample rate value to 6.25e7.

-221 Setting the trigger source changed the arb advance mode.

-221 Settings conflict;

50V input range not compatible with 50 ohm input impedance; impedance set to 1 Mohm

AM depth forced amplitude change

AM turned off by selection of other mode or modulation

amplitude changed due to function

amplitude changed due to offset

amplitude units changed to Vpp due to high-Z load

amplitude units changed to Vpp, dBm and Vrms not applicable to arb sequences

amplitude units unchanged, dBm and Vrms not applicable to arb sequences

arb advance changed to SRATE due to filter (33600 Series only)

arb advance changed to SRATE due to mode

arb voltage reduced due to output load or limits

Balance gain limited due to amplitude.

Balance offset changed due to amplitude

both edge times decreased due to period

both edge times decreased due to pulse duty cycle

both edge times decreased due to pulse width

BPSK turned off by selection of other mode or modulation

burst count reduced to fit entire burst

Burst mode has caused output phase to be set to zero degrees

burst period increased to fit entire burst

burst phase inapplicable for arbs larger than 1M. burst phase set to 0 (33500 Series only)

burst turned off by selection of other mode or modulation

Cannot combine DC function

cannot delete state selected and enabled for automatic power-on recall

Cannot modulate ARB carrier with ARB as modulation function. Modulation turned off.

Cannot modulate ARB carrier with ARB modulation function. Function unchanged.

Cannot modulate ARB carrier with USER as modulation function. Modulation turned off.

Cannot modulate ARB carrier with USER modulation function. Function unchanged.

Cannot modulate by a two-channel Arb

Cannot modulate Noise carrier with Noise as modulation function. Modulation turned off.

Cannot modulate Noise carrier with Noise modulation function. Function unchanged.

Cannot modulate PRBS carrier with PRBS as modulation function. Modulation turned off.

Cannot modulate PRBS carrier with PRBS modulation function. Function unchanged.

Cannot modulate USER carrier with ARB as modulation function. Modulation turned off.

Cannot modulate USER carrier with ARB modulation function. Function unchanged.

Cannot modulate USER carrier with USER as modulation function. Modulation turned off.

Cannot modulate USER carrier with USER modulation function. Function unchanged.

Cannot select channel as modulating source

Cannot use filter in advance arb trigger mode. (33600 Series only)

combine amplitude exceeds limit. Combine disabled

Combine turned off by selection of DC function

coupling cannot be ON with this function, coupling turned off

coupling violates settings, coupling turned off

edge time decreased due to bit rate

external gating not compatible with gate output; gate output disabled

FM deviation cannot exceed carrier

FM deviation exceeds maximum frequency

FM turned off by selection of other mode or modulation

frequency changed for pulse function

frequency changed for sine function (33600 Series only)

frequency changed for square function (33600 Series only)

frequency forced duty cycle change

frequency made compatible with burst mode (33500 Series only)

frequency reduced for ramp function

frequency reduced for user function

FSK turned off by selection of other mode or modulation

Function or modulation source cannot be USER. Tracking disabled

Function selection limited the FSK frequency.

Gated output not available for gated burst. Output mode changed to normal.

high level changed due to low level

high limit less than low limit. Limits disabled

infinite burst changed trigger source to BUS

input threshold voltage > input range; threshold clipped to range

leading edge time decreased due to period

leading edge time decreased due to pulse width

leading edge times decreased due to pulse duty cycle

limited frequency to 1MHz when sync mode carrier, burst ON, and function sine (33500 Series only)

list turned off by selection of other mode or modulation

low level changed due to high level

low reference >= high reference

marker forced into sweep span

marker off forced sync to normal mode

marker on forced sync to marker mode

marker point changed to fit arb length

modulation frequency made compatible with modulation shape

must stop operation to update trigger count

must stop operation to update trigger delay

not able to adjust phase for arb < 64 samples (33600 Series only)

not able to adjust phase in this function

not able to adjust phase in this mode

not able to burst DC, burst turned off

not able to burst this function

not able to change output load with limits enabled

not able to list arb, list turned off

not able to list DC, list turned off

not able to list noise, list turned off

not able to list PRBS, list turned off

not able to list this function

not able to modulate arb, modulation turned off

not able to modulate DC, modulation turned off

not able to modulate noise, modulation turned off

not able to modulate PRBS, modulation turned off

not able to modulate this function

not able to sweep arb, sweep turned off

not able to sweep DC, sweep turned off

not able to sweep noise, sweep turned off

not able to sweep PRBS, sweep turned off

not able to sweep this function

offset changed due to amplitude

offset changed on exit from DC function

PM turned off by selection of other mode or modulation

prbs edge time increased due to amplitude (33600 Series only)

pulse duty cycle and edge times increased due to amplitude (33600 Series only)

pulse duty cycle decreased due to period

pulse duty cycle increased due to amplitude (33600 Series only)

pulse duty cycle increased due to period

pulse edge times increased due to amplitude (33600 Series only)

pulse width and edge times increased due to amplitude (33600 Series only)

pulse width decreased due to period

pulse width increased due to amplitude (33600 Series only)

pulse width increased due to large period

PWM deviation decreased due to pulse parameters

PWM only available in pulse function

PWM turned off by selection of other mode or modulation

Range hold turned off by selection of new function (33600 Series only)

selected arb is missing, changing selection to default

selecting a sequence turned off modulation

sequences not supported, changing selection to default

signal exceeds high limit. Limits disabled

signal exceeds low limit. Limits disabled

Skew time between channels not available in Burst, Modulation, or Sweep

sum amplitude exceeds limit or range. Sum disabled

SUM turned off by selection of other mode or modulation

Sweep + Hold + Return time larger than trigger TIMER. Trig timer increased.

Sweep + Hold + Return time max (8000s) limited time setting.

Sweep + Hold + Return time max (8000s) limited time setting.

Sweep + Hold + Return time too large for IMM or TIMER trigger. Sweep turned off.

Sweep + Hold + Return time too large for IMM or TIMER trigger. Trig source unchanged.

Sweep time reduced due to log sweep setting.

sweep turned off by selection of other mode or modulation

Tracking turned off by selection of USER function or modulation source

trailing edge decreased due to leading edge

trailing edge time decreased due to period

trailing edge time decreased due to pulse width

trailing edge times decreased due to pulse duty cycle

trigger delay reduced to fit entire burst

trigger output connector used by BPSK

trigger output connector used by burst gate

trigger output connector used by FSK

trigger output connector used by trigger external

trigger output disabled

trigger output disabled by trigger external

Trigger source limited the sweep time; value clipped to upper limit

triggered burst not available for noise

turned off infinite burst to allow immediate trigger source

Use FUNC:ARB to select an ARB before selecting ARB as modulation function. Function unchanged.

Use FUNC:ARB to select an ARB before selecting ARB as modulation function. Modulation disabled.

Use FUNC:USER to select a user arb before selecting USER as modulation function. Function unchanged.

Use FUNC:USER to select a user arb before selecting USER as modulation function. Modulation disabled.

Arrow to top

-213 INIT ignored

-203 Command protected; Enter calibration password from front panel calibration menu (33500 Series only)

-203 Command protected; instrument must be unsecured (33600 Series only)

-203 Command protected; requires license BWD (33600 Series only)

-203 Command protected; requires license SEC (33600 Series only)

-203 Secure option: Instrument security is unlocked

-115 Invalid parameter; Parameter not supported on one channel instrument

-114 Header suffix out of range

100 Network Error

110 LXI mDNS Error

201 Memory lost: stored state

202 Memory lost: power-on state

203 Memory lost: stored measurements

263 Not able to execute while instrument is measuring

291 Not able to recall state: it is empty

292 State file size error

293 State file corrupt

301 Cannot reset input protection; high voltage present

305 Not able to perform requested operation

514 Not allowed

514 Not allowed; Instrument locked by another I/O session

521 Communications: input buffer overflow

522 Communications: output buffer overflow

532 Not able to achieve requested resolution

540 Cannot use overload as math reference

550 Not able to execute command in local mode

560 No valid external timebase

561 High voltage present on input channel

570 DDS Processor is not responding

580 Reference phase-locked loop is unlocked

581 Waveform DAC Timing is unlocked (33600 Series only)

581 Waveform DAC Timing regained lock (33600 Series only)

582 The DATA controller failed to lock for WFDAC (33600 Series only)

582 The MU controller failed to lock for WFDAC (33600 Series only)

582 The SYNC controller failed to lock for WFDAC (33600 Series only)

Arrow to top

600 Internal licensing error

601 License file corrupt or empty

602 No valid licenses found for this instrument

603 Some licenses could not be installed

604 License not found

605 License already installed

Most error codes between 600 and 699 refer to self-test errors. See Self-Test Procedures for details.

Arrow to top

701 Calibration error; security defeated by hardware jumper

702 Calibration error; calibration memory is secured

703 Calibration error; secure code provided was invalid

704 Calibration error: secure code too long

705 Calibration error; calibration aborted

706 Calibration error; provided value is out of range

707 Calibration error: computed correction factor out of range

707 Calibration error; signal input is out of range

708 Calibration error: signal measurement out of range

709 Calibration error: no calibration for this function/range

710 Calibration error: full scale correction out of range

710 Self-calibration failed

711 Calibration error: calibration string too long

711 Self-calibration failed

712 Calibration failed

712 Self-calibration failed

715 Self-calibration failed

720 Self-calibration failed

740 Calibration data lost: secure state

741 Calibration data lost: string data

742 Calibration data lost: corrections

748 Calibration memory write failure

770 Nonvolatile arb waveform memory corruption detected

781 Not enough memory to store new arb waveform; bad sectors

781 Not enough memory to store new arb waveform; use DATA:DELETE

782 Cannot overwrite a built-in arb waveform

784 Name of source arb waveform for copy must be VOLATILE

785 Specified arb waveform does not exist

786 Not able to delete a built-in arb waveform

786 Specified arb waveform already exists

787 Not able to delete the currently selected active arb waveform

787 Specified arb not loaded in waveform memory

788 Could not load specified arb; Loaded Built-in default arb

791 Firmware update error; unable to begin download

792 Firmware update error; programming operation failed

793 Firmware update error; data record invalid character

794 Firmware update error; data record length mismatch

795 Firmware update error; data record checksum mismatch

796 Firmware update error; bad checksum for download start

797 Firmware update error; bad checksum for download complete

798 Firmware update error; download in progress

799 Firmware update error; unable to complete download

Arrow to top

800 Firmware update error; invalid programming address

810 State has not been stored

850 Calibration error; set up is invalid

851 Calibration error; set up is out of order

870 Arb: Text File Format error; invalid format

871 Arb: Segment name is too long

872 Arb: File name is too long

873 Arb: Too many sequence steps

874 Arb: Too many segments defined

875 Arb: Too many sequences defined

876 Arb: Sequence already defined

877 Arb: Segment not found

878 Arb: Sequence not found

879 Arb: Segment edit too large

880 Arb: Out of memory

881 Arb: Channel count mismatch

881 Arb: Values are out of range

882 Arb: Segment too small

883 Arb: Error in closing file

884 Arb: Seek too large

885 Arb: Arb file cannot be stored as sequence file

886 Arb: Sequence file cannot be stored as arb file

887 File name error; not a valid extension

888 Arb: Could not create built in arb directory

889 Arb: Could not copy built in arb

890 enable combine forced tracking off

891 enable coupling forced tracking off

892 enable tracking forced coupling off

893 enable tracking forced combine off

894 Enable tracking forced range hold off (33600 Series only)

Arrow to top


Service and Repair - Introduction

This section contains basic service information for your instrument.

Types of Service Available

Cleaning

Electrostatic Discharge (ESD) Precautions

Additional service information is found here:

Block Diagram - 33500 Series

Block Diagram - 33600 Series

Power Supplies - 33500 Series

Power Supplies - 33600 Series

Troubleshooting - 33500 Series

Troubleshooting - 33600 Series

Self-Test Procedures

Replaceable Parts

Disassembly - 33500 Series

Disassembly - 33600 Series

Battery Replacement

Installing the Optional GPIB Interface

Types of Service Available

If your instrument fails during the warranty period, Keysight Technologies will repair or replace it under the terms of your warranty. After your warranty expires, Keysight offers repair services at competitive prices.

Extended Service Contracts

Many Keysight products have optional service contracts that extend coverage after the standard warranty expires.

Obtaining Repair Service (Worldwide)

To obtain service for your instrument, contact your nearest Keysight Technologies Service Center. They will arrange to have your unit repaired or replaced, and can provide warranty or repair–cost information where applicable. Ask the Keysight Technologies Service Center for shipping instructions, including what components to ship. Keysight recommends that you retain the original shipping carton for return shipments.

Repackaging for Shipment

To ship the unit to Keysight for service or repair:

  • Attach a tag to the unit identifying the owner and indicating the required service or repair. Include the model number and full serial number.
  • Place the unit in its original container with appropriate packaging material.
  • Secure the container with strong tape or metal bands.
  • If the original shipping container is unavailable, use a container that will ensure at least 10 cm (4 in.) of compressible packaging material around the entire instrument. Use static-free packaging materials.

Keysight suggests that you always insure shipments.

Cleaning

Clean the outside of the instrument with a soft, lint-free cloth slightly dampened with water only. Do not use detergent or any form of spray. Disassembly is not required or recommended for cleaning.

Electrostatic Discharge (ESD) Precautions

Almost all electrical components can be damaged by electrostatic discharge (ESD) during handling. Component damage can occur at electrostatic discharge voltages as low as 50 V.

The following guidelines will help prevent ESD damage during service operations:

  • Disassemble instruments only in a static-free work area.
  • Use a conductive work area to reduce static charges.
  • Use a conductive wrist strap to reduce static charge accumulation.
  • Minimize handling.
  • Keep replacement parts in original static-free packaging.
  • Remove all plastic, foam, vinyl, paper, and other static-generating materials from the immediate work area.
  • Use only anti-static solder suckers.


Introduction to Calibration - 33500 Series

This chapter contains procedures for verifying the instrument's performance and adjustment (calibration).

The instrument uses closed-case electronic calibration; no internal mechanical adjustments are required. The instrument calculates correction factors based on input reference values that you set and stores correction factors in non-volatile memory until the next calibration adjustment is performed. This data is not changed by cycling power or *RST.

Keysight Technologies Calibration Services

Your local Keysight Technologies Service Center offers low-cost recalibration. The service center uses automated calibration systems that allow Keysight to provide calibration at competitive prices.

Calibration Table of Contents

The section includes the following sections:

Calibration Overview

  • Calibration Interval
  • Adjustment is Recommended
  • Time Required for Calibration
  • Automating Calibration Procedures
  • Recommended Test Equipment
  • Test Considerations
  • Calibration Count
  • Calibration Message

Calibration Security

Performance Verification Tests

  • Self-Test
  • Quick Performance Check
  • Performance Verification Tests
  • Amplitude and Flatness Verification Procedures

Internal Timebase Verification

AC Amplitude (high-impedance) Verification

DC Offset Voltage Verification

-8 dB Range Flatness Verification

-24 dB Range Flatness Verification

General Calibration/Adjustment Procedure

Aborting a Calibration in Progress

Sequence of Adjustments

Self-Test

Frequency (Internal Timebase) Adjustment

Internal ADC Adjustment

Self Calibration Adjustment

Output Impedance Adjustment

AC Amplitude (high-impedance) Adjustment

-24 dB Range Flatness Adjustment

-8 dB Range Flatness Adjustment

Adjust Channel 2 (if necessary)

  • Self Calibration Adjustment (Channel 2)
  • Output Impedance Adjustment (Channel 2)
  • AC Amplitude (high-impedance) Adjustment (Channel 2)
  • -24 dB Range Flatness Adjustment (Channel 2)
  • -8 dB Range Flatness Adjustment (Channel 2)

Calibration Errors

Next Calibration Topic


Calibration Overview - 33500 Series

This section introduces the instrument's calibration features. For more detailed calibration information, see Introduction to Calibration.

Calibration Interval

The instrument should be calibrated on a regular interval determined by the accuracy requirements of your application. A one-year interval is adequate for most applications. Accuracy specifications are warranted only if adjustment is made at regular calibration intervals. Accuracy specifications are not warranted beyond the one-year calibration interval. Keysight Technologies does not recommend calibration intervals beyond two years for any application.

Adjustment is Recommended

Whatever calibration interval you select, Keysight Technologies recommends that complete re-adjustment should always be performed at the calibration interval. This ensures that the instrument will remain within specifications for the next calibration interval and provides the best long-term stability. Performance data measured using this method can be used to extend future calibration intervals. Use the Calibration Count to verify that all adjustments have been performed.

Time Required for Calibration

For incoming instrument verification, do performance verification tests first. Then perform adjustments and re-run the performance verification tests. Each of these steps, if done manually, takes approximately 30 minutes per channel to perform.

The instrument can also be automatically calibrated under computer control. With computer control you can perform the complete calibration procedure and performance verification tests in approximately 30 minutes (one channel) or 60 minutes (two channels) once the instrument is warmed-up (see Test Considerations).

Automating Calibration Procedures

You can use programmable test equipment to automate the complete verification and adjustment procedures. You can program each test's instrument configuration over the remote interface. Then enter read-back verification data into a test program and compare the results to the appropriate test limit.

You can also adjust the instrument from the remote interface, which is similar to the front panel procedure. Use a computer to perform the adjustment by first selecting the required function and range on the measurement equipment. Send the calibration value to the instrument and then initiate calibration over the remote interface.

You must unsecure the instrument before calibration.

A typical programming sequence for a single calibration setup is as follows:

  1. CAL:SETup 2 (configures instrument for calibration step 2)
  2. Measure the output frequency with the external frequency counter
  3. CAL:VALue 9.99994321E6 (send the measured value to the instrument)
  4. CAL? (initiates the calibration adjustment for setup 2)
  5. Read CAL? query value to determine the failure (+1) or success (+0) of adjustment
  6. CAL:SETup 3 (configures instrument for calibration step 3)

For further information on instrument programming, see Introduction to SCPI Language.

Recommended Test Equipment

The test equipment recommended for the performance verification and adjustment procedures is listed below. If the exact instrument is not available, substitute calibration standards of equivalent accuracy.

Instrument | Requirements | Recommended Model | Use*
Digital Multimeter (DMM) | ACV, true rms, AC coupled accuracy: ±0.02% to 1 MHz DCV accuracy: 50 ppm resolution: 100 µV Resistance Offset-compensated accuracy: ±0.1 Ω | Keysight 3458A | Q, P, T
Precision AC Voltmeter | 1000 Hz to 30 MHz, 0.1 Vrms to 2 Vrms (–7 dBm to +20 dBm) accuracy: 0.02 dB resolution: 0.01 dB | Fluke 5790A | Q, P, T
Frequency Counter | accuracy: 0.1 ppm | Keysight 53132A Opt 012 (high stability) | Q, P, T
Oscilloscope | 1 GHz 4 Gs/second 50 Ω input termination | Keysight MSO6104A | T
Adapter | N type (m) to BNC (m) | Keysight E9623A | Q, P, T
Cable (2 required) | Dual banana (m) to dual banana (m) | Keysight 11000-60000 | Q, P, T
Cable | RG58, BNC (m) to dual banana OR RG58 coaxial cable with BNC (m) to dual banana adapter | Keysight 11001-60001 | Q, P, T
Cable | RG58, BNC (m) to BNC (m) | Keysight 11170C | Q, P, T

* Q = Quick Verification P = Performance Verification T = Troubleshooting

Test Considerations

For optimal performance, all procedures should comply with the following recommendations:

  • Calibration ambient temperature is stable, between 18 and 28 °C. Ideally, it should be 23 ±1 °C.
  • Ambient relative humidity is less than 80%.
  • One-hour warm-up period before verification or adjustment.
  • Measurement cables as short as possible, consistent with the impedance requirements.
  • RG-58 or equivalent 50 Ω cable.

Calibration Count

You can query the instrument to determine how many calibrations have been performed. The instrument was calibrated at the factory. When you receive your instrument, be sure to read the count to determine its initial value.

  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Because the value increments for each calibration point that stores a value, a complete calibration increases the value by many counts.
  • Front Panel: System key Instr Setup softkey Calibrate softkey
  • SCPI: CAL:COUNt?

Calibration Message

You can store one message of up to 40 characters in calibration memory. For example, you can store the date when the last calibration was performed, the date when the next calibration is due, the instrument's serial number, or contact information for your calibration experts.

Unsecure the instrument to record a calibration message. You can read the message from either the front panel or over the remote interface, regardless of whether the instrument is secured.

  • Storing a calibration message overwrites any message previously stored.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel: System key Instr Setup softkey Calibrate softkey
  • SCPI: CAL:STR "Cal Due: 01 August 2012"


Calibration Security - 33500 Series

This section describes the instrument's calibration security system.

Security Overview

A security code prevents accidental or unauthorized instrument adjustments. On the 33500 Series, the factory default security code varies by model:

Models | Security Code
33521A and 33522A | AT33520A
335XXB | AT33500
  • Once you enter a security code, that code must be used for both front panel and remote operation. If you secure the instrument from the front panel, you must use that same code to unsecure it from the remote interface.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Security code rules:
    Unquoted string up to 12 characters
    Must start with letter (A-Z)
    May contain letters, numbers (0-9) and underscores
  • Front Panel:
    System key Instr Setup softkey Calibrate softkey Keypad and knob
  • SCPI: CALibration_SECurity:STATe

Unsecure Instrument Without Security Code

See Electrostatic Discharge (ESD) Precautions before beginning this procedure.
  1. Disconnect power cord and all input and output connections.
  2. Disassemble the instrument (see Disassembly - 33500 Series).
  3. Apply a temporary short between pin 1 and pin 6 of the header on the main board, shown below.

  4. Attach power and turn on the instrument.

    5. Warning

    Be careful not to touch the power line connections or high voltages on the power supply module. Power is present even if the instrument is turned off.
  5. The error queue will show the message "Calibration security has been disabled."

    Calibration security is unlocked, with password reset to its factory default value. Calibration count is incremented because jumper was connected during power-up, and error message +701,"Calibration error; security defeated by hardware jumper" is issued. Nonvolatile calibration storage is updated to reflect these operations.
  6. Turn off the instrument, remove temporary short, and remove power cord.
  7. Reassemble the instrument.
  8. Enter a new security code as described above, and record the security code in a safe location.


Verification - 33500 Series

The following topics describe the verification portion of the calibration procedure:

  • Performance Verification Tests
  • Internal Timebase Verification
  • AC Amplitude (high-impedance) Verification
  • DC Offset Voltage Verification
  • -8 dB Range Flatness Verification
  • -24 dB Range Flatness Verification


Performance Verification Tests - 33500 Series

Use the Performance Verification Tests to verify the measurement performance of the instrument. The performance verification tests use the instrument’s specifications listed on the product datasheet.

You can perform three levels of performance verification tests:

  • Self-Test A series of internal verification tests that give high confidence that the instrument is operational.
  • Quick Verification A combination of the internal self-tests and selected verification tests.
  • Performance Verification Tests An extensive set of tests that are recommended as an acceptance test when you first receive the instrument or after performing adjustments.

Self-Test

A brief power-on self-test occurs automatically whenever you turn on the instrument. This limited test assures that the instrument is operational. For details, see Self-Test Procedures.

Quick Performance Check

The quick performance check is a combination of internal self-test and an abbreviated performance test (specified by the letter Q in the performance verification tests). This test provides a simple method to achieve high confidence in the instrument's ability to functionally operate and meet specifications. These tests represent the absolute minimum set of performance checks recommended following any service activity. Auditing the instrument’s performance for the quick check points (designated by a Q) verifies performance for normal accuracy drift mechanisms. This test does not check for abnormal component failures.

To perform the quick performance check, do the following:

  1. Perform a complete self-test.
  2. Perform only the performance verification tests indicated with the letter Q.
  3. If the instrument fails the quick performance check, adjustment or repair is required.

Performance Verification Tests

The performance verification tests are recommended as acceptance tests when you first receive the instrument. The acceptance test results should be compared against the specifications on the product datasheet. After acceptance, you should repeat the performance verification tests at every calibration interval.

If the instrument fails performance verification, adjustment or repair is required.

Adjustment is recommended at every calibration interval. If adjustment is not made, you must guard band, using no more than 80% of the specifications listed in the datasheet, as the verification limits.

Amplitude and Flatness Verification Procedures

The flatness verification procedures use a precision AC voltmeter and a power meter. You may substitute Thermal Voltage Converters (TVCs) to make measurements using appropriate operating procedures and test equipment.

Flatness measurements for the -24 dB and -8 dB attenuator ranges are measured during the verification procedure. Other attenuator ranges are verified as a part of -24 dB and -8 dB attenuation range verification procedures. No separate verification procedure is given for these ranges.


Internal Timebase Verification - 33500 Series

Verifies output frequency accuracy. All output frequencies are derived from a single generated frequency.

  1. Connect a frequency counter to the channel 1 output as shown below (the frequency counter input should be terminated at 50 Ω).

    Adjustment setup 1
  2. Set the instrument to the output described in the table below and measure the output frequency. Be sure the instrument output is enabled.
    3. Use | Waveform Generator |  |  | Measurement
 | Function | Amplitude | Frequency | Nominal | Error*
Q | Sine | 1.00 Vpp | 10.0000000 MHz | 10.000 MHz | ±10 Hz

    * With the optional high-stability OCXO timebase, the measurement error is ±1 Hz.

  3. Compare the measured value to the test limits shown in the table.


AC Amplitude (high-impedance) Verification - 33500 Series

Checks AC amplitude output accuracy at 1 kHz frequency using each attenuator.

  1. Set the DMM to measure Vrms. Connect the DMM to the channel output as shown below.

    Adjustment setup 2
  2. Set the instrument to each output in the table below and measure the output voltage with the DMM. Be sure the output impedance is set to High–Z and the output is enabled.
    3. Use | Waveform Generator |  |  |  | Measurement
 | Output Setup | Function | Frequency | Amplitude | Nominal | Error*
Q | High Z** | Sine | 1.000 kHz | 400.0 mVrms | 400.0 mVrms | ±0.004707 Vrms
Q | High Z | Sine | 1.000 kHz | 400.0 mVrms | 400.0 mVrms | ±0.004707 Vrms
Q | High Z | Sine | 1.000 kHz | 1.00 Vrms | 1.00 Vrms | ±0.010707 Vrms
Q | High Z | Sine | 1.000 kHz | 2.500 Vrms | 2.500 Vrms | ±0.025707 Vrms
Q | High Z | Sine | 1.000 kHz | 7.000 Vrms | 7.000 Vrms | ±0.070707 Vrms

    * Based upon 1% of setting ±1 mVpp (50 Ω); converted to Vrms for High–Z.

    ** Use the following sequence to set this output:

    1. Set amplitude to 400.0 mVrms
    2. Set DC Offset to 1.0 VDC
    3. Set Auto-Range to OFF
    4. Set DC Offset Voltage to 0.0 VDC
    5. After the measurement, set autorange ON for remaining measurements.
  3. Compare the measured value to the test limits shown in the table.
  4. Two-channel instruments only: connect DMM to channel 2 output and repeat steps 2 and 3.


DC Offset Voltage Verification - 33500 Series

Checks the DC Offset Voltage on two attenuator ranges:

  1. Set the DMM to measure DCV. Connect the DMM to the channel output as shown below.
    Adjustment setup 2
  2. Set the instrument to each output in the table below and measure the output voltage with the DMM.
    3. Use | Waveform Generator |  |  | Measurement
 | Output Setup | Function | Voltage | Nominal | Error*
Q | High Z | DC | 0.0 V | 0.0 VDC | ±0.002 VDC
Q | High Z | DC | 500 mV | 0.500 VDC | ±0.007 VDC
Q | High Z | DC | 10.0 V | 10.0 VDC | ±0.102 VDC

    * Based upon 1% of setting ±2 mVDC for High-Z.

  3. Compare the measured value to the test limits shown in the table.
  4. Two-channel instruments only: connect DMM to channel 2 output and repeat steps 2 and 3.


-8 dB Range Flatness Verification - 33500 Series

Checks high frequency AC amplitude flatness on the -8 dB attenuator range. Also checks flatness for all other ranges excluding the -24 dB and 0 dB attenuator ranges.

  1. Connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.If you are using substitute test equipment, verify that the input impedance is 50 Ω, because load accuracy directly affects measurement quality.

    Adjustment setup 3
  2. Set the precision AC Voltmeter to "Medium, Medium" Digital Filter and Filter Restart.
  3. Set the instrument to each output described in the table below and measure the output amplitude with the AC voltmeter. This will become the reference measurement. Set the output impedance to 50 Ω. Be sure the output is enabled.
    4. Use | Waveform Generator |  |  |  | Measurement
 | Output Load | Function | Amplitude | Frequency | Nominal | Error
Q | 50 Ω | Sine | 1.200 Vrms | 1.000 kHz | 1.200 Vrms | ±0.0127 Vrms
  4. Set the measured value in Step 3 to be the reference value on the AC voltmeter.
  5. Set the instrument to each output described in the table below and measure the output amplitude relative to the source as a percent with the AC voltmeter. Note that the table also lists the output in dB if you are using a power meter to perform this test.
    6. Use | Waveform Generator |  |  |  | Measurement
 | Output Load | Function | Amplitude | Frequency | Nominal | Error | Nominal | Error
 | 50 Ω | Sine | 1.200 Vrms | 100.000 kHz | 100% | ±1.15% | 0 dB | ±0.10 dB
 |  |  |  | 500.000 kHz |  | ±1.74% |  | ±0.15 dB
 |  |  |  | 1.000 MHz |  | ±1.74% |  | ±0.15 dB
Q | 50 Ω | Sine | 1.200 Vrms | 2.000 MHz | 100% | ±1.74% | 0 dB | ±0.15 dB
 | 50 Ω | Sine | 1.200 Vrms | 5.000 MHz | 100% | ±1.74% | 0 dB | ±0.15 dB
 |  |  |  | 10.00 MHz |  | ±3.51% |  | ±0.30 dB
 |  |  |  | 15.00 MHz |  | ±3.51% |  | ±0.30 dB
 |  |  |  | 20.00 MHz |  | ±3.51% |  | ±0.30 dB
 |  |  |  | 22.00 MHz (unnecessary for 20 MHz instruments) |  | ±4.71% |  | ±0.40 dB
 |  |  |  | 27.00 MHz (unnecessary for 20 MHz instruments) |  | ±4.71% |  | ±0.40 dB
 |  |  |  | 30.00 MHz (unnecessary for 20 MHz instruments) |  | ±4.71% |  | ±0.40 dB
  6. Compare the measured value to the test limits shown in the table.
  7. Two-channel instruments only: Connect the AC voltmeter to channel 2 and repeat steps 2 through 6.


-24 dB Range Flatness Verification - 33500 Series

Checks high frequency AC amplitude flatness on the - 24 dB attenuator range. Also checks flatness for the 0 dB attenuator range.

  1. Connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.If you are using substitute test equipment, verify that the input impedance is 50 Ω, because load accuracy directly affects measurement quality.

    Adjustment setup 3
  2. Set the precision AC Voltmeter to "Medium, Medium" Digital Filter and Filter Restart.
  3. Set the instrument to each output described in the table below and measure the output amplitude with the AC voltmeter. This will become the reference measurement. Set the output impedance to 50 Ω. Be sure the output is enabled.
    4. Use | Waveform Generator |  |  |  | Measurement
 | Output Load | Function | Amplitude | Frequency | Nominal | Error
Q | 50 Ω | Sine | 0.190 Vrms | 1.000 kHz | 0.190 Vrms | ±0.0026 Vrms
  4. Set the measured value in Step 3 to be the reference value on the AC voltmeter.
  5. Set the instrument to each output described in the table below and measure the output amplitude relative to the source as a percent with the AC voltmeter. Note that the table also lists the output in dB if you are using a power meter to perform this test.
    6. Use | Waveform Generator |  |  |  | Measurement
 | Output Load | Function | Amplitude | Frequency | Nominal | Error | Nominal | Error
 | 50 Ω | Sine | 0.190 Vrms | 100.000 kHz | 100% | ±1.15% | 0 dB | ±0.10 dB
 |  |  |  | 500.000 kHz |  | ±1.74% |  | ±0.15 dB
 |  |  |  | 1.000 MHz |  | ±1.74% |  | ±0.15 dB
Q | 50 Ω | Sine | 0.190 Vrms | 2.000 MHz | 100% | ±1.74% | 0 dB | ±0.15 dB
 | 50 Ω | Sine | 0.190 Vrms | 5.000 MHz | 100% | ±1.74% | 0 dB | ±0.15 dB
 |  |  |  | 10.00 MHz |  | ±3.51% |  | ±0.30 dB
 |  |  |  | 15.00 MHz |  | ±3.51% |  | ±0.30 dB
 |  |  |  | 20.00 MHz |  | ±3.51% |  | ±0.30 dB
 |  |  |  | 22.00 MHz (unnecessary for 20 MHz instruments) |  | ±4.71% |  | ±0.40 dB
 |  |  |  | 27.00 MHz (unnecessary for 20 MHz instruments) |  | ±4.71% |  | ±0.40 dB
 |  |  |  | 30.00 MHz (unnecessary for 20 MHz instruments) |  | ±4.71% |  | ±0.40 dB
  6. Compare the measured value to the test limits shown in the table.
  7. Two-channel instruments only: Connect the AC voltmeter to channel 2 and repeat steps 2 through 6.


General Calibration/Adjustment Procedure - 33500 Series

Recommended method for a complete instrument calibration:

  1. Read Test Considerations.
  2. Perform the verification tests to characterize the instrument (incoming data).
  3. Press [System > Instr Setup > Calibrate. If the instrument is secured from calibration, unsecure it.
  4. Enter the Setup Number for the procedure being performed. The default setup number is "1" and, from the front panel, the number will increment as the procedures are performed.
  5. Select BEGIN.
  6. For setups that require an input, adjust the value shown in the display to the measured value and select ENTER VALUE.
  7. The setup automatically advances to the next required value.

    To cancel the adjustment procedure, select CANCEL STEP. The display will return to the setup number entry.
  8. When finished, select END CAL.
  9. (Optional) Set a new calibration message using the remote interface. The message (up to 40 characters) is stored with the calibration coefficients.
  10. Secure the instrument against calibration.
  11. Note the new security code and calibration count in the instrument’s maintenance records.


Aborting a Calibration in Progress - 33500 Series

Sometimes it may be necessary to abort a calibration in progress. You can abort a calibration at any time by turning off the power or by issuing a remote interface device clear message followed by *RST.

The instrument stores calibration constants at the end of each adjustment procedure. If you lose power, or otherwise abort an adjustment in progress, you will only need to perform the interrupted adjustment procedure again.

Caution

If power is lost when the instrument is attempting to write new calibration constants to memory, you may lose all calibration constants for the function. Typically, upon re-applying power, the instrument will report error "-313, Calibration Memory Lost".


Sequence of Adjustments - 33500 Series

The adjustment sequence in the numbered steps minimizes the number of test equipment setups and connection changes.

You may perform individual adjustments as necessary, but setups 1 through 7 must be performed in order, before any other setup procedure.


Self-Test - 33500 Series

Run self-test to ensure that the instrument is in working order before beginning any additional adjustments.

Be sure to unlock the instrument and follow the requirements listed in Test Considerations before beginning any adjustments.

  1. Press [System > Instr Setup > Calibrate. Enter setup number 1 and select BEGIN.
    2. Setup |
1 | Performs the self-test. The Main Output is disabled during test.
  2. If the instrument fails any self-test, you must repair the instrument before continuing the adjustment procedures.

A complete self-test (*TST?) takes approximately 15 seconds.


Frequency (Internal Timebase) Adjustment - 33500 Series

The instrument stores a calibration constant that sets the crystal oscillator to put out exactly 10 MHz. The instrument should have been running continuously for 30 minutes prior to this calibration adjustment to ensure timebase stability.

  1. Set the frequency counter resolution to better than 0.01 ppm and the input termination to 50 Ω (if your frequency counter does not have a 50 Ω input termination, you must provide an external termination). Make the connections shown below.

    Adjustment setup 1
  2. Use the frequency counter to measure the output frequency for each setup in the following table.
    3.  | Nominal Signal |  |
Setup | Frequency | Amplitude |
2 | <10 MHz | ~1 Vpp | Output frequency is slightly less than 10 MHz
3 | >10 MHz |  | Output frequency is slightly more than 10 MHz
4 | ~10 MHz |  | Output frequency should be near 10 MHz
5* | 10 MHz |  | Output frequency should be 10 MHz ± 1 ppm

    * Constants are stored after completing this setup.

  3. Using the numerical keypad or knob, adjust the displayed frequency at each setup to match the measured frequency. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform Internal Timebase Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


Internal ADC Adjustment - 33500 Series

The instrument stores calibration constants related to the gain and offset of the internal ADC. Setup 6 must always be performed before any other amplitude adjustments are attempted. The internal ADC is then used as a source for the calibration constants generated in self calibration (setup 7).

  1. Connect the channel 1 output to the instrument's rear panel Modulation Input and DMM as shown below.
    Adjustment setup 4
  2. Set the DMM to display 5½ digits and set the function to DCV.
  3. Enter the following setup.
    4.  | Nominal Signal |
Setup | DC level |
6* | ~1.0 VDC ±10% | Calibrates the internal ADC.

    * Constants are stored after completing this setup.

  4. Use the numeric keypad or knob to enter the value measured on the DMM.

    5. Note

    This setup requires approximately 15 seconds to complete.
  5. Disconnect all cables from the instrument.


Self Calibration Adjustment - 33500 Series

  1. Enter and begin the following setup.
    2. Setup |
7* | Self-calibration. The output is disabled.

    * Constants are stored after completing this setup.

  2. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform DC Offset Voltage Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.

Note

This setup requires approximately 15 seconds to complete.


Output Impedance Adjustment - 33500 Series

The instrument stores calibration constants for the channels' output impedance. These constants are generated with and without the post-amplifier attenuator.

  1. Set the DMM to measure offset-compensated, four-wire Ohms. Set the DMM to use 100 NPLC integration. Connect the Ohms Source and Ohms Sense DMM inputs to the channel output as shown below.
    Adjustment setup 5
  2. Use the DMM to make a 4-wire resistance measurement at the front panel output connector for each setup in the following table. The expected measured value is approximately 50 Ω.
    3. Setup |
8* | -24 dB post-attenuator range
9* | 0 dB

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed impedance at each setup to match the measured impedance. Select ENTER VALUE.
  4. There are no specific operational verification tests for output impedance. Continue with the next adjustment procedure in this section.


AC Amplitude (high-impedance) Adjustment - 33500 Series

The instrument stores a calibration constant for each high-impedance attenuator path. Each path's gain coefficient is calculated using two measurements: one with the waveform DAC at + output and one with waveform DAC at – output. The setups, therefore, must be performed in pairs.

  1. Connect the DMM to the channel output as shown below.
    Adjustment setup 2
  2. Use the DMM to measure the DC voltage at the front panel connector for each setup in the following table.

    Setup | Nominal Signal
    DC Level
    10 | +0.0028 V | Output of -72 dB range
    11* | -0.0028 V | Output of -72 dB range
    12 | +0.007 V | Output of -64 dB range
    13* | -0.007 V | Output of -64 dB range
    14 | +0.017 V | Output of -56 dB range
    15* | -0.017 V | Output of -56 dB range
    16 | +0.044 V | Output of -48 dB range
    17* | -0.044 V | Output of -48 dB range
    18 | +0.11 V | Output of -40 dB range
    19* | -0.11 V | Output of -40 dB range
    20 | +0.28 V | Output of -32 dB range
    21* | -0.28 V | Output of -32 dB range
    22 | +0.68 V | Output of -24 dB range
    23* | -0.68 V | Output of -24 dB range
    24 | +1.7 V | Output of -16 dB range
    25* | -1.7 V | Output of -16 dB range
    26 | +4.3 V | Output of -8 dB range
    27* | -4.3 V | Output of -8 dB range
    28 | +10.8 V | Output of 0 dB range
    29* | -10.8 V | Output of 0 dB range
    30 | +0.044V | Output of -48 dB High DC range
    31* | -0.044V | Output of -48 dB High DC range
    32 | +0.11 V | Output of -40 dB High DC range
    33* | -0.11 V | Output of -40 dB High DC range
    34 | +0.28 V | Output of -32 dB High DC range
    35* | -0.28 V | Output of -32 dB High DC range
    36 | +0.68 V | Output of -24 dB High DC range
    37* | -0.68 V | Output of -24 dB High DC range

    3. * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify this adjustment, exit the calibration menu and perform AC Amplitude (high-impedance) Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


-24 dB Range Flatness Adjustment - 33500 Series

  1. Connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 3
  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.

    Setup | Nominal Signal
    Frequency | Amplitude
    38* | 1 kHz | 0.192 Vrms | Flatness for -24 dB range
    39* | 100 kHz
    40* | 1 MHz
    41* | 5 MHz
    42* | 10 MHz
    43* | 20 MHz
    44* | 25 MHz
    45* | 30 MHz

    * Constants are stored after completing this setup.
  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform -24 dB Range Flatness Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


-8 dB Range Flatness Adjustment - 33500 Series

  1. Connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 3
  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.
    3. Setup | Nominal Signal |  |
 | Frequency | Amplitude |
46* | 1 kHz | 1.22 Vrms | Flatness for -8 dB range
47* | 100 kHz
48* | 1 MHz
49* | 5 MHz
50* | 10 MHz
51* | 20 MHz
52* | 25 MHz
53* | 30 MHz

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform -8 dB Range Flatness Verification.
  2. If you are making all the adjustments and then verifying the instrument’s performance, verify the output specifications of the instrument with the Performance Verification Tests.

This completes the adjustment procedures for the one-channel instrument. Verification of the output specifications is recommended.

If you are making adjustments to a two-channel instrument, continue with the next procedure in this section.


Channel 2 Adjustments - 33500 Series

The following topics describe calibration adjustments on channel 2.

  • Self Calibration Adjustment (Channel 2)
  • Output Impedance Adjustment (Channel 2)
  • AC Amplitude (high-impedance) Adjustment (Channel 2)
  • -24 dB Range Flatness Adjustment (Channel 2)
  • -8 dB Range Flatness Adjustment (Channel 2)


Self Calibration Adjustment (Channel 2) - 33500 Series

  1. Enter and begin the following setup.
    2. Setup |
54* | Self-calibration. The output is disabled.

    * Constants are stored after completing this setup.

  2. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform DC Offset Voltage Verification. Be sure to do this for channel 2.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.

Note

This setup requires approximately 15 seconds to complete.


Output Impedance Adjustment (Channel 2) - 33500 Series

The instrument stores calibration constants for the channels' output impedance. These constants are generated with and without the post-amplifier attenuator.

  1. Set the DMM to measure offset-compensated, four-wire Ohms. Set the DMM to use 100 NPLC integration. Connect the Ohms Source and Ohms Sense DMM inputs to the channel output as shown below.
    Adjustment setup 6
  2. Use the DMM to make a 4-wire resistance measurement at the front panel output connector for each setup in the following table. The expected measured value is approximately 50 Ω.
    3. Setup |
55* | -24 dB post-attenuator range
56* | 0 dB

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed impedance at each setup to match the measured impedance. Select ENTER VALUE.
  4. There are no specific operational verification tests for output impedance. Continue with the next adjustment procedure in this section.


AC Amplitude (high-impedance) Adjustment (Channel 2) - 33500 Series

The instrument stores a calibration constant for each high-impedance attenuator path. Each path's gain coefficient is calculated using two measurements: one with the waveform DAC at + output and one with waveform DAC at – output. The setups, therefore, must be performed in pairs.

  1. Connect the DMM to the channel output as shown below.
    Adjustment setup 7
  2. Use the DMM to measure the DC voltage at the front panel connector for each setup in the following table.

    Nominal Signal
    Setup | DC Level
    57 | +0.0028 V | Output of -72 dB range
    58* | -0.0028 V | Output of -72 dB range
    59 | +0.007 V | Output of -64 dB range
    60* | -0.007 V | Output of -64 dB range
    61 | +0.017 V | Output of -56 dB range
    62* | -0.017 V | Output of -56 dB range
    63 | +0.044 V | Output of -48 dB range
    64* | -0.044 V | Output of -48 dB range
    65 | +0.11 V | Output of -40 dB range
    66* | -0.11 V | Output of -40 dB range
    67 | +0.28 V | Output of -32 dB range
    68* | -0.28 V | Output of -32 dB range
    69 | +0.68 V | Output of -24 dB range
    70* | -0.68 V | Output of -24 dB range
    71 | +1.7 V | Output of -16 dB range
    72* | -1.7 V | Output of -16 dB range
    73 | +4.3 V | Output of -8 dB range
    74* | -4.3 V | Output of -8 dB range
    75 | +10.8 V | Output of 0 dB range
    76* | -10.8 V | Output of 0 dB range
    77 | +0.044 V | Output of -48 dB High DC range
    78* | -0.044 V | Output of -48 dB High DC range
    79 | +0.11 V | Output of -40 dB High DC range
    80* | -0.11 V | Output of -40 dB High DC range
    81 | +0.28 V | Output of -32 dB High DC range
    82* | -0.28 V | Output of -32 dB High DC range
    83 | +0.68 V | Output of -24 dB High DC range
    84* | -0.68 V | Output of -24 dB High DC range

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify this adjustment, exit the calibration menu and perform AC Amplitude (high-impedance) Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


-24 dB Range Flatness Adjustment (Channel 2) - 33500 Series

  1. Connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 8
  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.
    3. Setup | Nominal Signal |  |
 | Frequency | Amplitude |
85* | 1 kHz | 0.192 Vrms | Flatness for -24 dB range
86* | 100 kHz
87* | 1 MHz
88* | 5 MHz
89* | 10 MHz
90* | 20 MHz
91* | 25 MHz
92* | 30 MHz

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform -24 dB Range Flatness Verification. Be sure that you do this for Channel 2.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


-8 dB Range Flatness Adjustment (Channel 2) - 33500 Series

This section applies to channel 2. It checks high frequency AC amplitude flatness on the -8 dB attenuator range. It also checks flatness for all other ranges excluding the -24 dB and 0 dB attenuator ranges.

  1. Connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 8
  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.
    3.  | Nominal Signal |  |
Setup | Frequency | Amplitude |
93* | 1 kHz | 1.22 Vrms | Flatness for -8 dB range
94* | 100 kHz
95* | 1 MHz
96* | 5 MHz
97* | 10 MHz
98* | 20 MHz
99* | 25 MHz
100 | 30 MHz

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. You have now completed the recommended adjustment procedures. Verification of the output specifications is recommended.
    1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform -8 dB Range Flatness Verification.


Calibration Errors - 33500 Series

The following errors may occur during calibration. There are also system errors and self-test errors. Some error messages include a failing channel number (1 or 2), shown as n in the messages below.

701 Calibration error; security defeated by hardware jumper

If you short the calibration secure jumper (CAL ENABLE) while turning the instrument on, this error indicates the security password has been overwritten. See Calibration Security for details.

702 Calibration error; calibration memory is secured

To perform calibration, unsecure the instrument. See Calibration Security for details.

703 Calibration error; secure code provided was invalid

Specified security code was invalid.

706 Calibration error; value out of range

Value entered was outside valid range.

707 Calibration error; signal input is out of range

Occurs during the ADC Adjustment, setup 6, if the 1 V input voltage is too high. May also occur during self-calibration (setup 7). Run self-test to diagnose problem.

710 Self-calibration failed; Chan n, null DAC cal, invalid self cal
Self-calibration failed; Chan n, offset DAC cal with attenuator, invalid self cal
Self-calibration failed; Chan n, offset DAC cal no attenuator, invalid self cal

Error occurred while performing internal calibration of specified DAC. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

711 Self-calibration failed; Chan n, null DAC cal gain too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal with attenuator gain too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal no attenuator gain too low (too high), <meas_value>

Computed gain calibration factor for specified DAC was out of limits. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

712 Self-calibration failed; Chan n, null DAC cal zero too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal with attenuator zero too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal no attenuator zero too low (too high), <meas_value>
Self-calibration failed; Chan n, GND measurement out of limits, <meas_value>

Computed zero calibration factor for specified DAC was out of limits. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

715 Self-calibration failed; Chan n, null DAC cal, convergence error sub attenuator value dB

Internal null DAC calibration failed to converge during internal calibration. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

720 Self-calibration failed; Chan n, offset DAC cal with attenuator, convergence error
Self-calibration failed; Chan n, offset DAC cal no attenuator, convergence error

Internal offset DAC calibration failed to converge internal calibration. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

850 Calibration error; set up is invalid

Invalid calibration setup number selected.

850 Calibration error; set up is out of order

Certain calibration steps require a specific beginning and ending. Do not enter into the middle of a calibration sequence.

Previous Calibration Topic


Introduction to Calibration - 33600 Series

This chapter contains procedures for verifying the instrument's performance and adjustment (calibration).

The instrument uses closed-case electronic calibration; no internal mechanical adjustments are required. The instrument calculates correction factors based on input reference values that you set and stores correction factors in non-volatile memory until the next calibration adjustment is performed. This data is not changed by cycling power or *RST.

Keysight Technologies Calibration Services

Your local Keysight Technologies Service Center offers low-cost recalibration. The service center uses automated calibration systems that allow Keysight to provide calibration at competitive prices.

Calibration Table of Contents

The section includes the following sections:

Calibration Overview

  • Calibration Interval
  • Adjustment is Recommended
  • Time Required for Calibration
  • Automating Calibration Procedures
  • Recommended Test Equipment
  • Test Considerations
  • Calibration Count
  • Calibration Message

Calibration Security

Verification

Performance Verification Tests

  • Self-Test
  • Quick Performance Check
  • Performance Verification Tests
  • Amplitude and Flatness Verification Procedures

Internal Timebase Verification

AC Amplitude (high-impedance) Verification

DC Offset Voltage Verification

1 Vpp Range Flatness Verification

4 Vpp Range Flatness Verification

8 Vpp Range Flatness Verification

General Calibration/Adjustment Procedure

Aborting a Calibration in Progress

Sequence of Adjustments

Self-Test

Frequency (Internal Timebase) Adjustment

Internal ADC Adjustment

Self Calibration Adjustment

Output Impedance Adjustment

AC Amplitude (high-impedance) Adjustment

1 Vpp Flatness Adjustment

4 Vpp Flatness Adjustment

8 Vpp Flatness Adjustment

Adjust Channel 2 (if necessary)

  • Self Calibration Adjustment (Channel 2)
  • Output Impedance Adjustment (Channel 2)
  • AC Amplitude (high-impedance) Adjustment (Channel 2)
  • 1 Vpp Flatness Adjustment (Channel 2)
  • 4 Vpp Flatness Adjustment (Channel 2)
  • 8 Vpp Flatness Adjustment

Calibration Errors

Next Calibration Topic


Calibration Overview - 33600 Series

This section introduces the instrument's calibration features. For more detailed calibration information, see Introduction to Calibration.

Calibration Interval

The instrument should be calibrated on a regular interval determined by the accuracy requirements of your application. A one-year interval is adequate for most applications. Accuracy specifications are warranted only if adjustment is made at regular calibration intervals. Accuracy specifications are not warranted beyond the one-year calibration interval. Keysight Technologies does not recommend calibration intervals beyond two years for any application.

Adjustment is Recommended

Whatever calibration interval you select, Keysight Technologies recommends that complete re-adjustment should always be performed at the calibration interval. This ensures that the instrument will remain within specifications for the next calibration interval and provides the best long-term stability. Performance data measured using this method can be used to extend future calibration intervals. Use the Calibration Count to verify that all adjustments have been performed.

Time Required for Calibration

For incoming instrument verification, do performance verification tests first. Then perform adjustments and re-run the performance verification tests. Each of these steps, if done manually, takes approximately 30 minutes per channel to perform.

The instrument can also be automatically calibrated under computer control. With computer control you can perform the complete calibration procedure and performance verification tests in approximately 30 minutes (one channel) or 60 minutes (two channels) once the instrument is warmed-up (see Test Considerations).

Automating Calibration Procedures

You can use programmable test equipment to automate the complete verification and adjustment procedures. You can program each test's instrument configuration over the remote interface. Then enter read-back verification data into a test program and compare the results to the appropriate test limit.

You can also adjust the instrument from the remote interface, which is similar to the front panel procedure. Use a computer to perform the adjustment by first selecting the required function and range on the measurement equipment. Send the calibration value to the instrument and then initiate calibration over the remote interface.

You must unsecure the instrument before calibration.

A typical programming sequence for a single calibration setup is as follows:

  1. CAL:SETup 2 (configures instrument for calibration step 2)
  2. Measure the output frequency with the external frequency counter
  3. CAL:VALue 9.99994321E6 (send the measured value to the instrument)
  4. CAL? (initiates the calibration adjustment for setup 2)
  5. Read CAL? query value to determine the failure (+1) or success (+0) of adjustment
  6. CAL:SETup 3 (configures instrument for calibration step 3)

For further information on instrument programming, see Introduction to SCPI Language.

Recommended Test Equipment

The test equipment recommended for the performance verification and adjustment procedures is listed below. If the exact instrument is not available, substitute calibration standards of equivalent accuracy.

Instrument | Requirements | Recommended Model | Use*
Digital Multimeter (DMM) | ACV, true rms, AC coupled accuracy: ±0.02% to 1 MHz DCV accuracy: 50 ppm resolution: 100 µV Resistance Offset-compensated accuracy: ±0.1 Ω | Keysight 3458A | Q, P, T
Precision AC Voltmeter | 1000 Hz to 30 MHz, 0.1 Vrms to 2 Vrms (–7 dBm to +20 dBm) accuracy: 0.02 dB resolution: 0.01 dB | Fluke 5790A | Q, P, T
Frequency Counter | Accuracy: 0.1 ppm | Keysight 53230A Opt 010 (OCXO) | Q, P, T
Power Sensor | Specific model | Keysight N8482A | Q, P, T
Power Meter | Specific model (pick one of four) | Keysight N1911A, N1912A, N1913A, or N1914A | Q, P, T
Oscilloscope | 1 GHz 4 Gs/second 50 Ω input termination | Keysight MSO6104A | T
Adapter | N type (m) to BNC (m) | Keysight E9623A | Q, P, T
Cable (2 required) | Dual banana (m) to dual banana (m) | Keysight 11000-60000 | Q, P, T
Cable | RG58, BNC (m) to dual banana OR RG58 coaxial cable with BNC (m) to dual banana adapter |  | Q, P, T
Cable | RG58, BNC (m) to BNC (m) | Keysight 11170C | Q, P, T
Low-loss cable | Used for connecting to Type N attenuator, Fluke 5790A, and N8482A. Flatness verified by Precision Network Analyzer (PNA) | (Any as long as verified by PNA) | Q, P, T
10 to 20 dB Attenuator | Flatness verified by Precision Network Analyzer (PNA) | (Any as long as verified by PNA) | Q, P, T

* Q = Quick Verification P = Performance Verification T = Troubleshooting

Test Considerations

For optimal performance, all procedures should comply with the following recommendations:

  • Calibration ambient temperature is stable, between 18 and 28 °C. Ideally, it should be 23 ±1 °C.
  • Ambient relative humidity is less than 80%.
  • One-hour warm-up period before verification or adjustment.
  • Measurement cables as short as possible, consistent with the impedance requirements.
  • RG-58 or equivalent 50 Ω cable.

Calibration Count

You can query the instrument to determine how many calibrations have been performed. The instrument was calibrated at the factory. When you receive your instrument, be sure to read the count to determine its initial value.

  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Because the value increments for each calibration point that stores a value, a complete calibration increases the value by many counts.
  • Front Panel: System key Instr Setup softkey Calibrate softkey
  • SCPI: CAL:COUNt?

Calibration Message

You can store one message of up to 40 characters in calibration memory. For example, you can store the date when the last calibration was performed, the date when the next calibration is due, the instrument's serial number, or contact information for your calibration experts.

Unsecure the instrument to record a calibration message. You can read the message from either the front panel or over the remote interface, regardless of whether the instrument is secured.

  • Storing a calibration message overwrites any message previously stored.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Front Panel: System key Instr Setup softkey Calibrate softkey
  • SCPI: CAL:STR "Cal Due: 01 August 2012"


Calibration Security - 33600 Series

This section describes the instrument's calibration security system.

Security Overview

A security code prevents accidental or unauthorized instrument adjustments. The factory default security code for 33600 Series instruments is AT33600.

  • Once you enter a security code, that code must be used for both front panel and remote operation. If you secure the instrument from the front panel, you must use that same code to unsecure it from the remote interface.
  • This setting is non-volatile; it will not be changed by power cycling or *RST.
  • Security code rules:
    Unquoted string up to 12 characters
    Must start with letter (A-Z)
    May contain letters, numbers (0-9) and underscores
  • Front Panel:
    System key Instr Setup softkey Calibrate softkey Keypad and knob
  • SCPI: CALibration_SECurity:STATe

Unsecure Instrument Without Security Code

See Electrostatic Discharge (ESD) Precautions before beginning this procedure.
  1. Disconnect power cord and all input and output connections.
  2. Disassemble the instrument (see Disassembly - 33600 Series).
  3. On the 33600 Series, apply a temporary short across pins A1 and B1 on the front panel PCBA, as shown below.

  4. Attach power and turn on the instrument.

    5. Warning

    Be careful not to touch the power line connections or high voltages on the power supply module. Power is present even if the instrument is turned off.
  5. The error queue will show the message "Calibration security has been disabled."

    Calibration security is unlocked, with password reset to its factory default value. Calibration count is incremented because jumper was connected during power-up, and error message +701,"Calibration error; security defeated by hardware jumper" is issued. Nonvolatile calibration storage is updated to reflect these operations.
  6. Turn off the instrument, remove temporary short, and remove power cord.
  7. Reassemble the instrument.
  8. Enter a new security code as described above, and record the security code in a safe location.


Verification - 33600 Series

The following topics describe the verification portion of the calibration procedure:

  • Performance Verification Tests
  • Internal Timebase Verification
  • AC Amplitude (high-impedance) Verification
  • DC Offset Voltage Verification
  • 1 Vpp Range Flatness Verification
  • 4 Vpp Range Flatness Verification
  • 8 Vpp Range Flatness Verification


Performance Verification Tests - 33600 Series

Use the Performance Verification Tests to verify the measurement performance of the instrument. The performance verification tests use the instrument’s specifications listed on the product datasheet.

You can perform three levels of performance verification tests:

  • Self-Test A series of internal verification tests that give high confidence that the instrument is operational.
  • Quick Verification A combination of the internal self-tests and selected verification tests.
  • Performance Verification Tests An extensive set of tests that are recommended as an acceptance test when you first receive the instrument or after performing adjustments.

Self-Test

A brief power-on self-test occurs automatically whenever you turn on the instrument. This limited test assures that the instrument is operational. For details, see Self-Test Procedures.

Quick Performance Check

The quick performance check is a combination of internal self-test and an abbreviated performance test (specified by the letter Q in the performance verification tests). This test provides a simple method to achieve high confidence in the instrument's ability to functionally operate and meet specifications. These tests represent the absolute minimum set of performance checks recommended following any service activity. Auditing the instrument’s performance for the quick check points (designated by a Q) verifies performance for normal accuracy drift mechanisms. This test does not check for abnormal component failures.

To perform the quick performance check, do the following:

  1. Perform a complete self-test.
  2. Perform only the performance verification tests indicated with the letter Q.
  3. If the instrument fails the quick performance check, adjustment or repair is required.

Performance Verification Tests

The performance verification tests are recommended as acceptance tests when you first receive the instrument. The acceptance test results should be compared against the specifications on the product datasheet. After acceptance, you should repeat the performance verification tests at every calibration interval.

If the instrument fails performance verification, adjustment or repair is required.

Adjustment is recommended at every calibration interval. If adjustment is not made, you must guard band, using no more than 80% of the specifications listed in the datasheet, as the verification limits.

Amplitude and Flatness Verification Procedures

The flatness verification procedures use a precision AC voltmeter and a power meter. You may substitute Thermal Voltage Converters (TVCs) to make measurements using appropriate operating procedures and test equipment.

The Fluke 5790A precision AC voltmeter is used to measure the amplitude from 1 kHz to 20 MHz. From 20 to 120 MHz, a power meter with the Keysight N8482A power sensor is used. Measurements of amplitudes from both the 5790A and the N8482A at 1 MHz to 20 MHz are used to scale the N8482A to the 5790A.


Internal Timebase Verification - 33600 Series

Verifies output frequency accuracy. All output frequencies are derived from a single generated frequency.

  1. Connect a frequency counter to the channel 1 output as shown below (the frequency counter input should be terminated at 50 Ω).

    Adjustment setup 1
  2. Set the instrument to the output described in the table below and measure the output frequency. Be sure the instrument output is enabled.
    3. Use | Waveform Generator |  |  | Measurement
 | Function | Amplitude | Frequency | Nominal | Error*
Q | Sine | 1.00 Vpp | 10.0000000 MHz | 10.000 MHz | ±10 Hz

    * With the optional high-stability OCXO timebase, the measurement error is ±1 Hz.

  3. Compare the measured value to the test limits shown in the table.


AC Amplitude (high-impedance) Verification - 33600 Series

Checks AC amplitude output accuracy at 1 kHz frequency using each attenuator.

  1. Set the DMM to measure Vrms. Connect the DMM to the channel output as shown below.

    Adjustment setup 2
  2. Set the instrument to each output in the table below and measure the output voltage with the DMM. Be sure the output impedance is set to High–Z and the output is enabled.
    3. Use | Waveform Generator |  |  |  | Measurement
 | Output Setup | Function | Frequency | Amplitude | Nominal | Error*
Q | High Z** | Sine | 1.000 kHz | 400.0 mVrms | 400.0 mVrms | ±0.004707 Vrms
Q | High Z | Sine | 1.000 kHz | 400.0 mVrms | 400.0 mVrms | ±0.004707 Vrms
Q | High Z | Sine | 1.000 kHz | 1.00 Vrms | 1.00 Vrms | ±0.010707 Vrms
Q | High Z | Sine | 1.000 kHz | 2.500 Vrms | 2.500 Vrms | ±0.025707 Vrms
Q | High Z | Sine | 1.000 kHz | 7.000 Vrms | 7.000 Vrms | ±0.070707 Vrms

    * Based upon 1% of setting ±1 mVpp (50 Ω); converted to Vrms for High–Z.

    ** Use the following sequence to set this output:

    1. Set amplitude to 400.0 mVrms
    2. Set DC Offset to 1.0 VDC
    3. Set Auto-Range to OFF
    4. Set DC Offset Voltage to 0.0 VDC
    5. After the measurement, set autorange ON for remaining measurements.
  3. Compare the measured value to the test limits shown in the table.
  4. Two-channel instruments only: connect DMM to channel 2 output and repeat steps 2 and 3.


DC Offset Voltage Verification - 33600 Series

Checks the DC Offset Voltage on two attenuator ranges:

  1. Set the DMM to measure DCV. Connect the DMM to the channel output as shown below.
    Adjustment setup 2
  2. Set the instrument to each output in the table below and measure the output voltage with the DMM.
    3. Use | Waveform Generator |  |  | Measurement
 | Output Setup | Function | Voltage | Nominal | Error*
Q | High Z | DC | 0.0 V | 0.0 VDC | ±0.002 VDC
Q | High Z | DC | 500 mV | 0.500 VDC | ±0.007 VDC
Q | High Z | DC | 10.0 V | 10.0 VDC | ±0.102 VDC

    * Based upon 1% of setting ±2 mVDC for High-Z.

  3. Compare the measured value to the test limits shown in the table.
  4. Two-channel instruments only: connect DMM to channel 2 output and repeat steps 2 and 3.


1 Vpp Range Flatness Verification - 33600 Series

Checks high frequency AC amplitude flatness on the 1 Vpp range.

  1. Connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.If you are using substitute test equipment, verify that the input impedance is 50 Ω, because load accuracy directly affects measurement quality.

    Adjustment setup 3
  2. Set the precision AC Voltmeter to "Medium, Medium" Digital Filter and Filter Restart.
  3. Set the output impedance to 50 Ω. Be sure the output is enabled. Configure the instrument as described in the table below and measure the output amplitude with the AC voltmeter. This will become the reference measurement. Record this Vrms value in the table below and also record its dBm equivalent by using the formula dBm = 10×log10(20×Vrms2).

    Use | Waveform Generator | Measurement
    Output Load | Function | Amplitude | Frequency | Measured Result
    Q 50 Ω Sine 0.354 Vrms (3.990 dBm) 1.000 kHz

    Vrms

    dBm

  4. Set the waveform generator function, amplitude, and frequency as described in the table below. Measure the amplitude and record the results in the table below.
    Waveform Generator | Measurement
    Use Output Load Function Amplitude Frequency Error Relative to Step 3 Reference (Vrms) Measured Result
    (Vrms)
    50 Ω | Sine | 0.354 Vrms | 100.000 kHz | ±1.15%
    500.000 kHz
    1.000 MHz*
    5.000 MHz*
    50 Ω | Sine | 0.354 Vrms | 10.00 MHz* | ±2.92%
    20.00 MHz*

    * These values are used in the Correction Factor Table below.

  5. In order to scale the power meter to the Fluke 5790A, a correction factor is calculated using the table below. The measurements of amplitudes from both the 5790A and the power meter at 1 MHz to 20 MHz are used. Enter the measured values for 1, 5, 10, and 20 MHz made with the Fluke 5790A into the Correction Factor table below. Then use the following formula to convert the Vrms results to dBm:

    dBm = 10×log10(20×Vrms2)

    Compute the average (arithmetic mean) of the four dBm results and enter the result into the table at the bottom of the Fluke 5790A dBm column.
  6. Connect the N8482A to the channel 1 output of the waveform generator using a Type N connector as shown below. Repeat the 1, 5, 10, and 20 MHz measurements and enter the dBm results into the table below. Compute the average (arithmetic mean) of the four dBm results and enter the result into the table at the bottom of the Power Meter dBm column.

  7. Subtract the Power Meter dBm average from the Fluke 5790A dBm average to compute the correction factor. Record the result in the lower right corner of the Correction Factor table. Add this correction factor to all of your Power Meter measurements.

    Correction Factor Table

    Fluke 5790A | Power Meter
    Frequency | Vrms (measured) | dBm (see formula) | dBm (measured)
    1 MHz
    5 MHz
    10 MHz
    20 MHz
    Average (mean): Average (mean):
    Correction Factor (Fluke 5790A Average minus Power Meter average):
  8. Make the following measurements using the power meter. Set the 33600 Series instrument to the function, amplitude, and frequencies shown below. Record the measured dBm (remembering to add the correction factor) for each frequency in the table below.

    Waveform Generator | Measurement
    Use | Output Load | Function | Amplitude | Frequency | Error Relative to Step 3 Reference | Measured Result (dBm) | Corrected Result (dBm)
    50 Ω | Sine | 0.354 Vrms | 30.00 MHz | ±0.25 dB
    40.00 MHz
    50.00 MHz
    60.00 MHz
    50 Ω | Sine | 0.354 Vrms | 70.00 MHz | ±0.40 dB
    80.00 MHz
    50 Ω | Sine | 0.354 Vrms | 90.00 MHz | ±0.50 dB
    100.00 MHz
    110.00 MHz
    120.00 MHz
  9. Compare the measured values to the test limits shown in both tables.
  10. Two-channel instruments only: Connect the AC voltmeter to channel 2 and repeat steps 2 through 6.


4 Vpp Range Flatness Verification - 33600 Series

Checks high frequency AC amplitude flatness on the 4 Vpp range.

  1. Connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A. If you are using substitute test equipment, verify that the input impedance is 50 Ω, because load accuracy directly affects measurement quality.

    Adjustment setup 3
  2. Set the precision AC Voltmeter to "Medium, Medium" Digital Filter and Filter Restart.
  3. Set the output impedance to 50 Ω. Be sure the output is enabled. Configure the instrument as described in the table below and measure the output amplitude with the AC voltmeter. This will become the reference measurement. Record this Vrms value in the table below and also record its dBm equivalent by using the formula dBm = 10×log10(20×Vrms2).

    Use | Waveform Generator | Measurement
    Output Load | Function | Amplitude | Frequency | Measured Result
    Q 50 Ω Sine 1.414 Vrms (16.019 dBm) 1.000 kHz

    Vrms

    dBm

  4. Set the waveform generator function, amplitude, and frequency as described in the table below. Measure the amplitude and record the results in the table below.
    Waveform Generator | Measurement
    Use Output Load Function Amplitude Frequency Error Relative to Step 3 Reference (Vrms) Measured Result
    (Vrms)
    50 Ω | Sine | 1.414 Vrms | 100.000 kHz | ±1.15%
    500.000 kHz
    1.000 MHz*
    5.000 MHz*
    50 Ω | Sine | 1.414 Vrms | 10.00 MHz* | ±2.92%
    20.00 MHz*

    * These values are used in the Correction Factor Table below.

  5. In order to scale the power meter to the Fluke 5790A, a correction factor is calculated using the table below. The measurements of amplitudes from both the 5790A and the power meter at 1 MHz to 20 MHz are used. Enter the measured values for 1, 5, 10, and 20 MHz made with the Fluke 5790A into the Correction Factor table below. Then use the following formula to convert the Vrms results to dBm:

    dBm = 10×log10(20×Vrms2)

    Compute the average (arithmetic mean) of the four dBm results and enter the result into the table at the bottom of the Fluke 5790A dBm column.
  6. Connect the N8482A to the channel 1 output of the waveform generator using a Type N connector as shown below. Repeat the 1, 5, 10, and 20 MHz measurements and enter the dBm results into the table below. Compute the average (arithmetic mean) of the four dBm results and enter the result into the table at the bottom of the Power Meter dBm column.

  7. Subtract the Power Meter dBm average from the Fluke 5790A dBm average to compute the correction factor. Record the result in the lower right corner of the Correction Factor table. Add this correction factor to all of your Power Meter measurements.

    Correction Factor Table

    Fluke 5790A | Power Meter
    Frequency | Vrms (measured) | dBm (see formula) | dBm (measured)
    1 MHz
    5 MHz
    10 MHz
    20 MHz
    Average (mean): Average (mean):
    Correction Factor (Fluke 5790A Average minus Power Meter average):
  8. Make the following measurements using the power meter. Set the 33600 Series instrument to the function, amplitude, and frequencies shown below. Record the measured dBm (remembering to add the correction factor) for each frequency in the table below.

    Waveform Generator | Measurement
    Use | Output Load | Function | Amplitude | Frequency | Error Relative to Step 3 Reference | Measured Result (dBm) | Corrected Result (dBm)
    50 Ω | Sine | 1.414 Vrms | 30.00 MHz | ±0.25 dB
    40.00 MHz
    50.00 MHz
    60.00 MHz
    50 Ω | Sine | 1.414 Vrms | 70.00 MHz | ±0.40 dB
    80.00 MHz
    50 Ω | Sine | 1.414 Vrms | 90.00 MHz | ±0.50 dB
    100.00 MHz
    110.00 MHz
    120.00 MHz
  9. Compare the measured values to the test limits shown in both tables.
  10. Two-channel instruments only: Connect the AC voltmeter to channel 2 and repeat steps 2 through 6.


8 Vpp Range Flatness Verification - 33600 Series

Checks high frequency AC amplitude flatness on the 8 Vpp range.

  1. Connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.If you are using substitute test equipment, verify that the input impedance is 50 Ω, because load accuracy directly affects measurement quality.

    Adjustment setup 3
  2. Set the precision AC Voltmeter to "Medium, Medium" Digital Filter and Filter Restart.
  3. Set the output impedance to 50 Ω. Be sure the output is enabled. Configure the instrument as described in the table below and measure the output amplitude with the AC voltmeter. This will become the reference measurement. Record this Vrms value in the table below and also record its dBm equivalent by using the formula dBm = 10×log10(20×Vrms2).

    Use | Waveform Generator | Measurement
    Output Load | Function | Amplitude | Frequency | Measured Result
    Q 50 Ω Sine 2.828 Vrms (22.040 dBm) 1.000 kHz

    Vrms

    dBm

  4. Set the waveform generator function, amplitude, and frequency as described in the table below. Measure the amplitude and record the results in the table below.
    Waveform Generator | Measurement
    Use Output Load Function Amplitude Frequency Error Relative to Step 3 Reference (Vrms) Measured Result
    (Vrms)
    50 Ω | Sine | 2.828 Vrms | 100.000 kHz | ±1.15%
    500.000 kHz
    1.000 MHz*
    5.000 MHz*
    50 Ω | Sine | 2.828 Vrms | 10.00 MHz* | ±2.92%
    20.00 MHz*

    * These values are used in the Correction Factor Table below.

  5. In order to scale the power meter to the Fluke 5790A, a correction factor is calculated using the table below. The measurements of amplitudes from both the 5790A and the power meter at 1 MHz to 20 MHz are used. Enter the measured values for 1, 5, 10, and 20 MHz made with the Fluke 5790A into the Correction Factor table below. Then use the following formula to convert the Vrms results to dBm:

    dBm = 10×log10(20×Vrms2)

    Compute the average (arithmetic mean) of the four dBm results and enter the result into the table at the bottom of the Fluke 5790A dBm column.
  6. Connect the N8482A to the channel 1 output of the waveform generator using a Type N connector as shown below. Repeat the 1, 5, 10, and 20 MHz measurements and enter the dBm results into the table below. Compute the average (arithmetic mean) of the four dBm results and enter the result into the table at the bottom of the Power Meter dBm column.

    To avoid damaging the N8482A power sensor, be sure to insert the 10 to 20 dB attenuator in series with the measurement.

  7. Subtract the Power Meter dBm average from the Fluke 5790A dBm average to compute the correction factor. Record the result in the lower right corner of the Correction Factor table. Add this correction factor to all of your Power Meter measurements.

    Correction Factor Table

    Fluke 5790A | Power Meter
    Frequency | Vrms (measured) | dBm (see formula) | dBm (measured)
    1 MHz
    5 MHz
    10 MHz
    20 MHz
    Average (mean): Average (mean):
    Correction Factor (Fluke 5790A Average minus Power Meter average):
  8. Make the following measurements using the power meter. Set the 33600 Series instrument to the function, amplitude, and frequencies shown below. Record the measured dBm (remembering to add the correction factor) for each frequency in the table below.

    Waveform Generator | Measurement
    Use | Output Load | Function | Amplitude | Frequency | Error Relative to Step 3 Reference | Measured Result (dBm) | Corrected Result (dBm)
    50 Ω | Sine | 2.828 Vrms | 30.00 MHz | ±0.25 dB
    40.00 MHz
    50.00 MHz
    60.00 MHz
    50 Ω | Sine | 2.828 Vrms | 70.00 MHz | ±0.40 dB
    80.00 MHz
  9. Compare the measured values to the test limits shown in both tables.
  10. Two-channel instruments only: Connect the AC voltmeter to channel 2 and repeat steps 2 through 6.


General Calibration/Adjustment Procedure - 33600 Series

Recommended method for a complete instrument calibration:

  1. Read Test Considerations.
  2. Perform the verification tests to characterize the instrument (incoming data).
  3. Press [System > Instr Setup > Calibrate. If the instrument is secured from calibration, unsecure it.
  4. Enter the Setup Number for the procedure being performed. The default setup number is "1" and, from the front panel, the number will increment as the procedures are performed.
  5. Select BEGIN.
  6. For setups that require an input, adjust the value shown in the display to the measured value and select ENTER VALUE.
  7. The setup automatically advances to the next required value.

    To cancel the adjustment procedure, select CANCEL STEP. The display will return to the setup number entry.
  8. When finished, select END CAL.
  9. (Optional) Set a new calibration message using the remote interface. The message (up to 40 characters) is stored with the calibration coefficients.
  10. Secure the instrument against calibration.
  11. Note the new security code and calibration count in the instrument’s maintenance records.


Aborting a Calibration in Progress - 33600 Series

Sometimes it may be necessary to abort a calibration in progress. You can abort a calibration at any time by turning off the power or by issuing a remote interface device clear message followed by *RST.

The instrument stores calibration constants at the end of each adjustment procedure. If you lose power, or otherwise abort an adjustment in progress, you will only need to perform the interrupted adjustment procedure again.

Caution

If power is lost when the instrument is attempting to write new calibration constants to memory, you may lose all calibration constants for the function. Typically, upon re-applying power, the instrument will report error "-313, Calibration Memory Lost".


Sequence of Adjustments - 33600 Series

The adjustment sequence in the numbered steps minimizes the number of test equipment setups and connection changes.

You may perform individual adjustments as necessary, but setups 1 through 7 must be performed in order, before any other setup procedure.


Self-Test - 33600 Series

Run self-test to ensure that the instrument is in working order before beginning any additional adjustments.

Be sure to unlock the instrument and follow the requirements listed in Test Considerations before beginning any adjustments.

  1. Press [System > Instr Setup > Calibrate. Enter setup number 1 and select BEGIN.
    2. Setup |
1 | Performs the self-test. The Main Output is disabled during test.
  2. If the instrument fails any self-test, you must repair the instrument before continuing the adjustment procedures.

A complete self-test (*TST?) takes approximately 15 seconds.


Frequency (Internal Timebase) Adjustment - 33600 Series

The instrument stores a calibration constant that sets the crystal oscillator to put out exactly 10 MHz. The instrument should have been running continuously for 30 minutes prior to this calibration adjustment to ensure timebase stability

  1. Set the frequency counter resolution to better than 0.01 ppm and the input termination to 50 Ω (if your frequency counter does not have a 50 Ω input termination, you must provide an external termination). Make the connections shown below.

    Adjustment setup 1
  2. Use the frequency counter to measure the output frequency for each setup in the following table.
    3.  | Nominal Signal |  |
Setup | Frequency | Amplitude |
2 | <10 MHz | ~1 Vpp | Output frequency is slightly less than 10 MHz
3 | >10 MHz |  | Output frequency is slightly more than 10 MHz
4 | ~10 MHz |  | Output frequency should be near 10 MHz
5* | 10 MHz |  | Output frequency should be 10 MHz ± 1 ppm

    * Constants are stored after completing this setup.

  3. Using the numerical keypad or knob, adjust the displayed frequency at each setup to match the measured frequency. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform Internal Timebase Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


Internal ADC Adjustment - 33600 Series

The instrument stores calibration constants related to the gain and offset of the internal ADC. Setup 8 must always be performed before any other amplitude adjustments are attempted. The internal ADC is then used as a source for the calibration constants generated in self calibration (Setup9). (Setup 6 and Setup 7 are not used.)

  1. Connect the channel 1 output to the instrument's rear panel Modulation Input and DMM as shown below.
    Adjustment setup 4
  2. Set the DMM to display 5½ digits and set the function to DCV.
  3. Enter the following setup.
    4.  | Nominal Signal |
Setup | DC level |
8* | ~1.1 VDC ±10% | Calibrates the internal ADC.

    * Constants are stored after completing this setup.

  4. Use the numeric keypad or knob to enter the value measured on the DMM.

    5. Note

    This setup requires approximately 15 seconds to complete.
  5. Disconnect all cables from the instrument.


Self Calibration Adjustment - 33600 Series

  1. Enter and begin the following setup.
    2. Setup |
9* | Self-calibration. The output is disabled.

    * Constants are stored after completing this setup.

  2. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform DC Offset Voltage Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.

Note

This setup requires approximately 15 seconds to complete.


Output Impedance Adjustment - 33600 Series

The instrument stores calibration constants for the channels' output impedance. These constants are generated with and without the post-amplifier attenuator.

  1. Set the DMM to measure offset-compensated, four-wire Ohms. Set the DMM to use 100 NPLC integration. Connect the Ohms Source and Ohms Sense DMM inputs to the channel output as shown below.
    Adjustment setup 5
  2. Use the DMM to make a 4-wire resistance measurement at the front panel output connector for each setup in the following table. The expected measured value is approximately 50 Ω.
    3. Setup |
10* | Amplifier direct
11* | Amplifier plus 100 MHz filter
12* | Amplifier plus 150 MHz filter
13* | 24 dB post attenuator
14* | 24 dB post attenuator plus 150 MHz filter

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed impedance at each setup to match the measured impedance. Select ENTER VALUE.
  4. There are no specific operational verification tests for output impedance. Continue with the next adjustment procedure in this section.


AC Amplitude (high-impedance) Adjustment - 33600 Series

The instrument stores a calibration constant for each high-impedance attenuator path. Each path's gain coefficient is calculated using two measurements: one with the waveform DAC at + output and one with waveform DAC at – output. The setups, therefore, must be performed in pairs.

  1. Connect the DMM to the channel output as shown below.
    Adjustment setup 2
  2. Use the DMM to measure the DC voltage at the front panel connector for each setup in the following table.

    Setup | Nominal Signal
    DC Level
    15 | +0.0028 V | Output of -72 dB range
    16* | -0.0028 V | Output of -72 dB range
    17 | +0.0068 V | Output of -64 dB range
    18* | -0.0068 V | Output of -64 dB range
    19 | +0.0170 V | Output of -56 dB range
    20* | -0.0170 V | Output of -56 dB range
    21 | +0.0430 V | Output of -48 dB range
    22* | -0.0430 V | Output of -48 dB range
    23 | +0.1060 V | Output of -40 dB range
    24* | -0.1060 V | Output of -40 dB range
    25 | +0.2680 V | Output of -32 dB range
    26* | -0.2680 V | Output of -32 dB range
    27 | +0.6600 V | Output of -24 dB range
    28* | -0.6600 V | Output of -24 dB range
    29 | +1.6500 V | Output of -16 dB range
    30* | -1.6500 V | Output of -16 dB range
    31 | +4.2000 V | Output of -8 dB range
    32* | -4.2000 V | Output of -8 dB range
    33 | +10.4000 V | Output of 0 dB range
    34* | -10.4000 V | Output of 0 dB range
    35 | +0.0430 V | Output of -48 dB High DC range
    36* | -0.0430V | Output of -48 dB High DC range
    37 | +0.1060 V | Output of -40 dB High DC range
    38* | -0.1060 V | Output of -40 dB High DC range
    39 | +0.2680 V | Output of -32 dB High DC range
    40* | -0.2680 V | Output of -32 dB High DC range
    41 | +0.6600 V | Output of -24 dB High DC range
    42* | -0.6600 V | Output of -24 dB High DC range

    3. * Constants are stored after completing this setup.

  4. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  5. To proceed:
  1. If your calibration procedures require you to verify this adjustment, exit the calibration menu and perform AC Amplitude (high-impedance) Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


1 Vpp Flatness Adjustment - 33600 Series

  1. For frequencies up to and including 20 MHz, connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 3

    For frequencies above 20 MHz, connect a precision power sensor and power meter to measure the output amplitude as shown below.

  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.

    Setup | Nominal Signal
    Frequency | Amplitude
    43* | 1 kHz | 380 mVrms | Flatness for 1 Vpp range
    44* | 100 kHz
    45* | 1 MHz
    46* | 5 MHz
    47* | 10 MHz
    48* | 20 MHz
    49* | 25 MHz
    50* | 30 MHz
    51 | 40 MHz
    52 | 50 MHz
    53 | 60 MHz
    54 | 70 MHz
    55 | 80 MHz
    56 | 90 MHz
    57 | 100 MHz
    58 | 110 MHz
    59 | 120 MHz

    * Constants are stored after completing this setup.
  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform 1 Vpp Range Flatness Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


4 Vpp Flatness Adjustment - 33600 Series

  1. For frequencies up to and including 20 MHz, connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 3

    For frequencies above 20 MHz, connect a precision power sensor and power meter to measure the output amplitude as shown below.

  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.
    3. Setup | Nominal Signal |  |
 | Frequency | Amplitude |
60* | 1 kHz | 960 mVrms | Flatness for -8 dB range
61* | 100 kHz
62* | 1 MHz
63* | 5 MHz
64* | 10 MHz
65* | 20 MHz
66* | 25 MHz
67* | 30 MHz
68 | 40 MHz
69 | 50 MHz
70 | 60 MHz
71 | 70 MHz
72 | 80 MHz
73 | 90 MHz
74 | 100 MHz
75 | 110 MHz
76 | 120 MHz

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform 4 Vpp Range Flatness Verification.
  2. If you are making all the adjustments and then verifying the instrument’s performance, verify the output specifications of the instrument with the Performance Verification Tests.

This completes the adjustment procedures for the one-channel instrument. Verification of the output specifications is recommended.

If you are making adjustments to a two-channel instrument, continue with the next procedure in this section.


8 Vpp Flatness Adjustment - 33600 Series

  1. For frequencies up to and including 20 MHz, connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 3

    For frequencies above 20 MHz, connect a precision power sensor and power meter to measure the output amplitude as shown below.

  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.
    3. Setup | Nominal Signal |  |
 | Frequency | Amplitude |
77* | 1 kHz | 2.4 Vrms | Flatness for 0 dB range
78* | 100 kHz
79* | 1 MHz
80* | 5 MHz
81* | 10 MHz
82* | 20 MHz
83* | 25 MHz
84* | 30 MHz
85 | 40 MHz
86 | 50 MHz
87 | 60 MHz
88 | 70 MHz
89 | 80 MHz

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform 8 Vpp Range Flatness Verification.
  2. If you are making all the adjustments and then verifying the instrument’s performance, verify the output specifications of the instrument with the Performance Verification Tests.

This completes the adjustment procedures for the one-channel instrument. Verification of the output specifications is recommended.

If you are making adjustments to a two-channel instrument, continue with the next procedure in this section.


Channel 2 Adjustments - 33600 Series

The following topics describe calibration adjustments on channel 2.

  • Self Calibration Adjustment (Channel 2)
  • Output Impedance Adjustment (Channel 2)
  • AC Amplitude (high-impedance) Adjustment (Channel 2)
  • -16 dB Range Flatness Adjustment (Channel 2)
  • -8 dB Range Flatness Adjustment (Channel 2)
  • 0 dB Range Flatness Adjustment


Self Calibration Adjustment (Channel 2) - 33600 Series

  1. Enter and begin the following setup.
    2. Setup |
90* | Self-calibration. The output is disabled.

    * Constants are stored after completing this setup.

  2. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform DC Offset Voltage Verification. Be sure to do this for channel 2.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.

Note

This setup requires approximately 15 seconds to complete.


Output Impedance Adjustment (Channel 2) - 33600 Series

The instrument stores calibration constants for the channels' output impedance. These constants are generated with and without the post-amplifier attenuator.

  1. Set the DMM to measure offset-compensated, four-wire Ohms. Set the DMM to use 100 NPLC integration. Connect the Ohms Source and Ohms Sense DMM inputs to the channel output as shown below.
    Adjustment setup 6
  2. Use the DMM to make a 4-wire resistance measurement at the front panel output connector for each setup in the following table. The expected measured value is approximately 50 Ω.
  3. Setup
    91* | Amplifier direct
    92*

    Amplifier plus 100 MHz filter
    93* | Amplifier plus 150 MHz filter
    94* | 24 dB post attenuator
    95* | 24 dB post attenuator plus 150 MHz filter

    4. * Constants are stored after completing this setup.

  4. Using the numeric keypad or knob, adjust the displayed impedance at each setup to match the measured impedance. Select ENTER VALUE.
  5. There are no specific operational verification tests for output impedance. Continue with the next adjustment procedure in this section.


AC Amplitude (high-impedance) Adjustment (Channel 2) - 33600 Series

The instrument stores a calibration constant for each high-impedance attenuator path. Each path's gain coefficient is calculated using two measurements: one with the waveform DAC at + output and one with waveform DAC at – output. The setups, therefore, must be performed in pairs.

  1. Connect the DMM to the channel output as shown below.
    Adjustment setup 7
  2. Use the DMM to measure the DC voltage at the front panel connector for each setup in the following table.

  3. Setup | Nominal Signal
    DC Level
    96 | +0.0028 V | Output of -72 dB range
    97* | -0.0028 V | Output of -72 dB range
    98 | +0.0068 V | Output of -64 dB range
    99* | -0.0068 V | Output of -64 dB range
    100 | +0.0170 V | Output of -56 dB range
    101* | -0.0170 V | Output of -56 dB range
    102 | +0.0430 V | Output of -48 dB range
    103* | -0.0430 V | Output of -48 dB range
    104 | +0.1060 V | Output of -40 dB range
    105* | -0.1060 V | Output of -40 dB range
    106 | +0.2680 V | Output of -32 dB range
    107* | -0.2680 V | Output of -32 dB range
    108 | +0.6600 V | Output of -24 dB range
    109* | -0.6600 V | Output of -24 dB range
    110 | +1.6500 V | Output of -16 dB range
    111* | -1.6500 V | Output of -16 dB range
    112 | +4.2000 V | Output of -8 dB range
    113* | -4.2000 V | Output of -8 dB range
    114 | +10.4000 V | Output of 0 dB range
    115* | -10.4000 V | Output of 0 dB range
    116 | +0.0430 V | Output of -48 dB High DC range
    117* | -0.0430V | Output of -48 dB High DC range
    118 | +0.1060 V | Output of -40 dB High DC range
    119* | -0.1060 V | Output of -40 dB High DC range
    120 | +0.2680 V | Output of -32 dB High DC range
    121* | -0.2680 V | Output of -32 dB High DC range
    122 | +0.6600 V | Output of -24 dB High DC range
    123* | -0.6600 V | Output of -24 dB High DC range

  4. * Constants are stored after completing this setup.
  5. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  6. To proceed:
  1. If your calibration procedures require you to verify this adjustment, exit the calibration menu and perform AC Amplitude (high-impedance) Verification.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


1 Vpp Flatness Adjustment (Channel 2) - 33600 Series

  1. For frequencies up to and including 20 MHz, connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 3

    For frequencies above 20 MHz, connect a precision power sensor and power meter to measure the output amplitude as shown below.

  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.

    Setup | Nominal Signal
    Frequency | Amplitude
    124* | 1 kHz | 380 mVrms | Flatness for 1 Vpp range
    125* | 100 kHz
    126* | 1 MHz
    127* | 5 MHz
    128* | 10 MHz
    129* | 20 MHz
    130* | 25 MHz
    131* | 30 MHz
    132 | 40 MHz
    133 | 50 MHz
    134 | 60 MHz
    135 | 70 MHz
    136 | 80 MHz
    137 | 90 MHz
    138 | 100 MHz
    139 | 110 MHz
    140 | 120 MHz

    * Constants are stored after completing this setup.
  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform 1 Vpp Range Flatness Verification. Be sure that you do this for Channel 2.
  2. If you are making all of the adjustments and then verifying the instrument’s performance, continue with the next procedure in this section.


4 Vpp Flatness Adjustment (Channel 2) - 33600 Series

This section applies to channel 2. It checks high frequency AC amplitude flatness on the -8 dB attenuator range. It also checks flatness for all other ranges excluding the -24 dB and 0 dB attenuator ranges.

  1. For frequencies up to and including 20 MHz, connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 3

    For frequencies above 20 MHz, connect a precision power sensor and power meter to measure the output amplitude as shown below.

  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.

    Setup | Nominal Signal
    Frequency | Amplitude
    141* | 1 kHz | 960 mVrms | Flatness for -8 dB range
    142* | 100 kHz
    143* | 1 MHz
    144* | 5 MHz
    145* | 10 MHz
    146* | 20 MHz
    147* | 25 MHz
    148* | 30 MHz
    149 | 40 MHz
    150 | 50 MHz
    151 | 60 MHz
    152 | 70 MHz
    153 | 80 MHz
    154 | 90 MHz
    155 | 100 MHz
    156 | 110 MHz
    157 | 120 MHz

    3. * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. You have now completed the recommended adjustment procedures. Verification of the output specifications is recommended.
    1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform 4 Vpp Range Flatness Verification.


8 Vpp Flatness Adjustment - 33600 Series

  1. For frequencies up to and including 20 MHz, connect a precision AC voltmeter to measure the output amplitude as shown below. Connect the BNC cable to the Wide Band input of the Fluke 5790A.

    Adjustment setup 3

    For frequencies above 20 MHz, connect a precision power sensor and power meter to measure the output amplitude as shown below.

  2. Use the precision AC voltmeter to measure the output amplitude for each setup in the table below.
    3. Setup | Nominal Signal |  |
 | Frequency | Amplitude |
158* | 1 kHz | 2.4 Vrms | Flatness for 0 dB range
159* | 100 kHz
160* | 1 MHz
161* | 5 MHz
162* | 10 MHz
163* | 20 MHz
164* | 25 MHz
165* | 30 MHz
166 | 40 MHz
167 | 50 MHz
168 | 60 MHz
169 | 70 MHz
170 | 80 MHz

    * Constants are stored after completing this setup.

  3. Using the numeric keypad or knob, adjust the displayed voltage at each setup to match the measured voltage. Select ENTER VALUE.
  4. To proceed:
  1. If your calibration procedures require you to verify the adjustment just made, exit the calibration menu and perform 8 Vpp Range Flatness Verification.
  2. If you are making all the adjustments and then verifying the instrument’s performance, verify the output specifications of the instrument with the Performance Verification Tests.

This completes the adjustment procedures for the one-channel instrument.Verification of the output specifications is recommended.

If you are making adjustments to a two-channel instrument, continue with the next procedure in this section.


Calibration Errors - 33600 Series

The following errors may occur during calibration. There are also system errors and self-test errors. Some error messages include a failing channel number (1 or 2), shown as n in the messages below.

701 Calibration error; security defeated by hardware jumper

If you short the calibration secure jumper (CAL ENABLE) while turning the instrument on, this error indicates the security password has been overwritten. See Calibration Security for details.

702 Calibration error; calibration memory is secured

To perform calibration, unsecure the instrument. See Calibration Security for details.

703 Calibration error; secure code provided was invalid

Specified security code was invalid.

706 Calibration error; value out of range

Value entered was outside valid range.

707 Calibration error; signal input is out of range

Occurs during the ADC Adjustment, setup 6, if the 1 V input voltage is too high. May also occur during self-calibration (setup 7). Run self-test to diagnose problem.

710 Self-calibration failed; Chan n, null DAC cal, invalid self cal
Self-calibration failed; Chan n, offset DAC cal with attenuator, invalid self cal
Self-calibration failed; Chan n, offset DAC cal no attenuator, invalid self cal

Error occurred while performing internal calibration of specified DAC. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

711 Self-calibration failed; Chan n, null DAC cal gain too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal with attenuator gain too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal no attenuator gain too low (too high), <meas_value>

Computed gain calibration factor for specified DAC was out of limits. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

712 Self-calibration failed; Chan n, null DAC cal zero too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal with attenuator zero too low (too high), <meas_value>
Self-calibration failed; Chan n, offset DAC cal no attenuator zero too low (too high), <meas_value>
Self-calibration failed; Chan n, GND measurement out of limits, <meas_value>

Computed zero calibration factor for specified DAC was out of limits. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

715 Self-calibration failed; Chan n, null DAC cal, convergence error sub attenuator value dB

Internal null DAC calibration failed to converge during internal calibration. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

720 Self-calibration failed; Chan n, offset DAC cal with attenuator, convergence error
Self-calibration failed; Chan n, offset DAC cal no attenuator, convergence error

Internal offset DAC calibration failed to converge internal calibration. Self-calibration exited without changing self-calibration constants. Run self-test to diagnose problem.

850 Calibration error; set up is invalid

Invalid calibration setup number selected.

850 Calibration error; set up is out of order

Certain calibration steps require a specific beginning and ending. Do not enter into the middle of a calibration sequence.

Previous Calibration Topic


Block Diagram - 33500 Series

The instrument has four main assemblies:

  • Processor
  • Main board
  • Front panel
  • Main power supply

A simplified block diagram appears at the bottom of this section.

The processor is a single board computer that contains the CPU, RAM, ROM, and circuits used to drive the GPIB, LAN, and USB ports. The built in web interface is contained in the ROM. The processor circuitry is earth referenced.

When the power switch is pressed, the processor communicates with and loads the FPGA. This communication uses three asynchronous serial data lines and one serial clock line. These four lines are isolated.

The FPGA stores all waveforms except arbitrary waveforms. Arbitrary waveforms are loaded into SDRAM on the main board. All control of waveforms, triggers, sync signals, output path, attenuation, and offset is provided by the FPGA.

The main waveform for each channel (only one channel is shown in the block diagram) is loaded into the waveform DAC and clocked by the timebase. The DAC output passes through an elliptical filter before the main attenuators. There are three attenuators available in the path, -7.96 dB, -15.91 dB, and -23.87 dB.

The signal is applied to the output amplifier. The DC offset is summed at the output amplifier. A post amplifier -23.87 dB attenuator is available for low level signals. The table below show the attenuators that create the output signal amplitude.

Output Range DC Offset < 320 mV | -7.96 dB | -15.91 dB | -23.87 dB | -23.87 dB (post)
10 Vpp - 3.6 Vpp | Out | Out | Out | Out
4 Vpp - 1.44 Vpp | In | Out | Out | Out
1.6 Vpp - 576 mVpp | Out | In | Out | Out
640 mVpp - 230 mVpp | Out | Out | Out | In
256 mVpp - 92 mVpp | In | Out | Out | In
102.4 mVpp - 36.86 mVpp | Out | In | Out | In
40.96 mVpp - 14.75 mVpp | Out | Out | In | In
16.38 mVpp - 5.90 mVpp | In | Out | In | In
6.55 mVpp - 2.36 mVpp | Out | In | In | In
2.62 mVpp - 1.00 mVpp | In | In | In | In

Output Range DC Offset ≥ 320 mV | -7.96 dB | -15.91 dB | -23.87 dB | -23.87 dB (post)
9.36 Vpp - 3.6 Vpp | Out | Out | Out | Out
4 Vpp - 1.44 Vpp | In | Out | Out | Out
1.6 Vpp - 576 mVpp | Out | In | Out | Out
640 mVpp - 230 mVpp | Out | Out | In | Out
256 mVpp - 92 mVpp | In | Out | In | Out
102.4 mVpp - 36.86 mVpp | Out | In | In | Out
40.96 mVpp - 1.00 mVpp | In | In | In | Out

The output relay when enabled provides the waveform to the front panel BNC connector. Additionally, this relay, when disabled, routes the signal to the Modulation ADC for internal self-test and calibration routines.

The output relay is controlled by the FPGA. Two circuits provide overvoltage and over current protection, primarily from an external circuit. The instrument can source very low output impedances.

The Sync output signal is generated as a waveform from the FPGA to the Sync DAC.

External trigger in and out is chassis referenced at the BNC connector but is isolated before the FPGA.

Modulation in is an isolated input to the A/D converter. The FPGA applies the modulation signal to the output waveform.

The instrument's clock generator employs a 10-MHz crystal oscillator and a phase-locked loop to generate the 250-MHz clocks used by the FPGA and Waveform DACs. When an external 10-MHz frequency reference is used, a digital phase-locked loop in the FPGA keeps the crystal oscillator in sync.

Block Diagram - 33500 Series


Block Diagram - 33600 Series

The instrument has four main assemblies:

  • Processor
  • Main board
  • Front panel
  • Main power supply

A simplified block diagram appears at the bottom of this section.

The processor is contained within the Front Panel Assembly, and contains the CPU, RAM, and ROM, as well as circuits used to drive the GPIB, LAN, and USB ports. The built in web interface is contained in the ROM. The processor circuitry is earth referenced.

When the power switch is pressed, the processor communicates with and loads the FPGA on the Mezzanine Assembly. This communication uses three asynchronous serial data lines and one serial clock line. These four lines are isolated.

The FPGA stores all waveforms except arbitrary waveforms. Arbitrary waveforms are loaded into SDRAM on the Mezzanine Assembly. All control of waveforms, triggers, sync signals, output path, attenuation, and offset is provided by the FPGA.

The main waveform for each channel (only one channel is shown in the block diagram) is loaded into the waveform DAC and clocked by the Clock Generator. The DAC output passes through an Anti-Alias Filter before the main attenuators. There are three attenuators available in the path, -7.96 dB, -15.91 dB, and -23.87 dB.

The signal is applied to the output amplifier. The DC offset is summed at the output amplifier. A post amplifier -23.87 dB attenuator is available for low level signals. The table below show the attenuators that create the output signal amplitude.

Output Range DC Offset < 320 mV | -7.96 dB | -15.91 dB | -23.87 dB | -23.87 dB (post)
10 Vpp - 4.0001 Vpp | Out | Out | Out | Out
4.1 Vpp - 1.44 Vpp | In | Out | Out | Out
1.6 Vpp - 576 mVpp | Out | In | Out | Out
640 mVpp - 230 mVpp | Out | Out | Out | In
256 mVpp - 92 mVpp | In | Out | Out | In
102.4 mVpp - 36.86 mVpp | Out | In | Out | In
40.96 mVpp - 14.75 mVpp | Out | Out | In | In
16.38 mVpp - 5.90 mVpp | In | Out | In | In
6.55 mVpp - 2.36 mVpp | Out | In | In | In
2.62 mVpp - 1.00 mVpp | In | In | In | In

Output Range DC Offset ≥ 320 mV | -7.96 dB | -15.91 dB | -23.87 dB | -23.87 dB (post)
9.36 Vpp - 3.6 Vpp | Out | Out | Out | Out
4 Vpp - 1.44 Vpp | In | Out | Out | Out
1.6 Vpp - 576 mVpp | Out | In | Out | Out
640 mVpp - 230 mVpp | Out | Out | In | Out
256 mVpp - 92 mVpp | In | Out | In | Out
102.4 mVpp - 36.86 mVpp | Out | In | In | Out
40.96 mVpp - 1.00 mVpp | In | In | In | Out
DC Volts function < 320 mV | In | In | In | In
DC Volts function ≥ 320 mV | In | In | In | Out

Two relays in the Output Switching and Filters block provide three paths to the front anel BNC connector (one straight-through and two through filters that reduce output distortion) as well as an open path to disable the output. An attenuated version of the output is fed to the Modulation ADC to be used for internal self-test and calibration.

The output relays are controlled by the FPGA. Two circuits provide overvoltage and over current protection, primarily from an external circuit. The instrument can source very low output impedances.

The Sync output signal is generated as a waveform from the FPGA to the Sync DAC.

External trigger in and out is chassis referenced at the BNC connector but is isolated before the FPGA.

Modulation In is an input to the A/D converter. The FPGA applies the modulation signal to the output waveform.

The instrument's clock generator employs a 10-MHz crystal oscillator and a phase-locked loop to generate the 2-GHz clocks used by the FPGA and Waveform DACs. When an external 10-MHz frequency reference is used, a phase-locked loop in the FPGA keeps the crystal oscillator in sync.

Block Diagram - 33600 Series


Power Supplies - 33500 Series

The line voltage is filtered and applied to the main power supply, a +15 V supply that is always on when line power is applied. A regulator creates an earth referenced +3.3 V supply from the main supply, and this is also always active when line power is applied.

A small microprocessor on the main board senses the power switch and enables all other supplies.

Power supply block diagram


Power Supplies - 33600 Series

The line voltage is filtered and applied to the main power supply, a +24 V supply that is always on when line power is applied. A regulator creates an earth referenced +5 V supply from the main supply, and this is also always active when line power is applied.

A small microprocessor on the front panel senses the power switch and enables all other supplies.

Power supply block diagram


Troubleshooting - 33500 Series

A brief list of common failures appears below. Before troubleshooting or repairing the instrument, make sure the failure is in the instrument rather than any external connections. Also make sure that the instrument was accurately calibrated within the last year. The instrument’s circuits allow troubleshooting and repair with basic test equipment.

Unit is Inoperative

Verify that:

  • the AC power cord is securely connected to the instrument and plugged into a live outlet
  • the front panel Power On/Standby switch has been pushed

Unit Fails Self-Test

Ensure that all connections (front and rear) are removed when self-test is performed. During self-test, errors may be induced by signals present on external wiring, such as long test leads that can act as antennas.

Caution

DO NOT swap the motherboard, the processor board, or the front panel board from one instrument to another. These boards contain model number and serial number information that uniquely identifies a specific unit, and boards that are mismatched to the instrument may result in problems with its performance, licensing, serviceability, importability/exportability or warranty.

Power Supplies

Verify the main power supply.

Warning

Shock Hazard. To check the power supplies, remove the instrument cover as described in Disassembly.

The main power supply provides a +15 VDC (±0.3 VDC) supply to the main circuit board. All other supplies are derived from this supply. This supply is energized at all times while the line power cord is connected.

Test the supply at the connector to the main board. Note that the supply is not referenced to the chassis when disconnected from the main board.

  • Circuit failure can cause heavy supply loads which may pull down the supply output voltage. Disconnect the main supply from the main board to test.
  • Always check the supply is free of oscillations using an oscilloscope.
  • The main power supply contains a fuse. Replacing this fuse is not recommended. Replace the entire main power supply assembly. Note that power supply failures are often caused by other instrument failures.

Caution

The heat sinks on the main board are at different potentials. Damage may occur if any of the heat sinks are shorted together. Use care when probing the main board.

Verify the power supplies listed in the table below and shown in the power supply block diagram. Earth referenced supplies may be tested using the chassis as ground. Isolated supplied may be tested by using one of the heat sinks shown in the figure.

Supply

+3.3 V ER*

+5 ER

+15 V Isolated

-15 V Isolated

+9 V Isolated

-9 V Isolated

+3.3 V Isolated

+5 V Isolated

* This supply is active whenever AC power is applied to the instrument.

Power supply test

Self-Test Errors 605 - 609

Self-test errors 605-609 indicate that the processor board is unable to correctly program or communicate with the waveform FPGA (U1005) on the main board. In this case, further troubleshooting is required. The problem could be due to out of date firmware, or a failing or unseated processor board or main board. Before troubleshooting these errors, ensure that the instrument firmware is up to date. If the errors are still being reported, continue with the following procedure.

Reseat the Boards

Power off the unit, remove the cover. Reseat the processor board and the main board. Power up the unit and see if the errors 605-609 are still reported at power-on.

Check Power Supplies

Probe the system power supplies and verify they are operating within limits. If any of the power supplies are out of limit, diagnose the power supply. Otherwise, continue on to check SPI communications.

Check SPI Communications

If you still see errors after reseating the boards, the next step is to probe the SPI communications lines between the processor board and the main board. First, locate LED DS1001 on the main board as shown below. Cycle power on the unit, wait until it fully boots, and see whether the main board LED illuminates. The main board LED indicates whether the FPGA was successfully programmed. The following sections indicate which signal lines to probe on the main board connector (J201).

Main Board LED Lights up after Boot

This indicates that the FPGA is programmed and running. Most likely there is a communications failure from the main board to the processor board. Probe the J201, pin 27 line with an oscilloscope, and cycle power on the unit (wait for full boot) to see if there is activity on the line. Activity should be +3.3 V pulses (isolated). Note that activity ceases once the instrument is booted.

  • If there is no activity on the line even after the LED lights up, then most likely the main board is the cause of the failure.
  • If there is activity on the line, then the processor board is the most likely cause of the failure.

Serial data test

Main Board LED Does not Light up after Boot

This indicates that the processor was unable to program the FPGA. Most likely there is a communications failure from the processor board to the main board. Probe the following serial data lines at power up with an oscilloscope:

  • J201, pin 23
  • J201, pin 24
  • J201, pin 26
  • J201, pin 32

If all of the above SPI lines show activity during FPGA programming, then the main board is the most likely cause of the failure. Otherwise, the processor board is the most likely cause.

10 MHz Out

If the power supplies are functional and self-test passes, check the 10 MHz output at the rear panel. This output is present whenever the instrument has powered on and the processor and main board are operational. If the 10 MHz is present, but the display is not working, suspect the front panel board or display assembly.


Troubleshooting - 33600 Series

A brief list of common failures appears below. Before troubleshooting or repairing the instrument, make sure the failure is in the instrument rather than any external connections. Also make sure that the instrument was accurately calibrated within the last year. The instrument’s circuits allow troubleshooting and repair with basic test equipment.

Unit is Inoperative

Verify that:

  • the AC power cord is securely connected to the instrument and plugged into a live outlet
  • the front panel Power On/Standby switch has been pushed

Unit Fails Self-Test

Ensure that all connections (front and rear) are removed when self-test is performed. During self-test, errors may be induced by signals present on external wiring, such as long test leads that can act as antennas.

Caution

DO NOT swap the motherboard, the processor board, or the front panel board from one instrument to another. These boards contain model number and serial number information that uniquely identifies a specific unit, and boards that are mismatched to the instrument may result in problems with its performance, licensing, serviceability, importability/exportability or warranty.

Power Supplies

Verify the main power supply.

Warning

Shock Hazard. To check the power supplies, remove the instrument cover as described in Disassembly.

The main power supply assembly provides a +24 VDC supply to the main circuit board. All other supplies are derived from this supply. This supply is energized at all times while the line power cord is connected.

Caution

Test the supply at the connector to the main board. Note that the supply is not referenced to the chassis when disconnected from the main board. If the connector is connected to the main board, ensure that the main board mounting screw is in place and the AC inlet ground (green/yellow wire) is connected to the chassis.
  • Circuit failure can cause heavy supply loads which may pull down the supply output voltage. Disconnect the main supply from the main board to test.
  • Always check the supply output is free of oscillations using an oscilloscope.

Caution

The main power supply contains two fuses. Replacing these fuses is not recommended. Replace the entire main power supply assembly. Note that power supply failures are often caused by other instrument failures.

Caution

The heat sinks on the main board are at different potentials. Damage may occur if any of the heat sinks are shorted together. Use care when probing the main board.

Main Board Power Supplies

Verify the power supplies listed in the table below and shown in the power supply block diagram. Earth referenced supplies may be tested using the chassis as ground. Isolated supplied may be tested by using one of the heat sinks.

The line voltage is filtered and applied to the main power supply, a +24 V (±0.3 VDC) supply that is always on when line power is applied. Regulators on the front panel board create earth referenced +5 V and +3.3 V supplies from the main supply, which are also always active when line power is applied.

Main board LEDs illuminate at power-on to indicate that the +5 V Isolated and +3.3 V Isolated power supplies are good. On the main board, LED DS2001 illuminates to indicate the +3.3 V Isolated power supply is operating, and LED DS2002 illuminates to indicate the +5 V Isolated power supply is operating.

Power Supplies on Main Board

+3.3 V ER*

+5 ER

+15 V Isolated

-15 V Isolated

+9 V Isolated

-9 V Isolated

+3.3 V Isolated*** DS2001

+5 V Isolated**, *** DS2002

* This supply is active whenever AC power is applied to the instrument.
** This supply also provides power to the Mezzanine Board power supplies.
*** This supply has a "power-good" indicator LED as indicated in the picture below.

Mezzanine Board Power Supplies

Power Supplies on Mezzanine Board
+1.1 V*** DS1501 +1.5 V*** DS1501 +1.8 V*** DS1501 +2.5 V*** DS1501

*** This supply has a "power-good" indicator LED as indicated in the picture below.

Self-Test Errors 607 through 611

Self-test errors 607-611 indicate that the processor board is unable to correctly program or communicate with the waveform FPGA (U301) on the mezzanine board. In this case, further troubleshooting is required. The problem could be due to out of date firmware, or a failing or unseated processor board or main board. Before troubleshooting these errors, ensure that the instrument firmware is up to date. If the errors are still reported, continue with the following procedure.

Reseat the Boards

Power off the unit and remove the cover. Reseat the mezzanine board and the main board. Power up the unit and see whether errors 607 through 611 are still reported. Check all power good LEDs to see if the power supplies are operating. Not all power supplies have an LED.

Check SPI Communications

If you still see self-test errors after reseating the boards, the next step is to probe the SPI communications lines between the processor board and the main board. First, locate LED DS1501 on the mezzanine board as shown above. Cycle power on the unit, wait until it fully boots, and see whether the main board "power good" LEDs (DS2001, DS2002) illuminate. Check whether the mezzanine board "power good" LED DS1501 illuminates, indicating the mezzanine board power supplies are good.

Check FPGA programming success

The DS401 LED on the mezzanine board (to the left of DS1501 in the picture above) indicates whether the FPGA was successfully programmed. If illuminated, it indicates that the FPGA is programmed and running. If it fails to light and all power supplies are good, most likely there is a SPI communications failure from the processor board to the main board or from the main board to the mezzanine board.

Check SPI Communications

Probe the front panel to main board connector J201 pins 23, 24, 26 and 27 to check for activity during bootup between the main board and the front panel board. Activity should be +3.3 V pulses (isolated). Note that activity ceases or becomes infrequent once the instrument is booted. If there is no activity, the fault most likely lies in the front panel board.

Probe the Opto isolator U602 pin 6 on the main board with an oscilloscope, and cycle power on the unit (wait for full boot) to see if there is activity on the line. This line is used to reset the FPGA to initiate programming. Activity should be +3.3 V pulses (isolated).

Also check U601 (on the main board) pins 11, 12, 13, and 14 for activity during bootup. Note that activity ceases or becomes infrequent once the instrument is booted.

If there is no activity, the fault most likely lies in the main board.

If there is activity and the DS401 LED does not light, the fault most likely lies in the mezzanine board.

10 MHz Out

If the power supplies are functional and self-test passes, check the 10 MHz output at the rear panel. This output is present whenever the instrument has powered on and the processor and main board are operational. If the 10 MHz is present, but the display is not working, suspect the front panel board or display assembly.


Self-Test Procedures

Power-On Self-Test

Each time the instrument is powered on, self-tests are performed to check that the minimum set of logic and subsystems are functioning properly.

Full Self-Test

Passing self-test provides a high degree of confidence that instrument is operating normally. Self-test procedure systematically exercises internal oscillator, digital infrastructure, waveform memory, and analog attenuator paths. It attempts to isolate failures to a particular assembly to facilitate service. During the test, instrument main output(s) are disconnected internally from the BNC connectors and are connected to the internal ADC, which checks for expected signal levels throughout the instrument.

A complete self-test (*TST?) takes approximately 15 seconds. You may hear relays switching during the procedure. When self-test completes, either "Self-test Passed" or "Self-test Failed" appears on the front panel. Self-test error messages are described in detail below.

Execute self-test before any verifications or adjustments.

To Run Self-Test

Remove all input connections to instrument before self-test. Cycle power to run power-on self-test.

Remote I/O Execution

  1. Connect to instrument using remote interface (LAN Configuration Procedure).
  2. Send *TST? and read the result: Pass (+0) or fail (+1). Use SYSTem:ERRor? to view errors.

Front Panel Execution

  1. Press [System] > Instr Setup > Self Test.
  2. A progress bar will appear as self-test executes. After completion, view any failures by pressing [System] > Help and then choosing the topic View remote command error queue.

Self-Test Error Numbers and Messages (33500 Series)

A failure can generate multiple error messages; the first one should be considered the primary cause of failure. Some error messages include a failing channel number (1 or 2), shown as n in the messages below.

Error | Message and Meaning (33500 Series) | Probable Cause (33500 Series)
601 | Self-test failed; real time clock settings lost Real time clock's date-time settings were lost, likely due a disconnected or discharged RTC battery (coin cell found on the front panel board). Error can also occur if processor board is removed and reinserted into front panel assembly. This error condition is captured at power-on, and will be reported by self-test until the problem is corrected and power is cycled. | RTC Battery
602 | Self-test failed; main CPU power supply out of range Processor board detected that one of its supplies was more than 10% out of the nominal voltage range. | Processor Board
603 | Self-test failed; main CPU error accessing boot env Processor wasn't able to access its boot parameters from flash, possibly due to out of date firmware, or a problem on the processor board. | Processor Board
604 | Self-test failed; front panel processor ping failed Processor board tried to read front panel revision code and received a 0, possibly due to un-programmed front panel processor, unseated processor board, or defective front panel processor. | Front Panel Board
605 | Self-test failed; waveform FPGA not programmed Processor could not program the waveform FPGA (U1005) at boot-up. The hardware will not work properly. | Processor Board or Main Board. See Troubleshooting for additional information on troubleshooting errors 605-609.
606 | Self-test failed; waveform FPGA revision check failed Processor tried to read the revision register from the waveform FPGA (U1005) and received an invalid value, possibly due to un-programmed FPGA or internal SPI communications failure.
607 | Self-test failed; waveform FPGA read back error Processor was unable to write and read back from a test location in the waveform FPGA (U1005), possibly due to un-programmed FPGA or internal SPI communications failure.
608 | Self-test failed; waveform FPGA security check failed Waveform FPGA (U1005) failed internal security check, possibly due to FPGA failures (tests 605-608), invalid FPGA image, or malfunctioning security device (U1007).Self-test exits on this failure.
609 | Self-test failed; waveform FPGA security check failed Waveform FPGA (U1005) failed internal security check, possibly due to FPGA failures (tests 605-608), invalid FPGA image, or malfunctioning security device (U1007).Self-test exits on this failure.
610 | Self-test failed; main PLL not locked Waveform FPGA (U1005) unable to lock to internal 10MHz oscillator (U903 or U905). | Main Board
611 | Self-test failed; FPGA PLL not locked Waveform FPGA (U1005) unable to lock to internal sample clock generator IC (U906). | Main Board
612 | Self-test failed; Chan n, waveform memory PLL not locked Waveform RAM for indicated channel (U1101 or U1102) was unable to lock to its clock. | Main Board
613 | Self-test failed; Chan n, waveform memory not initialized Waveform RAM for indicated channel (U1101 or U1102) failed to initialize. | Main Board
615 | Self-test failed; modulation ADC offset too low (too high) Internal ADC's measurement of ACOM out of limits. | Main Board
616 | Self-test failed; modulation ADC reference too low (too high) Internal ADC's measurement of its voltage reference (VRef) was out of limits. | Main Board
620 | Self-test failed; Chan n, waveform memory test failed on idle Waveform memory test not started properly, probably due to error in waveform FPGA (U1005) | Main Board
621 | Self-test failed; Chan n, waveform memory test failed Waveform RAM memory test for the indicated channel (U1101 or U1102) failed; test consists of writing and reading back the entire waveform RAM with a predetermined pattern. | Main Board
625 | Self-test failed; Chan n, waveform DAC gain[idx] too low (too high) Waveform DAC (U1801 or U1501) not providing correct output. Gain [idx] of 1 references POS voltage test; gain [idx] of 2 references NEG voltage test. | Main Board
630 | Self-test failed; Chan n, sub attenuator failure 0dB Trim DAC inside waveform DAC (U1801 or U1501) not providing correct output at 0 dB. If this fails, test 631 will not be executed. | Main Board
631 | Self-test failed; Chan n, sub attenuator <-7.00 to 0.00>dB too low (too high) Trim DAC inside waveform DAC (U1801 or U1501) producing output outside expected range. | Main Board
635 | Self-test failed; Chan n, null DAC gain[idx] too low (too high) Aux DAC output of waveform DAC (U1801 or U1501) or its associated analog circuitry producing output outside expected range. Gain [idx] of 1 references POS voltage test; gain [idx] of 2 references NEG voltage test. | Main Board
640 | Self-test failed; Chan n, offset DAC gain[idx] too low (too high) Offset DAC (U1702 or U2002) or its associated circuitry producing output outside expected range. For offset DAC, [idx] polarities are inverted: gain [idx] of 1 references NEG voltage test; gain [idx] of 2 references POS voltage test. | Main Board
650 | Self-test failed; Chan n, 0dB path failure expected 0dB, measured value dB Straight-through path (no attenuator) from waveform DAC to ADC input producing output outside expected range. If this fails, extended attenuator test 655 is not executed. | Main Board
655 | Self-test failed; Chan n, -8 dB pre attenuator path too low (too high) Self-test failed; Chan n, -16 dB pre attenuator path too low (too high) Self-test failed; Chan n, -24 dB pre attenuator path too low (too high) Self-test failed; Chan n, -24 dB post attenuator path too low (too high) Specified attenuator relay malfunctioning, or associated circuitry not providing expected attenuation. | Main Board

Self-Test Error Numbers and Messages (33600 Series)

A failure can generate multiple error messages; the first one should be considered the primary cause of failure. Some error messages include a failing channel number (1 or 2), shown as n in the messages below.

Error | Message and Meaning (33600 Series) | Probable Cause (33600 Series)
601 | Self-test failed; real time clock settings lost Real time clock's date-time settings were lost, likely due a disconnected or discharged RTC battery (coin cell found on the front panel board). Error can also occur if processor board is removed and reinserted into front panel assembly. This error condition is captured at power-on, and will be reported by self-test until the problem is corrected and power is cycled. | RTC Battery
602 | Self-test failed; keyboard processor not responding A front panel microprocessor is not functional. | Front Panel Board
603 | Self-test failed; incorrect keyboard processor product ID A front panel microprocessor is faulty. | Front Panel Board
604 | Self-test failed; FPGA temperature out of limits Temperature sensor on the FPGA (U301 on the mezzanine board) indicates excessive temperature. | Mezzanine Board or Fan
604 | Self-test failed; unknown CPU exception during temperature test Attempt to communicate with temperature sensor on the FPGA (U301 on the mezzanine board) failed. | Front Panel Board
605 | Self-test failed; front panel I2C communication to main board temp sensor failed A front panel communications with a temperature sensor on the main board is not operating. | Main Board
605 | Self-test failed; main board temperature out of limits A temperature sensor on the main board indicates excessive temperature. | Main Board or Fan
606 | Self-test failed; front panel processor ping failed Processor board tried to read front panel revision code and received a 0, possibly due to an unprogrammed or defective front panel processor. | Front Panel Board
607 | Self-test failed; waveform FPGA not programmed Processor could not program the waveform FPGA (U301 on mezzanine board) at boot-up. The hardware will not work properly. | Front panel board, Main board, or Mezzanine board. See Troubleshooting 33600 Series for additional information on troubleshooting errors 607 to 611.
608 | Self-test failed; waveform FPGA revision check failed Processor tried to read the revision register from the waveform FPGA (U301 on mezzanine board) and received an invalid value, possibly due to an unprogrammed FPGA or an internal SPI communications failure.
609 | Self-test failed; waveform FPGA read back error Processor was unable to write and read back from a test location in the waveform FPGA (U301 on mezzanine board), possibly due to an unprogrammed FPGA or internal SPI communications failure.
610 | Self-test failed; waveform FPGA error Processor was unable to write and read back from the FPGA due to hardware failure in the waveform FPGA (U301 on mezzanine board), or possibly due to an unprogrammed FPGA or internal SPI communications failure.
611 | Self-test failed; waveform FPGA authentication failed Processor was unable to verify that the FPGA programmed correctly and verify the security check. | Mezzanine Board. See Troubleshooting 33600 Series for additional information on troubleshooting errors 607 to 611.
612 | Self-test failed; main PLL not locked Phase Locked Loop circuit on the Mezzanine board was unable to lock to the internal 10 MHz reference oscillator. | Mezzanine Board
613 | Self-test failed; FPGA not locked to 250MHz Phase Locked Loop circuit on the Mezzanine board was unable to lock at 250 MHz. | Mezzanine Board
614 | Self-test failed; waveform memory PLL not locked Phase Locked Loop circuit on the Mezzanine board was unable to lock at waveform memory frequency. | Mezzanine Board
615 | Self-test failed; waveform memory not initialized The waveform memory did not correctly initialize. |
616 | Self-test failed; modulation ADC offset too low The external modulation ADC circuit has failed to properly measure a ground reference voltage. | Main Board
616 | Self-test failed; modulation ADC offset too high The external modulation ADC circuit has failed to properly measure a ground reference voltage. | Main Board
617 | Self-test failed; modulation ADC reference too low The external modulation ADC circuit has failed to measure a reference voltage properly. | Main Board
617 | Self-test failed; modulation ADC reference too high The external modulation ADC circuit has failed to measure a reference voltage properly. | Main Board
620 | Self-test failed; Chan n, waveform memory test failed on idle Waveform memory test not started properly, probably due to error in waveform FPGA (U301). | Mezzanine Board
621 | Self-test failed; Chan n, waveform memory test failed Waveform RAM memory test for the indicated channel (U601 and U602 or U701 and U702) failed; test consists of writing and reading back the entire waveform RAM with a predetermined pattern. | Mezzanine Board
625 | Self-test failed; Chan n, waveform DAC gain[idx] too low (too high) Waveform DAC (U1001 or U1101 on mezzanine board) not providing correct output. Gain [idx] of 1 references Positive voltage test; gain [idx] of 2 references Negative voltage test. Also tests U901 and U902 for Channel 1 or U1401 and U1402 (for channel 2) on the main board. | Mezzanine Board or Main Board
626 | Self-test failed; CH1 waveform DAC is not synchronized properly The Waveform DAC (U1001) on Channel 1 cannot frequency lock to the clocking signals. | Mezzanine Board
626 | Self-test failed; CH2 waveform DAC is not synchronized properly The Waveform DAC (U1101) on Channel 2 cannot frequency lock to the clocking signals. | Mezzanine Board
626 | Self-test failed; Sync waveform DAC is not synchronized properly The Waveform DAC (U1201) on the Sync Channel cannot frequency lock to the clocking signals. | Mezzanine Board
630 | Self-test failed; Chan n, sub attenuator failure 0dB Trim DAC inside waveform DAC (U1001 – Ch1 or U1101 – Ch2) not providing correct output at 0 dB. This test also depends upon the signal attenuation circuit on the main board (for Channel 1 this means U1401, U1402, relay attenuators K1501 - K1503, K1701 - K1704 and the amplifier circuit). If this fails, test 631 will not be executed. | Mezzanine Board (DAC) or Main Board (signal attenuator chain).
631 | Self-test failed; Chan n, sub attenuator xx dB Trim DAC inside waveform DAC (U1001 or U1101) producing output outside expected range. | Mezzanine Board
635 | Self-test failed; Chan n, null DAC gain xx A DC Nulling circuit (U1404, U1405), has failed to produce the expected voltage change. | Main Board
640 | Self-test failed; Chan n, offset DAC gain xx A DC Offset signal generation circuit (U1609, U1610) has failed to produce the expected voltage change. | Main Board
650 | Self-test failed; 0dB path failure channel n expected 0dB, measured yy dB The straight-through path (no attenuator) from waveform DAC to ADC input producing output outside expected range. Waveform DAC (U1001 – Ch1 or U1101 – Ch2) not providing correct output at 0 dB. This test also depends upon the signal attenuation circuit on the main board (for Channel 1 this means U1401, U1402, relay attenuators K1501 - K1503, K1701 - K1704 and the amplifier circuit). If this fails, extended attenuator test 655 is not executed. | Mezzanine Board Waveform DAC or Main Board
655 | Self-test failed; Chan n, -8 dB pre attenuator path too low (too high) Self-test failed; Chan n, -16 dB pre attenuator path too low (too high) Self-test failed; Chan n, -24 dB pre attenuator path too low (too high) Self-test failed; Chan n, -24 dB post attenuator path too low (too high) Specified attenuator relay malfunctioning, or associated circuitry not providing expected attenuation. | Main Board
660 | Self-test failed; Channel n: xx dB pre/post attenuator relay inoperative Self-test is unable to change the signal amplitude with the relay attenuators named. | Main Board
661 | Self-test failed; EEPROM access failed Main CPU is unable to read a memory chip (U2) on the front panel board. | Main Board


Replaceable Parts

Caution

Always use anti-static techniques when assemblies are handled or serviced.

The following table lists the replacement assemblies for the instrument:

Part Number | Description
34401-86020 | Bumper Kit
34401-45021 | Handle
33220-84101 | Cover
1990-3263 | Encoder (33500 Series)
1990-3728 | Encoder (33600 Series)
35220-87401 | Knob
33521-80001 | Keypad for one-channel models
33522-80001 | Keypad for two-channel models
2090-0977 | Display (33500 Series)
2090-1051 | Display (33600 Series)
1250-3569 | Front Panel BNCs
33521-80002 | Front Panel for 33521A
33522-80002 | Front Panel for 33522A
33520-80001 | Front Panel for 335xxB one-channel models
33520-80002 | Front Panel for 335xxB two-channel models
33621-80002 | Front Panel for 33600 Series one-channel models
33622-80002 | Front Panel for 33600 Series two-channel models
33522-66502 | Front Panel Board (33500 Series)
1252-8483 | USB Connector
1253-4669 | LAN Connector (33500 Series)
1254-0795 | LAN Connector (33600 Series)
53200-61608 | Line Filter (33500 Series)
5041-5250 | Line Filter (33600 Series)
33250-68501 | Fan (33500 Series)
5041-5244 | Fan Kit (33600 Series)
1420-0356 | Battery (in Front Panel) CR2032
53200-80002 | Power Supply and Cover* (33500 Series)
5041-5252 | Power Supply Shield (33600 Series only)
5041-5256 | Power Supply* (33600 Series only)

* The 33500 Series models contain a 15 A, 250 V radial lead fuse. Fuse replacement is not recommended.

* The 33600 Series models contain two 3.15 A, 250 V radial lead fuses. Fuse replacement is not recommended.


Disassembly

Disassembly - 33500 Series

This section describes the procedure for disassembling the instrument.

Tools Required

The following tools are required for instrument disassembly.

  • T15 Torx driver (most disassembly)
  • T8 Torx driver (front panel disassembly)
  • Posidrive and flat bladed screw drivers
  • 14 mm nut driver, hollow shaft (rear-panel BNC connectors)
  • 7 mm nut driver (rear-panel GPIB connector)

Warning

Only qualified, service-trained personnel who are aware of the hazards involved should remove instrument covers. Always disconnect the power cable and any external circuits before removing the instrument cover. Some circuits are active and have power applied even when the power switch is turned off.

Always disconnect all inputs, cords, and cables before disassembling the instrument.

General Disassembly Procedure

  1. Turn off the power. Remove all cables from the instrument.
  2. Rotate the handle upright and pull off.
    Rotate and remove handle
  3. Pull off the instrument bumpers.
    Bumper removal
  4. Loosen the two captive screws (circled in red, below) in the rear bezel and remove the rear bezel.

    Bezel removal screws
  5. Slide off the instrument cover.

Many of the service procedures can now be performed without further disassembly. Troubleshooting and service procedures that require power be applied can be performed with the instrument in this state of disassembly.

Warning

SHOCK HAZARD. Only service-trained personnel who are aware of the hazards involved should remove the instrument covers. Dangerous voltages may be encountered with the instrument covers removed.

Main Component Disassembly

  1. Remove processor board. Turn instrument over. Remove the T-8 screw securing the processor board. Press the tabs on the processor board connector and slide processor board toward the back of instrument to disengage the connector. Lift processor board out.

  2. Remove front panel assembly. Remove T15 screw holding the main board. Press latch on left side of front panel and latch in power supply cover on right side of front panel. Push sides of metal chassis toward center to disengage studs on sides of front panel assembly. Gently pull front panel assembly straight off chassis. Note that front panel assembly has an electrical connector to the main board. Be careful not to damaged connector.
    Front panel removal
  3. Remove Main Board. Disconnect power supply connector from main board. Disconnect GPIB and Oscillator In ribbon cables. Disconnect fan power cable from main board. Loosen and remove nuts securing Modulation In and Ext Trig BNC connector to rear panel. Remove screw below GPIB board securing main board to chassis. Slide main board toward front of instrument to disengage tabs on power supply cover. Lift main board out.
    Disassembly main board
  4. Remove Power Supply. Disconnect input power to power supply board (blue and brown wires). Disconnect green ground connector on power supply board. Remove screw securing power supply cover to chassis. Slide power supply assembly toward front of instrument and remove.

    5. Warning

            Always re-attach the green ground wire to the power supply before operating the instrument.
  5. The remaining assemblies can be removed from the chassis if needed.

Front Panel Disassembly

  1. Pull the knob straight off. Remove six T8 screws securing front panel bracket to front panel assembly. Lift out bracket.

    Front panel disassembly
  2. Disconnect display ribbon cable from the front panel board. Remove T8 screws securing the front panel board to the front panel assembly. Lift out printed circuit board.
    Front panel disassembly

    Front panel disassembly

  3. All additional front panel assemblies can now be lifted out of front panel housing.


Disassembly

Disassembly - 33600 Series

This section describes the procedure for disassembling the instrument.

Tools Required

The following tools are required for instrument disassembly.

  • T15 Torx driver (most disassembly)
  • T8 Torx driver (front panel disassembly)
  • Posidrive and flat bladed screw drivers
  • 14 mm nut driver, hollow shaft (rear-panel BNC connectors)
  • T10 Torx driver (rear-panel GPIB connector)

Warning

Only qualified, service-trained personnel who are aware of the hazards involved should remove instrument covers. Always disconnect the power cable and any external circuits before removing the instrument cover. Some circuits are active and have power applied even when the power switch is turned off.

Always disconnect all inputs, cords, and cables before disassembling the instrument.

General Disassembly Procedure

  1. Turn off the power. Remove all cables from the instrument.
  2. Rotate the handle upright and pull off.
    Rotate and remove handle
  3. Pull off the instrument bumpers.
    Bumper removal
  4. Loosen the two captive screws (circled in red, below) in the rear bezel and remove the rear bezel.

    Bezel removal screws
  5. Slide off the instrument cover.

Many of the service procedures can now be performed without further disassembly. Troubleshooting and service procedures that require power be applied can be performed with the instrument in this state of disassembly.

Warning

SHOCK HAZARD. Only service-trained personnel who are aware of the hazards involved should remove the instrument covers. Dangerous voltages may be encountered with the instrument covers removed.

Main Component Disassembly

To remove the front panel and front panel PCBA

  1. Remove the two screws near the front of the power supply deck that secure the power supply deck in place.

  2. Tilt the power supply deck upward and lift it over the edge of the chassis. Then place it upside down on your bench, as shown below.

  3. Remove the two screws from the main board. These are located directly below the two screws that you removed in step 1.
  4. Push the sides of the chassis inward and slide the front panel forward to pull the front panel off.
  5. Disconnect the cable that connects the front panel board to the display by lifting up on the connector lever to release the cable.
  6. Remove the seven screws that hold the PCBA to the front panel plastic.

To remove the main board

  1. If you have the GPIB option installed, remove it as described here.
  2. Remove the front panel as described above.
  3. To access the main board, lift the power supply deck up and away from the instrument. You may either rest it in the groove on the instrument's chassis or move it completely out of the way and set it on your bench, as shown below.

  4. Remove the cable with the red and black wires from the connector at the front of the main board.
  5. Remove the other cables (from the AC power inlet module) from the rear of the power supply.
  6. Disconnect the red cable and the fan cable from the rear of the main board.
  7. Remove the screw that connects the main board to the chassis at the rear of the instrument.
  8. Remove the lock washers and nuts from the lower two BNC connectors on the rear panel.
  9. Slide the main board slightly to clear the chassis side hooks and then pull up and out to remove the board.


Battery Replacement

This section describes the procedure for replacing the battery on the instrument's front panel.

Warning

Only qualified, service-trained personnel who are aware of the hazards involved should remove instrument covers. Always disconnect the power cable and any external circuits before removing the instrument cover. Some circuits are active and have power applied even when the power switch is turned off.

Always disconnect all inputs, cords, and cables before disassembling the instrument.

Tools Required

  • T20 Torx driver (most disassembly)
  • Small, flat-blade screw driver (for prying)

Procedure

(Images shown below provided courtesy of Keystone Electronics Corp.)

  1. Turn off the power and remove all measurement leads and other cables, including the power cord, from the instrument before continuing.
  2. Follow the 33500 Series disassembly procedure or 33600 Series disassembly procedure to disassemble the instrument.
  3. Locate the battery on the front panel, and position the screwdriver tip under the battery, as shown.

  4. Use the screwdriver to pry the battery from the battery holder.

  5. Remove the battery and discard or recycle it in accordance with all applicable regulations.
  6. Position the new battery in the battery holder, + side up. Push down gently to seat the battery in the holder.

  7. Re-assemble the instrument completely before connecting any cables or cords.

This concludes the battery replacement procedure.


Installing the Optional GPIB Interface

Warning

This procedure should be performed by qualified service personnel only. Turn off the power and remove all measurement leads and other cables, including the power cord, from the instrument before continuing.

Tools Required

This procedure requires a T10 Torx driver.

Installation Procedure

  1. Turn off the power and remove all measurement leads and other cables, including the power cord, from the instrument before continuing.
  2. Use the Torx driver to remove the screw from the GPIB cover plate. Retain the screw for use later in this procedure. Then remove the cover plate by sliding it to the left.

    3. Retain GPIB Cover Plate

    After installing the GPIB option, retain the cover plate for use in the event that you ever remove the GPIB option. The instrument should never be connected to power or inputs on the measurement terminals without either the GPIB module or the cover plate securely covering the rear-panel opening.

  3. Locate the connector, just inside the unit, for the cable attached to the GPIB module

  4. Bend the cable so that it is extends above the circuit board. Attach the cable to the connector that was located in the previous step.

  5. Put the module into the unit and slide the GPIB board to the right so that it is flush against the instrument's sheet metal. Use the screw that was removed above to secure the GPIB plate in place.

This concludes the GPIB installation procedure.